Cisco Packet Tracer Üzerinde EIGRP Konfigürasyonu

EIGRP (Enhanced Interior Gateway Routing Protocol – İç Ağ Geçidi Yönlendirme Protokolü) sadece Cisco cihazlara özgü bir Hybrid Protocol (Hibrit Protokol) yönlendirme protokolüdür.

Cisco Packet Tracer Üzerinde EIGRP Konfigürasyonu

Packet Tracer ile Cisco Router Üzerinde EIGRP Yapılandırma

EIGRP Protokolü hem Distance Vektor hemde Link-State bir yönlendirme protokolüdür ve RIP’e göre yönlendirme tablolarını ağda değişiklik olduğunda gönderir. RIP ise yönlendirme tablosu güncellemelerini komşu Router’lara her 30 saniyede bir gönderir.

Sonuç olarak, RIP protokolü ağ kaynaklarını daha fazla kullanır ve Router‘lara ek yük oluşturur. EIGRP ağ üzerinde meydana gelen bir değişiklikte spesifik güncellemeler yapar.

EIGRP protokolü hakkında daha detaylı bilgi almak için https://www.cisco.com/c/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp-toc.html adresini ziyaret ediniz.

Bu yazımızda, simülatör yazılımı ile iki segmentteki bilgisayarları haberleştirmek için Router üzerinde EIGRP etkinleştireceğiz.

   Adım 1

Packet Tracer‘da aşağıdaki görüntüdeki gibi iki Router’lı basit bir ağ topolojisi oluşturunuz. Segmentler için IP bloklarını belirleyiniz ve tasarımın daha anlaşılabilir olması için çalışma alanına notlar ekleyiniz.

İki Cisco Router'lı Bir Ağ Topolojisi

   Adım 2

Cisco Router R1’in GigabitEthernet ve Serial arayüzlerini yapılandırmak için CLI komut istemini açınız ve aşağıdaki komutları uygulayınız.

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface gigabitethernet0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#interface serial 0/1/0
R1(config-if)#ip address 10.1.1.1 255.255.255.252
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down

Cisco Router R1'in Arayüzlerini Yapılandırma

   Adım 3

Cisco Router R2 arayüzlerini de aynı şekilde yapılandırınız.

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface gigabitethernet 0/1
R2(config-if)#ip address 192.168.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
R2(config-if)#exit
R2(config)#interface serial 0/1/1
R2(config-if)#ip address 10.1.1.2 255.255.255.252
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to up
R2(config)#

Cisco Router R2'nin Arayüzlerini Yapılandırma

   Adım 4

Router’larda EIGRP Routing yapılandırmadan önce, PC1’den R1’in GigabitEthernet0/0 ve Serial0/1/0 arayüzlerine Ping atarak bağlantıyı test ediniz.

PC1'den R1'in GigabitEthernet ve Serial Arayüzlerine Ping Atma

   Adım 5

Aynı şekilde, 192.168.10.0/24 ağındaki PC2 üzerinden Router R2’in arayüzlerini test ediniz.

PC2'den R2'nin GigabitEthernet ve Serial Arayüzlerine Ping Atma

   Adım 6

Bu kez PC1’den R2’nin Serial0/1/1 arayüzüne ve PC2’ye Ping attığınızda işlemin başarısız olduğunu göreceksiniz. Çünkü ağ ortamında herhangi bir yönlendirme protokolü yapılandırılmamıştır.

PC1'den R2'ye Ping Atma

   Adım 7

PC2’den R1 arayüzlerine de Ping işlemi başarısız olacaktır.

PC2'den R1'e Ping Atma

   Adım 8

Yönlendirme protokolünü etkinleştirmek için R1’in CLI komut istemini açınız ve aşağıdaki komutları uygulayınız. EIGRP etkinleştirmek için ilk kullanılacak komut router eigrp (AS Numarası)‘dır.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#
R1(config)#router eigrp ?
Autonomous system number
R1(config)#router eigrp 1
R1(config-router)#network 192.168.5.0 ?
A.B.C.D EIGRP wild card bits

R1(config-router)#network 192.168.5.0 0.0.0.255
R1(config-router)#network 10.1.1.0 0.0.0.3
R1(config-router)#end
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#

R1'de EIGRP Etkinleştirme

   Adım 9

R2 üzerinde de EIGRP protokolünü etkinleştiriniz.

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#
R2(config)#router eigrp 1
R2(config-router)#network 192.168.10.0 0.0.0.255
R2(config-router)#network 10.1.1.0 0.0.0.3
R2(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 10.1.1.1 (Serial0/1/1) is up: new adjacency
R2(config-router)#end
R2#

Router R2'de EIGRP Etkinleştirme

   Adım 10

R1 üzerinde show ip route komutunu kullanarak yönlendirme tablosunu inceleyebilirsiniz. Yönlendirme protokolü aşağıdaki görüntüdeki gibi D harfi ile belirtilmiştir ve ayrıca metriği 90‘dır.

show ip route

   Adım 11

Router R2 üzerinde de show ip route komutu ile yönlendirme tablosunu görüntüleyiniz.

show ip route

   Adım 12

Router’larda yönlendirmeyi yapılandırdıktan sonra, artık iki segmentteki cihazlar birbirleriyle haberleşebilecektir.

Ek olarak, EIGRP show komutları ile yönlendirme protokolü işleyişini test edebilir ve sorun giderebilirsiniz. Örnek show komutları aşağıdaki gibidir.

show ip eigrp neighbors
show ip eigrp topology
show ip eigrp traffic

EIGRP Show Komutları

   Adım 13

Router R2 üzerinde de show komutlarını kullanarak komşuluk bilgilerini, topoloji haritasını ve trafik akışını inceleyiniz.

EIGRP Show Komutları

   Adım 14

EIGRP sorun gidermek privileged modda debug eigrp packets komutunu kullanabilirsiniz.

debug eigrp packets

debug eigrp packets

   Adım 15

Aynı şekilde R2 üzerinde de debug komutu ile paketleri analiz edebilirsiniz.

debug eigrp packets

Show Komutları

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/1/0
L 10.1.1.1/32 is directly connected, Serial0/1/0
192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/24 is directly connected, GigabitEthernet0/0
L 192.168.5.1/32 is directly connected, GigabitEthernet0/0
D 192.168.10.0/24 [90/2170112] via 10.1.1.2, 00:00:36, Serial0/1/0
R1#

 

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/1/1
L 10.1.1.2/32 is directly connected, Serial0/1/1
D 192.168.5.0/24 [90/2170112] via 10.1.1.1, 00:01:03, Serial0/1/1
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, GigabitEthernet0/1
L 192.168.10.1/32 is directly connected, GigabitEthernet0/1
R2#

 

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.1.2 Se0/1/0 11 01:27:25 40 1000 0 3
R1#

 

R1#show ip eigrp topology
IP-EIGRP Topology Table for AS 1/ID(192.168.5.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status

P 10.1.1.0/30, 1 successors, FD is 2169856
via Connected, Serial0/1/0
P 192.168.5.0/24, 1 successors, FD is 2816
via Connected, GigabitEthernet0/0
P 192.168.10.0/24, 1 successors, FD is 2170112
via 10.1.1.2 (2170112/2816), Serial0/1/0
R1#

 

R1#show ip eigrp traffic
IP-EIGRP Traffic Statistics for process 1
Hellos sent/received: 2292/1137
Updates sent/received: 2/2
Queries sent/received: 0/0
Replies sent/received: 0/0
Acks sent/received: 2/2
Input queue high water mark 1, 0 drops
SIA-Queries sent/received: 0/0
SIA-Replies sent/received: 0/0
R1#

 

R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.1.1 Se0/1/1 11 01:35:21 40 1000 0 3
R2#

 

R2#show ip eigrp topology
IP-EIGRP Topology Table for AS 1/ID(192.168.10.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status

P 10.1.1.0/30, 1 successors, FD is 2169856
via Connected, Serial0/1/1
P 192.168.5.0/24, 1 successors, FD is 2170112
via 10.1.1.1 (2170112/2816), Serial0/1/1
P 192.168.10.0/24, 1 successors, FD is 2816
via Connected, GigabitEthernet0/1
R2#

 

R2#show ip eigrp traffic
IP-EIGRP Traffic Statistics for process 1
Hellos sent/received: 2480/1239
Updates sent/received: 2/2
Queries sent/received: 0/0
Replies sent/received: 0/0
Acks sent/received: 2/2
Input queue high water mark 1, 0 drops
SIA-Queries sent/received: 0/0
SIA-Replies sent/received: 0/0
R2#

 

R1#debug eigrp packets
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, ACK )
R1#
EIGRP: Received HELLO on Serial0/1/0 nbr 10.1.1.2
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on Serial0/1/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/0 nbr 10.1.1.2
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on Serial0/1/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/0 nbr 10.1.1.2
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on Serial0/1/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/0 nbr 10.1.1.2
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on Serial0/1/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

 

R2#debug eigrp packets
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, ACK )
R2#
EIGRP: Sending HELLO on Serial0/1/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/1 nbr 10.1.1.1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on Serial0/1/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/1 nbr 10.1.1.1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on GigabitEthernet0/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on Serial0/1/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/1 nbr 10.1.1.1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on GigabitEthernet0/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on Serial0/1/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/1 nbr 10.1.1.1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

 

R1#show running-config
Building configuration...

Current configuration : 835 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524470E
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
network 192.168.5.0
network 10.1.1.0 0.0.0.3
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R1#

 

R2#show running-config
Building configuration...

Current configuration : 817 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX152481GS
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
ip address 10.1.1.2 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
network 192.168.10.0
network 10.1.1.0 0.0.0.3

!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R2#

   Video

Yönlendiricide EIGRP konfigürasyonu için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


Bu yazımızda, Cisco ağ simülatör yazılımı ile iki Router’lı bir topolojide EIGRP yönlendirme protokolünü yapılandırdık. Bu Routing protokolünü daha geniş ağ tasarımlarında kullanmanız tavsiye edilir. Bu protokolün tek dezavantajı ise sadece Cisco cihazlarda kullanılmasıdır. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


RIP Etkinleştirme
RIP Version 2 Etkinleştirme
Static Routing Yapılandırma
Cisco DHCP Yapılandırma
Packet Tracer Ağ Kurulumu

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

You cannot copy content of this page