Cisco Packet Tracer Üzerinde RIP Version 1 (RIPv1) Konfigürasyonu

RIP, ağın iç kısmı için, İnternet omurgasına bağlı olmayan bir iç yönlendirme protokolüdür. Birçok kullanıcının bir ağa bağlandığı ve farklı yerlerden erişebildiği gibi internet bağlantı sistemlerinde yaygın olarak kullanılır.

Cisco Packet Tracer Üzerinde RIP Version 1 (RIPv1) Konfigürasyonu

Cisco Router Üzerinde RIPv1 Yapılandırma

Bir kullanıcı terminal sunucusuna (aramanın sona erdiği cihaz) bağlandığında, en yakın yönlendiriciye, kendisine ait olan IP adresini bir RIP mesajı uyarısı ile bildirir.

Dolayısıyla RIP’nin bilgi alışverişinde kullanılan farklı yönlendiriciler tarafından kullanılan bir protokol olduğunu görebilir ve böylece bir hedefe ulaşmak için bir paketi nereye yönlendirmeleri gerektiğini bilir.

RIP (Routing Information Protocol – Yönlendirme Bilgisi Protokolü) yaygın olarak kullanılan ve çoğu yönlendiricinin desteklediği bir uzaklık vektörü yönlendirme protokolüdür. Diğer bir deyişle, RIP bir Dinamik Yönlendirme protokolüdür.

Cisco Router‘lar üzerinde bu yönlendirme protokolünü yapılandırmak için, küresel yapılandırma modunda Router Rip komutu uygulanır ve bağlı olan network’ler tanımlanır.

Bu yazımızda, simülatör yazılımı ile iki Router üzerinde RIP Version 1 sürümünü yapılandıracağız.

   Adım 1

Packet Tracer programını açınız ve aşağıdaki görüntüdeki gibi bir ağ topolojisi oluşturduktan sonra çalışma alanına eklediğiniz bilgisayarlara IP adresi atayınız ve ardından tüm aygıtları kablolayınız.

İki Cisco Router'lı Bir Ağ Topolojisi

   Adım 2

Cisco Router R1’in, GigabitEthernet 0/1 ve Serial 0/1/0 arayüzlerine IP adresleri atayınız ve portları açınız.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface serial 0/1/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
R1(config-if)#exit
R1(config)#interface gigabitethernet 0/1
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
R1(config-if)#end
R1#

R1'in Gigabit ve Serial Arayüzlerine IP Adresi Atama

   Adım 3

Aynı şekilde, Router R2’nin de Serial0/1/1 ve Gig0/1 arayüzlerini aşağıdaki gibi yapılandırınız.

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#interface serial 0/1/1
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to up
R2(config-if)#exit
R2(config)#interface gigabitethernet 0/1
R2(config-if)#ip address 192.168.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
R2(config-if)#end
R2#

R2'nin Gigabit ve Serial Arayüzlerine IP Adresi Atama

   Adım 4

RIP’i etkinleştirmeden önce, bilgisayarlar üzerinden arayüzlere Ping atarak bağlantıyı test ediniz. Aşağıdaki gibi, PC1 üzerinden R1’in GigabitEthernet ve Serial arayüzlere Ping işlemi başarılı olacaktır.

PC1'den R1'in Gigabit ve Serial Arayüzlerine Ping Atma

   Adım 5

R2 Router’ın Serial arayüzüne Ping işlemi başarısız olacaktır çünkü herhangi bir yönlendirme protokolünü yapılandırılmadı.

PC1'den R2'nin Serial Arayüzüne Ping Atma

   Adım 6

İki farklı segmenti haberleştirebilmek için Router’lar üzerinde bir yönlendirme protokolü yapılandırmanız gerekir. Bu yazımızda, RIP’i açıkladığımız için öncelikle R1 üzerinde RIP’i yapılandırmak için aşağıdaki komutları CLI’da uygulayınız.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router rip
R1(config-router)#network 192.168.5.0
R1(config-router)#network 10.1.1.0
R1(config-router)#end
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#

R1 Üzerinde RIP Etkinleştirme

   Adım 7

Şimdi, R2’de de RIP etkinleştirmek için şu komutları uygulayınız:

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router rip
R2(config-router)#network 192.168.10.0
R2(config-router)#network 10.1.1.0
R2(config-router)#end
R2#
%SYS-5-CONFIG_I: Configured from console by console
R2#

R2 Üzerinde RIP Etkinleştirme

   Adım 8

RIPv1 yapılandırdıktan sonra Router’larda oluşturulan rotaları doğrulamak için show ip route komutunu kullanabilirsiniz.

R1 üzerindeki rota kayıları aşağıdaki gibidir;

show ip route komutu

   Adım 9

Aynı şekilde, Cisco Router R2 üzerinde de yönlendirme rotalarını öğrenmek için show ip route komutunu uygulayınız.

show ip route komutu

   Adım 10

PC1 üzerinden R2 Serial arayüzüne ve alt ağındaki PC3 ve PC4 bilgisayarlara Ping işlemi aşağıdaki gibi başarılı olacaktır.

Yönlendirmeyi Yapılandırdıktan Sonra Ping Testi

   Adım 11

192.168.10.0/24 ağından, 192.168.5.0/24 ağına da Ping işlemi başarılı bir şekilde gerçekleşecektir.

Yönlendirmeyi Yapılandırdıktan Sonra Ping Testi

   Adım 12

Show ip protocols komutu ile Router üzerinde çalışan yönlendirme protokolünü kontrol edebilirsiniz.

show ip protocols komutu

   Adım 13

Aynı şekilde, R2’yi de kontrol ediniz.

show ip protocols komutu

   Adım 14

R1’de show ip rip database komutunu uyguladıktan sonra, detaylı rota kayıtlarını görebilirsiniz.

show ip rip database komutu

   Adım 15

Aynı şekilde, R2 üzerinde de aynı komutu uygulayarak inceleyebilirsiniz.

show ip rip database komutu

Show Komutları

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Serial0/1/0
L 10.1.1.1/32 is directly connected, Serial0/1/0
192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/24 is directly connected, GigabitEthernet0/1
L 192.168.5.1/32 is directly connected, GigabitEthernet0/1
R 192.168.10.0/24 [120/1] via 10.1.1.2, 00:00:14, Serial0/1/0

R1#

 

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Serial0/1/1
L 10.1.1.2/32 is directly connected, Serial0/1/1
R 192.168.5.0/24 [120/1] via 10.1.1.1, 00:00:09, Serial0/1/1
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, GigabitEthernet0/1
L 192.168.10.1/32 is directly connected, GigabitEthernet0/1

R2#

 

R1#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 7 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
GigabitEthernet0/1 1 2 1
Serial0/1/0 1 2 1
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.5.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
10.1.1.2 120 00:00:00
Distance: (default is 120)
R1#

 

R2#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 14 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
GigabitEthernet0/1 1 2 1
Serial0/1/1 1 2 1
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.10.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
10.1.1.1 120 00:00:01
Distance: (default is 120)
R2#

 

R1#show running-config
Building configuration...

Current configuration : 823 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524N07E
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
ip address 10.1.1.1 255.255.255.0
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
network 10.0.0.0
network 192.168.5.0
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end
R1#

 

R2#show running-config
Building configuration...

Current configuration : 805 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX15248JFW
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
ip address 10.1.1.2 255.255.255.0
!
interface Vlan1
no ip address
shutdown
!
router rip
network 10.0.0.0
network 192.168.10.0
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end
R2#

 

R1#show ip rip dtbse
10.1.1.0/24 auto-summary
10.1.1.0/24 directly connected, Serial0/1/0
192.168.5.0/24 auto-summary
192.168.5.0/24 directly connected, GigabitEthernet0/1
192.168.10.0/24 auto-summary
192.168.10.0/24
[1] via 10.1.1.2, 00:00:15, Serial0/1/0
R1#

 

R2#show ip rip dtbse
10.1.1.0/24 auto-summary
10.1.1.0/24 directly connected, Serial0/1/1
192.168.5.0/24 auto-summary
192.168.5.0/24
[1] via 10.1.1.1, 00:00:03, Serial0/1/1
192.168.10.0/24 auto-summary
192.168.10.0/24 directly connected, GigabitEthernet0/1
R2#

   Video

Yönlendircide RIPv1 etkinleştirmek için aşağıdaki videoyu izleyerek gerçekleştirebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


Bu yazımızda, Router‘lar üzerinde dinamik yönlendirme protokolü olan RIPv1 yapılandırdık ve iki segmentteki bilgisayarları haberleştirdik. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


♦ Cisco Static NAT
♦ Cisco Dynamic NAT
♦ Cisco Static Routing
Cisco Port Security
♦ Cisco NAT PAT

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Show Buttons
Hide Buttons