Cisco Packet Tracer Üzerinde RIP Version 2 (RIPv2) Konfigürasyonu

RIP Routing protokolünün 2 sürümü vardır. RIP Version 1 sürümü yönlendirme tablosu güncellemelerini Broadcast (255.255.255.255) olarak yapmaktadır. RIP Version 2 sürümü ise Multicast yayın yapmaktadır.

Cisco Packet Tracer Üzerinde RIP Version 2 Konfigürasyonu

Packet Tracer ile Router Üzerinde RIPv2 Yapılandırma

RIPv1 Classfull yönlendirmeyi kullanır, saldırılara karşı çok hassastır, RIPv1’deki girişler hedef ağın IP adresini ve metriği içerir RIPv2, sınıfsız yönlendirme, MD5 şifresi ile kimlik doğrulama kullanır, RIPv2’deki girişler hedef ağın IP adresini, maskesini, bir sonraki yönlendiriciyi ve metriği içerir.

RIPv2, RFC 2453‘te tanımlanmıştır ve yönlendirme tablosu güncellemelerini Multicast olarak gönderir ve VLSM ve CIDR destekler. RIPv1 ise Broadcast kullanır, VLSM ve CIDR desteklemez.

Dolayısıyla RIPV1 yapılandırırken tüm cihazlar aynı ağ üzerinde olması gerekmektedir. RIP Version 2’de böyle bir zorunluluk yoktur ve daha kapsamlı bir ağ tasarımı yapılabilir.

Bu yazımızda, simülatör yazılımı üzerinde iki segmentteki bilgisayarları veya cihazları haberleştirebilmek için Router üzerinde RIP Version 2 (RIPv2) Routing yapılandırma adımlarını inceleyeceğiz.

   Adım 1

Packet Tracer programını açınız ve 192.168.5.0/24 ağını iki segmente ayıracak şekilde bir ağ topolojisi oluşturunuz.

Cisco Router R1 ve R2 arasındaki Serial bağlantının IP bloğu ise, 10.1.1.0/30 – 255.255.255.252’dir.

İki Cisco Router ile LAN'ları Birleştirme

   Adım 2

Cisco Router R1’in CLI komut istemini açınız ve GigabitEthernet0/0 ve Serial0/1/0 arayüzlerine IP adresleri atayınız ve portları açık konuma getiriniz.

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface gigabitethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.128
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
R1(config-if)#ex
R1(config)#interface serial 0/1/0
R1(config-if)#ip address 10.1.1.1 255.255.255.252
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
R1(config-if)#end
R1#

Cisco Router R1'in GigabitEthernet ve Serial Arayüzlerini Yapılandırma

   Adım 3

Router R2’nin de Gig0/1 ve Se0/1/1 arayüzlerini yapılandırınız.

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface gigabitethernet 0/1
R2(config-if)#ip address 192.168.5.129 255.255.255.128
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
R2(config-if)#exit
R2(config)#interface serial 0/1/1
R2(config-if)#ip address 10.1.1.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to up
R2(config-if)#end
R2#

Cisco Router R2'nin GigabitEthernet ve Serial Arayüzlerini Yapılandırma

   Adım 4

PC1’den PC2’ye ve R1’in Serial 0/1/0 arayüzüne Ping atarak bağlantıyı test ediniz.

PC1'den PC2, ve R1'in Gig0/0 ve Serial 0/1/0 Arayüzlerine Ping Atma

   Adım 5

PC1’den R2’nin Serial ve GigabitEthernet arayüzlerine Ping işlemi başarısız olacaktır. Çünkü, Router’lar üzerinde RIPv2 yönlendirme protokolü etkinleştirilmedi!

PC1'den R2'in GigabitEthernet 0/1 ve Serial 0/1/1 Arayüzlerine Ping Atma

   Adım 6

192.168.5.128/25 ağındaki PC3 üzerinden de bağlı olduğu Router arayüzlerini pingleyerek ağ bağlantısını test ediniz.

PC3'ten PC4, ve R2'nin Arayüzlerine Ping Atma

   Adım 7

Yukarıdaki adımlarda, Router’lara bağlı aynı ağ üzerindeki cihazların haberleştiğini incelediniz. Şimdi iki farklı ağdaki bilgisayarları haberleşebildiğini kontrol etmek için tekrar ping ile ağ bağlantısı testi yapınız.

PC3’ten Router R1’in Serial ve GigabitEthernet arayüzlerine de Ping işlemi aşağıdaki gibi başarısız olacaktır.

PC3'ten R1'in Arayüzlerine Ping Atma

   Adım 8

Şimdi, Router’larda RIP Versiyon 2 etkinleştirmek için önce R1’in CLI komut istemini açınız ve aşağıdaki komutları uygulayınız.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.1.1.0
R1(config-router)#network 192.168.5.0
R1(config-router)#end
R1#

R1 Üzerinde RIP Etkinleştirme

   Adım 9

R2 üzerinde de RIP Versiyon 2’yi etkinleştiriniz ve Router’a bağlı olan ağları tanımlayınız. Burada, network 192.168.5.128 ağına dikkat ediniz.

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 10.1.1.0
R2(config-router)#network 192.168.5.128
R2(config-router)#end
R2#

R2 Üzerinde RIP Etkinleştirme

   Adım 10

Yönlendirme protokolünü yapılandırdıktan sonra, artık PC1 üzerinden Ping işlemleri aşağıdaki görüntüdeki gibi başarılı olacaktır!

Karşı Ağı Pingleme

   Adım 11

Aynı şekilde, PC3 üzerinden de Ping atarak ağ bağlantısının başarılı olduğunu inceleyiniz.

Karşı Ağı Pingleme

   Adım 12

RIPv2’yi tamamen konfigüre ettikten sonra, şimdi yönlendiricilerde oluşturulan tabloları kontrol etmek için show ip route komutunu uygulayınız ve Rotaları kontrol ediniz.

show ip route

   Adım 13

R2’deki Rota kayıtları da aşağıdaki gibidir.

show ip route

   Adım 14

Cisco yönlendirici’lerde RIP Version 2’yi doğrulamak için debug ip rip komutunu uygulayarak, yönlendirme güncelleştirmelerinin nasıl yapıldığını görebilirsiniz.

Aşağıdaki görüntüde gördüğünüz gibi RIP V2’nin 224.0.0.9 Multicast adresi ile güncelleme yaptığını inceleyebilirsiniz.

debug ip rip

   Adım 15

Cisco Router R2’de güncellemeleri 224.0.0.9 multicast adresine göndermektedir.

debug ip rip

   Adım 16

Yönlendirmeyi doğrulamanın diğer bir yolu da show ip protocols komutunu kullanmaktır.

R1 üzerinde bu komutu çalıştırınız ve Routing Protocol is “rip” yazdığını kontrol ediniz.

show ip protocols

   Adım 17

Aynı şekide, Router R2 üzerinde de show ip protocols komutunu uygulayarak çıkan sonuçlara göz atabilirsiniz.

show ip protocols

Show Komutları

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/1/0
L 10.1.1.1/32 is directly connected, Serial0/1/0
192.168.5.0/24 is variably subnetted, 3 subnets, 3 masks
R 192.168.5.0/24 [120/1] via 10.1.1.2, 00:00:26, Serial0/1/0
C 192.168.5.0/25 is directly connected, GigabitEthernet0/0
L 192.168.5.1/32 is directly connected, GigabitEthernet0/0
R1#

 

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/1/1
L 10.1.1.2/32 is directly connected, Serial0/1/1
192.168.5.0/24 is variably subnetted, 3 subnets, 3 masks
R 192.168.5.0/24 [120/1] via 10.1.1.1, 00:00:04, Serial0/1/1
C 192.168.5.128/25 is directly connected, GigabitEthernet0/1
L 192.168.5.129/32 is directly connected, GigabitEthernet0/1
R2#

 

R1#debug ip rip
RIP protocol debugging is on
R1#RIP: sending v2 update to 224.0.0.9 via Serial0/1/0 (10.1.1.1)
RIP: build update entries
192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via GigabitEthernet0/0 (192.168.5.1)
RIP: build update entries
10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
192.168.5.0/24 via 0.0.0.0, metric 2, tag 0
R1#

 

R2#debug ip rip
RIP protocol debugging is on
R2#RIP: sending v2 update to 224.0.0.9 via Serial0/1/1 (10.1.1.2)
RIP: build update entries
192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via GigabitEthernet0/1 (192.168.5.129)
RIP: build update entries
10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
192.168.5.0/24 via 0.0.0.0, metric 2, tag 0
R2#

 

R1#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 13 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
Serial0/1/0 2 2
GigabitEthernet0/0 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.5.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
10.1.1.2 120 00:00:02
Distance: (default is 120)
R1#

 

R2#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 27 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
Serial0/1/1 2 2
GigabitEthernet0/1 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.5.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
10.1.1.1 120 00:00:14
Distance: (default is 120)
R2#

 

R1#show running-config
Building configuration...
Current configuration : 834 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524GC61
!
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
ip address 192.168.5.1 255.255.255.128
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
network 192.168.5.0
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R1#

 

R2#show running-config
Building configuration...
Current configuration : 816 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX15241561
!
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 192.168.5.129 255.255.255.128
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
ip address 10.1.1.2 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
network 192.168.5.0
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R2#

 

   Video

Yönlendiricilerde RIPv2 etkinleştirmek için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


Bu yazımızda, Cisco ağ simülatörü ile Router üzerinde RIP Version 2 (RIPv2) nasıl yapılandırılır ve doğrulanır adım adım inceledik. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


♦ Cisco Telnet
Cisco SSH
Cisco Port Security
Cisco Static Routing
♦ Cisco DHCP

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Show Buttons
Hide Buttons