Cisco Packet Tracer Üzerinde DHCP Konfigürasyonu

Cisco Packet Tracer programı ile ağ topolojileri oluşturabilir ve deneyimler elde edebilirsiniz. Bu yazılım Cisco firmasının bir ağ simulatör programıdır ve tamamen ücretsizdir.

Cisco Packet Tracer Üzerinde DHCP Konfigürasyonu

Cisco Router Üzerinde DHCP Etkinleştirme ve Yapılandırma

Bir ağı yapılandırmanın en kolay yolu yönlendiricilerde bulunan DHCP sunucularından yararlanmaktır. DHCP sunucusu, kendisine bağlanan tüm ekipman ve cihazlara bir IP adresi ve ağ parametreleri (alt ağ maskesi ve ağ geçidi) vermekten sorumludur.

Bu sunucu, bağlı ekipmanın DNS sunucularını yapılandırmaktan da sorumludur, ancak sağlayıcılar tarafından yönlendiricilerine yüklenen donanım yazılımı nedeniyle, varsayılan olarak eklenen DNS, üretici şirketin DNS’leridir.

Dinamik Ana Bilgisayar Yapılandırma Protokolü, IP adreslerinin otomatik olarak atanmasına izin veren protokoldür.

DHCP protokolü, aktarım protokolü olarak UDP’yi kullanır, 67 numaralı UDP portu, bir sunucunun hedef portudur ve istemci, 68 numaralı UDP portunu kullanır.

DHCP servisi ile aşağıdaki parametreleri otomatik olarak yapılandırabilirsiniz:

  • IP Adresi
  • Alt Ağ Maskesi
  • Varsayılan Ağ Geçidi
  • DNS

Cisco’nun ağ simülatör yazılımını kullanarak yeni bir ağ topolojisi oluşturup, ağa birden fazla istemci ve bir adet Cisco Router ekleyerek, ağ bağlanan veya sonradan bağlanılacak tüm istemcilerin TCP/IP yapılandırmasını manuel olarak yapılandırmak yerine, DHCP servisi ile otomatik olarak yapılandırabilirsiniz.

   Adım 1

Öncelikle Packet Tracer programında iki ayrı segmentli (192.168.1.0/24 ve 192.168.2.0/24) bir ağ topolojisi oluşturunuz.

Router'a Bağlı İki LAN

   Adım 2

Router0 penceresinde, CLI komut istemi sekmesine tıklayınız ve ilk yapılandırma ekranında, No (Hayır) yazarak Enter tuşuna basınız. Bu ekranda eğer Yes (Evet) seçeneği seçerseniz, Cisco yönlendirici temel ayarları yapmak için adım adım soru soracaktır.

IOS Command Interface

   Adım 3

Cisco yönlendirici arayüzlerine oluşturduğunuz ağ topolojisine göre IP adresleri atayınız ve portları açınız. Daha sonra, Router’dan istemcilere otomatik IP bilgileri dağıtmak için aşağıdaki komutları uygulayarak DHCP’yi etkinleştiriniz.

Router>enable
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface gigabitethernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#interface gigabitethernet 0/1
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
Router(config-if)#exit
Router(config)#ip dhcp pool LAN1
Router(dhcp-config)#network 192.168.1.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.1.1
Router(dhcp-config)#dns-server 192.168.1.1
Router(dhcp-config)#exit
Router(config)#ip dhcp excluded-address 192.168.1.1
Router(config)#ip dhcp pool LAN2
Router(dhcp-config)#network 192.168.2.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.2.1
Router(dhcp-config)#dns-server 192.168.2.1
Router(dhcp-config)#exit
Router(config)#ip dhcp excluded-address 192.168.2.1
Router(config)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#wr
Building configuration...
[OK]
Router#

Router'da DHCP Etkinleştirme

   Adım 4

Cisco DHCP komutlarını uyguladıktan sonra, Packet Tracer çalışma alanına eklediğiniz bilgisayarları otomatik IP adresi için ayarlamanız gerekir. Bu işlem için, PC0 üzerine tıklayarak açılan pencerede IP Configuration (IP Yapılandırma) seçeneğine tıklayınız ve ardından DHCP seçeneğini aktif ediniz.

Packet Tracer'da PC İçin DHCP Etkinleştirme

   Adım 5

PC0 üzerinde DHCP aktif ettikten sonra, aşağıdaki görüntüdeki gibi bir IP adresi isteği gönderilecektir.

Requesting IP Address

   Adım 6

DHCP, PC0’ın isteğini yanıtlayarak bir IP adresi tahsis edecektir.

DHCP Request Successful

   Adım 7

192.168.2.0/24 ağında bulunan bilgisayarlar için de DHCP seçeneğini etkinleştiriniz ve durumu kontrol ediniz.

PC2'nin IP Yapılandırması

   Adım 8

Cisco yönlendirici üzerinde 192.168.2.0/24 ağı için DHCP havuzu yapılandırıldığı için PC2 de başarılı bir şekilde IP adresi alacaktır.

DHCP Request Successful

   Adım 9

PC0’dan 2.0 ağına ping atarak ağ bağlantısını test ettiğinizde bu işlem aşağıdaki gibi başarılı olacaktır.

Farklı Ağlar Üzerinden Ping İşlemi

   Adım 10

PC3 üzerinden de 1.0 ağına ping işlemi de başarılı olacaktır.

Farklı Ağlar Üzerinden Ping İşlemi

   Adım 11

Yönlendirici üzerinde show ip dhcp binding komutu ile istemcilere atanan IP adreslerini ve MAC adreslerini görebilirsiniz.

show ip dhcp binding

   Adım 12

Ayrıca, show ip dhcp pool komutunu uyguladığınızda da aşağıdaki görüntüdeki gibi DHCP havuzu detaylarını inceleyebilirsiniz.

show ip dhcp pool

Show Komutları

Router#show ip dhcp ?
binding DHCP address bindings
conflict DHCP address conflicts
pool DHCP pools information
relay Miscellaneous DHCP relay information

 

Router#show ip dhcp binding
IP address     Client-ID/                      Lease expiration    Type
Hardware address
192.168.1.2 000C.8536.A381           --                           Automatic
192.168.1.3 00E0.B0AC.5779           --                           Automatic
192.168.2.2 00E0.F7CA.7827           --                           Automatic
192.168.2.3 000A.F383.BCDE           --                           Automatic

 

Router#show ip dhcp pool

Pool LAN1 :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 254
Leased addresses : 2
Excluded addresses : 2
Pending event : none

1 subnet is currently in the pool
Current index IP address range Leased/Excluded/Total
192.168.1.1 192.168.1.1 - 192.168.1.254 2 / 2 / 254

Pool LAN2 :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 254
Leased addresses : 2
Excluded addresses : 2
Pending event : none

1 subnet is currently in the pool
Current index IP address range Leased/Excluded/Total
192.168.2.1 192.168.2.1 - 192.168.2.254 2 / 2 / 254
Router#

   Video

PT yazılımını kullanarak Cisco yönlendirici üzerinde DHCP’yi yapılandırmak için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


Büyüyen bir network topolojisinde, ağ cihazlarının TCP/IP ayarlarını manuel olarak yapılandırmanız size zaman kaybı oluşturacağı için ortama bir DHCP Server (Sunucu) ekleyerek istemcilere IP bilgilerini otomatik olarak dağıtabilirsiniz ya da kullandığınız Router cihazında sunucuyu etkinleştirerek bu işlemi gerçekleştirebilirsiniz. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


DHCP Relay Agent
Windows Packet Tracer
♦ Cisco Telnet Konfigürasyonu
♦ Cisco Konsol Bağlantısı
♦ Cisco SSH Bağlantısı

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

You cannot copy content of this page