Cisco Packet Tracer Üzerinde Static Routing Konfigürasyonu

Bu yazımızda iki farklı segmentteki bilgisayarları Static Routing (Statik Yönlendirme) ile birbirleri ile haberleştireceğiz.

Cisco Packet Tracer Üzerinde Static Routing Konfigürasyonu

Cisco Router Üzerinde Static Routing Yapılandırma

İki tür yönlendirme türü vardır. Bunlar;

1. Static Routing (Statik Yönlendirme)
2. Dynamic Routing (Dinamik Yönlendirme)

Bu yazımızda, Static Routing nedir ve nasıl çalışır açıkladıktan sonra küçük bir network ortamında yönlendirme yapılandıracağız.

Eğer network ortamı birkaç Router’dan oluşuyorsa, yönlendirme için statik rotaları kullanmanız önerilir. Çünkü, Router’lar Dynamic Routing ile yapılandırıldığında performans bakımından daha yavaş çalışmaktadır. Fakat, küçük bir ağ ortamında manuel olarak rotalar ekleyerek yönlendiricilerin daha performanslı çalışmasını sağlayabiliriz.

Bu yönlendirme türünü diğerlerine göre manuel/elle yapılandırmanız gerekmektedir. Fakat büyüyen bir ağda bu işlemi gerçekleştirmek zor alacağı için dinamik yönlendirme türlerinden uygun olanı kullanabilirsiniz.

Şimdi, Cisco Packet Tracer ile yönlendiricilere statik rota eklemek için aşağıdaki adımları sırasıyla takip ediniz.

   Adım 1

Simülatör programını açınız ve aşağıdaki görüntüdeki gibi ağ topolojisi oluşturduktan sonra bilgisayarların TCP/IP ayarlarını yapılandırınız.

İki Router'lı Bir Network Tasarımı

   Adım 2

Cisco Router’ın GigabitEthernet ve Serial arayüzlerini yapılandırmak için CLI komut istemini açınız ve aşağıdaki komutları uygulayınız.

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#
R1(config)#interface gigabitethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#
R1(config)#interface serial0/1/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
R1(config-if)#end
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#

R1'in Gig0/0 ve Se0/1/0 Arayüzlerini Yapılandırma

   Adım 3

Aynı şekilde R2 yönlendiricinin de GigabitEthernet ve Serial arayüzlerini aşağıdaki komutlar ile konfigüre ediniz.

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#
R2(config)#interface gigabitethernet 0/0
R2(config-if)#ip address 192.168.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
R2(config-if)#exit
R2(config)#
R2(config)#interface serial 0/1/0
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up
R2(config-if)#end
R2#

R2'nin Gig0/0 ve Se0/1/1 Arayüzlerini Yapılandırma

   Adım 4

Router’lara static rota eklemeden önce, ağ bağlantısını test etmek için PC0’dan varsayılan ağ geçidine ve R1’in Serial arayüzüne ping atınız.

Ping işlemi aşağıdaki gibi başarılı bir şekilde gerçekleşecektir.

PC0'dan R1'e Ping Atma

   Adım 5

Aynı şekilde PC1 üzerinden de varsayılan ağ geçidine ve onun bağlı olduğu R2’nin Serial arayüzüne ping atarak bağlantıyı test ediniz.

PC1'den R2'ye Ping Atma

   Adım 6

PC0’dan Cisco Router R2’nin Serial arayüzüne ve onun 192.168.5.0/24 ağındaki bilgisayara ping attığınızda aşağıdaki görüntüdeki gibi başarısız olacaktır.

PC0'dan R2'ye Ping Atma

   Adım 7

PC1’den de R1’in arayüzlerine ping atınız ve sonucu kontrol ediniz.

PC1'den R1'e Ping Atma

   Adım 8

Ağ ortamında herhangi bir yönlendirme etkinleştirilmediği için iki segmentteki istemciler arasında ping başarısız oldu. Eğer bu ağ dizaynına göre Router’dan Router’a ping atarsanız, sonucun başarılı olduğunu göreceksiniz.

Örneğin, R1’den R2’ye ping aşağıdaki gibi başarılı olacaktır;

R1'den R2'ye Ping Testi

   Adım 9

R2’den R1’e de ping işlemi başarılı olacaktır.

R2'den R1'e Ping Testi

   Adım 10

Şimdi, PC0 ile PC1’i haberleştirebilmek için Router’lara statik rota ekleyiniz. R1’e statik rota eklemek için ip route 192.168.10.0 255.255.255.0 10.1.1.2 komutunu uygulayınız.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#ip route 192.168.10.0 255.255.255.0 10.1.1.2
R1(config)#exit
R1#

R1(config)#ip route 192.168.10.0 255.255.255.0 10.1.1.2

R1 üzerinde Static yönlendirmeyi etkinleştirdikten sonra, show ip route komutunu çalıştırınız ve çıktıda S 192.168.10.0/24 [1/0] via 10.1.1.2 satırının olup olmadığını kontrol ediniz.

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Serial0/1/0
L 10.1.1.1/32 is directly connected, Serial0/1/0
192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/24 is directly connected, GigabitEthernet0/0
L 192.168.5.1/32 is directly connected, GigabitEthernet0/0
S 192.168.10.0/24 [1/0] via 10.1.1.2
R1#

S    192.168.10.0/24 [1/0] via 10.1.1.2 ⇒ Bu satır, PC0’ın 192.168.10.0/24 ağ ortamına 10.1.1.2 IP adresi üzerinden ulaşacağını bildirir.

   Adım 11

R2’ye de statik rota eklemek için şu komutu uygulayınız:

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#
R2(config)#ip route 192.168.5.0 255.255.255.0 10.1.1.1
R2(config)#
R2(config)#exit
R2#

R2(config)#ip route 192.168.5.0 255.255.255.0 10.1.1.1

R2’de show ip route komut çıktısı;

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Serial0/1/0
L 10.1.1.2/32 is directly connected, Serial0/1/0
S 192.168.5.0/24 [1/0] via 10.1.1.1
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, GigabitEthernet0/0
L 192.168.10.1/32 is directly connected, GigabitEthernet0/0
R2#

S    192.168.5.0/24 [1/0] via 10.1.1.1 ⇒ Bu satır, PC1’in 192.168.5.0/24 ağ ortamına 10.1.1.1 IP adresi üzerinden ulaşacağını bildirir.

   Adım 12

Router’larda Static Routing yapılandırdıktan sonra, PC0’dan PC1’e ping atarak bağlantıyı test ediniz. İki farklı lokasyondaki istemciler artık birbirleriyle başarılı bir şekilde iletişim kuracaklardır.

PC0'dan PC1'e Ping Testi

   Adım 13

Aynı şekilde PC1’den PC0’a ping atıldığında ping işlemi aşağıdaki gibi başarılı olacaktır.

PC1'den PC0'a Ping Testi

Show Komutları

R1#show running-config
Building configuration...

Current configuration : 813 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX152494BG
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 10.1.1.1 255.255.255.0
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.10.0 255.255.255.0 10.1.1.2
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end
R1#

 

R2#show running-config
Building configuration...

Current configuration : 793 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524GA8Z
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 10.1.1.2 255.255.255.0
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.5.0 255.255.255.0 10.1.1.1
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R2#

 

   Video

Packet Tracer üzerinde Static Routing etkinleştirmek için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


Bu yazımızda, Cisco simülatör yazılımını kullanarak iki yönlendiriciye statik rotalar ekledik ve iki segmentteki bilgisayarları haberleştirdik. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


Cisco Basit Ağ Oluşturma
♦ Cisco DHCP
♦ Cisco Telnet
♦ Cisco SSH
♦ Cisco Static NAT

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

You cannot copy content of this page