Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma – Bu yazıda Cisco Switch temel yapılandırma ve ilk konfigürasyon için gerekli komutları inceleyeceğiz. Daha sonra, Cisco Switch VLAN oluşturma işlemini tamamlayacağız.
Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

GNS3 ve VMware Workstation programlarını kullanarak Cisco Switch konfigürasyonu adımlarını gerçekleştireceğiz. Cisco Switch’ler Layer2 (Katman2) ve Layer3 (Katman) olmak üzere ikiye ayrılır. OSI Katman2’de çalışan Switchler MAC adresi tablolarını kullanarak bilgisayarların haberleşmesini sağlar. Ayrıca, Katman2 Switch’ler VLAN özelliğine sahiptirler.

Bilgisayarlar ağ üzerinde MAC (ethernet frame) adres çerçevelerini göndererek, Switch’ler MAC adres tablosunu oluştururlar. Ağ ortamında Switch’ler kullanılarak broadcast trağininin önüne geçilir ve böylece ağ trafiğinde performans artışı sağlanır.

Cisco CCNA sınavlarına hazırlanan kişiler, GNS3 veya Cisco Packet Tracer programlarına hakimdirler. Bu programlar Cisco ürünlerini bilgisayarda simüle ederek kullanmaya imkan tanırlar.

Cisco Switch temel yapılandırma adımlarına artık geçebiliriz. Ciscp Switch konfigürasyonu adımlarını takip ederek uygulayabilirsiniz.

Temel Cisco Switch Komutları

Temel Cisco Switch komutları kullanarak, GNS3’te Cisco Switch’i adım adım yapılandıralım.

   Adım 1

Öncelikle GNS3 programını çalıştırınız ve yeni bir proje oluşturunuz. Daha sonra, aşağıdaki görüntüdeki gibi bir topoloji oluşturunuz. Bu topolojide Layer 3 Switch kullanılmıştır. Layer 3 Switch’ler OSI katmanının Network katmanında çalışır.

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

   Adım 2

Switch CLI konsol penceresinde, Cisco Switch temel yapılandırma adımları için gereken komutları uygulamalısınız. Bu adımda Cisco Switch Ip adresi verme, Cisco Switch Telnet konfigürasyonu ve Cisco Switch ilk yapılandırma işlemleri yapılmıştır.

Aşağıdaki komutları Cisco Switch CLI konsolunda giriniz.

[code] ESW1# conf t
ESW1(config)# hostname IT
IT# conf t
IT(config)# interface fastethernet 0/0
IT(config-if)# no shutdown
IT(config-if)# exit
IT(config)# interface fastethernet 0/1
IT(config-if)# no shutdown
IT(config-if)# exit
IT(config)# username cisco password cisco123
IT(config)# line vty 0 4
IT(config-line)# login local
IT(config-line)# transport input telnet
IT(config-line)# exit
IT(config)# enable password 12345
IT(config)# enable secret 123456
IT(config)# service password-encryption
IT(config)# banner motd #
Enter TEXT message. End with the character ‘#’.
###Unauthorized Access###
IT(config)# ip default-gateway 192.168.8.254
IT(config)# end
IT# wr
[/code]

Cisco Switch Ip adresi Verme

Cisco Switch Ip adresi verme, Switch üzerinde varsayılan olarak oluşturulan VLAN1 arayüzüne verilir. VLAN1 yönetim arayüzüdür. Cisco Switch Ip adresi verme konfigürasyonunu VLAN1 arayüzüne uygulamak için aşağıdaki komutu uygulayınız.

[code] IT# conf t
IT(config)# interface vlan1
IT(config-vlan)# ip address 192.168.8.10 255.255.255.0
IT(config-vlan)# no shutdown
IT(config-vlan)# end
IT# wr
[/code]

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

VMware sanallaştırma programı üzerinde sanal makina oluşturmak için, VMware Workstation 12 Sanal Makina Kurulumu adlı yazıyı okuyabilirsiniz…

   Adım 3

VMware Workstation programında sanal bir makina oluşturduktan sonra, Windows 10 veya başka bir işletim sistemi kurabilirsiniz. VMware üzerinde sanal makinayı çalıştırdıktan sonra, Ip ayarlarını kontrol edelim.

Windows Tuşu + R’ye basılı tutarak Çalıştır penceresini açınız ve CMD yazarak Enter tuşuna tıklayınız. CMD komut istemi açılacak ve ipconfig komutu ile Ip yapılandırmasını kontrol edebilirsiniz.

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

   Adım 4

Cisco Switch Ip adresi verme işleminde VLAN arayüzüne Ip adresi vermiştik. Şimdi, VMware sanal makinadan, Cisco Switch VLAN yönetim arayüzüne ping işlemini gerçekleştiriniz.

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

   Adım 5

Ayrıca, Cisco Switch temel yapılandırma adımlarında, Cisco Switch Telnet konfigürasyonu işlemini gerçekleştirmiştik. VMware sanal makinadan, Cisco Switch VLAN yönetim arayüzüne telnet bağlantısını gerçekleştirmek için, CMD komut isteminde telnet 192.168.10.10 komutunu uygulayınız.

Windows üzerinde Telnet’i etkinleştirmek için, Telnet Nedir? Ne İşe Yarar? adlı yazıyı okumanızı öneririm!

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

   Adım 6

Cisco Switch VLAN yönetimi için Telnet bağlantısını gerçekleştirdik. Oluşturulan kullanıcı adı ve parolayı girdikten sonra küresel yapılandırma moduna geçebilirsiniz.

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma


Cisco Switch VLAN Oluşturma

Cisco Switch temel yapılandırma adımları birkaç komuttan oluşmaktadır. Cisco anahtarları daha detaylı kullanmak için VLAN’lar oluşturmamız gereklidir. Cisco Switch VLAN oluşturma sürecinden sonra, VLAN’lar arası bağlantıyı test edeceğiz.

   Adım 1

Cisco Switch VLAN oluşturma sürecinde, Cisco Switch üzerinde ayrıcalıklı mod üzerindeyken show vlan-switch komutunu uyguladıktan sonra, VLAN yapısını görebilirsiniz.

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

   Adım 2

Cisco Router CLI komut penceresini açınız ve FastEthernet 0/0 arayüzünü aşağıdaki görüntüdeki gibi yapılandırınız.

Cisco Router Arayüz Ip Adresi Verme;

[code] R1# conf t
R1(config)# interface fastethernet 0/0
R1(config-if)# ip address 192.168.8.254 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# exit
R1# wr
[/code]

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

Cisco yönlendirici detaylı arayüz yapılandırması için, Cisco Router Ip Adresi Verme adlı yazıyı okuyabilirsiniz…

   Adım 3

VMware sanal makinadan Cisco Router FastEthernet0/0 arayüzüne ping işlemi başarılıdır!

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

   Adım 4

Şimdi, Cisco Switch VLAN oluşturma işlemini gerçekleştireceğiz. Cisco Switch CLI konsolunu çalıştırınız ve aşağıdaki komutları sırasıyla uygulayınız.

Cisco Switch VLAN Oluşturma;

Cisco Switch VLAN oluşturma adımında ayrıcalıklı modda olduğunuzdan emin olunuz.

[code] IT# vlan database
IT(vlan)# vlan 10 name ITVLAN10
VLAN 10 added:
Name: ITVLAN10
IT(vlan)# vlan 20 name ITVLAN20
VLAN 20 added:
Name: ITVLAN10
IT(vlan)# vlan 100 name ITMANAGEMENTVLAN100
VLAN 100 added:
Name: ITMANAGEMENTVLAN100
IT(vlan)# exit
APPLY completed.
Exiting….
IT#
[/code]

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

   Adım 5

Cisco Switch CLI konsolunda show vlan-switch komutunu çalıştırınız ve oluşturduğunuz VLAN’ları kontrol ediniz.

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

   Adım 6

GNS3 çalışma alanına aşağıdaki gibi bir adet VPCS ekleyiniz. Eklediğiniz VPCS’yi Cisco Switch FastEthernet0/10 arayüzüne bağlayınız.

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

   Adım 7

PC1 CLI konsolunu açarak, VPCS’ye Ip adresi atayınız.

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

GNS3’te VPCS nedir? Sorunun cevabı için, GNS3 VPCS Kullanımı adlı yazıyı okuyunuz…

   Adım 8

Cisco Switch VLAN oluşturma işleminden sonra, VPCS’yi bir VLAN’a üye yapmamız gerekir. Cisco Switch VLAN ekleme işlemi hangi arayüze bağlı ise, o arayüzü VLAN’a dahil etmemiz gerekir.

VPCS’yi Cisco Switch FastEthernet0/10 arayüzüne bağladığımız için, FastEthernet0/10 arayüzünü VLAN10’a üye yapmamız gereklidir.

VLAN’ların haberleşmesi için Cisco Router’a bağlanan arayüzde TRUNK konfigürasyonu yapmalıyız.

VPCS Cisco Switch VLAN10 Ayarı

[code] IT# conf t
IT(config)# interface fastethernet 0/10
IT(config-if)# switchport mode access
IT(config-if)# switchport access vlan 10
IT(config-if)# exit
IT(config)# interface fastethernet 0/0
IT(config-if)# switchport mode trunk
IT(config-if)# exit
IT(config)# end
IT# wr
[/code]

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

   Adım 9

Cisco Switch VLAN oluşturma işleminden sonra VLAN’ların haberleşmesi için Cisco Router üzerinde Subinterface oluşmalıyız.

Cisco Router Trunk Konfigürasyonu

Cisco Router Trunk konfigürasyonu için aşağıdaki komutları sırasıyla uygulayınız.

[code] R1# conf t
R1(config)# interface fastethernet 0/0
R1(config-if)# no ip address
R1(config-if)# exit
R1(config)# interface fastethernet 0/0.1
R1(config-if)# ip address 192.168.8.254 255.255.255.0
R1(config-if)# encapsulation dot1Q 1
R1(config-if)# exit
R1(config)# interface fastethernet 0/0.10
R1(config-if)# ip address 192.168.10.254 255.255.255.0
R1(config-if)# encapsulation dot1Q 10
R1(config-if)# exit
R1(config)# end
R1# wr
[/code]

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

   Adım 10

Cisco Switch üzerinde show vlan-switch komutu ile arayüzleri kontrol edelim.

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

   Adım 11

Switch üzerinde show ip interface brief komutu ile arayüzlerin durumlarını kontrol edelim. Yapılandırdığımız arayüzler Up (Açık) durumdadır.

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

   Adım 12

Cisco Router arayüzlerini de aynı komutla kontrol ettiğimizde Cisco arayüzlerinde herhangi bir sorun görünmemektedir.

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

   Adım 13

VPCS üzerinden VMware sanal makinaya ping attığımızda işlemin başarılı olduğunu görebilirsiniz.

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

   Adım 14

VMware sanal makina TCP/IP ayarlarını kontrol edelim. Herhangi bir sorun bulunmamaktadır.

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

   Adım 15

Aynı şekilde, VMware sanal makinadan VPCS’ye ping attığımızda da işlemin başarılı olduğunu görebilirsiniz.

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma

Cisco Switch Temel Yapılandırma Komutları

Cisco Switch Temel KomutlarCisco Switch VLAN OluşturmaCisco Switch Trunk AyarıCisco Router Trunk AyarıVPCS TCP/IP Ayarı

ESW1# conf t
ESW1(config)# hostname IT
IT# conf t
IT(config)# interface fastethernet 0/0
IT(config-if)# no shutdown
IT(config-if)# exit
IT(config)# interface fastethernet 0/1
IT(config-if)# no shutdown
IT(config-if)# exit
IT(config)# username cisco password cisco123
IT(config)# line vty 0 4
IT(config-line)# login local
IT(config-line)# transport input telnet
IT(config-line)# exit
IT(config)# enable password 12345
IT(config)# enable secret 123456
IT(config)# service password-encryption
IT(config)# banner motd #
Enter TEXT message. End with the character ‘#’.
###Unauthorized Access###
IT(config)# ip default-gateway 192.168.8.254
IT(config)# end
IT# wr

IT# vlan database
IT(vlan)# vlan 10 name ITVLAN10
VLAN 10 added:
Name: ITVLAN10
IT(vlan)# vlan 20 name ITVLAN20
VLAN 20 added:
Name: ITVLAN10
IT(vlan)# vlan 100 name ITMANAGEMENTVLAN100
VLAN 100 added:
Name: ITMANAGEMENTVLAN100
IT(vlan)# exit
APPLY completed.
Exiting….
IT#

IT# conf t
IT(config)# interface fastethernet 0/10
IT(config-if)# switchport mode access
IT(config-if)# switchport access vlan 10
IT(config-if)# exit
IT(config)# interface fastethernet 0/0
IT(config-if)# switchport mode trunk
IT(config-if)# exit
IT(config)# end
IT# wr

R1# conf t
R1(config)# interface fastethernet 0/0
R1(config-if)# no ip address
R1(config-if)# exit
R1(config)# interface fastethernet 0/0.1
R1(config-if)# ip address 192.168.8.254 255.255.255.0
R1(config-if)# encapsulation dot1Q 1
R1(config-if)# exit
R1(config)# interface fastethernet 0/0.10
R1(config-if)# ip address 192.168.10.254 255.255.255.0
R1(config-if)# encapsulation dot1Q 10
R1(config-if)# exit
R1(config)# end
R1# wr

PC1> ip 192.168.10.10/24 192.168.10.254

Cisco Switch Temel Yapılandırma ⇒ Video

Cisco Switch temel yapılandırma ve Cisco Switch VLAN oluşturma adımlarını video olarak da izleyebilirsiniz. Ayrıca, YouTube kanalımıza abone olabilirsiniz…

  Son Söz

Cisco Switch Temel Yapılandırma | Cisco Switch VLAN Oluşturma – Sonuç olarak, Cisco Switch komutları gördüğünüz gibi Cisco Router komutları gibidirler. Switch konfigürasyonu adımlarını birkaç komutla tamamladık. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

Cisco Switch Temel Yapılandırma İlgili Yazılar

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

10 + eleven =