Cisco SDM Üzerinde NAT Konfigürasyonu

Cisco Router’lar üzerinde Security Device Manager (SDM) kurarak cihazların web tabanlı yönetimini sağlayabilirsiniz. SDM ile Router üzerinde basit ve gelişmiş ayarları yapabilirsiniz.

Cisco SDM Üzerinde NAT Konfigürasyonu

SDM Kullanarak Router Üzerinde NAT Nasıl Yapılandırılır?

NAT, özel IP adreslerini küresel IP adreslerine dönüştürür ve sonuç olarak yerel ağdaki bilgisayarı İnternet’e çıkarır.

Özel IP adresleri RFC1918‘de tanımlanmıştır.

LAN üzerindeki özel IP adreslerine sahip bilgisayarlar veya cihazlar İnternet’e NAT sayesinde erişirler.

Bu yazımızda, Basic NAT (Temel NAT) yapılandırması için SDM uygulamasını kullanacağız. Eğer daha önce, SDM’i kurmadıysanız, bu yazımıza göz atabilirsiniz.

Security Device Manager ile NAT Konfigürasyonu

SDM ile NAT yapılandırmak için GNS3 ve VMware Workstation programlarını kullanacağız. Dolayısıyla, VMware’de bir sanal makine hazırlayınız ve ağ bağdaştırıcısını Host-Only olarak yapılandırınız.

   Adım 1

GNS3 programını çalıştırdıktan sonra aşağıdaki görüntüdeki gibi basit bir ağ topolojisi oluşturunuz.

GNS3 Üzerinde Ağ Topolojisi Oluşturma

   Adım 2

Sanal makine üzerinden SDM’i açınız ve Router’a bağlanınız. Ya da Router’a bir Browser üzerinden erişim sağlayabilirsiniz.

SDM’e eriştikten sonra, Configure (Yapılandır) seçeneğine tıklayınız.

Cisco SDM / Configure

   Adım 3

Configure sekmesine tıkladıktan sonra, sol bölümde bulunan NAT seçeneğine tıklayınız.

Cisco SDM / NAT

   Adım 4

Basit NAT seçeneğini seçiniz ve ardından Launch the selected task (Seçili görevi başlat) butonuna tıklayınız.

Basic NAT

   Adım 5

NAT Wizard penceresinde Next (İleri) butonuna tıklayınız.

Basic NAT Wizard

   Adım 6

Bu adımda İnternet’e bağlı olan İnterface (Arayüz) seçmeniz gerekir. Çünkü, NAT işleminde İç Bacak ve Dış Bacak yapılandırmanız gerekir.

Choose an interface

   Adım 7

Şimdi, ağ topolojisine göre İnternet’e bağlı olan arayüzü seçiniz.

FastEthernet0/1

   Adım 8

FastEthernet0/1 arayüzünü seçtikten sonra, IP adres aralığını seçmeniz gerekmektedir.

IP Address Range

   Adım 9

NAT için gerekli ayarları yaptıktan sonra Next butonuna tıklayarak devam ediniz.

Sharing the Internet Connection

   Adım 10

Basic NAT komutlarının uygulanması için Finish butonuna tıklayınız.

Summary of the Configuration

   Adım 11

SDM, komutları başarılı bir şekilde Router’a gönderdi!

Command Delivery Status

   Adım 12

SDM üzerinde NAT yapılandırmasının özet bilgilerini inceleyebilirsiniz.

Edit NAT Configuration

   Adım 13

VMware üzerinde kurulu olan sanal makineden Google DNS sunucularına ping işleminin başarılı bir şekilde gerçekleştiğini aşağıdaki gibi kontrol ediniz.

Ping 8.8.8.8

   Adım 14

NAT adres çevirilerini görüntülemek için komut isteminde show ip nat translations komutunu uygulayınız.

Router’ın CLI konsolunda NAT çevirilerini incelediğinizde, 192.168.8.5 IP adresinin 192.168.1.101 IP adresine çevrildiğini görebilirsiniz.

show ip nat translations

   Adım 15

Sanal bilgisayardan Google’a erişim sağladığınızda Cisco Router üzerinde oluşan NAT kayıtlarını inceleyiniz.

Sanal Makinenin İnternet'e Erişmesi

   Adım 16

Yönlendirici üzerinde show ip nat translations komutunu uygulayınız ve çıktıyı kontrol ediniz.

show ip nat translations

   Adım 17

Son olarak, show ip nat statistics komutunu uygulayınız ve çevrime uğrayan işlem sayısını inceleyiniz.

show ip nat statistics

Show Komutları

R1#show running-config
Building configuration...
Current configuration : 1449 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
crypto pki trustpoint TP-self-signed-4279256517
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4279256517
revocation-check none
rsakeypair TP-self-signed-4279256517
!
username ciscosdm privilege 15 secret 5 $1$P8AQ$58kw7DHT7YUj3far7KDoM.
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
ip address 192.168.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.8.0 0.0.0.255
no cdp log mismatch duplex
!
control-plane
!
gatekeeper
shutdown
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login local
transport input telnet
!
end
R1#

 

R1#show ip nat statistics
Total active translations: 85 (0 static, 85 dynamic; 85 extended)
Outside interfaces:
FastEthernet0/1
Inside interfaces:
FastEthernet0/0
Hits: 2977 Misses: 94
CEF Translated packets: 2921, CEF Punted packets: 297
Expired translations: 62
Dynamic mappings:
-- Inside Source
[Id: 1] access-list 1 interface FastEthernet0/1 refcount 85
Appl doors: 0
Normal doors: 0
Queued Packets: 0
R1#

 

R1#show ip nat translations
Pro Inside global Inside local Outside local Outside global
udp 192.168.1.101:49225 192.168.8.5:49225 192.168.1.1:53 192.168.1.1:53
udp 192.168.1.101:49701 192.168.8.5:49701 192.168.1.1:53 192.168.1.1:53
tcp 192.168.1.101:49750 192.168.8.5:49750 23.198.21.99:80 23.198.21.99:80
tcp 192.168.1.101:49751 192.168.8.5:49751 204.79.197.203:80 204.79.197.203:80
tcp 192.168.1.101:49753 192.168.8.5:49753 204.79.197.203:80 204.79.197.203:80
tcp 192.168.1.101:49754 192.168.8.5:49754 151.101.193.108:80 151.101.193.108:80
tcp 192.168.1.101:49755 192.168.8.5:49755 13.107.5.80:80 13.107.5.80:80
tcp 192.168.1.101:49756 192.168.8.5:49756 13.107.5.80:80 13.107.5.80:80
tcp 192.168.1.101:49757 192.168.8.5:49757 195.175.112.105:80 195.175.112.105:80
tcp 192.168.1.101:49758 192.168.8.5:49758 195.175.112.105:80 195.175.112.105:80
tcp 192.168.1.101:49759 192.168.8.5:49759 195.175.112.105:80 195.175.112.105:80
tcp 192.168.1.101:49760 192.168.8.5:49760 195.175.112.105:80 195.175.112.105:80
tcp 192.168.1.101:49761 192.168.8.5:49761 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.101:49762 192.168.8.5:49762 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.101:49763 192.168.8.5:49763 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.101:49764 192.168.8.5:49764 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.101:49765 192.168.8.5:49765 2.17.23.122:80 2.17.23.122:80

 

SDM ile NAT Etkinleştirme ⇒ Video

SDM kullanarak NAT etkinleştirmek için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


Bu yazımızda, ağ üzerindeki bir Router’da SDM ile Network Address Translation nasıl etkinleştirilir inceledik. Bu işlemi, CLI komut istemi kullanarakta gerçekleştirebilirsiniz. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


Cisco SDM Express Kurulumu
♦ GNS3 VM Kurulumu
GNS3 VM’ye Router Ekleme
IOS Yedekleme
Router Konfigürasyonu Yedekleme

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

You cannot copy content of this page