Cisco Packet Tracer Üzerinde SSH Bağlantısı Yapılandırma

SSH (Secure Shell – Güvenli Kabuk), ağ cihazlarının güvenli bir şekilde yönetilmesini sağlar. SSH kullanarak erişim sağladığınız bir ağ cihazına güvenli bir bağlantı kurmuş olursunuz ve ayrıca verileriniz şifreli olarak gönderilir.

Packet Tracer Üzerinde SSH Bağlantısı Yapılandırma

Packet Tracer ile Cisco Router Üzerinde SSH Etkinleştirme

SSH, Telnet protokolüne göre çok daha güvenli bir protokoldür ve varsayılan olarak TCP 22 portunu kullanır. Bağlantı noktası numarası isteğe göre değişebilir.

SSH protokolünün 2 adet sürümü vardır. Bunlar; Version 1 ve Version 2’dir.

SSH V1, birkaç patentli şifreleme algoritmasından yararlanır ve bir saldırganın iletişim akışına veri girmesine olanak tanıyan iyi bilinen bir güvenlik açığına açıktır.

SSH V2, bu sürüm aynı istismara açık olmayan gelişmiş bir anahtar değişim algoritmasına sahiptir ve daha güçlü ve kapsamlı özellikler içerir:

• 3DES ve AES gibi şifreleme.
• Bütünlük kontrolü için ses şifreleme Mesaj Doğrulama Kodu (MAC) algoritmalarının kullanılması.
• Açık anahtar sertifikaları desteği.

Ağ aygıtlarını uzaktan yönetmek için mümkün olduğunca SSH V2 sürümünü kullanmanızı öneririz.

Gerçek senaryoda SSH’ı etkinleştirmek için, Cisco IOS yazılımınızın dosya adında k9(crypto) ifadesinin yer aldığından emin olunuz.

   Adım 1

Öncelikle Packet Tracer programını çalıştırınız ve ardından aşağıdaki görüntüdeki gibi bir ağ topolojisi oluşturunuz. Çalışma alanına ek olarak bir adet daha Router ekleyiniz çünkü yapılandırma sonrasında Router’dan Router’a SSH ile bağlantı sağlayacağız.

Router'dan Router'a SSH

   Adım 2

SYSNETTECH Router’ının üzerine tıklayarak CLI komut istemini açınız ve ilk yapılandırmayı atlamak için No yazarak Enter’a basınız.

IOS Command Line Interface

   Adım 3

Router üzerinde SSH etkinleştirmek için aşağıdaki komutları sırasıyla uygulayınız.

Router>enable
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname SYSNETTECH
SYSNETTECH(config)#interface gigabitethernet 0/0
SYSNETTECH(config-if)#ip address 192.168.1.1 255.255.255.0
SYSNETTECH(config-if)#no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
SYSNETTECH(config-if)#exit
SYSNETTECH(config)#ip domain name sysnettechsolutions.com
SYSNETTECH(config)#crypto key generate rsa
The name for the keys will be: SYSNETTECH.sysnettechsolutions.com
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.
How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]
SYSNETTECH(config)#ip ssh version 2
*Mar 1 0:6:12.698: %SSH-5-ENABLED: SSH 1.99 has been enabled
SYSNETTECH(config)#ip ssh time-out 10
SYSNETTECH(config)#ip ssh authentication-retries 3
SYSNETTECH(config)#line vty 0 4
SYSNETTECH(config-line)#login local
SYSNETTECH(config-line)#privilege level 15
SYSNETTECH(config-line)#transport input ssh
SYSNETTECH(config-line)#exit
SYSNETTECH(config)#username cisco privilege 15 password cisco123
SYSNETTECH(config)#end
SYSNETTECH#wr
Building configuration...
[OK]
SYSNETTECH#

Yönlendiricide SSH Etkinleştirme

   Adım 4

PC1’in IP ayarlarını aşağıdaki gibi yapılandırınız.

PC1'in TCP/IP Ayarlarını Yapılandırma

   Adım 5

R1’in arayüzünü hızlıca yapılandırmak için üzerine çift tıklayınız ve açılan pencerede Config sekmesine tıklayınız ve ardından GigabitEthernet0/0 arayüzünün Port Status (Port Durumu) seçeneğini On (Açık) olarak yapılandırdıktan sonra IP adresi atayınız.

Router'ın Arayüzüne IP Adresi Atama

   Adım 6

SSH’ın çalışıp çalışmadığını test etmek için PC1 komut istemini açınız ve aşağıdaki komutu uygulayarak bağlantı sağlayınız.

ssh -l cisco 192.168.1.1

 

-l : Login anlamına gelmektedir.
cisco : Router'a bağlantı yapmak için kullanılacak kullanıcı adı.
192.168.1.1 : Router'ın IP adresi.

ssh -l cisco 192.168.1.1

   Adım 7

Oluşturduğunuz kullanıcı adını, parolayı yazınız ve Enter’a basar basmaz aşağıdaki görüntüdeki gibi bağlantı gerçekleşmiş olacaktır.

PC'den Router'a SSH ile Bağlanıldı

   Adım 8

PC1 Command Prompt üzerinde show ssh komutunu uyguladıktan sonra, bağlantı yapılan SSH protokolünün sürümünü kontrol edebilirsiniz.

Router'da show ssh komutu kullanımı

   Adım 9

Bu adımda, yönlendiriciden yönlendiriciye SSH yapmak için aşağıdaki komutu uygulayınız.

ssh -l cisco 192.168.1.1

Router Komut Arayüzü

   Adım 10

Aynı şekilde, Cisco Router üzerinde oluşturduğunuz kullanıcı hesap bilgilerini giriniz ve Enter’a basınız.

Router'da SSH Komutunu Kullanma

   Adım 11

Aşağıdaki görüntüde gördüğünüz gibi başarılı bir şekilde SSH bağlantısı gerçekleştirildi.

Router'a Bağlantı Başarılı

Show Komutları

SYSNETTECH#show running-config
Building configuration...

Current configuration : 799 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SYSNETTECH
!
no ip cef
no ipv6 cef
!
username cisco privilege 15 password 0 cisco123
!
license udi pid CISCO1941/K9 sn FTX152488GK
!
ip ssh version 2
ip ssh time-out 10
ip domain-name sysnettechsolutions.com
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login local
transport input ssh
privilege level 15
!
end
SYSNETTECH#

 

SYSNETTECH#show ssh
Connection Version Mode Encryption Hmac State Username
133 1.99 IN aes128-cbc hmac-sha1 Session Started cisco
133 1.99 OUT aes128-cbc hmac-sha1 Session Started cisco
133 1.99 IN aes128-cbc hmac-sha1 Session Started cisco
133 1.99 OUT aes128-cbc hmac-sha1 Session Started cisco
%No SSHv1 server connections running.
SYSNETTECH#

 

SYSNETTECH#show ip ssh
SSH Enabled - version 2.0
Authentication timeout: 10 secs; Authentication retries: 3
SYSNETTECH#

   Video

Simülatör ile yönlendirici üzerinde SSH etkinleştirmek ve PC’den bağlantı sağlamak için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


Bu yazımızda, SSH nasıl etkinleştirilir ve nasıl bağlantı yapılır inceledikten sonra, bağlantıyı doğrulamak için PC’den Router’a ve Router’dan Router’a SSH nasıl yapılır adım adım inceledik. Gerçek senaryoda Router’lar üzerinde SSH yapılandırmak için IOS yazımının k9(crypto) özelliğinin olduğundan emin olunuz. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


Packet Tracer VLAN
Packet Tracer Inter-VLAN
Packet Tracer Static NAT
Packet Tracer Dynamic NAT
Packet Tracer PAT

14 Comments

  1. Avatar for Naseh Naseh 24 Nisan 2018

    Teşekkürler

    Cevapla

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Show Buttons
Hide Buttons