Cisco Packet Tracer Üzerinde NAT PAT Konfigürasyonu

PAT (Port Address Translation – Port Adres Çevirici), özel IP adreslerini küresel IP adreslerine dönüştürürken port numaralarını kullanır.

Cisco Packet Tracer Üzerinde NAT PAT Konfigürasyonu

Cisco Router Üzerinde NAT PAT Yapılandırma

PAT, Static NAT ve Dynamic NAT yapılandırmasına göre en çok kullanılan yöntemdir. Genellikle ev kullanıcıları veya küçük işletmeler tarafından kullanılmaktadır. ADSL Modemler tek bir ISP IP adresi ile İnternet’e erişirler. Yerel ağ üzerinden tüm bilgisayarlar tek bir küresel IP adresi ile İnternet’e erişirken, PAT işlemi uygulanır.

PAT ayrıca NAT Aşırı Yüklemesi olarak da adlandırılır. Yerel ağdaki veya uzak ağdaki bir bilgisayar hedef bilgisayara bir paket gönderdiğinde, IP adresinin yanına port numarası eklenir.

Ev kullanılarının kullandığı ADSL modem cihazı üzerinde PAT varsayılan olarak etkin durumdadır.

Packet Tracer ile PAT özelliğini etkinleştirmek için aşağıdaki adımları sırasıyla takip ediniz.

   Adım 1

Öncelikle Cisco simülatör programını açınız ve aşağıdaki görüntüdeki gibi bir topoloji oluşturduktan sonra cihazlara IP adresleri atayınız ve çalışma alanına açıklamalar ekleyiniz.

IP NAT Inside ve Outside

   Adım 2

PC0 ve PC1’in TCP/IP ayarlarını aşağıdaki gibi yapılandırınız.

Packet Tracer'da PC'lere IP Adresleri Atama

   Adım 3

Cisco Router‘ın CLI komut isteminde PAT’ı etkinleştirmek için aşağıdaki komutları sırasıyla uygulayınız.

Router# conf t
Router(config)# interface gigabitethernet 0/0
Router(config-if)# ip address 192.168.10.1 255.255.255.0
Router(config-if)# ip nat inside
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface gigabitethernet 0/1
Router(config-if)# ip address 10.0.0.1 255.255.255.0
Router(config-if)# ip nat outside
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# access-list 1 permit 192.168.10.0 0.0.0.255
Router(config)# ip nat inside source list 1 interface gigabitethernet0/1 overload
Router(config)# end
Router# wr

NAT Etkinleştirme

   Adım 4

PAT’ı yapılandırdıktan sonra yerel ağ üzerindeki bilgisayarlardan 10.0.0.2 IP adresine Ping atarak ağ bağlantısını test ediniz.

Aşağıdaki görüntüdeki gibi yerel ağdaki bilgisayarlar Cisco Router R1 ile başarıyla bağlantı kurmuştur.

Bilgisayarlar'dan Router'a Ping Testi

   Adım 5

Router0 üzerine tıklayınız ve ayrıcalıklı yapılandırma modunda show IP nat translations komutunu çalıştırınız ve NAT kayıtlarını inceleyiniz.

show IP nat translations

Show Komutları

Router0#show ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 10.0.0.1:1024 192.168.10.20:1 10.0.0.2:1 10.0.0.2:1024
icmp 10.0.0.1:1025 192.168.10.20:2 10.0.0.2:2 10.0.0.2:1025
icmp 10.0.0.1:1026 192.168.10.20:3 10.0.0.2:3 10.0.0.2:1026
icmp 10.0.0.1:1027 192.168.10.20:4 10.0.0.2:4 10.0.0.2:1027
icmp 10.0.0.1:2 192.168.10.10:2 10.0.0.2:2 10.0.0.2:2
icmp 10.0.0.1:3 192.168.10.10:3 10.0.0.2:3 10.0.0.2:3
icmp 10.0.0.1:4 192.168.10.10:4 10.0.0.2:4 10.0.0.2:4

 

Router0#show ip nat statistics
Total translations: 0 (0 static, 0 dynamic, 0 extended)
Outside Interfaces: GigabitEthernet0/1
Inside Interfaces: GigabitEthernet0/0
Hits: 7 Misses: 8
Expired translations: 8
Dynamic mappings:

 

Router0#show running-config
Building configuration...
Current configuration : 772 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524V4OL
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 192.168.10.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.0.0.1 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip nat inside source list 1 interface GigabitEthernet0/1 overload
ip classless
!
ip flow-export version 9
!
!
access-list 1 permit 192.168.10.0 0.0.0.255
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
Router#

 

Router1#show running-config
Building configuration...
Current configuration : 617 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX15247004
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
ip address 10.0.0.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
Router#

   Video

Cisco yönlendirici üzerinde Port Address Translation yapılandırması için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


Bu yazımızda, simülatör yazılımı ile NAT PAT nasıl yapılandırılır inceledik. PAT işlemi en çok kullanılan yöntem olup 64.000’den fazla port numarası kullanır ve yönlendirici adreslerinin tükenmesi çok düşük bir olasılıktır. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


Statik NAT
Dinamik NAT
VLAN Konfigürasyonu
VLAN Yönlendirme
Port Security

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

You cannot copy content of this page