Cisco Packet Tracer Üzerinde Telnet Konfigürasyonu

Bu yazımızda, Cisco Packet Tracer programı ile küçük bir ağ topolojisi oluşturduktan sonra, yerel ağ üzerinden Cisco yönlendiriciye telnet bağlantısını gerçekleştireceğiz.

Cisco Packet Tracer Üzerinde Telnet Konfigürasyonu

Cisco Router Üzerinde Telnet Etkinleştirme ve Yapılandırma

Telnet, Telekomünikasyon Ağı’nın kısaltmasıdır. Bu, bir bilgisayara uzaktan erişmek ve çalıştırmak için kullanılan bir ağ protokolünün adıdır.

Başka bir bilgisayara erişim terminal modunda (herhangi bir grafik arayüzü olmadan) yapılır ve uzaktan sorun gidermeye izin verir, böylece teknisyen söz konusu ekipmana fiziksel olarak yakın olmadan sorunu çözebilir. Telnet ayrıca, UNIX cihazıyla uzaktan veri sorgulamayı veya bir oturum başlatmayı mümkün kılar (bu durumda, birden fazla kullanıcı aynı anda oturum açabilir ve aynı bilgisayarla çalışabilir).

Telnet’in tek dezavantajı ise güvenliktir. Verileri ağ üzerinden şifrelemeden gönderir ve bu da casusların kullanıcı adları ve şifreler gibi verilere erişmesini sağlar. Bu yüzden Secure Shell (SSH) 1990’ların ortalarında bir tür şifreli telnet olarak ortaya çıktı.

Cisco sınavlarına hazırlanmak için kullanılan Packet Tracer yazılımı ile bir Cisco Router üzerinde Telnet’i etkinleştirebilir ve çalışma ortamındaki bilgisayarlardan Router’a erişim sağlayabilirsiniz.

Telnet veya SSH protokolünü etkinleştirmenin en büyük faydası, yönlendiriciye sürekli konsol bağlantısı yapmaya gerek duymamaktır. Böylelikle, yerel ağ üzerinden yönlendiriciye kolaylıkla telnet ile erişim sağlayabilir ve yönetebilirsiniz.

Router üzerinde Telnet yapılandırması için aşağıdaki adımları sırasıyla takip ediniz.

   Adım 1

Packet Tracer çalışma alanı üzerine bir adet Cisco Router, Switch ve Bilgisayar ekledikten sonra tüm cihazları kablolayınız.

Cisco Switch'e Takılı Bir Router ve Bilgisayar

   Adım 2

Cisco Router1’e çift tıklayarak CLI komut istemini açınız ve ilk yapılandırmayı atlamak için No yazınız ve Enter’a basınız.

Cisco Router'ın CLI Komut İstemi

   Adım 3

Cisco yönlendirici üzerinde Telnet’i etkinleştirmek için, aşağıdaki komutları sırasıyla uygulayınız.

Router> enable
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface gigabitethernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#username cisco privilege 15 password cisco123
Router(config)#line vty 0 4
Router(config-line)#login local
Router(config-line)#privilege level 15
Router(config-line)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#wr
Building configuration...
[OK]
Router#

Router'da Telnet'i Etkinleştirme

   Adım 4

Cisco yönlendirici arayüzünü yapılandırdıktan sonra, Telnet bağlantısı için bir kullanıcı adı ve parola oluşturduk. Cisco Router1’e bağlanmadan önce çalışma alanındaki Desktop1’in TCP/IP konfigürasyonunu aşağıdaki gibi yapılandırınız.

Packet Tracer'da PC'nin IP Yapılandırması

   Adım 5

PC üzerine tıkladıktan sonra Desktop tabına ve ardından CMD Command Prompt tıklayınız.

CMD komut isteminde telnet 192.168.1.1 yazınız ve Enter’a basarak cihaza bağlanınız. Bağlantının kurulum sırasında oluşturduğunuz kullanıcı adını ve parolayı giriniz.

CMD Kullanarak Telnet Bağlantısı

   Adım 6

Cisco Router’a bağlandıktan sonra, artık cihazınızı LAN veya WAN üzerinden erişerek yönetebilirsiniz. Cihaza yapılan bağlantıları görüntülemek için ise, show line komutunu çalıştırmanız yeterlidir.

Show Line Komutu Kullanımı

   Adım 7

Cisco yönlendirici üzerindeki açık oturumları inceleyebilirsiniz.

Show Line Komutu

Çalışan Yapılandırma Dosyası

Router#show running-config
Building configuration...

Current configuration : 696 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
username cisco privilege 15 password 0 cisco123
!
license udi pid CISCO1941/K9 sn FTX15241Q66
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login local
privilege level 15
!
end
Router#

   Video

PC’den Telnet aracılığıyla Router’a bağlanabilmek ve yönetebilmek için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


Bu yazımızda, Cisco Telnet konfigürasyonu nasıl yapılır adım adım inceledik. Eğer Telnet’i kapatmak/devre dışı bırakmak istiyorsanız, line vty 0 4 içerisinde transport input ssh (sadece SSH bağlantılarını kabul et) komutunu uygulayabilirsiniz. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


Cisco SSH
Cisco DHCP
Packet Tracer Kullanımı
Packet Tracer Kurulumu
Cisco VLAN

28 Comments

  1. Avatar for Ömer Ömer 24 Nisan 2017

    Çok teşekkürler ssh bağlantısınıda bu şekilde gösterirmisiniz iyi günler

    Cevapla
    • Avatar for tolqabaqci tolqabaqci 25 Nisan 2017

      Rica ederim. Tabiki anlatıma devam edeceğim. Ssh bağlantısı bir sonraki konuydu. Yakında yayınlayacağım. İyi çalışmalar dilerim

      Cevapla
  2. Avatar for Naseh Naseh 23 Nisan 2018

    Teşekkürler

    Cevapla

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

You cannot copy content of this page