Cisco Packet Tracer Üzerinde Static NAT Konfigürasyonu

Bu yazımızda Cisco Packet Tracer ağ simulator programında Cisco yönlendirici üzerinde Static (Statik) NAT nasıl yapılandırılır inceleyeceğiz.

Cisco Packet Tracer Üzerinde Static NAT Konfigürasyonu

Cisco Router Üzerinde Static NAT Yapılandırma

Statik NAT ile, yerel ağdaki bir bilgisayar harici veya isteğe bağlı bir arabirimin bağlantı noktasına bir paket gönderdiğinde, hedef IP adresini güvenlik duvarının arkasındaki bir bağlantı noktası ile eşleştirir.

Böylece özel ağdaki her bilgisayarın İnternete erişmek için atanmış ortak IP adresine sahip olması gerekir. Bunun en büyük dezavantajı ise, Internet’e erişmek istediğiniz her bilgisayar için manuel bir rota eklemeniz gerektiğidir.

Güvenilir veya özel bir arayüze bağlantılar için statik NAT yapılandıramazsınız. Örneğin; VPN bağlantıları.

Bir Cisco yönlendiricide Static NAT yapılandırması için ağ tasarımınıza göre Inside (İç Ağ) ve Outside (Dış Ağ) alanlarını belirlemelisiniz. Yerel ağ için Router’ın iç arayüzünü IP NAT Inside, dış arayüzünü ise IP NAT Outside komutu ile ayarlamanız gerekir.

Packet Tracer’da Cisco Router’da Statik bir NAT kaydı oluşturmak için aşağıdaki adımları takip edebilirsiniz.

   Adım 1

Öncelikle Packet Tracer programını açınız ve aşağıdaki görüntüdeki gibi ağ topolojisi oluşturduktan sonra Inside ve Outside alanlarını belirtiniz ve çalışma alanına açıklamalar ekleyiniz.

Aşağıdaki topolojide, İnternet’e çıkış yapan arayüz GigabitEthernet0/0 olduğu için Outside olarak seçilmiştir.

Ağ Topolojisinde IP NAT Inside ve Outside Kısımlarını Belirleme

   Adım 2

Topoloji için IP bloklarını belirleyip yapılandırdıktan sonra çalışma alanına iki bilgisayar ekleyiniz ve TCP/IP ayarlarını yapılandırınız.

Packet Tracer'daki PC'leri Yapılandırma

   Adım 3

Şimdi, Router0’ın CLI komut isteminde Inside ve Outside arayüzleri seçiniz ve 192.168.10.1 ve 192.168.20.1 IP adreslerine sahip bilgisayarlar için statik kayıt eklemek için aşağıdaki komutları uygulayınız.

Yaptığınız ayarları kaydetmek için privileged modda ( write / wr ) komutunu kullanabilirsiniz.

Router# enable
Router(config)# interface gigabitethernet 0/0
Router(config-if)# ip address 10.0.0.1 255.255.255.252
Router(config-if)# ip nat outside
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface gigabitethernet 0/1
Router(config-if)# ip address  192.168.10.1 255.255.255.0
Router(config-if)# ip nat inside
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# ip nat inside source static 192.168.10.1 10.0.0.1
Router(config)# ip nat inside source static 192.168.20.1 10.0.0.1
Router(config)# end
Router# wr

Yönlendiriciye Statik Bir NAT Kaydı Ekleme

   Adım 4

Şimdi, LAN’daki bilgisayarlardan Router1’e ping atınız ve ardından CLI’da show ip nat translations komutunu kullanarak Router’da oluşturulan NAT kayıtlarını inceleyiniz.

show ip nat translations

Show Komutları

Router#show ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 10.0.0.1:3 192.168.10.20:3 10.0.0.2:3 10.0.0.2:3
icmp 10.0.0.1:4 192.168.10.20:4 10.0.0.2:4 10.0.0.2:4
icmp 10.0.0.1:5 192.168.10.20:5 10.0.0.2:5 10.0.0.2:5
icmp 10.0.0.1:6 192.168.10.20:6 10.0.0.2:6 10.0.0.2:6
--- 10.0.0.1 192.168.10.20 --- ---

 

Router#show running-config
Building configuration...

Current configuration : 768 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524T6MD
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 10.0.0.1 255.255.255.252
ip nat outside
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip nat inside source static 192.168.10.10 10.0.0.1
ip nat inside source static 192.168.10.20 10.0.0.1
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end
Router#

 

Router#show ip nat statistics
Total translations: 3 (2 static, 1 dynamic, 3 extended)
Outside Interfaces: GigabitEthernet0/0
Inside Interfaces: GigabitEthernet0/1
Hits: 11 Misses: 12
Expired translations: 6
Dynamic mappings:

 

Router#show running-config
Building configuration...

Current configuration : 619 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524B4CT
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 10.0.0.2 255.255.255.252
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
Router#

   Video

Cisco yönlendiricide Static NAT etkinleştirmek için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


Bu yazımızda, Packet Tracer kullanarak bir Router üzerinde Statik bir NAT kaydı nasıl oluşturulur inceledik. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


Router’da DHCP Yapılandırması
Router’da Telnet Yapılandırması
Packet Tracer ile Konsol Bağlantısı
♦ Router SSH Bağlantısı
♦ Switch VLAN Konfigürasyonu

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

You cannot copy content of this page