Cisco Packet Tracer PortFast Konfigürasyonu – Cisco Switch’lerde Spanning Tree protokolünü yapılandırırken, STP convergence işleminden istemci bilgisayarları veya sunucuları hariç tutarak bir nebze performans artışı sağlayabiliriz.
Cisco Packet Tracer PortFast Konfigürasyonu

Cisco Packet Tracer PortFast Konfigürasyonu

Cisco Packet Tracer PortFast Konfigürasyonu

Cisco Switch’ler üzerinde PortFast konfigürasyonu yapmamızın en temel mantığı uç noktadaki bir sunucunun STP convergence işlemine uğramadan 50 saniye down süresinden kurtarmaktır. Sunucunun her zaman online olması ve hizmet vermesi sağlanmalıdır. Aksi taktirde bir sunucu için down süresi en kötü etken olacaktır.

Katman 2’de Cisco Switch’leri yapılandırırken oluşabilecek Loop‘ları engellemek amacıyla Spanning Tree Protokolünü konfigüre ederiz. Standart Spanning Tree protokolünü (802.1d) kullanırken ağda performans artışı için PortFast, UplinkFast ve BackboneFast özelliklerini etkinleştiririz.

Bu yazımızda, Cisco Packet Tracer programını kullanarak yedekli bir ağda Cisco Switch’ler üzerinde PortFast konfigürasyonu nasıl yapılır açıklayacağız.

Cisco Switch PortFast Etkinleştirme

Cisco Packet Tracer‘da aşağıdaki görüntüdeki gibi bir ağ topolojisi oluşturunuz. Daha sonra hangi Cisco Switch’ler üzerinde PortFast yapılandıracağımızı birlikle inceleyelim.

   Adım 1

Daha açıklayıcı olması bakımından ağ topolojisi üzerine açıklamalar ekleyebilirsiniz. LenovoPC IP adresi 192.168.1.10 ve Web Sunucu ise 192.168.1.100’dür.

Cisco Packet Tracer PortFast Konfigürasyonu
Yukarıdaki Packet Tracer ağ topolojisinde Cisco Switch’ler yedekli yollara sahiptir ve SW1’in Priority değeri değiştirilerek Root Bridge olduğunu görebilirsiniz.

   Adım 2

Buna ilaveten, LenovoPc adlı istemci bilgisayarı ve bir adette HTTP Sunucumuz vardır. HTTP Server üzerinde DNS ayarlarında cisco.com için A kaydı girilmiştir. Bu işlemi aşağıdaki görüntüdeki gibi yapabilirsiniz;

Cisco Packet Tracer PortFast Konfigürasyonu
   Adım 3

LenovoPC’den cisco.com’a Ping atarak bağlantıyı test ediniz ve daha sonra LenovoPC Web Browser’dan www.cisco.com yazarak siteye ulaşmaya çalışınız.

Cisco Packet Tracer PortFast Konfigürasyonu
   Adım 4

Bu adıma kadar Web Sunucu’yu test etmiş olduk. LenovoPC’den Web Sunucuya bağlantı her zaman aktif olmak zorundadır ve dolayısıyla SW2 ve SW4 üzerindeki FastEthernet 0/10 arayüzlerinde PortFast etkinleştirmeliyiz. Ve ağ üzerinde bir kablo hatası meydana geldiğinde STP Convergence hızlıca tamamlanmalıdır.

Bu yüzden SW3 üzerinde UplinkFast özelliğini etkinleştirmemiz gereklidir. Packet Tracer’da UplinkFast özelliği desteği olmadığı için bu işlemi daha sonra GNS3 üzerinde gerçekleştireceğiz.

SW3 üzerinde UplinkFast özelliği etkinleştirildikten sonra, SW4 FastEthernet 0/10 arayüzünde PortFast etkin olduğu için kablo hatası olsa da Ping işlemi devam edecektir. Sonuç olarak, LenovoPC ve Web Server arasındaki bağlantı kesilmemiş olacaktır.

Burada dikkat edilmesi gereken tek nokta, bu yazıda Standart Spanning Tree Protokolünü değerlendirmekteyiz. Eğer Cisco Packet Tracer’da bu ağ topolojisi ele alınarak Rapid STP protokolünü etkinleştirseydik, UplinkFast otomatik olarak etkinleştirilmiş olacaktı. Çünkü Rapid Spanning Tree protokolü PortFast, UplinkFast ve BackboneFast özelliklerini tek çatı altında toplamaktadır.
Rapid STP sürümünde UplinkFast varsayılan olarak aktif durumdadır.

SW2 Üzerinde PortFast Konfigürasyonu

[code]
SW2# conf t
SW2(config)# interface fastethernet 0/10
SW2(config-if)# spanning-tree portfast
SW2(config-if)# end
[/code]

Cisco Packet Tracer PortFast Konfigürasyonu

SW4 Üzerinde PortFast Konfigürasyonu

[code]
SW4# conf t
SW4(config)# interface fastethernet 0/10
SW4(config-if)# spanning-tree portfast
SW4(config-if)# end
[/code]

Cisco Packet Tracer PortFast Konfigürasyonu

Yukarıda Cisco Switch’ler üzerinde PortFast etkinleştirdiğimizde bize küçük bir uyarı verilmektedir. Yukarıdaki mesajda PortFast özelliğini nerede kullanacağımızı bildirmektedir.

Cisco Packet Tracer PortFast Konfigürasyonu Show Komutları
[su_tabs active=”1″]
[su_tab title=”SW2#show running-config”]
SW2#show running-config
Building configuration…

Current configuration : 1097 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW2
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
spanning-tree portfast
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
end
SW2#
[/su_tab]
[su_tab title=”SW4#show running-config”]
SW4#show running-config
Building configuration…

Current configuration : 1097 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW4
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
spanning-tree portfast
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
end
SW4#
[/su_tab]
[su_tab title=”SW2#show spanning-tree”]
SW2#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address 0001.969B.9621
Cost 4
Port 26(GigabitEthernet0/2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 00D0.5865.9D80
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20

Interface Role Sts Cost Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Gi0/1 Desg FWD 4 128.25 P2p
Gi0/2 Root FWD 4 128.26 P2p
Fa0/24 Desg FWD 19 128.24 P2p
Fa0/10 Desg FWD 19 128.10 P2p

SW2#
[/su_tab]
[su_tab title=”SW4#show spanning-tree”]
SW4#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address 0001.969B.9621
Cost 4
Port 25(GigabitEthernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 00D0.D343.A8E0
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20

Interface Role Sts Cost Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Fa0/10 Desg FWD 19 128.10 P2p
Fa0/24 Altn BLK 19 128.24 P2p
Gi0/1 Root FWD 4 128.25 P2p
Gi0/2 Desg FWD 4 128.26 P2p

SW4#
[/su_tab]
[su_tab title=”SW2#show spanning-tree detail”]
SW2#show spanning-tree detail

VLAN0001 is executing the ieee compatible Spanning Tree Protocol
Bridge Identifier has priority of 32768, sysid 1, 00D0.5865.9D80
Configured hello time 2, max age 20, forward delay 15
Current root has priority 4097
Root port is 26 (GigabitEthernet0/2), cost of root path is 4
Topology change flag not set, detected flag not set
Number of topology changes 0 last change occurred 00:00:00 ago
from FastEthernet0/1
Times: hold 1, topology change 35, notification 2
hello 2, max age 20, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300

Port 10 (FastEthernet0/10) of VLAN0001 is designated forwarding
Port path cost 19, Port priority 128, Port Identifier 128.10
Designated root has priority 128, address 00D0.BCB2.001A
Designated bridge has priority 4097, address 0001.969B.9621
Designated port id is 128.10, designated path cost 19
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 24 (FastEthernet0/24) of VLAN0001 is designated forwarding
Port path cost 19, Port priority 128, Port Identifier 128.24
Designated root has priority 128, address 00D0.BCB2.001A
Designated bridge has priority 4097, address 0001.969B.9621
Designated port id is 128.24, designated path cost 19
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 25 (GigabitEthernet0/1) of VLAN0001 is designated forwarding
Port path cost 4, Port priority 128, Port Identifier 128.25
Designated root has priority 128, address 00D0.BCB2.001A
Designated bridge has priority 4097, address 0001.969B.9621
Designated port id is 128.25, designated path cost 4
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 26 (GigabitEthernet0/2) of VLAN0001 is root forwarding
Port path cost 4, Port priority 128, Port Identifier 128.26
Designated root has priority 128, address 00D0.BCB2.001A
Designated bridge has priority 4097, address 0001.969B.9621
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
SW2#
[/su_tab]
[su_tab title=”SW4#show spanning-tree detail”]
SW4#show spanning-tree detail

VLAN0001 is executing the ieee compatible Spanning Tree Protocol
Bridge Identifier has priority of 32768, sysid 1, 00D0.D343.A8E0
Configured hello time 2, max age 20, forward delay 15
Current root has priority 4097
Root port is 25 (GigabitEthernet0/1), cost of root path is 4
Topology change flag not set, detected flag not set
Number of topology changes 0 last change occurred 00:00:00 ago
from FastEthernet0/1
Times: hold 1, topology change 35, notification 2
hello 2, max age 20, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300

Port 10 (FastEthernet0/10) of VLAN0001 is designated forwarding
Port path cost 19, Port priority 128, Port Identifier 128.10
Designated root has priority 128, address 0030.F2D5.1C19
Designated bridge has priority 4097, address 0001.969B.9621
Designated port id is 128.10, designated path cost 19
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 24 (FastEthernet0/24) of VLAN0001 is alternate blocking
Port path cost 19, Port priority 128, Port Identifier 128.24
Designated root has priority 128, address 0030.F2D5.1C19
Designated bridge has priority 4097, address 0001.969B.9621
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 25 (GigabitEthernet0/1) of VLAN0001 is root forwarding
Port path cost 4, Port priority 128, Port Identifier 128.25
Designated root has priority 128, address 0030.F2D5.1C19
Designated bridge has priority 4097, address 0001.969B.9621
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 26 (GigabitEthernet0/2) of VLAN0001 is designated forwarding
Port path cost 4, Port priority 128, Port Identifier 128.26
Designated root has priority 128, address 0030.F2D5.1C19
Designated bridge has priority 4097, address 0001.969B.9621
Designated port id is 128.26, designated path cost 4
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
SW4#
[/su_tab]
[/su_tabs]

Cisco Packet Tracer PortFast Konfigürasyonu ⇒ Video

Cisco Packet Tracer PortFast konfigürasyonu adımlarını aşağıdaki videoyu izleyerek gerçekleştirebilir ve ayrıca YouTube kanalımıza abone olabilirsiniz…

  Son Söz

Cisco Packet Tracer PortFast Konfigürasyonu – Bu yazımızda Cisco Switch’ler üzerinde PortFast konfigürasyonunu gerçekleştirdik. Cisco Packet Tracer programı çok geniş bir program olmasına rağmen bazı durumlarda kullanışsız olabilmektedir. Switch’lerin PortFast yapılandırmasını anlamanız için Packet Tracer üzerinde istemci ve sunucu’ya takılan ağ kablosunu çıkarıp taktığınızda daha iyi anlayabilirsiniz. Bu konuyu GNS3 programında daha detaylı bir şekilde ele alacağız. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

Cisco Packet Tracer PortFast Konfigürasyonu İlgili Yazılar

[su_box title=”İlgili Yazılar” box_color=”#242424″ radius=”0″]
♦ Cisco Packet Tracer VLAN Konfigürasyonu
♦ Cisco Packet Tracer VLAN Yönlendirme
♦ Cisco Packet Tracer Port Security Konfigürasyonu
♦ Cisco Packet Tracer Cisco Router IOS Kurtarma
 Cisco Packet Tracer TFTP IOS Kopyalama
[/su_box]

Cisco Packet Tracer PortFast Konfigürasyonu İlgili PKT Dosyası

[su_box title=”İlgili Dosya” box_color=”#242424″ radius=”0″]

Bu yazıda kullanılan Packet Tracer PKT çalışma dosyasını aşağıdaki butondan bilgisayarınıza indirebilirsiniz.

[su_button url=”http://bit.ly/PortFast-PKT” target=”blank” style=”flat” background=”#7ad03a” size=”6″ center=”yes” icon=”icon: cloud-download” icon_color=”#ffffff” text_shadow=”0px 0px 0px #000000″ rel=”nofollow”]PKT Dosyasını İndir[/su_button]

[/su_box]

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir