Cisco Packet Tracer Kullanarak Cisco Switch Üzerinde PortFast Konfigürasyonu

Cisco Switch’lerde Spanning Tree protokolünü yapılandırırken, STP convergence işleminden istemci bilgisayarları veya sunucuları hariç tutarak performans artışı elde edebilirsiniz.

Cisco Packet Tracer Üzerinde PortFast Konfigürasyonu

Cisco Switch PortFast Yapılandırma

Switch’ler üzerinde PortFast kullanımının en temel mantığı uç noktadaki bir sunucuyu STP convergence işlemine uğramadan 50 saniye down süresinden kurtarmaktır. Sunucunun her zaman online olması ve hizmet vermesi sağlanmalıdır. Aksi taktirde bir sunucu için down süresi en kötü etken olacaktır.

Katman 2’de Switch’leri yapılandırırken oluşabilecek Loop’ları engellemek amacıyla Spanning Tree Protokolünü konfigüre ederiz. Standart Spanning Tree protokolünü (802.1d) kullanırken ağda performans artışı için PortFast, UplinkFast ve BackboneFast özelliklerini etkinleştiririz.

Bu yazımızda, Cisco Packet Tracer programını kullanarak yedekli bir ağda Switch’ler üzerinde PortFast yapılandıracağız.

PortFast Etkinleştirme

Öncelikle, Cisco Packet Tracer‘da Adım 1’deki gibi bir ağ topolojisi oluşturunuz.

   Adım 1

Daha açıklayıcı olması bakımından ağ topolojisi üzerine açıklamalar ekleyebilirsiniz. Örneğin; LenovoPC IP adresi 192.168.1.10 ve Web Sunucu ise 192.168.1.100’dür.

Dört Cisco Switch'li Bir Ağ Topolojisi

Yukarıdaki ağ topolojisinde Switch’lerin yedekli yollara sahip olduğunu ve ayrıca SW1’in Priority değerinden yola çıkarak Root Bridge olduğunu inceleyebilirsiniz.

   Adım 2

Buna ilaveten, ağ topolojisinde LenovoPC adlı istemci bilgisayarı ve bir adette HTTP sunucusu vardır. HTTP Server üzerinde DNS ayarlarında cisco.com için A kaydı girilmiştir. Bu işlemi aşağıdaki görüntüdeki gibi yapabilirsiniz;

Packet Tracer'da DNS Yapılandırması

   Adım 3

LenovoPC’den cisco.com’a Ping atarak bağlantıyı test ediniz ve daha sonra Web Browser’dan www.cisco.com yazarak siteye ulaşmaya çalışınız.

Websitesine Ping Atma

   Adım 4

Bu adıma kadar Web Sunucu’yu test ettik!

LenovoPC’den Web Sunucuya bağlantı her zaman aktif olmak zorundadır ve dolayısıyla ağ üzerinde bir kablo hatası meydana geldiğinde STP Convergence hızlıca gerçekleşmesi için SW2 ve SW4 üzerindeki FastEthernet 0/10 arayüzlerinde PortFast etkinleştirmelisiniz.

SW4 FastEthernet 0/10 arayüzünde PortFast etkin olduğu için kablo hatası olsa da veri transferi devam edecektir ve sonuç olarak, istemci ile sunucu arasındaki bağlantı kesilmemiş olacaktır.

Burada dikkat edilmesi gereken tek nokta, bu yazıda Standart Spanning Tree Protokolünü değerlendirmekteyiz. Eğer bu ağ topolojisi ele alınarak Rapid STP protokolünü etkinleştirseydik, UplinkFast otomatik olarak etkinleştirilmiş olacaktı. Çünkü RST protokolü PortFast, UplinkFast ve BackboneFast özelliklerini bir arada barındırmaktadır.

Rapid STP sürümünde UplinkFast varsayılan olarak aktif durumdadır.

SW2 Yapılandırma

SW2# conf t
SW2(config)# interface fastethernet 0/10
SW2(config-if)# spanning-tree portfast
SW2(config-if)# end

Port-Fast Etkinleştirme

SW4 Yapılandırma

SW4# conf t
SW4(config)# interface fastethernet 0/10
SW4(config-if)# spanning-tree portfast
SW4(config-if)# end

SW4'ü Yapılandırma

PortFast etkinleştirdiğinizde bu özelliği nerede kullanacağınızı bildiren yukarıdaki görüntüdeki gibi bir uyarı göreceksiniz.

Show Komutları

SW2#show running-config
Building configuration...

Current configuration : 1097 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW2
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
spanning-tree portfast
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
end
SW2#

 

SW4#show running-config
Building configuration...

Current configuration : 1097 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW4
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
spanning-tree portfast
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
end
SW4#

 

SW2#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address 0001.969B.9621
Cost 4
Port 26(GigabitEthernet0/2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 00D0.5865.9D80
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi0/1 Desg FWD 4 128.25 P2p
Gi0/2 Root FWD 4 128.26 P2p
Fa0/24 Desg FWD 19 128.24 P2p
Fa0/10 Desg FWD 19 128.10 P2p

SW2#

 

SW4#show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address 0001.969B.9621
Cost 4
Port 25(GigabitEthernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 00D0.D343.A8E0
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 20

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/10 Desg FWD 19 128.10 P2p
Fa0/24 Altn BLK 19 128.24 P2p
Gi0/1 Root FWD 4 128.25 P2p
Gi0/2 Desg FWD 4 128.26 P2p

SW4#

 

SW2#show spanning-tree detail
VLAN0001 is executing the ieee compatible Spanning Tree Protocol
Bridge Identifier has priority of 32768, sysid 1, 00D0.5865.9D80
Configured hello time 2, max age 20, forward delay 15
Current root has priority 4097
Root port is 26 (GigabitEthernet0/2), cost of root path is 4
Topology change flag not set, detected flag not set
Number of topology changes 0 last change occurred 00:00:00 ago
from FastEthernet0/1
Times: hold 1, topology change 35, notification 2
hello 2, max age 20, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300
Port 10 (FastEthernet0/10) of VLAN0001 is designated forwarding
Port path cost 19, Port priority 128, Port Identifier 128.10
Designated root has priority 128, address 00D0.BCB2.001A
Designated bridge has priority 4097, address 0001.969B.9621
Designated port id is 128.10, designated path cost 19
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
Port 24 (FastEthernet0/24) of VLAN0001 is designated forwarding
Port path cost 19, Port priority 128, Port Identifier 128.24
Designated root has priority 128, address 00D0.BCB2.001A
Designated bridge has priority 4097, address 0001.969B.9621
Designated port id is 128.24, designated path cost 19
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
Port 25 (GigabitEthernet0/1) of VLAN0001 is designated forwarding
Port path cost 4, Port priority 128, Port Identifier 128.25
Designated root has priority 128, address 00D0.BCB2.001A
Designated bridge has priority 4097, address 0001.969B.9621
Designated port id is 128.25, designated path cost 4
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
Port 26 (GigabitEthernet0/2) of VLAN0001 is root forwarding
Port path cost 4, Port priority 128, Port Identifier 128.26
Designated root has priority 128, address 00D0.BCB2.001A
Designated bridge has priority 4097, address 0001.969B.9621
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
SW2#

 

SW4#show spanning-tree detail

VLAN0001 is executing the ieee compatible Spanning Tree Protocol
Bridge Identifier has priority of 32768, sysid 1, 00D0.D343.A8E0
Configured hello time 2, max age 20, forward delay 15
Current root has priority 4097
Root port is 25 (GigabitEthernet0/1), cost of root path is 4
Topology change flag not set, detected flag not set
Number of topology changes 0 last change occurred 00:00:00 ago
from FastEthernet0/1
Times: hold 1, topology change 35, notification 2
hello 2, max age 20, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300

Port 10 (FastEthernet0/10) of VLAN0001 is designated forwarding
Port path cost 19, Port priority 128, Port Identifier 128.10
Designated root has priority 128, address 0030.F2D5.1C19
Designated bridge has priority 4097, address 0001.969B.9621
Designated port id is 128.10, designated path cost 19
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 24 (FastEthernet0/24) of VLAN0001 is alternate blocking
Port path cost 19, Port priority 128, Port Identifier 128.24
Designated root has priority 128, address 0030.F2D5.1C19
Designated bridge has priority 4097, address 0001.969B.9621
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 25 (GigabitEthernet0/1) of VLAN0001 is root forwarding
Port path cost 4, Port priority 128, Port Identifier 128.25
Designated root has priority 128, address 0030.F2D5.1C19
Designated bridge has priority 4097, address 0001.969B.9621
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default

Port 26 (GigabitEthernet0/2) of VLAN0001 is designated forwarding
Port path cost 4, Port priority 128, Port Identifier 128.26
Designated root has priority 128, address 0030.F2D5.1C19
Designated bridge has priority 4097, address 0001.969B.9621
Designated port id is 128.26, designated path cost 4
Timers: message age 16, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
SW4#

   Video

Switch’lerde PortFast kullanımı için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


Bu yazımızda Cisco ağ simülatör yazılımı ile Switch’ler üzerinde PortFast nasıl konfigüre edilir inceledik. Yapılandırdığınız bu özelliği test etmek için istemci veya sunucunun ağ kablosunu çıkarıp tekrar taktığınızda daha iyi anlayabilirsiniz. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


VLAN Konfigürasyonu
VLAN Yönlendirme
Port Security
IOS Kurtarma
IOS Kopyalama

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Show Buttons
Hide Buttons