Cisco Packet Tracer Üzerinde VLAN Konfigürasyonu

VLAN (Sanal LAN) yapısı, fiziksel ağ topolojierini mantıksal ağ bölümlerine ayırmak için kullanılır. VLAN’lar yapılandırıldığında, fiziksel ağ ortamının daha performanslı çalışması sağlanır ve ayrıca daha iyi bir ağ yönetimi elde edilir.

Cisco Packet Tracer Üzerinde VLAN Konfigürasyonu

Packet Tracer ile Cisco Switch Üzerinde VLAN Oluşturma ve Yapılandırma

Fiziksel bir network ortamında, belirli bir konumda bulunan kullanıcıları VLAN‘lar ile mantıksal alanlara ayırabilirsiniz. Örneğin, 3 katlı bir şirketin her bir katında finans departmanı bulunuyorsa, katlar arasındaki bu departmanları haberleştirebilmeniz için VLAN’ı konfigüre edebilirsiniz.

Gerçek senaryoda, bu işlemi yaptığınızda, kullanıcılar bu değişiklikten etkinlenmezler. Sadece, mevcut ağı mantıksal olarak gruplara ayırarak daha fazla ağ performansı elde etmiş olursunuz ve aynı zamanda, VLAN grupları arasındaki veri trafiğini kısıtlayabilirsiniz.

Şimdi, simülatör yazılımını kullanarak Switch’ler üzerinde VLAN oluşturmak ve konfigüre etmek için aşağıdaki adımları takip edebilirsiniz.

   Adım 1

Öncelikle, Packet Tracer çalışma ortamına bir adet Router, Switch ve altı adet PC ekleyerek aşağıdaki görüntüdeki gibi bir ağ topolojisi oluşturunuz.

3 Ayrı VLAN'lı Bir Ağ Topolojisi

   Adım 2

Cisco Router’ın arayüzünü ve bilgisayarların TCP/IP ayarlarını yapılandırdıktan sonra Switch üzerine tıklayınız ve açılan pencerede CLI sekmesine tıklayınız. Privileged moda geçmek için enable komutunu uygulayınız.

Cisco Switch'in CLI Komut İstemini Açma

   Adım 3

Temel ayarları yaptıktan sonra, şimdi Switch üzerinde oluşturduğunuz topolojiye göre 3 farklı VLAN grubu oluşturunuz. Topolojiye göre VLAN oluşturmak için aşağıdaki komutları uygulayınız.

Switch# conf t
Switch(config)# hostname SWITCH
SWITCH(config)# vlan 10
SWITCH(config-vlan)# name VLAN10
SWITCH(config-vlan)# exit
SWITCH(config)# vlan 20
SWITCH(config-vlan)# name VLAN20
SWITCH(config-vlan)# exit
SWITCH(config)# vlan 30
SWITCH(config-vlan)# name VLAN30
SWITCH(config-vlan)# exit

VLAN Oluşturma

   Adım 4

Departmanlar için VLAN’lar oluşturduktan sonra, Switch’in arayüzüne bağlanan istemcileri VLAN’lara üye yapmanız gerekir.

Cisco Switch üzerinde ayrıcalıklı yapılandırma modundan, küresel yapılandırma moduna (config mode) geçiş yapınız.

Kırmızı bölgedeki istemcileri VLAN10’a atamak için aşağıdaki komutları sırasıyla uygulayınız.

SWITCH# conf t
SWITCH(config)# interface fastethernet 0/1
SWITCH(config-if)# switchport mode access
SWITCH(config-if)# switchport access vlan 10
SWITCH(config-if)# exit
SWITCH(config)# interface fastethernet 0/2
SWITCH(config-if)# switchport mode access
SWITCH(config-if)# switchport access vlan 10
SWITCH(config-if)# exit
SWITCH(config)# end

Switch Portlarını VLAN'lara Atama

   Adım 5

Mavi bölgedeki istemcileri VLAN20’a atamak için aşağıdaki komutları sırasıyla uygulayınız.

SWITCH# conf t
SWITCH(config)# interface fastethernet 0/3
SWITCH(config-if)# switchport mode access
SWITCH(config-if)# switchport access vlan 20
SWITCH(config-if)# exit
SWITCH(config)# interface fastethernet 0/4
SWITCH(config-if)# switchport mode access
SWITCH(config-if)# switchport access vlan 20
SWITCH(config-if)# exit
SWITCH(config)# end

VLAN20'ye Switch Portlarını Ekleme

   Adım 6

Yeşil bölgedeki istemcileri VLAN20’a atamak için aşağıdaki komutları sırasıyla uygulayınız.

SWITCH# conf t
SWITCH(config)# interface fastethernet 0/5
SWITCH(config-if)# switchport mode access
SWITCH(config-if)# switchport access vlan 30
SWITCH(config-if)# exit
SWITCH(config)# interface fastethernet 0/6
SWITCH(config-if)# switchport mode access
SWITCH(config-if)# switchport access vlan 30
SWITCH(config-if)# exit
SWITCH(config)# end

VLAN30'a Switch Portlarını Ekleme

   Adım 7

Switchportlarını VLAN’lara ekledikten sonra, show vlan komutu ile Switch üzerindeki oluşturduğunuz ve üye yaptığınız arayüzleri kontrol ediniz.

Switch Üzerinde Show VLAN Komutu Kullanımı

   Adım 8

PC0 ve PC1’in ağ kablosunun bağlı olduğu Switchportları VLAN10’a üye olduğu için bu bilgisayarlar arasında ping testi yaptığınızda bağlantının olduğunu göreceksiniz.

Aynı VLAN'daki Bilgisayarlar Arasında Ping İşlemi

   Adım 9

Ayrı VLAN’lara sahip bilgisayarlar arasında ping testi yaptığınızda işlemin başarısız olduğunu göreceksiniz.

PC0’dan VLAN20’ya üye olan PC2’ye ping testi;

VLAN10'dan VLAN20'ye Ping Atma

   Adım 10

PC0’dan VLAN30’ya üye olan PC4’ye ping attığınızda, ping işlemi başarısız olacaktır. Ping işleminin başarısız olmasının sebebi, VLAN’lar arasında bir yönlendirme yapılmamış olmasıdır.

NOT: Katman 2 anahtar üzerinde VLAN’ları yapılandırdığınızda, eğer ortamda bir Router varsa, Inter-VLAN yapılandırması yapmanız gerekir.

VLAN10'dan VLAN30'a Ping Atma

VLAN’lara Yönetim IP Adresi Atama

VLAN’lara yönetim IP adresi vererek, cihazlarınızı yerel veya uzak ağdan kontrol edebilirsiniz.

Bir Router’ın arayüzüne IP adresi vermek için ilgili portun yapılandırma modunda ip address komutu kullanılır. Switch’te ise IP vereceğiniz VLAN’ın yapılandırmasına geçilerek bu işlem gerçekleştirilir.

Oluşturulan her VLAN için bir management IP verilebilir.

Ağ topolojisini ele alarak, VLAN10, VLAN20 ve VLAN30 için yönetim adresleri eklemek için şu adımları takip ediniz:

   Adım 1

CLI’da önce configure terminal komutunu ve ardından ilgili VLAN’nın ayarlarını yapmak için interface (vlan’ın adı) komutunu uygulayınız.

SWITCH#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SWITCH(config)#interface vlan 10
SWITCH(config-if)#
%LINK-5-CHANGED: Interface Vlan10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
SWITCH(config-if)#ip address 192.168.10.100 255.255.255.0
SWITCH(config-if)#no shutdown
SWITCH(config-if)#exit
SWITCH(config)#
SWITCH(config)#interface vlan 20
SWITCH(config-if)#
%LINK-5-CHANGED: Interface Vlan20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
SWITCH(config-if)#ip address 192.168.20.100 255.255.255.0
SWITCH(config-if)#no shutdown
SWITCH(config-if)#exit
SWITCH(config)#
SWITCH(config)#interface vlan 30
SWITCH(config-if)#
%LINK-5-CHANGED: Interface Vlan30, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to up
SWITCH(config-if)#ip address 192.168.30.100 255.255.255.0
SWITCH(config-if)#no shutdown
SWITCH(config-if)#end
SWITCH#

VLAN'lara Yönetim IP Adresi Ekleme

   Adım 2

Switch’te show ip interface brief komutu ile arayüzlere ait IP adreslerini ve port durumlarını inceleyebilirsiniz.

Switch Üzerinde show ip interface brief Komutunu Çalıştırma

   Adım 3

PC0’dan VLAN 10 yönetim IP adresine (192.168.10.100) ping işlemi aşağıdaki gibi başarılı olacaktır.

PC'den VLAN'nın Yönetim IP'sine Ping Atma

   Adım 4

PC0’dan VLAN 20 ve VLAN 30 IP adreslerine (192.168.20.100 ve 192.168.30.100) ping attığınızda işlem başarısız olacaktır.

PC'den Diğer VLAN'ların Yönetim Adreslerini Pingleme

   Adım 5

Son olarak, VLAN20’nin üyesi olan PC2’den yönetim adresine ping attığınızda ping başarılı olacaktır çünkü aynı VLAN’a üye olan istemciler haberleşebilir.

Eğer diğer VLAN’ın yönetim adresine ping atarsanız, işlem yine hatalı olacaktır.

PC'den Diğer VLAN'ları Pingleme

Show Komutları

SWITCH#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24, Gig0/1, Gig0/2
10 VLAN10 active Fa0/1, Fa0/2
20 VLAN20 active Fa0/3, Fa0/4
30 VLAN30 active Fa0/5, Fa0/6
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
30 enet 100030 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

Remote SPAN VLANs
------------------------------------------------------------------------------

Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------
SWITCH#

 

SWITCH#show vlan brief

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24, Gig0/1, Gig0/2
10 VLAN10 active Fa0/1, Fa0/2
20 VLAN20 active Fa0/3, Fa0/4
30 VLAN30 active Fa0/5, Fa0/6
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
SWITCH#

 

SWITCH#show running-config
Building configuration...

Current configuration : 1351 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SWITCH
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
end
SWITCH#

 

SWITCH#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/1 unassigned YES manual up up
FastEthernet0/2 unassigned YES manual up up
FastEthernet0/3 unassigned YES manual up up
FastEthernet0/4 unassigned YES manual up up
FastEthernet0/5 unassigned YES manual up up
FastEthernet0/6 unassigned YES manual up up
FastEthernet0/7 unassigned YES manual down down
FastEthernet0/8 unassigned YES manual down down
FastEthernet0/9 unassigned YES manual down down
FastEthernet0/10 unassigned YES manual down down
FastEthernet0/11 unassigned YES manual down down
FastEthernet0/12 unassigned YES manual down down
FastEthernet0/13 unassigned YES manual down down
FastEthernet0/14 unassigned YES manual down down
FastEthernet0/15 unassigned YES manual down down
FastEthernet0/16 unassigned YES manual down down
FastEthernet0/17 unassigned YES manual down down
FastEthernet0/18 unassigned YES manual down down
FastEthernet0/19 unassigned YES manual down down
FastEthernet0/20 unassigned YES manual down down
FastEthernet0/21 unassigned YES manual down down
FastEthernet0/22 unassigned YES manual down down
FastEthernet0/23 unassigned YES manual down down
FastEthernet0/24 unassigned YES manual down down
GigabitEthernet0/1 unassigned YES manual up up
GigabitEthernet0/2 unassigned YES manual down down
Vlan1 unassigned YES manual administratively down down
Vlan10 192.168.10.100 YES manual up up
Vlan20 192.168.20.100 YES manual up up
Vlan30 192.168.30.100 YES manual up up

   Video

Packet Tracer üzerinde sanal LAN’lar oluşturmak için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


Bu yazımızda, simülatör programı ile bir Cisco Switch’te VLAN’lar nasıl oluşturulur, VLAN’a IP adresi nasıl atanır inceledik. Eğer, VLAN’lar arası veri iletişimini sağlamak isterseniz, Inter-VLAN’ı etkinleştirmelisiniz. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


VLAN Nedir
VLAN Yönlendirme
SSH
Telnet
DHCP Relay Agent

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

You cannot copy content of this page