Cisco Packet Tracer Üzerinde Inter-VLAN Routing (VLAN’lar Arası Yönlendirme) Konfigürasyonu

Cisco Packet Tracer kullanarak bir Switch’te VLAN’lar oluşturduktan sonra, VLAN’lar arasında veri iletişimini sağlamanız gerekir. Layer 2 Switch üzerinde farklı VLAN’lara üye olan istemcileri haberleştirebilmeniz için Inter-VLAN Routing yapılandırmanız gerekir.

Cisco Packet Tracer Üzerinde Inter-VLAN Routing (VLAN'lar Arası Yönlendirme) Konfigürasyonu

Packet Tracer Üzerinde Router-on-a-Stick ile Inter-VLAN Yapılandırması

Router-on-a-Stick Nedir?

Router-on-a-Stick, Inter-VLAN yönlendirmesinin ikinci türüdür ve Router, Switch’e tek bir arayüz ile bağlanır. Router’a bağlanan Switchport, Trunk port olarak konfigüre edilir.

VLAN’lar arası yönlendirmeyi etkinleştirmek için ise, Router’ın Switchport’una bağlı arayüzünde VLAN’ların IP adreslerine göre subinterface’ler oluşturulur ve yönlendirme işlemi sağlanır. Subinterface yapılandırılan arayüz, tüm VLAN’lardan gelen trafiği kabul eder.

Eğer ağ ortamında bir Layer 3 Switch varsa, VLAN’lara arası yönlendirme işlemi için yapmanız gereken tek işlem config modunda ip routing komutunu uygulamaktır.

VLAN yönlendirmeyi etkinleştirmenin diğer bir yolu da Switch’ten Router’a VLAN sayısı kadar kablo takmaktır. Daha fazla kablo kullanılması hem Router üzerindeki boş arayüzlerin sayısının azaltılmasına hem de kablo maliyetinin artmasına neden olacağı için bu yöntem tavsiye edilmemektedir.

Şimdi, Cisco simülatör yazılımı üzerinde Adım 1’deki gibi bir ağ topolojisi oluşturunuz. Ağ topolojinizi tasarladıktan sonra, Cisco Switch üzerinde VLAN10, VLAN20 ve VLAN30 adında VLAN’lar oluşturunuz ve yönetim IP adresleri ekleyiniz.

Oluşturduğunuz yeni VLAN’lar arasında yönlendirmeyi etkinleştirmek için aşağıdaki adımları sırasıyla takip ediniz.

Cisco Switch Üzerinde VLAN Yönlendirme

   Adım 1

Aşağıdaki görüntüdeki gibi bir ağ topolojisi oluşturduktan sonra, Inter-VLAN Routing için Router üzerine tıklayınız ve CLI’yı açınız.

VLAN'lara Ayrılmış Bir Ağ Topolojisi

   Adım 2

Cisco Router’ın CLI komut isteminde, Switch’e bağlanan arayüzü için Subinterface’ler oluşturmak için aşağıdaki komutları uygulayınız.

Subinterface oluştururken, ilgili arayüzün port ve slot numarası yanına karışıklık olmaması için VLAN ID’sinin numarasını yazabilirsiniz. Örneğin; gigabitethernet0/0.10, VLAN10’a hedeflenmiş bir subinterface’dir.

Router#conf t
Router(config)# interface gigabitethernet0/0
Router(config-if)# no ip address
Router(config-if)# no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
Router(config-if)# exit
Router(config)# interface gigabitethernet0/0.10
%LINK-5-CHANGED: Interface GigabitEthernet0/0.10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.10, changed state to up
Router(config-subif)# encapsulation dot1q 10
Router(config-subif)# ip address 192.168.10.1 255.255.255.0
Router(config-subif)# exit
Router(config)# interface gigabitethernet0/0.20
%LINK-5-CHANGED: Interface GigabitEthernet0/0.20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.20, changed state to up
Router(config-subif)# encapsulation dot1q 20
Router(config-subif)# ip address 192.168.20.1 255.255.255.0
Router(config-subif)# exit
Router(config)# interface gigabitethernet0/0.30
%LINK-5-CHANGED: Interface GigabitEthernet0/0.30, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.30, changed state to up
Router(config-subif)# encapsulation dot1q 30
Router(config-subif)# ip address 192.168.30.1 255.255.255.0
Router(config-subif)# end
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router# wr
Building configuration...
[OK]
Router#

Cisco Router Üzerinde Subinterface Oluşturma

   Adım 3

Cisco Router üzerinde Subinterface oluşturduktan sonra, CLI komut isteminde show ip interface brief komutunu uygulayarak Subinterface’lerin durumunu kontrol ediniz.

show ip interface brief

   Adım 4

Çalışma alanındaki PC0’a tıklayınız ve açılan pencereden Command Prompt açınız. PC0’dan VLAN20 ve VLAN30’a üye olan PC’lere ping attığınızda işlemin başarız olduğunu göreceksiniz.

Ping işleminin başarısız olmasının sebebi, Cisco Router’a bağlı olan Cisco Switch Gig0/1 arayüzünün TRUNK olarak yapılandırılmamasıdır.

Trunk Port Olmadan Ping Testi

   Adım 5

Cisco Switch üzerinde GigabitEthernet0/1 arayüzünü TRUNK port olarak yapılandırmak için ilgili arayüzün config modunda switchport mode trunk komutunu uygulayınız.

Switch# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface gigabitethernet 0/1
Switch(config-if)# switchport mode trunk
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
Switch(config-if)# end
%SYS-5-CONFIG_I: Configured from console by console
Switch# wr
Building configuration...
[OK]

Cisco Switch'in Router'a Bağlı Arayüzünü Trunk Olarak Yapılandırma

   Adım 6

VLAN yönlendirme adımlarını tamamladıktan sonra, PC0 üzerinden diğer VLAN’lara üye olan PC’lere ping attığınızda işlemin başarılı olduğunu görebilirsiniz.

Trunk Etkin Olduğunda Ping Testi

Show Komutları

Router# show ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 unassigned YES unset up up
GigabitEthernet0/0.10 192.168.10.1 YES manual up up
GigabitEthernet0/0.20 192.168.20.1 YES manual up up
GigabitEthernet0/0.30 192.168.30.1 YES manual up up
GigabitEthernet0/1 unassigned YES unset administratively down down
Vlan1 unassigned YES unset administratively down down

 

Switch# show interfaces gigabitEthernet 0/1 switchport
Name: Gig0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none
Switch#

 

Router# show running-config
Building configuration...
Current configuration : 891 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX15243C2U
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!
interface GigabitEthernet0/0.30
encapsulation dot1Q 30
ip address 192.168.30.1 255.255.255.0
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end

 

Switch# show running-config
Building configuration...
Current configuration : 1638 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 0002.4ad8.4b01
ip address 192.168.10.100 255.255.255.0
!
interface Vlan20
mac-address 0002.4ad8.4b02
ip address 192.168.20.100 255.255.255.0
!
interface Vlan30
mac-address 0002.4ad8.4b03
ip address 192.168.30.100 255.255.255.0
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
Switch#

   Video

Switch üzerinde Inter-VLAN yapılandırma için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


Bu yazımızda, Packet Tracer simülatör programı ile bir Switch üzerinde Inter-VLAN yönlendirme nasıl yapılır adım adım inceledik. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


Cisco Statik NAT
Cisco Dinamik NAT
♦ Cisco NAT PAT
♦ Ubuntu Packet Tracer
♦ Cisco Port Güvenliği

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

You cannot copy content of this page