Debian 11 Üzerinde GNS3 2.2 (2.2.32) Kurulumu

Bu yazımızda, Linux dağıtımları arasında ün salmış Debian 11 Bullseye işletim sistemi kurulu bir bilgisayarda Cisco sınavlarına profesyonel olarak hazırlanmak için kullanılan GNS3 (Graphical Network Simulator 3) ağ yazılımı nasıl kurulur ve kullanılır inceleyeceğiz.

Debian 11 Üzerinde GNS3 2.2 (2.2.32) Kurulumu

Debian 11 Bullseye Üzerinde Cisco Router/Switch Çalıştırmak için GNS3 2.2 (2.2.32) Nasıl Kurulur?

Bilgisayar ağlarının temelini oluşturan cihazları sanal ortamda kullanabilmeniz için GNS3 gibi ağ simülatör programlarından birini kullanmanız gerekir. GNS3 yazılımı gerçek bir Cisco Router veya Switch cihazını bilgisayarınızda emüle ederek çalıştırabilmenizi sağlar.

GNS3 ağ emülatörünü Windows, Linux veya macOS platformlarına kolayca kurabilir ve temel veya gelişmiş bir ağ topolojisi oluşturabilirsiniz. Fakat bir ağ cihazı eklemeniz gerektiğinden İnternet’teki farklı kaynaklardan veya bu yazımızda yayınladığımız IOS imajlarından birini GNS3’e eklemeniz gerekir.

Microsoft’tun Windows işletim sistemi yerine bir Debian sistemi kullanıyorsanız yazılımın kurulum aşamaları için temel seviyede Linux komutlarına hakim olmalısınız. Windows sistemlerinde herhangi bir programın kurulumu oldukça basittir, fakat Linux sisteminde dağıtıma göre uygun komut dizilimini uygulamanız gerekir.

GNS3’ün kurulum talimatlarını resmi websitesinde yayınlanan rehberlere göz atarak gerçekleştirebilirsiniz. Fakat, bazen kurulum sırasında bağımlı paketlerini de kurmanız gerekebileceğinden daha detaylı teknik makalelere göz atma ihtiyacınız olabilir.

GNS3 İndirme ve Kurma

Debian’ın 11 Bullseye sürümüne ağ simülatör programını kurmadan önce repo adreslerinizi güncellemeniz ve ardından pip3 aracılığıyla PyPI (Python Package Index) üzerinden yazılımı indirip kurmanız gerekir.

   Adım 1

Debian sisteminizde Activities (Aktiviteler) kısmından terminali aratınız, bulunuz ve çalıştırınız. Gnome masaüstü ortamınızda terminal’i açtıktan sonra “sudo apt update” komutunu yürütünüz ve yazılım listesini güncelleyiniz.

sudo apt update

Debian Paket Listesini Güncelleme

   Adım 2

Repo adreslerini tazeledikten sonra GNS3’ü pip3 kullanarak sisteminize indireceğiniz için python3 ve ek paketleri kurmak için terminalde alttaki komutu yürütünüz.

sudo apt install python3-pip python3-pyqt5 python3-pyqt5.qtsvg python3-pyqt5.qtwebsockets qemu qemu-kvm qemu-utils libvirt-clients libvirt-daemon-system virtinst wireshark xtightvncviewer apt-transport-https ca-certificates curl gnupg2 software-properties-common -y

Python ve Gerekli Paketleri Kurma

   Adım 3

GNS3 ağ yazılımını bilgisayarınıza pip3 kullanarak indirmek ve kurmak için terminalde “sudo pip3 install gns3-server gns3-gui” komutunu yürütünüz ve indirme işlemin tamamlanmasını bekleyiniz.

sudo pip3 install gns3-server gns3-gui

Pip3 ile GNS3 İndirme ve Kurma

   Adım 4

GNS3 için gerekli Dynamips yazılımını da kurmanız gerekir, aksi takdirde Router veya Switch imajlarını bilgisayarınızda emüle edemeyeceksiniz.

Debian havuzundan Dynamips’i indirmek ve kurmak için terminalde alttaki komutları yürütünüz.

wget http://ftp.us.debian.org/debian/pool/non-free/d/dynamips/dynamips_0.2.14-1_amd64.deb
sudo dpkg -i dynamips_0.2.14-1_amd64.deb

Dynamips İndirme ve Kurma

   Adım 5

Linux bilgisayarınıza GNS3 ağ yazılımını kurduktan sonra başlat menüsünde onu bulunuz ve çalıştırınız.

GNS3'ü Çalıştırma

   Adım 6

GNS3’ü açtıktan sonra karşınıza Setup Wizard (Kurulum Sihirbazı) çıkacaktır. Bu pencerede, IOS imajlarını yerel sunucuda mı yoksa sanal sunucuda mı çalıştıracağınızı seçmeniz gerekir.

IOS cihazlarını Localhost üzerinde çalıştırmak için Run appliances on my local computer (Cihazları yerel bilgisayarımda çalıştır) seçeneğini işaretleyiniz ve Next’e tıklayınız.

Run Appliances on My Local Computer

   Adım 7

Local Server Configuration (Yerel Sunucu Yapılandırması) penceresinde Server Path (Sunucu Yolu) ayarını değiştirmeyiniz ve Host Binding ayarının localhost olduğunu kontrol ettikten sonra Next’e tıklayınız.

Ayrıca, sisteminizde kurulu 3. parti başka bir yazılım varsa ve TCP 3080 portunu kullanıyorsa, yazılımın doğru çalışması için port numarasını değiştirebilirsiniz.

Host Binding Ayarını Localhost Olarak Yapılandırma

   Adım 8

Local Server Status (Yerel Sunucu Durumu) penceresinde bağlantısının başarılı olduğunu kontrol ettikten sonra Next’e tıklayınız. Summary (Özet) penceresinde ise yaptığınız ayarları gözden geçiriniz ve sihirbazı kapatınız.

Yerel Sunucu Ayarlarını Kontrol Etme

Cisco IOS İmajı Ekleme

Debian bilgisayarınıza GNS3 kurduktan sonra ve yerel sunucu bağlantısını yaptıktan sonra yapmanız gereken tek şey programa bir Router veya Switch IOS imajı eklemektir.

   Adım 1

GNS3 programının araç menüsünden Edit (Düzenle) / Preferences (Tercihler) seçeneğine tıklayınız.

GNS3'e Cisco IOS İmajı Ekleme

   Adım 2

Preferences penceresinde birden fazla ayarın olduğunu sol panelden inceleyebilirsiniz. IOS cihazı eklemek için Dynamips altında IOS Routers seçeneğine tıklayınız ve ardından New (Yeni) butonuna tıklayarak sihirbazı açınız.

New IOS Router Template (Yeni IOS Yönlendirici Şablonu) sihirbazı açıldığında IOS dosyasını eklemek için Browse (Gözat) tıklayınız.

IOS Ekleme Sihirbazını Açma

   Adım 3

Bilgisayarınıza indirdiğiniz c7200-adventerprisek9-mz.152-4.M7.bin IOS dosyasını veya başka bir dosyayı seçiniz ve açınız.

Router IOS'u Seçme

   Adım 4

IOS imajının sıkıştırmasını açmayı onaylamak için Yes tıklayınız ve decompress işlemini bekleyiniz.

IOS Sıkıştırmasını Açma

   Adım 5

IOS konumunu belirttikten sonra Next’e tıklayınız ve diğer ayarlara geçiniz.

İmaj Konumunu Kontrol Etme

   Adım 6

Name and Platform (İsim ve Platform) penceresinde Name kısmında seçtiğiniz IOS cihazının adını görebilirsiniz. Eğer programa birden fazla aynı cihaz modeli ekleyeceksiniz Name kısmından cihaz adını değiştiriniz ve platformunu düzenleyiniz.

Platformu Düzenleme

   Adım 7

Host bilgisayarınızın RAM boyutuna göre Router IOS cihazının daha verimli ve performanslı çalışabilmesi için uygun bir bellek boyutu yapılandırınız.

Router İçin Bellek Boyutu Yapılandırma

   Adım 8

Eklediğiniz Router cihazına eklemek istediğiniz ek arayüzler varsa Network Adapters (Ağ Bağdaştırıcıları) penceresinde Slot kısımlarından seçebilirsiniz.

Yönlendiriciye Ağ Bağdaştırıcı Ekleme

   Adım 9

Idle-PC değeri, IOS cihazının bilgisayarınızın işlemcisini %100 kullanmaması için gerekli bir yapılandırmadır. Bu yüzden, PC’nizin performansına bağlı olarak c7200 için Idle-PC değeri belirlemek için Idle-PC Finder butonuna tıklayınız ve uygun değerin bulunmasını bekleyiniz.

Idle-PC Değeri Bulma

   Adım 10

Router c7200 cihazını ekledikten sonra Server (Sunucu) ayarını kontrol ettiğinizde cihazın Localhost’ta çalışacağını görebilirsiniz.

Sunucu Değerini Kontrol Etme

uBridge Hatasını Giderme

GNS3 mantıksal çalışma alanına eklediğinzi Router ile Switch aygıtlarını birbirine kablolamaya çalıştığınızda uBridge hatası ile karşılaşabilirsiniz. Bu hatanın nedeni, uBridge paketinin Linux dağıtımınızın sürümü ile uyumlu olmamasıdır.

   Adım 1

Switch ile Router bağlantısını yaparken alttaki görseldeki gibi “Error while creating link: uBridge is not available, path doesn’t exist, or you just installed GNS3 and need to restart your user session to refresh user permissions.” hatası alabilirsiniz.

Error while creating link: uBridge is not available, path doesn't exist, or you just installed GNS3 and need to restart your user session to refresh user permissions.

uBridge Hatası

   Adım 2

Debian sisteminizde uBridge hatasını gidermek için öncelikle gerekli paketleri kurmanız gerekir. Libpcap paketini kurmak için terminalde “sudo apt install libpcap-dev -y” komutunu yürütünüz.

sudo apt install libpcap-dev -y

Libpcap Paketini Kurma

   Adım 3

Libpcap paketini kurduktan sonra uBridge paketini Git aracılığıyla indirmek ve derlemek için sisteminize Git yazılımını da kurmanız gerekir. Git’i kurmak için terminalde “sudo apt install git -y” komutunu yürütünüz.

sudo apt install git -y

Git Paketini Kurma

   Adım 4

Github üzerinden uBridge klonlamak için terminalde önce “cd ~/Downloads” komutu ile Downloads (İndirilenler) konumuna gidiniz ve ardından “git clone https://github.com/GNS3/ubridge.git” komutunu yürütünüz.

uBridge klonladıktan “cd ubridge” komutu ile klasör içerisine geçiniz ve dizin içerisinde onu derlemek için “make” komutunu yürütünüz.

cd ~/Downloads
git clone https://github.com/GNS3/ubridge.git
cd ubridge
make

uBridge Paketini Debian'a Klonlama

   Adım 5

Son olarak gerekli izinleri ve ayarları yapılandırmak için terminalde “sudo make install” komutunu yürütünüz.

sudo make install

uBridge Kurma

No path to a VPCS executable has been set Hatasını Giderme

uBridge sorununu giderdikten sonra çalışma alanındaki tüm cihazları çalıştırdığınızda topolojiye eklediğiniz VPCS’ler kullandığınız Linux dağıtımına göre bazen çalışmamaktadır.

   Adım 1

Topolojideki tüm cihazları çalıştırdığınızda alttaki görseldeki gibi “No path to a VPCS executable has been set” hatası alacaksınız. Bunun sebebi, VPCS cihazının doğru olarak kurulmamasından kaynaklıdır.

No path to a VPCS executable has been set

No path to a VPCS executable has been set

   Adım 2

Debian bilgisayarınızda VPCS kurmak için terminalde “sudo apt install vpcs” komutunu yürütünüz.

sudo apt install vpcs

VPCS'yi Kurma

VPCS Executable Version Hatasını Giderme

VPCS’yi kurduktan sonra tekrar ağ cihazlarını çalıştırdığınızda bu kez VPCS sürümü ile ilgili bir hata alabilirsiniz. Sanal bilgisayarın versiyon sürümü hatası Debian 11 sürümünden kaynaklanmaktadır.

   Adım 1

Topolojideki VPCS’leri çalıştırdığınızda alttaki görseldeki “VPCS executable version must be >= 0.6.1 but not a 0.8” hatası alacaksınız ve cihazları çalıştıramayacaksınız.

VPCS executable version must be >= 0.6.1 but not a 0.8

   Adım 2

Linux platformlarında VPCS sorunu gidermek için uygun bir versiyonu indirip kurmanız gerekir. VPCS 0.8.1 sürümünü kurmak için terminalde sırasıyla alttaki komutları yürütünüz.

cd ~/Downloads
git clone https://github.com/TolgaBagci/vpcs_0.8-1_amd64.deb.git
cd vpcs_0.8-1_amd64.deb
sudo dpkg -i vpcs_0.8-1_amd64.deb

VPCS'yi İndirme ve Kurma

   Adım 3

VPCS’nin eski sürümünü de kurduktan sonra artık topolojideki tüm cihazların sorunsuz olarak çalıştığını görebilirsiniz.

Tüm Ağ Cihazlarının Sorunsuz Çalıştığını Kontrol Etme

Bir Ağ Topolojisi Oluşturma

GNS3 yazılımını kullanarak basit ve profesyonel bir ağ tasarımı oluşturarak ağdaki bilgisayarların nasıl haberleştiğini analiz edebilirsiniz.

   Adım 1

GNS3 araç menüsünden New simgesine veya CTRL + N’ye tıklayarak proje sihirbazını açınız. Tasarlayacağınız ağ topolojisine uygun bir isim veriniz ve kaydetmek istediğiniz konumu belirtiniz ve OK’a tıklayınız.

Yeni Bir Proje Oluşturma

   Adım 2

Projenize iki adet c7200 Router cihazı eklemek için sol panelden Routers cihazlarına tıklayınız ve cihazı çalışma alanına sürükleyip bırakınız.

Çalışma Alanına İki Adet Cisco Router Ekleme

   Adım 3

Switches kategorisinden Ethernet Switch’i seçiniz ve çalışma alanına iki adet Switch ekleyiniz.

Çalışma Alanına İki Adet Cisco Switch Ekleme

   Adım 4

All Devices (Tüm Aygıtlar) kategorisini açınız ve çalışma alanına iki adet VPCS (Virtual PC Simulator) ekleyiniz.

Çalışma Alanına İki Adet VPCS Ekleme

   Adım 5

Topolojideki Router’ların boş portlarına Serial Interface eklemek için üzerlerinde sağ tuş / Configure (Yapılandır) seçeneğine tıklayınız.

Router'ın Ayarlarını Açma

   Adım 6

Node Properties penceresinde Slots sekmesinde Adapters kısmındaki Slot1 portuna PA-4T+ (Seri Arayüz) ekleyiniz ve OK’a tıklayınız.

Router'a Serial Arayüz Ekleme

   Adım 7

Router’lara seri arayüz ekledikten sonra VPCS’leri Switch’lere bağlamak için kablolama seçeneğini aktif ediniz ve kablonun bir ucunu PC’lerin Ethernet0 portuna diğer ucunu ise Switch’lerin boş portlarından birine takınız.

VPCS'leri Switch'lere Bağlama

   Adım 8

Aynı şekilde, Switch’leri Router’lara bağlamak için kablonun bir ucunu Switch’lere diğer ucunu ise Router’ların FastEthernet0/0 portlarına takınız.

Switch'leri Router'lara Bağlama

   Adım 9

Cisco Router’ları birbirine bağlamak için kablonun bir ucunu R1’in Serial 1/0 portuna diğer ucunu ise R2’nin Serial 1/0 portuna takınız.

Router'ları Serial Port ile Bağlama

   Adım 10

Tüm cihazları kabloladıktan sonra onları çalıştırmak için araç menüsünden yeşik ok’a tıklayınız ve açılan pencerede Yes’e tıklayınız.

Tüm Ağ Cihazlarını Çalıştırma

   Adım 11

VPCS PC’lere statik IP adresleri eklemek için üzerlerine tıklayarak CLI komut istemini açınız ve PC1 ve PC2’nin TCP/IP ayarlarını yapılandırınız.

PC1> ip 192.168.1.10/24 192.168.1.1
PC1> show ip
PC1> ip 192.168.2.20/24 192.168.2.1
PC1> show ip

VPCS'lere IP Adresi Atama

   Adım 12

Cisco Router’ların FastEthernet portlarına IP adresleri atamak ve onları açmak için CLI’da alttaki komutları yürütünüz.

R1# conf t
R1(config)# interface fastethernet 0/0
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# no shutdown
R2# conf t
R2(config)# interface fastethernet 0/0
R2(config-if)# ip address 192.168.2.1 255.255.255.0
R2(config-if)# no shutdown

Router'ların FastEthernet Portlarına IP Adresi Atama

   Adım 13

Router R1 ve R2’yi Serial Interface portu ile bağladığınız için o portları da yapılandırınız.

R1# conf t
R1(config)# interface serial 1/0
R1(config-if)# ip address 192.168.3.1 255.255.255.0
R1(config-if)# no shutdown
R2# conf t
R2(config)# interface serial 1/0
R2(config-if)# ip address 192.168.3.2 255.255.255.0
R2(config-if)# no shutdown

Router'ların Serial Portlarına IP Adresi Atama

   Adım 14

PC’lerden Router’ların dış seri portlarına ping attığınızda ağ bağlantısının olduğunu görebilirsiniz.

PC1> ping 192.168.3.1
PC2> ping 192.168.3.2

PC'lerden Serial Arayüzlere Ping Atma

   Adım 15

Fakat, Router’larda RIPv1/v2, IGRP, EIGRP veya OSPF yönlendirme protokollerinden birini veya bir statik rota yapılandırılmadığı için PC’lerden birbirine ping atamayacaksınız ve alttaki görseldeki gibi Destination host unreachable hatası alacaksınız.

PC1> ping 192.168.2.20
PC2> ping 192.168.1.10

Yönlendirme Protokolü Olmadan PC'ler Arasındaki Ağ Bağlantısını Kontrol Etme

   Adım 16

Router’larda EIGRP protokolünü yapılandırarak her iki alt ağdaki bilgisayarlara bağlantı kurabilirsiniz. Router R1 ve R2 CLI komut isteminde EIGRP etkinleştirmek için alttaki komutları yürütünüz.

R1# conf t
R1(config)# router eigrp 10
R1(config-router)# network 192.168.3.0 0.0.0.255
R1(config-router)# network 192.168.1.0 0.0.0.255
R2# conf t
R2(config)# router eigrp 10
R2(config-router)# network 192.168.3.0 0.0.0.255
R2(config-router)# network 192.168.2.0 0.0.0.255

Router'larda EIGRP Protokolünü Etkinleştirme

   Adım 17

EIGRP protokolünü yapılandırdıktan sonra tekrar PC’lerden birbirlerine ping attığınızda ağ bağlantısının başarılı olduğunu görebilirsiniz.

EIGRP Yapılandırdıktan Sonra PC'lerden Birbirlerine Ping Atma

GNS3 Kaldırma

Linux işletim sisteminizden GNS3 yazılımını kaldırmak istiyorsanız kurulum aşamasında kurduğunuz gerekli paketleri de kaldırmanız gerekir.

   Adım 1

GNS3 ile yaptığınız projeleri yedekledikten sonra terminali açınız ve programı kaldırmak için “sudo pip3 uninstall gns3-server gns3-gui -y” komutunu yürütünüz.

sudo pip3 uninstall gns3-server gns3-gui -y

GNS3 Kaldırma

   Adım 2

Debian sisteminizden VPCS ve Dynamips kaldırmak için de terminalde “sudo apt purge vpcs -y && sudo apt purge dynamips -y” komutunu yürütünüz.

sudo apt purge vpcs -y && sudo apt purge dynamips -y

VPCS ve Dynamips Kaldırma

   Adım 3

GNS3 ile ilgili tüm bağımlı paketleri sisteminizden silmek için terminalde “sudo apt purge python3-pip python3-pyqt5 python3-pyqt5.qtsvg python3-pyqt5.qtwebsockets qemu qemu-kvm qemu-utils libvirt-clients libvirt-daemon-system virtinst wireshark xtightvncviewer apt-transport-https ca-certificates curl gnupg2 software-properties-common -y” komutunu yürütünüz.

sudo apt purge python3-pip python3-pyqt5 python3-pyqt5.qtsvg python3-pyqt5.qtwebsockets qemu qemu-kvm qemu-utils libvirt-clients libvirt-daemon-system virtinst wireshark xtightvncviewer apt-transport-https ca-certificates curl gnupg2 software-properties-common -y

GNS3 ile İlgili Python ve Diğer Paketleri Kaldırma

   Adım 4

GNS3’ü kaldırdıktan sonra sisteminizde hala kurulu olan gereksiz paketleri de kaldırmak ve silmek için terminalde “sudo apt autoremove && sudo apt autoclean” komutunu yürütünüz.

sudo apt autoremove && sudo apt autoclean

Gereksiz Paketleri Kaldırma ve Temizleme

   Adım 5

Son olarak, sisteminizde indirdiğiniz uBridge ve VPCS kurulum dosyalarını da siliniz.

sudo rm -rf ~/Downloads/ubridge
sudo rm -rf ~/Downloads/vpcs_0.8-1_amd64.deb

uBridge ve VPCS Dosyalarını Silme

   Video

Eski Sürümlerin Kurulumu

   Debian 8 Jessie

deb http://ppa.launchpad.net/gns3/ppa/ubuntu trusty main
deb-src http://ppa.launchpad.net/gns3/ppa/ubuntu trusty main
sudo apt-get update
sudo apt-get install gns3-gui gns3-server -y

   Debian 9 Stretch

deb http://ppa.launchpad.net/gns3/ppa/ubuntu xenial main
deb-src http://ppa.launchpad.net/gns3/ppa/ubuntu xenial main
sudo apt-get update
sudo apt-get install gns3-gui gns3-server -y

   Debian 10 Buster

sudo apt install -y python3-pip python3-pyqt5 python3-pyqt5.qtsvg python3-pyqt5.qtwebsockets qemu qemu-kvm qemu-utils libvirt-clients libvirt-daemon-system virtinst wireshark xtightvncviewer apt-transport-https ca-certificates curl gnupg2 software-properties-common -y
sudo pip3 install gns3-server gns3-gui

Eski Sürümlerin Kurulumu – Video

Debian Versiyon
YouTube Video
Slayt
9 / 2.1
11 / 2.2 (YENİ)

 

   İlgili Yazılar


macOS’ta GNS3 Kurulumu
GNS3 İçin vIOS-L2 İndir
Kali’de GNS3 Kurulumu
Ubuntu’da GNS3 Kurulumu
Linux Mint’te GNS3 Kurulumu

Add a Comment

E-posta hesabınız yayımlanmayacak.

error: