How to Configure Telnet in Cisco Packet Tracer

In this article, after creating a small network topology with the Packet Tracer program, we will make a telnet connection to the router over the local network.

How to Configure Telnet in Cisco Packet Tracer

How to Enable Telnet on a Cisco Router

Telnet stands for Telecommunication Network. This is the name of a network protocol used to remotely access and operate a computer.

Access to another computer is done in terminal mode (without any graphical interface) and allows remote troubleshooting so that the technician can solve the problem without being physically close to the equipment in question. Telnet also makes it possible to query data remotely or start a session with the UNIX device (in this case, multiple users can log on simultaneously and work with the same computer).

The only disadvantage of Telnet is security. It sends data over the network without encrypting it, allowing spies to access data such as user names and passwords. Therefore, Secure Shell (SSH) emerged as a kind of encrypted telnet in the mid-1990s.

With PT software used to prepare for exams, you can setup Telnet on a Router and access the Router from computers in the work environment.

The biggest benefit of enabling Telnet or SSH protocol is that there is no need to make a console connection to the router. This way, you can easily access and manage the router over the local network via telnet.

Follow the steps below to configure Telnet on the router.

   Step 1

After adding a Cisco Router, Switch, and PC on the Packet Tracer workspace, cabling all devices.

A Router and Computer Attached to Cisco Switch

   Step 2

Double-click Cisco Router1 to open the CLI prompt and type No to skip the initial configuration and press Enter.

Cisco Router's CLI Command Prompt

   Step 3

To enable Telnet on the Router, execute the following commands in order.

Router> enable
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface gigabitethernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#username cisco privilege 15 password cisco123
Router(config)#line vty 0 4
Router(config-line)#login local
Router(config-line)#privilege level 15
Router(config-line)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#wr
Building configuration...
[OK]
Router#

 
Enabling Telnet on the Router

   Step 4

After configuring the Cisco Router interface, we created a user name and password for the Telnet connection. Before connecting to Cisco Router1, configure the TCP/IP configuration of Desktop1 in the workspace as follows.

IP Configuration of PC in Packet Tracer

   Step 5

Click on the PC, click the Desktop tab, and then click CMD Command Prompt.

At the CMD prompt, type telnet 192.168.1.1 and press Enter to connect to the device. Enter the user name and password you created during the setup of the connection.

Telnet Connection Using CMD

   Step 6

Once connected to the Cisco Router, you can now manage your device by accessing it through LAN or WAN. To view the connections to the device, simply run the show line command.

Show Line Command Usage

   Step 7

You can review open sessions on the Cisco Router.

Show Line Command

Running-Config File

Router#show running-config
Building configuration...

Current configuration : 696 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
username cisco privilege 15 password 0 cisco123
!
license udi pid CISCO1941/K9 sn FTX15241Q66
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login local
privilege level 15
!
end
Router#

 
   Video

You can watch the video below to connect and manage your Router from your PC via Telnet and also subscribe to our YouTube channel to support us!

   Final Word


In this article, we have examined step-by-step on how to configure Cisco Telnet. If you want to disable Telnet, you can execute the transport input ssh command in line vty 0 4. Thanks for following us!

   Related Articles


Cisco SSH
Cisco DHCP
How to Use Packet Tracer
How to Install Packet Tracer
Cisco VLAN

Add a Comment

Your email address will not be published. Required fields are marked *

You cannot copy content of this page