How to Configure RIP Version 2 (RIPv2) in Cisco Packet Tracer

There are 2 versions of the RIP Routing protocol. RIP Version 1 updates the routing table as Broadcast (255.255.255.255). RIP Version 2 broadcasts as Multicast.

How to Configure RIP Version 2 (RIPv2) in Cisco Packet Tracer

How to Enable RIPv2 on a Router with Packet Tracer

RIPv1 uses Classful routing, is very sensitive to attacks, the entries in RIPv1 contain the IP address and metric of the destination network RIPv2 uses classless routing, authentication with MD5 password.

RIPv2 is defined in RFC 2453 and sends routing table updates as Multicast and supports VLSM and CIDR. RIPv1 uses Broadcast and does not support VLSM and CIDR.

Therefore when configuring RIPV1 all devices must be on the same network. RIP Version 2 does not have such a requirement, and more comprehensive network design can be made.

In this article, we will examine the steps of configuring RIP Version 2 (RIPv2) Routing on the Router to communicate computers or devices in two segments on the simulator software.

   Step 1

Open Packet Tracer and create a network topology that divides the 192.168.5.0/24 network into two segments.

The IP block of the Serial connection between Cisco Router R1 and R2 is 10.1.1.0/30 – 255.255.255.252.

Combining LANs with Two Cisco Routers

   Step 2

Open the CLI command prompt of the Cisco Router R1 and assign IP addresses to the GigabitEthernet0/0 and Serial0/1/0 interfaces and turn on the ports.

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface gigabitethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.128
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
R1(config-if)#ex
R1(config)#interface serial 0/1/0
R1(config-if)#ip address 10.1.1.1 255.255.255.252
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
R1(config-if)#end
R1#

 
Configuring the GigabitEthernet and Serial Interfaces of the Cisco Router R1

   Step 3

Configure the Gig0/1 and Se0/1/1 interfaces of Router R2 as well.

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface gigabitethernet 0/1
R2(config-if)#ip address 192.168.5.129 255.255.255.128
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
R2(config-if)#exit
R2(config)#interface serial 0/1/1
R2(config-if)#ip address 10.1.1.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to up
R2(config-if)#end
R2#

 
Configuring the GigabitEthernet and Serial Interfaces of Cisco Router R2

   Step 4

Test the connection by pinging PC1 to PC2 and R1’s Serial 0/1/0 interface.

Ping from PC1 to PC2, and R1 to Gig0/0 and Serial 0/1/0 Interfaces

   Step 5

Ping from PC1 to Serial and GigabitEthernet interfaces of R2 will fail. Because RIPv2 routing protocol is not enabled on routers!

Ping from PC1 to the GigabitEthernet 0/1 and Serial 0/1/1 Interfaces of R2

   Step 6

Test the network connection by pinging the Router interfaces to which it is connected via PC3 on the 192.168.5.128/25 network.

Ping from PC3 to PC4, and R2's Interfaces

   Step 7

In the above steps, you have examined that the devices on the same network connected to the routers are communicating. Now ping the network connection again to check that it can communicate with computers on two different networks.

Pinging from PC3 to the Router R1’s Serial and GigabitEthernet interfaces will also fail as follows.

Ping from PC3 to R1's Interfaces

   Step 8

Now, to activate RIP Version 2 on routers, first open the CLI prompt of R1 and execute the following commands.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.1.1.0
R1(config-router)#network 192.168.5.0
R1(config-router)#end
R1#

 
Enable RIP on R1

   Step 9

Activate RIP Version 2 on R2 and define the networks connected to the router. Note here the network 192.168.5.128.

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 10.1.1.0
R2(config-router)#network 192.168.5.128
R2(config-router)#end
R2#

 
Enable RIP on R2

   Step 10

After configuring the routing protocol, Pinging over PC1 will now succeed as shown in the image below!

Ping Network

   Step 11

Similarly, check that the network connection is successful by pinging over PC3.

Ping Network

   Step 12

Once you have fully configured RIPv2, execute the show ip route command to check the tables created on the routers and check the Routes.

show ip route

   Step 13

Route records in R2 are as follows.

show ip route

   Step 14

You can see how routing updates are performed by applying the debug ip rip command to verify the routing protocol on Cisco Routers.

As you can see in the image below, you can see that RIP V2 is updating with 224.0.0.9 Multicast address.

debug ip rip

   Step 15

On the Cisco Router R2, it sends updates to the multicast address 224.0.0.9.

debug ip rip

   Step 16

Another way to verify the routing is to use the show ip protocols command.

Execute this command on R1 and check that Routing Protocol is “rip”.

show ip protocols

   Step 17

Similarly, you can use the show ip protocols command on Router R2 to browse the results.

show ip protocols

Show Commands

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/1/0
L 10.1.1.1/32 is directly connected, Serial0/1/0
192.168.5.0/24 is variably subnetted, 3 subnets, 3 masks
R 192.168.5.0/24 [120/1] via 10.1.1.2, 00:00:26, Serial0/1/0
C 192.168.5.0/25 is directly connected, GigabitEthernet0/0
L 192.168.5.1/32 is directly connected, GigabitEthernet0/0
R1#

 

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/1/1
L 10.1.1.2/32 is directly connected, Serial0/1/1
192.168.5.0/24 is variably subnetted, 3 subnets, 3 masks
R 192.168.5.0/24 [120/1] via 10.1.1.1, 00:00:04, Serial0/1/1
C 192.168.5.128/25 is directly connected, GigabitEthernet0/1
L 192.168.5.129/32 is directly connected, GigabitEthernet0/1
R2#

 

R1#debug ip rip
RIP protocol debugging is on
R1#RIP: sending v2 update to 224.0.0.9 via Serial0/1/0 (10.1.1.1)
RIP: build update entries
192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via GigabitEthernet0/0 (192.168.5.1)
RIP: build update entries
10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
192.168.5.0/24 via 0.0.0.0, metric 2, tag 0
R1#

 

R2#debug ip rip
RIP protocol debugging is on
R2#RIP: sending v2 update to 224.0.0.9 via Serial0/1/1 (10.1.1.2)
RIP: build update entries
192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via GigabitEthernet0/1 (192.168.5.129)
RIP: build update entries
10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
192.168.5.0/24 via 0.0.0.0, metric 2, tag 0
R2#

 

R1#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 13 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
Serial0/1/0 2 2
GigabitEthernet0/0 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.5.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
10.1.1.2 120 00:00:02
Distance: (default is 120)
R1#

 

R2#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 27 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
Serial0/1/1 2 2
GigabitEthernet0/1 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.5.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
10.1.1.1 120 00:00:14
Distance: (default is 120)
R2#

 

R1#show running-config
Building configuration...
Current configuration : 834 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX1524GC61
!
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
ip address 192.168.5.1 255.255.255.128
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
network 192.168.5.0
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R1#

 

R2#show running-config
Building configuration...
Current configuration : 816 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX15241561
!
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 192.168.5.129 255.255.255.128
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
ip address 10.1.1.2 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
network 192.168.5.0
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R2#

 

   Video

You can watch the video below to enable RIPv2 on routers and also subscribe to our YouTube channel to support us!

   Final Word


In this article, we have examined step by step how to setup and verify RIP Version 2 (RIPv2) on the Router with Cisco network simulator. Thanks for following us!

   Related Articles


Cisco Telnet
Cisco SSH
Cisco Port Security
Cisco Static Routing
♦ Cisco DHCP

Add a Comment

Your email address will not be published. Required fields are marked *

You cannot copy content of this page