How to Configure EIGRP in Cisco Packet Tracer

EIGRP (Enhanced Interior Gateway Routing Protocol) is a Hybrid Protocol routing protocol specific to Cisco devices only.

How to Configure EIGRP in Cisco Packet Tracer

How to Enable EIGRP on Cisco Router with Packet Tracer

The EIGRP Protocol is both a Distance Vector and Link-State routing protocol and sends routing tables according to the RIP when there is a change in the network. RIP sends routing table updates to neighboring Routers every 30 seconds.

As a result, the RIP protocol uses more network resources and creates additional overhead for routers. EIGRP makes specific updates to a change in the network.

For more information on the EIGRP protocol, please visit https://www.cisco.com/c/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/16406-eigrp-toc.html.

In this article, we will enable EIGRP to communicate computers in two segments with the simulator software.

   Step 1

In the Packet Tracer, create a simple network topology with two Routers as shown in the image below. Identify the IP blocks for the segments and add notes to the workspace so that the design is more understandable.

A Network Topology with Two Cisco Routers

   Step 2

To configure the GigabitEthernet and Serial interfaces of the Cisco Router R1, open the CLI prompt and perform the following commands.

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface gigabitethernet0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#interface serial 0/1/0
R1(config-if)#ip address 10.1.1.1 255.255.255.252
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down

 
Configuring the Interfaces of the Cisco Router R1

   Step 3

Configure the Cisco Router R2 interfaces in the same way.

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface gigabitethernet 0/1
R2(config-if)#ip address 192.168.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
R2(config-if)#exit
R2(config)#interface serial 0/1/1
R2(config-if)#ip address 10.1.1.2 255.255.255.252
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/1/1, changed state to up
R2(config)#

 
Configuring Interfaces for Cisco Router R2

   Step 4

Before configuring EIGRP Routing, test the connection from PC1 to the GigabitEthernet0/0 and Serial0/1/0 interfaces of R1.

Ping from PC1 to R1's GigabitEthernet and Serial Interfaces

   Step 5

In the same way, test the interfaces of Router R2 via PC2 on the 192.168.10.0/24 network.

Ping from PC2 to GigabitEthernet and Serial Interfaces of R2

   Step 6

This time, when you Ping from PC1 to the Serial0/1/1 interface of R2 and PC2, you will see that the process failed. Because no routing protocol is configured in the network environment.

Ping from PC1 to R2

   Step 7

Pinging from PC2 to R1 interfaces will also fail.

Ping from PC2 to R1

   Step 8

To activate the routing protocol, open the CLI prompt of R1 and perform the following commands. The first command to use to enable EIGRP is the router eigrp (AS Number).

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#
R1(config)#router eigrp ?
Autonomous system number
R1(config)#router eigrp 1
R1(config-router)#network 192.168.5.0 ?
A.B.C.D EIGRP wild card bits

R1(config-router)#network 192.168.5.0 0.0.0.255
R1(config-router)#network 10.1.1.0 0.0.0.3
R1(config-router)#end
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#

 
Setting Up EIGRP in R1

   Step 9

Activate the EIGRP protocol on R2.

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#
R2(config)#router eigrp 1
R2(config-router)#network 192.168.10.0 0.0.0.255
R2(config-router)#network 10.1.1.0 0.0.0.3
R2(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 10.1.1.1 (Serial0/1/1) is up: new adjacency
R2(config-router)#end
R2#

 
Enabling EIGRP on Router R2

   Step 10

You can examine the routing table using the show ip route command on R1. The routing protocol is indicated by the letter D as in the following image, and its metric is 90 as well.

show ip route

   Step 11

On Router R2, examine the route table with the show ip route command.

show ip route

   Step 12

After configuring routing on routers, devices in the two segments will now be able to communicate with each other.

Additionally, you can test and troubleshoot routing protocol operation with EIGRP show commands. Example show commands are as follows.

show ip eigrp neighbors
show ip eigrp topology
show ip eigrp traffic

 
EIGRP Show Commands

   Step 13

Use the show commands on Router R2 to view the neighborhood information, topology map, and traffic flow.

EIGRP Show Commands

   Step 14

You can use the debug eigrp packets command in privileged mode to troubleshoot.

debug eigrp packets

 
debug eigrp packets

   Step 15

You can also analyze the packages with debug command on R2.

debug eigrp packets

Show Commands

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/1/0
L 10.1.1.1/32 is directly connected, Serial0/1/0
192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/24 is directly connected, GigabitEthernet0/0
L 192.168.5.1/32 is directly connected, GigabitEthernet0/0
D 192.168.10.0/24 [90/2170112] via 10.1.1.2, 00:00:36, Serial0/1/0
R1#

 

R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/1/1
L 10.1.1.2/32 is directly connected, Serial0/1/1
D 192.168.5.0/24 [90/2170112] via 10.1.1.1, 00:01:03, Serial0/1/1
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, GigabitEthernet0/1
L 192.168.10.1/32 is directly connected, GigabitEthernet0/1
R2#

 

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.1.2 Se0/1/0 11 01:27:25 40 1000 0 3
R1#

 

R1#show ip eigrp topology
IP-EIGRP Topology Table for AS 1/ID(192.168.5.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status

P 10.1.1.0/30, 1 successors, FD is 2169856
via Connected, Serial0/1/0
P 192.168.5.0/24, 1 successors, FD is 2816
via Connected, GigabitEthernet0/0
P 192.168.10.0/24, 1 successors, FD is 2170112
via 10.1.1.2 (2170112/2816), Serial0/1/0
R1#

 

R1#show ip eigrp traffic
IP-EIGRP Traffic Statistics for process 1
Hellos sent/received: 2292/1137
Updates sent/received: 2/2
Queries sent/received: 0/0
Replies sent/received: 0/0
Acks sent/received: 2/2
Input queue high water mark 1, 0 drops
SIA-Queries sent/received: 0/0
SIA-Replies sent/received: 0/0
R1#

 

R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.1.1 Se0/1/1 11 01:35:21 40 1000 0 3
R2#

 

R2#show ip eigrp topology
IP-EIGRP Topology Table for AS 1/ID(192.168.10.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status

P 10.1.1.0/30, 1 successors, FD is 2169856
via Connected, Serial0/1/1
P 192.168.5.0/24, 1 successors, FD is 2170112
via 10.1.1.1 (2170112/2816), Serial0/1/1
P 192.168.10.0/24, 1 successors, FD is 2816
via Connected, GigabitEthernet0/1
R2#

 

R2#show ip eigrp traffic
IP-EIGRP Traffic Statistics for process 1
Hellos sent/received: 2480/1239
Updates sent/received: 2/2
Queries sent/received: 0/0
Replies sent/received: 0/0
Acks sent/received: 2/2
Input queue high water mark 1, 0 drops
SIA-Queries sent/received: 0/0
SIA-Replies sent/received: 0/0
R2#

 

R1#debug eigrp packets
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, ACK )
R1#
EIGRP: Received HELLO on Serial0/1/0 nbr 10.1.1.2
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on Serial0/1/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/0 nbr 10.1.1.2
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on Serial0/1/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/0 nbr 10.1.1.2
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on Serial0/1/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/0 nbr 10.1.1.2
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on Serial0/1/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/0
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

 

R2#debug eigrp packets
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, ACK )
R2#
EIGRP: Sending HELLO on Serial0/1/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/1 nbr 10.1.1.1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on Serial0/1/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/1 nbr 10.1.1.1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on GigabitEthernet0/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on Serial0/1/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/1 nbr 10.1.1.1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

EIGRP: Sending HELLO on GigabitEthernet0/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on Serial0/1/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Sending HELLO on GigabitEthernet0/1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0 iidbQ un/rely 0/0

EIGRP: Received HELLO on Serial0/1/1 nbr 10.1.1.1
AS 1, Flags 0x0, Seq 4/0 idbQ 0/0

 

R1#show running-config
Building configuration...

Current configuration : 835 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
no ip cef
no ipv6 cef
!
license udi pid CISCO1941/K9 sn FTX1524470E
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
network 192.168.5.0
network 10.1.1.0 0.0.0.3
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R1#

 

R2#show running-config
Building configuration...

Current configuration : 817 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO1941/K9 sn FTX152481GS
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
ip address 10.1.1.2 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
network 192.168.10.0
network 10.1.1.0 0.0.0.3

!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
end
R2#

 
   Video

You can watch the video below for configuring EIGRP Routing, and you can also subscribe to our YouTube channel to support us!

   Final Word


In this article, we have configured the EIGRP routing protocol in a topology with two Routers with Cisco network simulator software. It is recommended that you use this Routing protocol in larger network designs. The only disadvantage of this protocol is that it is only used on Cisco devices. Thanks for following us!

   Related Articles


Enabling RIP
Enabling RIP Version 2
Configuring Static Routing
Configuring Cisco DHCP
Creating a Network in Packet Tracer

Add a Comment

Your email address will not be published. Required fields are marked *

error: