How to Configure BackboneFast on Cisco Switch in GNS3

When configuring the Standard Spanning Tree Protocol, we often come across terms such as UplinkFastPortFast, and BackboneFast. These features are specific to the Cisco brand only, and they cannot use with other brands.

How to Configure BackboneFast on Cisco Switch in GNS3

How to Enable BackboneFast on Cisco Switch with GNS3

In Layer 2 Switches, the STP protocol works to prevent loops in the network. In older IOS versions that do not support the Rapid STP protocol, the PVST (Per VLAN Spanning Tree) protocol use. We can briefly call this term the Standard Spanning Tree Protocol.

As a result of a cable failure on a redundancy network, the Spanning Tree Protocol is immediately activated and continues to forward packets. However, you need to configure the STP protocol on Cisco Switches.

To make the standard STP protocol more efficient, you need to enable PortFastUplinkFast, and Backbone Fast.

The BackboneFast (BF) feature provides fast STP Convergence between Switches as a result of a cable failure. When BackboneFast is not enabled on Switches using the conventional STP protocol, the STP convergence time in a link error will last for 50 seconds.

In short, after a BF transaction, the Max-Age Timer time will not evaluate as a result of a link failure, and the 50-second downtime will reduce to 30 seconds.

How to Configure Spanning Tree BackboneFast in GNS3

Before activating BF on the switches, we will take a little test to look at the downtime. Then we will enable this feature in L2 Switches using GNS3 program.

First, you need to perform the GNS3 VM Setup and Cisco IOU Setup. To better understand and configure Backbone Fast, an IOU image is required. Otherwise, you will not be able to review it in detail.

To activate BackboneFast, follow the steps below.

   Step 1

Open the GNS3 program and create a new project for BF configuration.

Creating a New Project in GNS3

   Step 2

At the same time, after installing GNS3 VM, open VMware Workstation.

GNS3 VM

   Step 3

Add 4 L2 Switches to GNS3 workspace.

Adding Layer 2 Switch

   Step 4

Rename the Cisco Switches as follows.

Changing the Hostname

   Step 5

After wiring the Layer 2 Switches, add 2 VPCS computers to the workspace. Select Local for Server selection when adding VPCS.

Selecting a Server

   Step 6

Configure the TCP/IP configuration of VPCS computers, and then initialize all devices.

Configuring VPCS Computers

   Step 7

Check the network connection by pinging from the Lenovo PC to the HP PC. After the ping is successful, go to the next step.

Ping

   Step 8

Configure Switch SW1 as Root Bridge before BF configuration. Then open the SW1 CLI command prompt, and execute show spanning-tree to see if it is Root Bridge.

Also, note the Spanning Tree Port States on the Switches in the workspace.

Root Bridge Selection

   Step 9

After specifying Root Bridge and the Port States, the network topology is as follows.

Port States

   Step 10

Before enabling BF, start continuous pinging from Lenovo PC to HP PC and immediately click the SW3 tab.

Continuous Ping

   Step 11

To generate an Indirect link error, you can close the interface that exits to the HP PC with the shutdown command. Then click the Lenovo PC tab to review the status.

shutdown command usage

   Step 12

After creating a link error, the STP Convergence time will be 50 seconds as you can see in the image below because the BF not configured on the Switch.

You can activate the SW3 Ethernet 0/2 interface with the no shutdown command.

no shutdown command

   Step 13

Open the CLI prompts for the switches and then run the spanning-tree backbonefast command in config mode.

To verify that BF is enabled, use the show spanning-tree summary command.

spanning-tree backbonefast

   Step 14

Also, activate BF on SW2.

Backbone Fast Configuration

   Step 15

In the same way, activate BF on SW3.

SW3 Backbone Fast

   Step 16

Finally, enable BF on Switch SW4 and confirm the configuration with the show spanning-tree summary command.

show spanning-tree summary

   Step 17

After completing the configuration steps, execute the debug spanning-tree backbonefast detail command in Privileged mode to examine how BF works on Cisco Switches.

When an indirect link error occurs in the Switches on the network, the BF will be activated, and the logs of the RLQ BPDU packets will fall to the CLI command prompt.

On all Layer 2 Switches, run the debug spanning-tree backbonefast detail command.

debug spanning-tree

   Step 18

Start continuous pinging on the HP PC again and immediately close the SW3 Ethernet 0/2 interface with the shutdown command.

Ping from PC1 to PC2

   Step 19

As soon as Cisco Switch SW3 closes the Ethernet 0/2 interface, logs will occur on SW1, SW2, and SW4.

Port Down

   Step 20

When we check Ping from Lenovo PC, it has a 30-second downtime. BF was 50 seconds before activation. However, after enabling this feature, we reduced the downtime by 20 seconds to 30 seconds.

Downtime Time

   Step 21

Because the SW3 Root Bridge loses its connection, it sends an inferior BPDU packet to the neighboring SW4 Switch to become the new Root Bridge. SW1 responds to an inferior (RLQ) packet received from SW4 as follows.

inferior BPDU

   Step 22

The SW2 receiving the packet transmits the packet via the Ethernet 0/2 Root port of the SW4.

BPDU Packet

   Step 23

SW4 receives a response to the RLQ packet it has sent and skips the max-age timer to terminate the old interior package received from SW3, saving up to 20 seconds.

max age timer

   Step 24

After completing the configuration steps, you can see the benefit of BF in the Spanning Tree Protocol by reviewing the image below.

BackBone Fast Comparison

Show Commands


SW1#conf t
SW1(config)# spanning-tree vlan 1 priority 4096
SW1(config)# end
SW1#

 


SW1#show spanning-tree

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address aabb.cc00.0100
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 4097 (priority 4096 sys-id-ext 1)
Address aabb.cc00.0100
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0 Desg FWD 100 128.1 Shr
Et0/1 Desg FWD 100 128.2 Shr
Et0/2 Desg FWD 100 128.3 Shr
Et0/3 Desg FWD 100 128.4 Shr
Et1/0 Desg FWD 100 128.33 Shr
Et1/1 Desg FWD 100 128.34 Shr
Et1/2 Desg FWD 100 128.35 Shr
Et1/3 Desg FWD 100 128.36 Shr
Et2/0 Desg FWD 100 128.65 Shr
Et2/1 Desg FWD 100 128.66 Shr
Et2/2 Desg FWD 100 128.67 Shr
Et2/3 Desg FWD 100 128.68 Shr
Et3/0 Desg FWD 100 128.97 Shr
Et3/1 Desg FWD 100 128.98 Shr
Et3/2 Desg FWD 100 128.99 Shr
Et3/3 Desg FWD 100 128.100 Shr

SW1#

 


SW2#show spanning-tree

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address aabb.cc00.0100
Cost 100
Port 1 (Ethernet0/0)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address aabb.cc00.0200
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0 Root FWD 100 128.1 Shr
Et0/1 Desg FWD 100 128.2 Shr
Et0/2 Desg FWD 100 128.3 Shr
Et0/3 Desg FWD 100 128.4 Shr
Et1/0 Desg FWD 100 128.33 Shr
Et1/1 Desg FWD 100 128.34 Shr
Et1/2 Desg FWD 100 128.35 Shr
Et1/3 Desg FWD 100 128.36 Shr
Et2/0 Desg FWD 100 128.65 Shr
Et2/1 Desg FWD 100 128.66 Shr
Et2/2 Desg FWD 100 128.67 Shr
Et2/3 Desg FWD 100 128.68 Shr
Et3/0 Desg FWD 100 128.97 Shr
Et3/1 Desg FWD 100 128.98 Shr
Et3/2 Desg FWD 100 128.99 Shr
Et3/3 Desg FWD 100 128.100 Shr

SW2#

 


SW3#show spanning-tree

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address aabb.cc00.0100
Cost 100
Port 3 (Ethernet0/2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address aabb.cc00.0300
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0 Desg FWD 100 128.1 Shr
Et0/1 Desg FWD 100 128.2 Shr
Et0/2 Root FWD 100 128.3 Shr
Et0/3 Desg FWD 100 128.4 Shr
Et1/0 Desg FWD 100 128.33 Shr
Et1/1 Desg FWD 100 128.34 Shr
Et1/2 Desg FWD 100 128.35 Shr
Et1/3 Desg FWD 100 128.36 Shr
Et2/0 Desg FWD 100 128.65 Shr
Et2/1 Desg FWD 100 128.66 Shr
Et2/2 Desg FWD 100 128.67 Shr
Et2/3 Desg FWD 100 128.68 Shr
Et3/0 Desg FWD 100 128.97 Shr
Et3/1 Desg FWD 100 128.98 Shr
Et3/2 Desg FWD 100 128.99 Shr
Et3/3 Desg FWD 100 128.100 Shr

SW3#

 


SW4#show spanning-tree

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address aabb.cc00.0100
Cost 200
Port 3 (Ethernet0/2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address aabb.cc00.0400
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0 Desg FWD 100 128.1 Shr
Et0/1 Altn BLK 100 128.2 Shr
Et0/2 Root FWD 100 128.3 Shr
Et0/3 Desg FWD 100 128.4 Shr
Et1/0 Desg FWD 100 128.33 Shr
Et1/1 Desg FWD 100 128.34 Shr
Et1/2 Desg FWD 100 128.35 Shr
Et1/3 Desg FWD 100 128.36 Shr
Et2/0 Desg FWD 100 128.65 Shr
Et2/1 Desg FWD 100 128.66 Shr
Et2/2 Desg FWD 100 128.67 Shr
Et2/3 Desg FWD 100 128.68 Shr
Et3/0 Desg FWD 100 128.97 Shr
Et3/1 Desg FWD 100 128.98 Shr
Et3/2 Desg FWD 100 128.99 Shr
Et3/3 Desg FWD 100 128.100 Shr

SW4#

 
Show Spanning-Tree Summary Outputs


SW1#show spanning-tree summary
Switch is in pvst mode
Root bridge for: VLAN0001
Extended system ID is enabled
Portfast Default is disabled
PortFast BPDU Guard Default is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default is disabled
EtherChannel misconfig guard is enabled
Configured Pathcost method used is short
UplinkFast is disabled
BF is enabled

Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0001 0 0 0 16 16
---------------------- -------- --------- -------- ---------- ----------
1 vlan 0 0 0 16 16

BF statistics
-----------------------
Number of transition via BF (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
SW1#

 

]
SW1#conf t
SW1(config)#spanning-tree backbonefast
SW1(config)# end
SW1#

 

]
SW2# show spanning-tree summary
Switch is in pvst mode
Root bridge for: none
Extended system ID is enabled
Portfast Default is disabled
PortFast BPDU Guard Default is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default is disabled
EtherChannel misconfig guard is enabled
Configured Pathcost method used is short
UplinkFast is disabled
BF is enabled

Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0001 0 0 0 16 16
---------------------- -------- --------- -------- ---------- ----------
1 vlan 0 0 0 16 16

BF statistics
-----------------------
Number of transition via BF (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
SW2(config)#

 


SW3#show spanning-tree summary
Switch is in pvst mode
Root bridge for: none
Extended system ID is enabled
Portfast Default is disabled
PortFast BPDU Guard Default is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default is disabled
EtherChannel misconfig guard is enabled
Configured Pathcost method used is short
UplinkFast is disabled
BF is enabled

Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0001 0 0 0 16 16
---------------------- -------- --------- -------- ---------- ----------
1 vlan 0 0 0 16 16

BF statistics
-----------------------
Number of transition via BF (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
SW3#

 


SW4#show spanning-tree summary
Switch is in pvst mode
Root bridge for: none
Extended system ID is enabled
Portfast Default is disabled
PortFast BPDU Guard Default is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default is disabled
EtherChannel misconfig guard is enabled
Configured Pathcost method used is short
UplinkFast is disabled
BF is enabled

Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0001 1 0 0 15 16
---------------------- -------- --------- -------- ---------- ----------
1 vlan 1 0 0 15 16

BF statistics
-----------------------
Number of transition via BF (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
SW4#

 
Debug Logs


SW1#debug spanning-tree backbonefast detail
Spanning Tree BF detail debugging is on
SW1#

 


SW1#
*Sep 13 22:11:43.751: STP FAST: VLAN0001 Ethernet0/0: sending requested RLQ response PDU
SW1#

 


SW2#
*Sep 13 22:11:43.748: STP FAST: VLAN0001 Ethernet0/2: forwarding RLQ request PDU over root port
SW2#

 


SW4#
*Sep 13 22:11:43.752: STP FAST: received RLQ response PDU was expected on VLAN0001 Ethernet0/2 - resp root id 4097-aabb.cc00.0100 .
*Sep 13 22:11:43.752: STP FAST: received_rlq_bpdu on VLAN0001 Ethernet0/1 - making Ethernet0/1 a designated port
SW4#

 
Show Running-Config Outputs


SW1#show running-config
Building configuration...

Current configuration : 1587 bytes
!
! Last configuration change at 22:03:42 UTC Wed Sep 13 2017
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW1
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
no ip icmp rate-limit unreachable
!
no ip domain-lookup
ip cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree BF
spanning-tree vlan 1 priority 4096
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
interface Ethernet0/0
duplex auto
!
interface Ethernet0/1
duplex auto
!
interface Ethernet0/2
duplex auto
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!
interface Ethernet3/0
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
shutdown
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

SW1#

 


SW2#show running-config
Building configuration...

Current configuration : 1552 bytes
!
! Last configuration change at 22:09:13 UTC Wed Sep 13 2017
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW2
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
no ip icmp rate-limit unreachable
!
no ip domain-lookup
ip cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree BF
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
interface Ethernet0/0
duplex auto
!
interface Ethernet0/1
duplex auto
!
interface Ethernet0/2
duplex auto
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!
interface Ethernet3/0
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
shutdown
!
!
no ip http server
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

SW2#

 


SW3#show running-config
Building configuration...

Current configuration : 1562 bytes
!
! Last configuration change at 22:18:37 UTC Wed Sep 13 2017
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW3
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
no ip icmp rate-limit unreachable
!
no ip domain-lookup
ip cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree BF
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
!
interface Ethernet0/0
duplex auto
!
interface Ethernet0/1
duplex auto
!
interface Ethernet0/2
shutdown
duplex auto
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!
interface Ethernet3/0
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
shutdown
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

SW3#

 


SW4#show running-config
Building configuration...

Current configuration : 1552 bytes
!
! Last configuration change at 22:07:26 UTC Wed Sep 13 2017
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW4
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
no ip icmp rate-limit unreachable
!
no ip domain-lookup
ip cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree BF
!
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
interface Ethernet0/0
duplex auto
!
interface Ethernet0/1
duplex auto
!
interface Ethernet0/2
duplex auto
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!
interface Ethernet3/0
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
shutdown
!
!
no ip http server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

 
Show Spanning-Tree BackboneFast Outputs


SW1#show spanning-tree backbonefast
BF is enabled

BF statistics
-----------------------
Number of transition via BF (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 2
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 2
SW1#

 


SW2#show spanning-tree backbonefast
BF is enabled

BF statistics
-----------------------
Number of transition via BF (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 2
Number of RLQ response PDUs received (all VLANs) : 2
Number of RLQ request PDUs sent (all VLANs) : 2
Number of RLQ response PDUs sent (all VLANs) : 30
SW2#

 


SW3#show spanning-tree backbonefast
BF is enabled

BF statistics
-----------------------
Number of transition via BF (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
SW3#

 


SW4#show spanning-tree backbonefast
BF is enabled

BF statistics
-----------------------
Number of transition via BF (all VLANs) : 2
Number of inferior BPDUs received (all VLANs) : 2
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 2
Number of RLQ request PDUs sent (all VLANs) : 2
Number of RLQ response PDUs sent (all VLANs) : 0
SW4#

 

How to Activate Backbone Fast in L2 Switch ⇒ Video

You can watch the video below to enable BackboneFast on the switches and also subscribe to our YouTube channel to support us!

   Final Word


In this article, we have examined how to configure Backbone Fast on Switches. The Layer 2 Cisco IOU Switch used in this Lab is i86bi-linux-l2-ipbasek9-15.1a.bin. You can also check our UplinkFast Configuration and PortFast Configuration articles.

In our next article, we will review the Rapid Spanning Tree Protocol, and when we enable this protocol, the UplinkFast and Backbone Fast configuration steps will not be necessary. Thanks for following us!

   Related Articles


How to Configure DHCP in GNS3
How to Configure Static NAT in GNS3
How to Configure Dynamic NAT in GNS3
How to Configure PAT in GNS3
How to Backup Cisco IOS in GNS3

Add a Comment

Your email address will not be published. Required fields are marked *