How to Install Cisco Packet Tracer 7.2.2 on Debian 10

Networking Academy recently released the latest version 7.2.2 of Cisco Packet Tracer network simulator software for Windows, Linux, and macOS systems.

How to Install Cisco Packet Tracer on Debian

How to Run Packet Tracer on Debian 10

The latest version of the Cisco Packet Tracer (CPT) is 7.2.2. Networking Academy has added many new advanced features to its network simulator program. In particular, we can say that the simulator gives more importance to visual appearance.

You can install, run and use this version on your Windows, Linux, and even macOS operating systems. In our previous articles, we have examined the steps of installing this network simulator on different systems;

In this article, we’ll create a desktop and start menu shortcuts after installing the latest version of Packet Tracer.

How to Install CPT 7.2.2

First, download the network simulator to your Linux computer and then follow the steps below.

   Step 1

Open Terminal by right-clicking on your desktop and use the chmod command in the image below to change the permissions for PacketTracer-7.2.2-ubuntu-setup.run.

chmod +x PacketTracer-7.2.2-ubuntu-setup.run

 
Then execute ./PacketTracer-7.2.2-ubuntu-setup.run to start the installation.

chmod +x PacketTracer-7.2.2-ubuntu-setup.run

   Step 2

In older versions of CPT, the extension of the setup file published as tar.gz. Now Cisco is using a .run file with a GUI setup interface to make Linux users easier to install for new versions of its software.

Now, click Next in the Packet Tracer GUI wizard.

Packet Tracer GUI

   Step 3

Continue with the /opt/pt option, which is configured by default in the Installation Folder window.

Selecting the Installation Folder

   Step 4

Select I accept the license to accept the Cisco simulator’s license agreement, and then click Next.

Accepting the License

   Step 5

In the Ready to Install window, click the Install button to configure CPT on your Debian system.

Ready to Install

   Step 6

In the Authorization Required window, type your password for your sudo account to confirm the installation, and then click OK.

Authentication Required

   Step 7

Wait while installing the Cisco simulator software.

Installing Cisco Simulator

   Step 8

When the Wizard notifies you that the installation is complete, click Finish.

Installation Complete

   Step 9

When installing programs on Linux systems, you may sometimes need to install dependent packages. One of these programs is Packet Tracer.

To run Packet Tracer on Linux, you must install the libpng package. Download the libpng12-0_1.2.50.deb package to your computer by running the command below in Terminal.

wget https://ftp.us.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_amd64.deb

 
wget https://ftp.us.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_amd64.deb

   Step 10

To install the libpng package you downloaded, execute the following command on the terminal.

dpkg -i libpng12-0_1.2.50-2+deb8u3_amd64.deb

 
If you see an error indicating that it should be installed the multiarch package as in the image below, you will need to install it.

dpkg -i libpng12-0_1.2.50-2+deb8u3_amd64.deb

   Step 11

To install the multiarch package in Debian, execute the command below.

sudo apt-get install multiarch-support

 
sudo apt-get install multiarch-support

   Step 12

After installing the Multiarch-support package, try installing libpng again. If you encounter an error this time, as in the following image, you must copy the libpng12.so.0 file to the /opt/pt/bin/ folder.

(Reading database ... 157517 files and directories currently installed.)
Preparing to unpack libpng12-0_1.2.50-2+deb8u3_amd64.deb ...
Unpacking libpng12-0:amd64 (1.2.50-2+deb8u3) ...
dpkg: error processing archive libpng12-0_1.2.50-2+deb8u3_amd64.deb (--install):
unable to install new version of '/usr/lib/x86_64-linux-gnu/libpng12.so.0': No such file or directory
Errors were encountered while processing:
libpng12-0_1.2.50-2+deb8u3_amd64.deb

 
unable to install new version of '/usr/lib/x86_64-linux-gnu/libpng12.so.0': No such file or directory

   Step 13

To copy the file, you must first extract the .deb package to the folder. To extract the Deb package and copy the libpng12.so.0 file, execute the following commands on the terminal and then run Packet Tracer.

mkdir cpt; dpkg -x libpng12-0_1.2.50-2+deb8u3_amd64.deb ./cpt
cp ./cpt/lib/x86_64-linux-gnu/libpng12.so.0 /opt/pt/bin/
packettracer

 
mkdir cpt; dpkg -x libpng12-0_1.2.50-2+deb8u3_amd64.deb ./cpt

   Step 14

If Packet Tracer does not start and you see the following error, you will need to install the libqt5webkit5 package. To do this, run the following command on the terminal.

sudo apt-get install libqt5webkit5

 

Starting Packet Tracer 7.2.2
/usr/local/bin/packettracer: line 8: 2219 Aborted ./PacketTracer7 "[email protected]" > /dev/null 2>&1

 
/usr/local/bin/packettracer: line 8: 2219 Aborted ./PacketTracer7 "$@" > /dev/null 2>&1

   Step 15

Press Y to confirm the use of additional disk space, and then press Enter.

sudo apt-get install libqt5webkit5

   Step 16

After installing the libqt5webkit5 package, run the program using the packettracer command.

Packet Tracer Works Smoothly

   Step 17

In the Cisco login window, if you have a Netacad account, enter your account information and click User Login. If you want to proceed without logging in, click the Guest Login button.

Guest Login

   Step 18

Once you have successfully installed Packet Tracer, you can check the version by clicking Help / About.

Checking the Version of the Program

How to Create/Make a Desktop Shortcut for Packet Tracer

Creating shortcuts on Windows operating systems is very easy. But creating a desktop shortcut on a Linux-based Debian or Ubuntu can be a bit complicated.

To create a desktop shortcut for a program on Debian, you must first edit the file named program.desktop. You can also configure this file with gedit.

Execute the following commands to create a desktop shortcut to the Cisco Packet Tracer.

cp /opt/pt/bin/Cisco-PacketTracer.desktop /home/user/Desktop/
chmod +x Cisco-PacketTracer.desktop

 
Creating a Packet Tracer Desktop Shortcut

How to Create a Start Menu Shortcut for Packet Tracer

Shortcuts for some programs installed on Linux platforms do not automatically add to the start menu. So if we create a new desktop shortcut, you can add it to the Start Menu.

You must run the following command to create a start menu shortcut for Packet Tracer.

cp Cisco-PacketTracer.desktop /usr/share/applications

 
Creating a Packet Tracer Start Shortcut

After you apply the command, you can see that the shortcut created in the start menu.

Check the Packet Tracer Shortcut

   Video Tutorial

To use Packet Tracer on your Linux computer, you can watch the video below and also subscribe to our YouTube channel to support us!

How to Install CPT 7.2.1

If you want to use an older version of Packet Tracer, you can follow the same steps. However, the requirement of dependent packets may be different.

Therefore, you can follow the steps below to install CPT 7.2 on Debian 9 versions.

   Step 1

First, open the terminal by pressing CTRL + Alt + T to edit the sources.list. After executing sudo nano /etc/apt/sources.list in Terminal, add the following addresses to the resource list.

Press CTRL + X to save your changes to the Sources.list file, and then press Y and Enter.

deb https://ftp.us.debian.org/debian jessie main
deb https://ftp.us.debian.org/debian stretch main
deb https://deb.debian.org/debian unstable main

 
Debian Sources.list Editing

   Step 2

After editing Sources.list, use sudo apt-get update to update the package list.

sudo apt-get update

 
sudo apt-get update

   Step 3

Create a new folder with the mkdir command and extract the PacketTracer72.tar.gz file to the folder you created.

mkdir CPT72
tar -xvzf Packet\ Tracer\ 7.2.1\ for\ Linux\ 64\ bit.tar.gz -C CPT72/

 
tar -xvzf Packet\ Tracer\ 7.2.1\ for\ Linux\ 64\ bit.tar.gz -C CPT72/

   Step 4

Go to the CPT72 folder and execute the ./install command to start the installation.

./install

 
./install

   Step 5

After installation, execute the packettracer command on the Terminal. If it doesn’t, go to cd /opt/pt/bin/ and execute ./PacketTracer7.

If it still doesn’t work, you may receive libpng12.so.0 error as follows.

libpng12.so.0 Error

   Step 6

To resolve this error you need to install the libpng package to do this, use sudo apt-get install libpng12-0.

sudo apt-get install libpng12-0

 
sudo apt-get install libpng12-0

   Step 7

When you try to open a program again, if you receive a ./libcrypto.so.1.0.0: no version information available (required by ./PacketTracer7) error, you must install libcrypto package.

./libcrypto.so.1.0.0: no version information available (required by ./PacketTracer7)

   Step 8

To install the Libcrypto package, execute sudo apt-get install libssl1.0.0 at the Terminal.

sudo apt-get install libssl1.0.0

 
When you try to open Packet Tracer 7.2 after installation, you will get the same error again.

sudo apt-get install libssl1.0.0

   Step 9

Now execute cp -i /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /opt/pt/bin/. Then press Y to confirm the overwriting of the existing file.

cp -i /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /opt/pt/bin/
cp: overwrite '/opt/pt/bin/libcrypto.so.1.0.0'? Y

 
As you can see in the image below, libcrypto error no longer interferes with Packet Tracer’s operation!

cp -i /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /opt/pt/bin/

   Step 10

Finally, execute sudo apt-get install libqt5webkit5 to install dependent packages for Packet Tracer 7.2.1.

sudo apt-get install libqt5webkit5

 
sudo apt-get install libqt5webkit5

   Step 11

Now the CPT starts smoothly!

Packet Tracer Opened

   Step 12

You can check the version of the software in Help / About.

Verifying Software Version

   Video

You can watch the video below to install CPT 7.2.1 step by step on Debian and subscribe to our YouTube channel to support us!

How to Install CPT 7.1.1

If you try to install an older version of Packet Tracer 7.1, you will get libQt5WebKitWidgets.so.5 error. To resolve this issue, install the following dependent packages on your system, respectively.

apt-get install qtmultimedia5-dev
apt-get install libqt5webkit5-dbg
apt-get install libqt5script5
apt-get install libqt5scripttools5

 
Finally, if you do not match your system when you download libpng with the wget command, you can download and install the corresponding package at https://packages.debian.org/jessie-backports/amd64/libssl1.0.0/download.

   Video

   Final Word


In this article, we have examined how to install and use new and old versions of the Cisco simulator in Linux/Debian. And finally, we’ve created a desktop and start menu shortcuts for the program. Thanks for following us!

   Related Articles


How to Use Packet Tracer
Packet Tracer VLAN
Packet Tracer DHCP
Packet Tracer OSPF
Packet Tracer EIGRP

Add a Comment

Your email address will not be published. Required fields are marked *

shares
error: