How to Configure Interface on Cisco Router in GNS3

In this article, we will examine the configuration of the basic interfaces on Routers using the Graphical Network Simulator software.

How to Configure Interface on Cisco Router in GNS3

How to Setup a Cisco Router’s Ethernet and Serial Interfaces

The most basic process of configuring an interface is to open the port and assign an IP address.

After assigning an IP address to the Router, you can also add a description for the network on which you will use that interface. Adding comments on interfaces can prevent complexity in a growing network environment.

You can connect and use different interfaces to a router.

The most common interfaces are Serial, Ethernet, FastEthernet, and GigabitEthernet.

It is used the Ethernet, FastEthernet and GigabitEthernet interfaces for the local network.

It is used the serial Interfaces for WAN connections. The Clock Rate is configured to ensure the timing of the data communication with this interface. And also, unlike Ethernet interfaces, it requires a CSU/DSU data communication device.

CSU/DSU devices determine the clock speed through Serial Interfaces. CSU/DSU devices that regulate the clock rate timing support digital data transmission over the WAN. For analog connections, it usually requires a Modem.

These devices receive the signal from the router and then convert the packets into a suitable format for the WAN environment. Similarly, the signal outgoing from the device to the router is converted to the appropriate format.

Cisco Routers are also DTE devices.

The Clock Rate timing set by DCE devices is automatically accepted by DTE devices.

Two routers can be connected to each other via Serial Interfaces.

In network simulation programs such as GNS3 and Packet Tracer, Serial Interfaces are used to connect two devices when designing a network topology.

CSU/DSU devices are;

   CSU/DSU Device 1

CSU/DSU Device

   CSU/DSU Device 2

CSU/DSU Device

If the two routers are connected to each other via the Serial Interface, the clock rate must be configured for one of the routers to act as Clock Rate.

How to Configure FastEthernet and Serial Interface

If you haven’t installed GNS3 on your computer before, you can check out our article here.

After installing GNS3, run it, and create a new project.

Then, follow the steps below to add an Ethernet and Serial Interface (WIC-1T).

   Step 1

After creating a new project, add and wire the relevant devices to the workspace as shown in the image below.

Additionally, configure the connection of the PC that you added to the project to VMnet.

Router and PC Connected to a Switch

   Step 2

Open the Network and Sharing Center on your host and check the IP address of VMnet3.

Configuring VMnet on a Host Computer

   Step 3

Also, check the VMnet3 type and IP address block in the virtual network editor.

VMware Virtual Network Editor

   Step 4

After running the virtual machine that you added to your project, be sure to configure the adapter setting to Custom: VMnet3.

Configure a Virtual Machine as Host-Only

   Step 5

Now open the Properties window to add a new interface to the router. Click the Slots tab here.

Adding an Interface

   Step 6

In the WICs section, you can add Serial interfaces to Routers. In this step, click on WIC0 and view the available interfaces that you can add.

Adding a Serial Interface

   Step 7

From the options listed, select WIC-1T and click OK to save the settings.

WIC-1T: Adds only one Serial Interface.

WIC-1T

   Step 8

To configure the router’s FastEthernet0/0 and Serial0/0 ports, run the following commands at the CLI prompt.

Command descriptions:

ip address: Adds an address and subnet mask to the interface.
description: Adds a comment to the interface.
no shutdown: Switches the interface from off to on.
exit: Switches to the previous mode.
wr: Saves the running configuration.

R1#
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface fastethernet0/0
R1(config-if)#description Connection to LAN
R1(config-if)#ip address 192.168.8.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
R1(config)#interface serial0/0
R1(config-if)#description Connection to WAN
R1(config-if)#ip address 192.168.200.1 255.255.255.252
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#exit
R1#wr
Building configuration...
[OK]
R1#

 
Setting the FastEthernet and Serial Interfaces

   Step 9

Run your VMware virtual machine and verify the TCP/IP settings by comparing the IP block you assigned to the Router.

Assigning Manual IP Addresses to Windows 8.1

   Step 10

Run the CMD and Ping the Router’s FastEthernet0/0 to test the connection.

Ping from Virtual Machine to the Router

   Step 11

Similarly, test the connection by pinging the Router’s Serial0/0 from the virtual computer.

Using Hostname Command in CMD

Router’s Show Command Output

Execute the show running-config command and check the output.

R1#show running-config
Building configuration...
Current configuration : 1064 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
description Connection to LAN
ip address 192.168.8.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
description Connection to WAN
ip address 192.168.200.1 255.255.255.252
clock rate 64000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
gatekeeper
shutdown
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end
R1#

 

How to Install Cisco Router Serial Interface ⇒ Video

You can watch the video below to assign an IP address to the ports of Router, and also subscribe to our YouTube channel to support us!

   Final Word


Finally, you can download the Cisco Router or Switch IOS images to your computer and integrate it into the GNS3 program to study your Cisco exams more professionally. Thanks for following us!

   Related Articles


Router Boot Process
Cisco IOU Setup
GNS3 and VMware 
♦ GNS3 DHCP
♦ GNS3 NAT

Add a Comment

Your email address will not be published. Required fields are marked *