How to Configure PAT NAT Overload on Cisco Router in GNS3

One of the NAT types used on the router as well is Overload. Also, it is known as PAT (Port Address Translation).

How to Configure PAT NAT Overload on Cisco Router in GNS3

How to Configure PAT on the Router

PAT works differently than Static NAT and Dynamic NAT.

The IP address to be converted is configured on the Router statically. In Dynamic NAT, a pool is created, and the idle IP address in the pool is used.

The pool system created in the router consists of IP addresses assigned by the Internet Service Provider (ISP).

The main feature that distinguishes PAT from other configurations is the use of a single IP address.

In short, many companies or home users use one global IP address assigned by their ISP. Therefore, NAT PAT is applied to the ADSL Router so that all computers on the LAN can access the Internet.

How to Configure PAT

To better understand the operating logic of NAT Overload PAT, run the network simulator and follow the steps below.

   Step 1

Create a network topology as in the image below and add Router, Cloud, Switch, and two Hosts to the workspace.

Internal and External Network Topology with GNS3

   Step 2

Open the Cloud settings and select and add your computer’s physical adapter on the Ethernet tab.

Configuring Cloud Settings

   Step 3

Adding two virtual computers to a Switch in GNS3 may cause network connection problems.

To resolve this issue, you can make changes to the port numbers to which virtual computers installed in the Switch settings.

SW1 Configuration

   Step 4

Open Virtual Network Editor and add a new VMnet3 and configure the IP address block according to the network topology.

Configure the adapter settings of the virtual machines as VMnet3 because these computers are in block 192.168.8.0/24 in the network topology.

VMware Virtual Network Editor

   Step 5

Open the CLI command prompt by double-clicking on R1, and then perform the following commands in order to configure PAT in GNS3.

R1# conf t
R1(config)# interface fastethernet 0/0
R1(config)# ip address 192.168.8.1 255.255.255.0
R1(config-if)# ip nat inside
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface fastethernet 0/1
R1(config-if)# ip address dhcp
R1(config-if)# ip nat outside
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# access-list 1 permit 192.168.8.0 0.0.0.255
R1(config)# ip nat inside source list 1 interface fastethernet 0/1 overload
R1(config)#exit
R1# copy running-config startup-config

 
Enabling PAT on Router

   Step 6

After enabling PAT, ping the Google DNS servers from the Windows 8.1 virtual machine on VMware to test the network connection.

Pinging the Google DNS servers will be successful as you can see in the image below!

Ping 8.8.8.8

   Step 7

Pinging from the Windows 10 virtual machine to the Google DNS servers will succeed as follows!

Ping 8.8.8.8

   Step 8

After pinging, execute the show ip nat translations command on the Router, and examine the IP addresses and port numbers of the computers that converted when accessing the Internet.

show ip nat translations

   Step 9

In the same way, execute the show ip nat statistics command and examine the NAT records.

show ip nat statistics

   Step 10

Execute the clear ip nat translations * command in the CLI to delete the PAT records of the converted LAN IP addresses. Then review the NAT translations again.

clear ip nat translations *

Show Commands

R1#show running-config
Building configuration...

Current configuration : 1095 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
ip address 192.168.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 192.168.8.0 0.0.0.255
no cdp log mismatch duplex
!
control-plane
!
gatekeeper
shutdown
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end
R1#

 

R1#show ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 192.168.1.102:1 192.168.8.5:1 8.8.8.8:1 8.8.8.8:1
tcp 192.168.1.102:49193 192.168.8.5:49193 2.17.20.139:80 2.17.20.139:80
tcp 192.168.1.102:49194 192.168.8.5:49194 2.17.20.139:80 2.17.20.139:80
tcp 192.168.1.102:49195 192.168.8.5:49195 2.22.109.171:80 2.22.109.171:80
icmp 192.168.1.102:0 192.168.8.10:1 8.8.8.8:1 8.8.8.8:0
tcp 192.168.1.102:49706 192.168.8.10:49706 23.62.98.64:80 23.62.98.64:80
tcp 192.168.1.102:49730 192.168.8.10:49730 23.62.98.64:80 23.62.98.64:80
tcp 192.168.1.102:49731 192.168.8.10:49731 23.62.98.8:80 23.62.98.8:80
tcp 192.168.1.102:49736 192.168.8.10:49736 23.62.98.8:80 23.62.98.8:80
tcp 192.168.1.102:49809 192.168.8.10:49809 173.223.11.177:80 173.223.11.177:80
tcp 192.168.1.102:49854 192.168.8.10:49854 13.107.4.50:80 13.107.4.50:80
tcp 192.168.1.102:49858 192.168.8.10:49858 23.62.98.8:80 23.62.98.8:80
tcp 192.168.1.102:49895 192.168.8.10:49895 13.107.4.50:80 13.107.4.50:80
tcp 192.168.1.102:49897 192.168.8.10:49897 13.107.4.50:80 13.107.4.50:80
tcp 192.168.1.102:49908 192.168.8.10:49908 40.77.229.91:443 40.77.229.91:443
tcp 192.168.1.102:49909 192.168.8.10:49909 40.77.229.17:443 40.77.229.17:443
tcp 192.168.1.102:49914 192.168.8.10:49914 40.77.229.10:443 40.77.229.10:443
tcp 192.168.1.102:49916 192.168.8.10:49916 40.77.226.250:443 40.77.226.250:443
tcp 192.168.1.102:49917 192.168.8.10:49917 92.123.166.179:443 92.123.166.179:443
udp 192.168.1.102:59225 192.168.8.10:59225 192.168.1.1:53 192.168.1.1:53

 

R1#show ip nat translations
Pro Inside global Inside local Outside local Outside global
tcp 192.168.1.102:49212 192.168.8.5:49212 151.101.194.49:80 151.101.194.49:80
R1#
R1#show ip nat
R1#show ip nat s
R1#show ip nat statistics
Total active translations: 1 (0 static, 1 dynamic; 1 extended)
Outside interfaces:
FastEthernet0/1
Inside interfaces:
FastEthernet0/0
Hits: 180715 Misses: 431
CEF Translated packets: 179908, CEF Punted packets: 2474
Expired translations: 635
Dynamic mappings:
-- Inside Source
[Id: 1] access-list 1 interface FastEthernet0/1 refcount 1
Appl doors: 0
Normal doors: 0
Queued Packets: 0
R1#

 

How to Configure NAT Overload ⇒ Video

You can watch the video below to configure NAT Overload and also subscribe to our YouTube channel to support us!

   Final Word


In this article, we have examined how to configure NAT Overload using Graphical network simulator and virtual machines on VMware. Thanks for following us!

   Related Articles


How to Use VPCS
Switch Configuration
GNS3 Configuration
Cisco SDM and NAT 
IOS Backup

Add a Comment

Your email address will not be published. Required fields are marked *

error: