Linux Üzerinde (libcrypto.so.1.0.0: no version information available for Packet Tracer7) Hatası Çözümü

Linux Üzerinde (libcrypto.so.1.0.0: no version information available for Packet Tracer7) Hatası Çözümü – Bu yazımızda, Linux sistemler üzerinde Cisco Packet Tracer kurulumu sorununa neden olan “libcrypto.so.1.0.0” hatasını çözeceğiz.
Linux Üzerinde (libcrypto.so.1.0.0: no version information available for Packet Tracer7) Hatası Çözümü

Linux Üzerinde (libcrypto.so.1.0.0: no version information available for Packet Tracer7) Hatası Çözümü

Linux tabanlı Ubuntu, Debian, Linux Mint gibi sistemler üzerinde Cisco sınavlarına hazırlanmak için kullandığınız Cisco Packet Tracer ağ simülatör programını kurmaya çalıştığınızda uyumluluk sorunları ile karşılaşabilirsiniz.

Her ne kadar bir Windows 10 üzerine Packet Tracer kurmak basit olsa da bu durum Linux işletim sistemlerinde söz konusu olmayabiliyor.

Yeni bir Linux dağıtımı yayınlandığında sisteminizi hemen güncellemek isteyebilirsiniz fakat size önerimiz öncelikle bilgisayarınızın yedeğini almanızdır. Çünkü sisteminizde kurulu Packet Tracer gibi programlar yeni Linux dağıtımlarında sorun çıkarabilmektedir.

Linux/Debian 9.5 üzerinde Packet Tracer 7, Packet Tracer 7.1.1 veya Packet Tracer 7.2’yi kurmaya çalıştığınızda “libcrypto.so.1.0.0: no version information available required by ./Packet Tracer7” hatası alırsanız, bu yazımız sorununuzu kesinlikle çözecektir.

Linux Üzerinde Cisco Packet Tracer 7 İçin “libcrypto.so.1.0.0: no version information available required by ./Packet Tracer7” Hatası Çözümü

Linux üzerinde Packet Tracer’ı çalıştırdığınızda Terminal’de libcrypto.so.1.0.0 hatasını görürseniz, bu paketin sisteminizde kurulu olup olmadığını doğrulamanız gerekir. Eğer Linux sisteminizde “libcrypto.so.1.0.0” kurulu ve yine de Packet Tracer’ı başlatamıyorsanız, paketi tekrar kurmanız gerekir.

Linux’te “libcrypto.so.1.0.0” nedir? libcrypto paketi, kriptografik algoritmalar kullanan C++ programları oluşturmak için kütüphanedir. Kütüphane, şablonların ve soyut temel sınıfların yoğun kullanımıyla Pipes ve Filters mimarisini kullanır.

Linux libcrypto hakkında daha fazla bilgi almak için https://debian.pkgs.org/9/debian-main-amd64/libcrypto++-dev_5.6.4-7_amd64.deb.html adresini ziyaret ediniz.

Linux sisteminizde (libcrypto.so.1.0.0: no version information available required by ./Packet Tracer7 / libcrypto.so.1.0.0: Packet Tracer 7 tarafından gerekli hiçbir versiyon bilgisi mevcut değil) hatası gidermek için öncelikle masaüstünüzde Terminal’i açınız ve Root erişimine geçiniz.

Linux üzerinde Packet Tracer 7 için gerekli libcrypto.so.1.0.0 paketini kurmak için aşağıdaki komutları Terminal’de uygulayınız.

1) sudo apt-get update
2) sudo apt-get install libssl1.0.0
./PacketTracer7 komutunu tekrar uyguladığınız aynı hata ile karşılaşırsanız bir sonraki komutu uygulayınız.
3) cp -i /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /opt/pt/bin/
cp: overwrite '/opt/pt/bin/libcrypto.so.1.0.0'? Y -->> Yes (Y) tuşuna basın.
4) ./PacketTracer7
Starting Cisco Packet Tracer…

 
Eğer Linux üzerinde libssl1.0.0 paketini kurmaya çalışırken hata alırsanız, /etc/apt/sources.list reponuzu güncelleyiniz. Yine de libssl1.0.0 kuramıyorsanız, aşağıdaki komutları kullabilirsiniz.

1) wget http://ftp.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.50-2+deb8u3_amd64.deb
2) sudo dpkg -i libpng12-0_1.2.50-2+deb8u3_amd64.deb

 

Linux libcrypto.so.1.0.0 Hatası Çözümü ⇒ Video

Linux/Debian üzerinde libcrypto hatasını çözmek için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz…

  Son Söz

Bu yazımızda, Linux/Debian üzerinde Cisco Packet Tracer 7.2 kurulumu sırasında meydana gelen libcrypto.so.1.0.0 hatası nasıl giderilir adım adım inceledik. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

Linux libcrypto.so.1.0.0 Hatası Çözümü İlgili Yazılar

[su_box title=”İlgili Yazılar” box_color=”#242424″ radius=”0″]
♦ Ubuntu 18.10 Üzerinde Cisco Packet Tracer 7.2 Kurulumu
♦ Debian Üzerinde Cisco Packet Tracer 7.2 Kurulumu
♦ openSUSE Leap 15 Üzerinde Cisco Packet Tracer 7.1.1 Kurulumu
♦ Ubuntu 18.10 Üzerinde Cisco Packet Tracer 7.1.1 Kurulumu
Cisco Packet Tracer Kullanımı
[/su_box]

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

1 × 5 =

Show Buttons
Hide Buttons