How to Use VPCS in GNS3? | How to Configure VPCS on GNS3? – The VPCS used in the GNS3 program refer to computers. To use VPCS in GNS3 you need to configure. For example; Ip address, DNS address…
How to Use VPCS in GNS3?

How to Use VPCS in GNS3?

How to Use VPCS in GNS3?

After running the GNS3 program, there are network devices such as Switch, Router, and Hub in the left pane. You can add these network devices in the GNS3 program by drag and drop into the workspace.

Once you have added GNS3 network devices to your workspace, you can provide a test environment by creating a topology. In contrast, to use VPCS in GNS3, you can also use normal Hosts. However, you need VMware Workstation or VirtualBox program.

The process to use VPCS in GNS3 is a more specific and faster method. In this article, after explaining the use of GNS3 VPCS and GNS3 VPCS configuration steps, you can easily use VPCS in GNS3.

The VPCS is called as the Virtual PC Simulator. We can also call VPCS as a virtual computer simulator.

To add a virtual computer in GNS3, you can read the topic called “How to Integrate VMware with GNS3?“.

Our Recommendation

You can purchase “CCNA Routing and Switching” from Amazon.

How to Configure VPCS on GNS3?

We need to configure VPCS on GNS3 for VPCS usage. You can follow the steps below for GNS3 VPCS commands. Once you have completed the steps of the GNS3 VPCS commands, it will be very easy for you to test your topologies.

Follow the processes to use VPCS in GNS3 and configure VPCS on GNS3.

   Step 1

First run the GNS3 program and create the topology as shown below.

How to Use VPCS in GNS3? | How to Configure VPCS on GNS3?

   Step 2

Run the CLI console by double-clicking on VPCS PC1. Apply the ip (ip adddress) (subnet mask) (default gateway) command to configure the VPCS PC1 TCP/IP settings by going through the GNS3 VPCS commands.

The show ip i command is used to control the TCP/IP settings on the VPCS PC1.

PC1> show ip

NAME : PC1[1]
IP/MASK : 0.0.0.0/0
GATEWAY : 0.0.0.0
DNS :
MAC : 00:50:79:66:68:00
LPORT : 10000
RHOST:PORT : 127.0.0.1:10001
MTU: : 1500
PC1> ip 192.168.10.10/24 192.168.10.1
Checking for duplicate address...
PC1 : 192.168.10.10 255.255.255.0 gateway 192.168.10.1

How to Use VPCS in GNS3? | How to Configure VPCS on GNS3?

   Step 3

Likewise, configure the VPCS PC2 TCP/IP settings.

How to Use VPCS in GNS3? | How to Configure VPCS on GNS3?

   Step 4

Ping to check the connection between PC1 and PC2.

How to Use VPCS in GNS3? | How to Configure VPCS on GNS3?

   Step 5

You can use the clear ip command to delete the settings on VPCS PCs configured in the process to use VPCS in GNS3.

Delete the settings on both PCs and then check the TCP/IP settings with the show ip  command.

How to Use VPCS in GNS3? | How to Configure VPCS on GNS3?

To configure the DHCP server on Cisco routers, you can read the topic called “How to Configure DHCP on Cisco Router?“.

   Step 6

After you configure the VPCS computers to use VPCS in GNS3, configure the Cisco Router as a DHCP server for the VPCS DHCP settings.

Commands for Cisco Router DHCP configuration;

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ip dhcp pool DHCPLANPOOL
R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.10.1
R1(dhcp-config)#dns-server 192.168.10.1
R1(dhcp-config)#exit
R1(config)#ip dhcp excluded-address 192.168.10.1
R1(config)#end
R1#

How to Use VPCS in GNS3? | How to Configure VPCS on GNS3?

   Step 7

We configured the Cisco Router for VPCS DHCP and DNS configuration. Now, for the VPCS computers to automatically receive the TCP/IP settings, execute the ip dhcp command.

In the image below you can see that the settings have been successfully…

How to Use VPCS in GNS3? | How to Configure VPCS on GNS3?

   Step 8

Likewise, configure the TCP/IP settings on the VPCS PC2.

How to Use VPCS in GNS3? | How to Configure VPCS on GNS3?

   Step 9

Once you have completed the GNS3 VPCS configuration steps, you can use the save command to save these settings. Otherwise, the settings on the restarted or shutdown VPCS will be lost.

When you restart VPCS computers, you must save the configurations to not lose these settings.

How to Use VPCS in GNS3? | How to Configure VPCS on GNS3?

Commands Related to How to Use VPCS in GNS3

PC1 show ipPC1 ip configPC1 ip dhcpPC1 save configPC2 show ipPC2 ip configPC2 ip dhcpPC2 save configCisco Router DHCP Config

PC1> show ip

NAME : PC1[1] IP/MASK : 0.0.0.0/0
GATEWAY : 0.0.0.0
DNS :
MAC : 00:50:79:66:68:00
LPORT : 10000
RHOST:PORT : 127.0.0.1:10001
MTU: : 1500

PC1> ip 192.168.10.10/24 192.168.10.1
Checking for duplicate address…
PC1 : 192.168.10.10 255.255.255.0 gateway 192.168.10.1

PC1> ip dhcp
DDORA IP 192.168.10.2/24 GW 192.168.10.1
PC1> show ip

NAME : PC1[1] IP/MASK : 192.168.10.2/24
GATEWAY : 192.168.10.1
DNS : 192.168.10.1
DHCP SERVER : 192.168.10.1
DHCP LEASE : 86393, 86400/43200/75600
MAC : 00:50:79:66:68:00
LPORT : 10000
RHOST:PORT : 127.0.0.1:10001
MTU: : 1500

PC1> save
Saving startup configuration to startup.vpc
. done

PC2> show ip

NAME : PC2[1] IP/MASK : 0.0.0.0/0
GATEWAY : 0.0.0.0
DNS :
MAC : 00:50:79:66:68:01
LPORT : 10002
RHOST:PORT : 127.0.0.1:10003
MTU: : 1500

PC2> ip 192.168.10.20/24 192.168.10.1
Checking for duplicate address…
PC1 : 192.168.10.20 255.255.255.0 gateway 192.168.10.1

PC2> ip dhcp
DDORA IP 192.168.10.3/24 GW 192.168.10.1

PC2>
PC2>
PC2> show ip

NAME : PC2[1] IP/MASK : 192.168.10.3/24
GATEWAY : 192.168.10.1
DNS : 192.168.10.1
DHCP SERVER : 192.168.10.1
DHCP LEASE : 86391, 86400/43200/75600
MAC : 00:50:79:66:68:01
LPORT : 10002
RHOST:PORT : 127.0.0.1:10003
MTU: : 1500

PC2> save
Saving startup configuration to startup.vpc
. done

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ip dhcp pool DHCPLANPOOL
R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.10.1
R1(dhcp-config)#dns-server 192.168.10.1
R1(dhcp-config)#exit
R1(config)#ip dhcp excluded-address 192.168.10.1
R1(config)#end
R1#

How to Use VPCS in GNS3 | How to Configure VPCS on GNS3 ⇒ Video

You can watch how to use VPCS in GNS3. Also, you can subscribe to our YouTube channel…

  Final Word

How to Use VPCS in GNS3? | How to Configure VPCS on GNS3? – That’s all GNS3 VPCS commands for GNS3 VPCS configuration. By applying the GNS3 VPCS configuration steps, you can familiar to these virtual computer simulators.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to the browser bookmarks by pressing the Ctrl+D to read this article later!

Articles Related to How to Use VPCS in GNS3
Products Related to How to Use VPCS in GNS3
Related Products

Leave a Reply

Your email address will not be published. Required fields are marked *