GNS3 Üzerinde VPCS Yapılandırma

GNS3 kullanarak ağ projeleri tasarlarken performans açısından sanal makineler yerine VPCS‘leri kullanabilirsiniz.

GNS3 Üzerinde VPCS Yapılandırma

GNS3 Üzerinde VPCS Nasıl Yapılandırılır?

GNS3 programında Devices (Aygıtlar) panelinde Switch, Router ve Hub gibi ağ cihazları bulunmaktadır. Cisco sınavlarına hazırlanırken sanal makineleri bu programa eklemeniz gerekebilir.

Diğer yandan bir sanal makine kullanımı bilgisayarınıza extra yük bindireceği için Virtual PC Simulator (VPCS) kullanmanızı tavsiye ederiz.

VPCS kullanarak daha spesifik ve daha hızlı bir yöntemdir. VPCS’yi sanal bilgisayar simulatörü olarak da adlandırabilirsiniz.

Virtual PC Simulator (VPCS) Konfigürasyonu

GNS3 ağ simütörü üzerinde VPCS yapılandırmak için aşağıdaki adımları sırasıyla takip ediniz.

   Adım 1

Öncelikle GNS3 yazılımını açınız ve aşağıdaki görüntüdeki gibi bir topoloji oluşturarak çalışma alanına iki adet Virtual PC ekleyiniz.

Bir Switch'e Bağlı Bir Cisco Router ve İki Virtual PC Simulator

   Adım 2

VPCS PC1’in üzerinde çift tıklayarak CLI komut istemini açtıktan sonra TCP/IP ayarlarını yapılandırmak için ip (ip adresi) (alt ağ maskesi) (varsayılan ağ geçidi) komutunu uygulayınız.

TCP/IP ayarlarını kontrol etmek için show ip komutunu kullanabilirsiniz.

PC1> show ip

NAME : PC1[1]
IP/MASK : 0.0.0.0/0
GATEWAY : 0.0.0.0
DNS :
MAC : 00:50:79:66:68:00
LPORT : 10000
RHOST:PORT : 127.0.0.1:10001
MTU: : 1500

PC1> ip 192.168.10.10/24 192.168.10.1
Checking for duplicate address...
PC1 : 192.168.10.10 255.255.255.0 gateway 192.168.10.1

 
VPCS'e IP Adresi Atama

   Adım 3

Aynı şekilde, VPCS PC2’nin TCP/IP ayarlarını yapılandırınız.

VPCS'e IP Adresi Atama

   Adım 4

PC1 ve PC2 arasındaki bağlantıyı kontrol etmek için Ping atınız.

VPCS'ler Arasında Ping Atma

   Adım 5

TCP/IP konfigürasyonlarını silmek için clear ip komutunu kullanabilirsiniz.

Her iki PC’de ayarları siliniz ve ardından show ip komutu ile TCP/IP ayarlarını tekrara kontrol ediniz.

show ip ve clear ip komutları

   Adım 6

VPCS’lere IP adresleri atadıktan sonra, aşağıdaki komutları kullanarak Cisco Router’ı DHCP sunucu olarak yapılandırınız.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ip dhcp pool DHCPLANPOOL
R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.10.1
R1(dhcp-config)#dns-server 192.168.10.1
R1(dhcp-config)#exit
R1(config)#ip dhcp excluded-address 192.168.10.1
R1(config)#end
R1#

 
Cisco Router'da DHCP Etkinleştirme

   Adım 7

VPCS’lere otomatik IP adresi atamak için DHCP yapılandırdıktan sonra, PC1 üzerinde ip dhcp komutunu uygulayınız.

VPCS PC1, TCP/IP ayarlarını Router üzerinde yapılandırdığınız DHCP sunucusundan aldığını aşağıdaki görüntüden inceleyebilirsiniz.

ip dhcp komutu

   Adım 8

Aynı şekilde, VPCS PC2’ye de otomatik bir IP adresi atamak için ip dhcp komutunu çalıştırınız.

ip dhcp komutu

   Adım 9

VPCS yapılandırma adımlarını inceledikten sonra, yaptığını ayarları kaydedebilmek için save komutunu kullanabilirsiniz.

Aksi taktirde, yeniden başlatılan veya kapatılan VPCS’ler üzerindeki ayarlar kaybolacaktır.

VPCS Ayarlarını Save Komutu İle Kaydetme

Yapılandırma Komutları

PC1> show ip

NAME : PC1[1]
IP/MASK : 0.0.0.0/0
GATEWAY : 0.0.0.0
DNS :
MAC : 00:50:79:66:68:00
LPORT : 10000
RHOST:PORT : 127.0.0.1:10001
MTU: : 1500

 

PC1> ip 192.168.10.10/24 192.168.10.1
Checking for duplicate address...
PC1 : 192.168.10.10 255.255.255.0 gateway 192.168.10.1

 

PC1> ip dhcp DDORA IP 192.168.10.2/24 GW 192.168.10.1 PC1> show ip NAME : PC1[1] IP/MASK : 192.168.10.2/24 GATEWAY : 192.168.10.1 DNS : 192.168.10.1 DHCP SERVER : 192.168.10.1 DHCP LEASE : 86393, 86400/43200/75600 MAC : 00:50:79:66:68:00 LPORT : 10000 RHOST:PORT : 127.0.0.1:10001 MTU: : 1500

 

PC1> save
Saving startup configuration to startup.vpc
. done

 

PC2> show ip

NAME : PC2[1]
IP/MASK : 0.0.0.0/0
GATEWAY : 0.0.0.0
DNS :
MAC : 00:50:79:66:68:01
LPORT : 10002
RHOST:PORT : 127.0.0.1:10003
MTU: : 1500

 

PC2> ip 192.168.10.20/24 192.168.10.1
Checking for duplicate address...
PC1 : 192.168.10.20 255.255.255.0 gateway 192.168.10.1

 

PC2> ip dhcp
DDORA IP 192.168.10.3/24 GW 192.168.10.1

PC2>
PC2>
PC2> show ip

NAME : PC2[1]
IP/MASK : 192.168.10.3/24
GATEWAY : 192.168.10.1
DNS : 192.168.10.1
DHCP SERVER : 192.168.10.1
DHCP LEASE : 86391, 86400/43200/75600
MAC : 00:50:79:66:68:01
LPORT : 10002
RHOST:PORT : 127.0.0.1:10003
MTU: : 1500

 

PC2> save
Saving startup configuration to startup.vpc
. done

 

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ip dhcp pool DHCPLANPOOL
R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.10.1
R1(dhcp-config)#dns-server 192.168.10.1
R1(dhcp-config)#exit
R1(config)#ip dhcp excluded-address 192.168.10.1
R1(config)#end
R1#

 

Virtual PC Simulator Nasıl Kullanılır? ⇒ Video

Switch, Router ile VPCS bağlantısı için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


Bu yazımızda, GNS3 ile Cisco sınavlarına daha rahat çalışabilmek için VPCS ayarları nasıl yapılır inceledik. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


GNS3 VM Yükleme
GNS3 Yükleme
Switch Yapılandırma
Cisco IOU
♦ Cisco IOS Yedekleme

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

shares
error: