GNS3 VPCS Kullanımı | GNS3 VPCS Yapılandırma – GNS3 programında kullanılan VPCS’ler bilgisayarları hitap etmektedir. GNS3 üzerinde VPCS’leri kullanmak için yapılandırmaları gerekir. Örneğin; Ip adresi, DNS adresi gibi…
GNS3 VPCS Kullanımı | GNS3 VPCS Yapılandırma

GNS3 VPCS Kullanımı | GNS3 VPCS Yapılandırma

GNS3 VPCS Kullanımı | GNS3 VPCS Yapılandırma

GNS3 programını çalıştırdıktan sonra sol bölmede Switch, Router ve Hub gibi ağ cihazları bulunmaktadır. GNS3 programındaki bu ağ cihazlarını çalışma alanına sürükle bırak yöntemiyle ekleyebilirsiniz.

GNS3 ağ cihazlarını çalışma alanına ekledikten sonra topoloji oluşturarak test ortamı sağlayabilirsiniz. GNS3’te VPCS’leri kullanmanın aksine normal Host (Bilgisayar)’ları da kullanabilirsiniz. Fakat, VMware Workstation veya VirtualBox programına ihtiyacınız olmaktadır.

GNS3 VPCS kullanımı daha spesifik ve daha hızlı bir yöntemdir. Bu yazıda GNS3 VPCS kullanımı ve GNS3 VPCS yapılandırma adımlarını uyguladıktan sonra, GNS3 üzerinde kolayca VPCS’leri kullanabileceksiniz.

VPCS açılımı Virtual PC Simulator’dür. VPCS’yi sanal bilgisayar simulatörü olarak da adlandırabiliriz.

GNS3’te sanal bilgisayar eklemek için, GNS3 ile VMware Workstation Bağlantısı adlı yazıyı okuyabilirsiniz…

GNS3 VPCS Yapılandırma

GNS3 VPCS kullanımı için GNS3 VPCS yapılandırma işlemlerini gerçekleştirmeliyiz. GNS3’te VPCS komutları için aşağıdaki adımları takip edebilirsiniz. GNS3 VPCS komutları adımlarını tamamladıktan sonra, oluşturduğunuz topolojileri test etmek sizin için çok kolay olacaktır.

GNS3 VPCS kullanımı ve GNS3 VPCS yapılandırma işlemlerini sırasıyla takip ediniz.

   Adım 1

Öncelikle GNS3 progrmanı çalıştırınız ve aşağıdaki görüntüdeki gibi topoloji oluşturunuz.

GNS3 VPCS Kullanımı | GNS3 VPCS Yapılandırma

   Adım 2

VPCS PC1’in üzerinde çift tıklayarak CLI konsolunu çalıştırınız. GNS3 VPCS komutları’na giriş yaparak, VPCS PC1 TCP/IP ayarlarını yapılandırmak için ip (ip adresi) (alt ağ maskesi) (varsayılan ağ geçidi) komutunu uygulayınız.

VPCS PC1 üzerinde TCP/IP ayarlarını kontrol etmek için show ip komutu kullanılmaktadır.

[code] PC1> show ip

NAME : PC1[1] IP/MASK : 0.0.0.0/0
GATEWAY : 0.0.0.0
DNS :
MAC : 00:50:79:66:68:00
LPORT : 10000
RHOST:PORT : 127.0.0.1:10001
MTU: : 1500
[/code] [code] PC1> ip 192.168.10.10/24 192.168.10.1
Checking for duplicate address…
PC1 : 192.168.10.10 255.255.255.0 gateway 192.168.10.1
[/code]

GNS3 VPCS Kullanımı | GNS3 VPCS Yapılandırma

   Adım 3

Aynı şekilde, VPCS PC2 TCP/IP ayarlarını yapılandırınız.

GNS3 VPCS Kullanımı | GNS3 VPCS Yapılandırma

   Adım 4

PC1 ve PC2 arasında bağlantıyı kontrol etmek için Ping işlemini uygulayınız.

GNS3 VPCS Kullanımı | GNS3 VPCS Yapılandırma

   Adım 5

GNS3 VPCS kullanımı’nda yapılandırılan VPCS PC’ler üzerindeki ayarları silmek için clear ip komutunu kullanabilirsiniz.

Her iki PC’de ayarları siliniz ve ardından show ip komutu ile TCP/IP ayarlarını kontrol ediniz.

GNS3 VPCS Kullanımı | GNS3 VPCS Yapılandırma

Cisco yönlendiricilerde DHCP sunucu yapılandırmak için, Cisco Router DHCP Yapılandırma adlı yazıyı okuyabilirsiniz…

   Adım 6

GNS3 VPCS kullanımı’nda VPCS bilgisayarları yapılandırdıktan sonra, VPCS DHCP ayarları için Cisco Router’ı DHCP sunucu olarak yapılandırınız.

Cisco Router DHCP konfigürasyonu için gereken komutlar;

[code] R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ip dhcp pool DHCPLANPOOL
R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.10.1
R1(dhcp-config)#dns-server 192.168.10.1
R1(dhcp-config)#exit
R1(config)#ip dhcp excluded-address 192.168.10.1
R1(config)#end
R1#
[/code]

GNS3 VPCS Kullanımı | GNS3 VPCS Yapılandırma

   Adım 7

VPCS DHCP ve DNS yapılandırma için Cisco Router’ı yapılandırdık. Şimdi, VPCS bilgisayarların TCP/IP ayarlarını otomatik almaları için, ip dhcp komutunu uygulayınız.

Aşağıdaki görüntüde ayarların başarılı bir şekilde alındığını görebilirsiniz…

GNS3 VPCS Kullanımı | GNS3 VPCS Yapılandırma

   Adım 8

Aynı şekilde, VPCS PC2 üzerinde de TCP/IP ayarlarını yapılandırınız.

GNS3 VPCS Kullanımı | GNS3 VPCS Yapılandırma

   Adım 9

GNS3 VPCS yapılandırma adımlarını tamamladıktan sonra, bu ayarları kaydedebilmek için save komutunu kullanabilirsiniz. Aksi taktirde, yeniden başlatılan veya kapatılan VPCS’ler üzerindeki ayarlar kaybolacaktır.

VPCS bilgisayar’ları yeniden başlattığınızda bu ayarları kaybetmemek için konfigürasyonları kaydememiz gerekir.

GNS3 VPCS Kullanımı | GNS3 VPCS Yapılandırma

GNS3 VPCS Kullanımı Komutları

PC1 show ipPC1 ip configPC1 ip dhcpPC1 save configPC2 show ipPC2 ip configPC2 ip dhcpPC2 save configCisco Router DHCP Config

PC1> show ip

NAME : PC1[1] IP/MASK : 0.0.0.0/0
GATEWAY : 0.0.0.0
DNS :
MAC : 00:50:79:66:68:00
LPORT : 10000
RHOST:PORT : 127.0.0.1:10001
MTU: : 1500

PC1> ip 192.168.10.10/24 192.168.10.1
Checking for duplicate address…
PC1 : 192.168.10.10 255.255.255.0 gateway 192.168.10.1

PC1> ip dhcp
DDORA IP 192.168.10.2/24 GW 192.168.10.1
PC1> show ip

NAME : PC1[1] IP/MASK : 192.168.10.2/24
GATEWAY : 192.168.10.1
DNS : 192.168.10.1
DHCP SERVER : 192.168.10.1
DHCP LEASE : 86393, 86400/43200/75600
MAC : 00:50:79:66:68:00
LPORT : 10000
RHOST:PORT : 127.0.0.1:10001
MTU: : 1500

PC1> save
Saving startup configuration to startup.vpc
. done

PC2> show ip

NAME : PC2[1] IP/MASK : 0.0.0.0/0
GATEWAY : 0.0.0.0
DNS :
MAC : 00:50:79:66:68:01
LPORT : 10002
RHOST:PORT : 127.0.0.1:10003
MTU: : 1500

PC2> ip 192.168.10.20/24 192.168.10.1
Checking for duplicate address…
PC1 : 192.168.10.20 255.255.255.0 gateway 192.168.10.1

PC2> ip dhcp
DDORA IP 192.168.10.3/24 GW 192.168.10.1

PC2>
PC2>
PC2> show ip

NAME : PC2[1] IP/MASK : 192.168.10.3/24
GATEWAY : 192.168.10.1
DNS : 192.168.10.1
DHCP SERVER : 192.168.10.1
DHCP LEASE : 86391, 86400/43200/75600
MAC : 00:50:79:66:68:01
LPORT : 10002
RHOST:PORT : 127.0.0.1:10003
MTU: : 1500

PC2> save
Saving startup configuration to startup.vpc
. done

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ip dhcp pool DHCPLANPOOL
R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.10.1
R1(dhcp-config)#dns-server 192.168.10.1
R1(dhcp-config)#exit
R1(config)#ip dhcp excluded-address 192.168.10.1
R1(config)#end
R1#

GNS3 VPCS Kullanımı | GNS3 VPCS Yapılandırma ⇒ Video

GNS3’te VPCS komutları ve kullanımı ile ilgili video’yu izleyebilir ve ayrıca YouTube kanalımıza abone olabilirsiniz…

  Son Söz

GNS3 VPCS Kullanımı | GNS3 VPCS Yapılandırma adlı yazımı burada noktalandırıyorum. GNS3 VPCS kullanımı için bilgisayarların yapılandırılması için gerekli GNS3 VPCS komutları bu kadardır. GNS3 VPCS komutları’nı uygulayarak bu sanal bilgisayar simulatörlerine haşina olabilirsiniz. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

GNS3 VPCS Kullanımı | GNS3 VPCS Yapılandırma İlgili Yazılar

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

14 + eleven =