GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı – GNS3 üzerinde daha önce Layer 2 Switch kurulumu yapmıştık. Layer 2 Switch’ler yalnızca MAC adresleri tablosuna göre paketleri iletir. Layer 3 Switch’ler de MAC adres tablosunu kullanır ve ilaveten Ip yönlendirme görevi yaparlar.
GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

GNS3 Layer 3 Switch ekleme işlemi, GNS3 programında Cisco Router ekleme işlemi ile hemen hemen aynıdır. GNS3 ile Switching (Anahtarlama) bazlı işlemleri gerçekleştirebilmek için, GNS3 Layer 3 Switch ekleme adımlarını uygulamalısınız.

GNS3 üzerinde Layer 3 Switch’ler ile VLAN, 802.1Q Trunking ve InterVLAN Routing gibi işlemleri gerçekleştirebilirsiniz. Bu işlemleri GNS3 Katman 3 Anahtar kullanımı ile gerçekleştirebilirsiniz.

GNS3 Layer 3 Switch Ekleme İşlemi İçin IOS İndir

GNS3 Layer 3 Switch ekleme işleminden önce, IOS yazılımını aşağıdaki butondan bilgisayarınıza indiriniz.

 

GNS3 Katman 3 Anahtar Kullanımı

GNS3 Katman 3 Anahtar kullanımı adımlarına artık geçebiliriz. Yukarıdaki butondan IOS’u bilgisayarınıza indirdikten sonra GNS3 Layer 3 Switch ekleme adımlarını aşağıdaki görüntülerden takip ediniz.

   Adım 1

Öncelikle GNS3 programını çalıştırınız ve Edit menüsüne tıklayınız.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 2

Edit menüsünden Preferences seçeneğine tıklayınız.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 3

Açılan General Preferences penceresinde, IOS Routers sekmesini tıklayınız.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

GNS3 ağ simulasyon programında Katman 2 Switch eklemek için, GNS3 Layer 2 Switch Ekleme adlı yazıyı okuyabilirsiniz…

   Adım 4

Daha önce eklediğimiz Layer 2 Switch, Qemu VMs kısmından eklenmiştir. GNS3 Layer 3 Switch ekleme işlemi ise bu kısımdan yapılmaktadır. Cisco Router template penceresinde New butonuna tıklayınız.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 5

IOS Image penceresinde, New Image (Yeni İmaj) seçeneğini seçtikten sonra, Browse butonuna tıklayınız.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 6

Yukarıdaki butondan indirdiğiniz IOS’u seçerek Open (Aç) butonuna tıklayınız.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 7

GNS3 programı IOS’u varsayılan imaj klasörüne kopyalamak istediğini soruyor, Yes (Evet) butonuna tıklayınız.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 8

Next butonuna tıklayarak devam ediniz.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 9

GNS3 Layer 3 Switch ekleme işleminin en önemli adımıdır. Buradaki “This is an EthernetSwitch Router” seçeneğini seçmeniz gerekmektedir. Bu seçeneği seçtikten sonra Next butonuna tıklayarak devam ediniz.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 10

Katman 3 Anahtar’ın RAM değerini varsayılan olarak bırakarak Next butonuna tıklayınız.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 11

Network Adapters penceresinde Slot 0’da NM-16ESW arayüzünü seçiniz ve bir sonraki adıma devam ediniz.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 12

Katman 3 Anahtar IOS’u için bilgisayarınızın işlemci performansı için en uygun değerin seçilebilmesi için Idle-PC Finder butonuna tıklayınız.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 13

Idle-PC değeri hesaplanıyor…

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 14

GNS3 Layer 3 Switch ekleme sürecinde, IOS için en uygun Idle-PC değeri belirlenmiştir. OK butonuna tıklayarak devam ediniz.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 15

Gördüğünüz gibi, GNS3 Layer 3 Switch ekleme işlemi başarıyla tamamlanmıştır.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 16

GNS3 çalışma alanına Katman 3 Anahtarı sürükleyip bırakınız.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 17

Aşağıdaki gibi topoloji oluşturunuz. GNS3 Layer 3 Switch’i test etmek için üzerine çift tıklayınız.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 18

GNS3 Layer 3 Switch ekleme işlemini tamamladık. Şimdi, Switch’i test etmek için, CLI komut arayüzünde show vlan-switch komutunu uygulayınız.

GNS3 Katman 3 Anahtarı aşağıdaki komutları uygulayarak yapılandırınız.

ESW1# conf t
ESW1(config)#interface vlan 1
ESW1(config-if)#ip address 192.168.10.1 255.255.255.0
ESW1(config-if)#no shutdown
ESW1(config-if)#exit
ESW1(config)#infterface fastethernet0/0
ESW1(config-if)#no shutdown
ESW1(config-if)#exit
ESW1(config)#exit
ESW1#

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 19

GNS3 üzerinde VPCS’leri yapılandırınız ve daha sonra aşağıdaki gibi bağlantıyı test etmek için Vlan 1 arayüzüne ping atınız.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

   Adım 20

VPCS’ler üzerinde birbirine ping işlemi gerçekleştirildiğinde işlemin başarılı olduğunu görebilirsiniz. Katman 3 Switch’imiz sorunsuz çalışmaktadır.

GNS3 Layer 3 Switch Ekleme | GNS3 Katman 3 Anahtar Kullanımı

Cisco yönlendirici üzerinde çalışan IOS yazılımını TFTP sunucuya kaydetmek için, Cisco IOS Yedekleme | Cisco TFTP Yedek Alma adlı yazıyı okuyabilirsiniz…

GNS3 Layer 3 Switch Ekleme Show Komutları

ESW1#show running-configESW1#show ip int brESW1#show vlan-switch

ESW1#show running-config
Building configuration…

Current configuration : 2035 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname ESW1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip icmp rate-limit unreachable
!
!
no ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
vtp file nvram:vlan.dat

!
!
ip tcp synwait-time 5
!
!
!
interface FastEthernet0/0
description *** Unused for Layer2 EtherSwitch ***
!
interface FastEthernet0/1
description *** Unused for Layer2 EtherSwitch ***
shutdown
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface Vlan1
ip address 192.168.10.1 255.255.255.0
no ip route-cache
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
no cdp log mismatch duplex
!
!
control-plane
!
!
mgcp behavior g729-variants static-pt
!
!
banner exec ^C

***************************************************************
This is a normal Router with a SW module inside (NM-16ESW)
It has been preconfigured with hard coded speed and duplex

To create vlans use the command “vlan database” from exec mode
After creating all desired vlans use “exit” to apply the config

To view existing vlans use the command “show vlan-switch brief”

Warning: You are using an old IOS image for this router.
Please update the IOS to enable the “macro” command!
***************************************************************

^C
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

ESW1#

ESW1#show ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset up up
FastEthernet0/1 unassigned YES unset administratively down down
FastEthernet0/2 unassigned YES unset up down
FastEthernet0/3 unassigned YES unset up down
FastEthernet0/4 unassigned YES unset up down
FastEthernet0/5 unassigned YES unset up down
FastEthernet0/6 unassigned YES unset up down
FastEthernet0/7 unassigned YES unset up down
FastEthernet0/8 unassigned YES unset up down
FastEthernet0/9 unassigned YES unset up down
FastEthernet0/10 unassigned YES unset up down
FastEthernet0/11 unassigned YES unset up down
FastEthernet0/12 unassigned YES unset up down
FastEthernet0/13 unassigned YES unset up down
FastEthernet0/14 unassigned YES unset up down
FastEthernet0/15 unassigned YES unset up down
Vlan1 192.168.10.1 YES manual up up
ESW1#

ESW1#show vlan-switch

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/0, Fa0/1, Fa0/2, Fa0/3
Fa0/4, Fa0/5, Fa0/6, Fa0/7
Fa0/8, Fa0/9, Fa0/10, Fa0/11
Fa0/12, Fa0/13, Fa0/14, Fa0/15
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
—- —– ———- —– —— —— ——– —- ——– —— ——
1 enet 100001 1500 – – – – – 1002 1003
1002 fddi 101002 1500 – – – – – 1 1003
1003 tr 101003 1500 1005 0 – – srb 1 1002
1004 fdnet 101004 1500 – – 1 ibm – 0 0
1005 trnet 101005 1500 – – 1 ibm – 0 0

GNS3 Layer 3 Switch Ekleme ⇒ Video

GNS3’te Switch kullanımı ile ilgili video’yu izleyebilirsiniz. Ayrıca, YouTube kanalımıza abone olabilirsiniz…

  Son Söz

GNS3 Layer 3 Switch Ekleme ve GNS3 Katman 3 Anahtar Kullanımı – GNS3 programında bu işlem ile yönetilebilir bir Switch ekleyebilmekteyiz. Cisco Packet Tracer programında bu tarz işleme gerek yoktur. Bu yazıda temel olarak küçük bir test yaptık. Daha gelişmiş konfigürasyonlar için bizleri takip ediniz. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

GNS3 Layer 3 Switch Ekleme İlgili Yazılar

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir