GNS3 Üzerinde Cloud Yapılandırma

GNS3’te VMware veya VirtualBox sanal makineleri kullanmak için en basit yol Cloud (Bulut) yapısını kullanmaktır.

GNS3 Üzerinde Cloud Yapılandırma

GNS3 Üzerinde Cloud ile Sanal Makine Ekleme

GNS3 programının sürekli güncellenmesiyle, programın kullanımı daha da basitleştirilmektedir. GNS3’te sanal makineleri kullanarak daha gerçekçi bir ağ tasarımı oluştururak test yapabilirsiniz.

Programın eski sürümünde araçlar bölümünde Host seçeneği vardı. Ve GNS3 ile VMware bağlantısını bu Host seçeneğinden ayarlıyorduk. GNS3 2.0 sürümü ile birlikte gelen Cloud Nodes (Bulut Düğümleri) özelliği ile bu işlem artık daha kolay yapılmaktadır.

Bu yazımızda GNS3 ve VMware Workstation programlarını kullanarak, ağ topolojisine sanal bilgisayarlar ekleyeceğiz.

GNS3 Üzerine VMware Sanal Makine Ekleme

Yapılandırma için, VMware programında iki adet sanal makine oluşturunuz ve ardından Cloud eklemek için aşağıdaki adımları sırasıyla takip ediniz.

   Adım 1

Öncelikle GNS3 ağ simülatör programını çalıştırınız ve yeni bir proje oluşturunuz.

GNS3 Üzerinde Yeni Bir Proje Oluşturma

   Adım 2

Edit menüsüne tıklayınız.

GNS3 Edit Menüsüne Tıklama

   Adım 3

Edit menüsünden Preferences seçeneğine tıklayınız.

Edit / Preferences

   Adım 4

Aşağıdaki görüntüdeki gibi, Cloud nodes seçeneğine tıklayınız. Bu pencerede Cloud taslağı oluşturmak için New butonuna tıklayınız.

GNS3 Cloud nodes

   Adım 5

Oluşturacağınız Cloud düğümü sanal makineler ile alakalı olacağı için, sanal makine işletim sistemi adını yazabilirsiniz.

New Cloud Mode Template

   Adım 6

VMware sanal makine işletim sistemi adını yazdıktan sonra, Finish butonuna tıklayınız.

Cloud Düğümü İçin Bir İsim Yazma

   Adım 7

Şimdi, Edit butonuna tıklayarak devam ediniz.

Cloud Ayarlarını Düzenleme

   Adım 8

Aşağıdaki görüntüde Cloud için Host üzerinde oluşturulan bir Ethernet arayüzü eklemeniz gerekiyor.

VMware Virtual Network Editör programında daha önceden oluşturduğunuz VMnet’leri ekleyebilmek için Show special Ethernet interfaces (Özel Ethernet arayüzlerini göster) seçeneğine tıklayınız.

Cloud / Ethernet Interfaces

   Adım 9

VMnet’i seçmek için aşağı ok’a tıklayınız.

Cloud'a VMnet Ekleme

   Adım 10

Windows 8.1 makinesi için VMnet1’i seçiniz ve Add (Ekle) butonuna tıklayınız.

VMnet1

   Adım 11

Çalışma alanına eklediğini Cloud (Bulut) sembolünü Bilgisayar sembolüne değiştirmek için Misc. tabına tıklayınız.

Cloud / Misc Tabına Tıklama

   Adım 12

Sembolü değiştirmek için Browse (Gözat) butonuna tıklayınız.

Cloud'un Sembolünü Değiştirme

   Adım 13

Açılan sembol penceresinde, Bilgisayar sembolünü seçiniz ve OK butonuna tıklayınız.

Bilgisayar Sembolünü Seçme

   Adım 14

Yaptığınız ayarları kaydetmek için OK butonuna tıklayarak pencereyi kapatınız.

Cloud Yapılandırma Penceresini Kapatma

   Adım 15

Şimdi tekrardan Windows 10 sanal makine için yeni bir Cloud eklemek için New (Yeni) butonuna tıklayınız.

Yeni Bir Cloud Oluşturma

   Adım 16

Aynı şekilde, Cloud için bir ad yazınız ve Finish butonuna tıklayınız.

Sanal Makine Adını Yazma

   Adım 17

Windows 10 makine için de VMnet2’yi seçiniz. Ve ardından sembolünü değiştiriniz.

VMnet2

   Adım 18

Şimdi, GNS3 programında küçük bir ağ tasarımı oluşturarak Cloud’ları test edelim.

Cloud Node Templates

   Adım 19

Aşağıdaki ekranda gördüğünüz gibi araçlar bölümüne 2 adet Cloud bilgisayar eklendi.

GNS3'te Aygıtlar Listesi

   Adım 20

VMware üzerindeki sanal makinelerin VMnet ayarlarını kontrol ediniz. Virtual Network Editör’de gördüğünüz gibi VMnet’ler Host Only olarak yapılandırılmıştır.

Windows 8.1 ayarları aşağıdaki gibidir.

VMware Sanal Ağ Editörü

   Adım 21

Windows 10 VM ayarlarını da kontrol ediniz.

Windows 10 VMnet Ayarları

   Adım 22

Sanal makineleri çalıştırmadan önce, fiziksel bilgisayarınızdan Ağ Bağlantısı Ayarları‘na giriniz. VMnet1 ve VMnet2 ayarları aşağıdaki görüntüdeki gibi olmalıdır.

Burada VMnet’leri IP adreslerini değiştirmenin asıl amacı, .1’li IP adreslerin genellikle varsayılan ağ geçidi olarak kullanılmasıdır.

Buraya dikkat etmezseniz, GNS3 projelerinde bir ağ hatası meydana gelebilir.

Windows'ta Ağ Bağdaştırıcılarını Yapılandırma

   Adım 23

Aşağıdaki görüntüdeki gibi bir ağ topolojisi oluşturunuz ve eklediğiniz Cloud bilgisayarları çalışma alanına ekleyiniz.

Cloud1’in Hostname adını değiştiriniz.

Hostname Adını Değiştirme

   Adım 24

Cloud2’nin de Hostname adını değiştiriniz.

Hostname Adını Değiştirme

   Adım 25

Son olarak, Cisco Router’ın FastEthernet arayüzlerini yapılandırmak için Router’ı çalıştırınız.

GNS3 Ağ Topolojisi

   Adım 26

Cisco Router R1 CLI komut istemini açınız ve FastEthernet0/0 ve FastEthernet0/1 arayüzlerine IP adresi atayınız.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
*Mar 1 00:02:19.999: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:02:20.999: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config)#interface fastethernet 0/1
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#end
R1#

 
Cisco Router Arayüzlerine IP Adresi Atama

   Adım 27

Win 8.1 sanal bilgisayarı çalıştırınız ve TCP/IP ayarını yapılandırınız.

Windows 8 / ipconfig

   Adım 28

Aynı şekilde Win 10 sanal bilgisayarında TCP/IP ayarını yapılandırınız.

Windows 10 / ipconfig

   Adım 29

Win8.1’den Win10’a Ping atarak ağ bağlantısını test ediniz.

Windows 8'den Windows 10'a Ping Atma

   Adım 30

Win10’dan Win8.1’e Ping atınız ve ağ bağlantısını sınayınız.

Görüldüğü gibi iki sanal makine de birbirleriyle Cisco Router aracılığıyla başarıyla haberleşmektedir.

Windows 10'dan Windows 8'e Ping Atma

Router Show Komutları


R1#show running-config
Building configuration...
Current configuration : 1043 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#

 


R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.10.0/24 is directly connected, FastEthernet0/1
C 192.168.5.0/24 is directly connected, FastEthernet0/0
R1#

 


R1#show ip route connected
C 192.168.10.0/24 is directly connected, FastEthernet0/1
C 192.168.5.0/24 is directly connected, FastEthernet0/0
R1#

 

GNS3 Cloud Konfigürasyonu ⇒ Video

GNS3’e sanal bilgisayar eklemek için aşağıdaki videoyu izleyebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz!

   Son Söz


Bu yazımızda, GNS3 çalışma alanına eklenen Cloud yapısına VMware sanal bilgisayar ekledik. Daha spesifik çalışmalarınız için VPCS yerine Cloud yapısını kullanmanızı tavsiye ederiz. Bizi takip ettiğiniz için teşekkürler!

   İlgili Yazılar


♦ GNS3 ve OSPF
♦ GNS3 IOU VM Kurulumu
♦ Ubuntu GNS3 Kurulumu
♦ GNS3 Cisco IOS Ekleme
♦ GNS3 İçin Cisco IOS

Add a Comment

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

shares
error: