GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları – GNS3’te VMware veya VirtualBox sanal makinaları kullanmak için en uygun yol Cloud (Bulut) yapısını kullanmaktır.
GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

GNS3 programının sürekli güncellenmesiyle, programın kullanımı daha da kolaylaşmaktadır. GNS3’te sanal makinaları kullanarak daha gerçekçi bir ağ tasarımı oluştururak test edebiliriz. GNS3 2.0.2 sürümünün piyasaya sürülmesiyle yeni gelen Cloud Nodes (Bulut Düğümleri) ile VMware sanal makinaları kolaylıkla GNS3’e entegre edebiliriz.

GNS3 Cloud yapılandırma adımları yeni sürümde biraz daha farklıdır. Fakat GNS3 Cloud ayarları gayet kolay ve basittir. Bu yazımızda GNS3 ve VMware Workstation programlarını kullanarak, ağ topolojimize Cloud sanal bilgisayarlar ekleyeceğiz.

GNS3 eski sürümünde araçlar bölümünde Host seçeneği vardı. Ve GNS3 ile VMware bağlantısını bu Host seçeneğinden ayarlıyorduk. GNS3 2.0.2 sürümü ile Cloud seçeneği gelerek daha kolay sanal makinaları entegre edebiliriz.

GNS3 Cloud VMware Sanal Makina Bağlantısı

GNS3 Cloud VMware sanal makina bağlantısı için, VMware Workstation programında iki adet sanal makina oluşturunuz. GNS3 için kuracağınız sanal işletim sistemleri farketmemektedir.

GNS3 Cloud yapılandırma adımlarını sırasıyla takip ediniz.

   Adım 1

Öncelikle GNS3 programını açınız ve yeni bir proje oluşturunuz.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 2

GNS3 Edit menüsüne tıklayınız.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 3

Edit menüsünden Preferences seçeneğine tıklayınız.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 4

Aşağıdaki görüntüdeki gibi, GNS3 Cloud yapılandırma penceresi açılacaktır. Daha sonra bu pencereden, GNS3 Cloud ayarları için GNS3 Cloud nodes seçeneğine tıklayınız.

Cloud node templates penceresinde, Cloud taslağı oluşturmak için New butonuna tıklayınız.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 5

Oluşturacağınız Cloud düğümü sanal makinalar ile alakalı olacağı için, sanal makina işletim sistemi adını girebilirsiniz.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 6

VMware sanal makina işletim sistemi adını yazdıktan sonra, Finish butonuna tıklayınız.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 7

GNS3 Cloud yapılandırma işlemi daha tamamlanmadı. Edit butonuna tıklayarak devam ediniz.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 8

Aşağıdaki ekranda Cloud için fiziksel bilgisayarımızda oluşturulan bir Ethernet arayüzü eklememiz gerekiyor. VMware Virtual Network Editör programında daha önceden oluşturduğunuz VMnet’leri bu ekranda görmek için, alttaki seçeneği işaretleminiz gerekmektedir.

Show special Ethernet interfaces (Özel Ethernet arayüzlerini göster) seçeneğine tıklayınız.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 9

VMnet’i seçmek için aşağı ok’a tıklayınız.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 10

VMware VMnet1’i seçiniz ve Add (Ekle) butonuna tıklayınız.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 11

VMware Windows 8.1 sanal makina VMnet1’de tanımlı olduğu için, bu adımda VMnet1 seçeneğini seçtik. GNS3 Cloud yapılandırma adımı tamamlandı. Fakat son bir işlem kaldı o da Cloud (Bulut) sembolünü değiştirmektir.

Misc. tabına tıklayarak devam ediniz.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 12

GNS3 Cloud sembolünü değiştirmek için Browse (Gözat) butonuna tıklayınız.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 13

Açılan sembol penceresinde, bilgisayar sembolünü seçiniz ve OK butonuna tıklayınız.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 14

OK butonuna tıklayarak pencereyi kapatınız.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 15

VMware Windows 8.1 sanal makina için GNS3 Cloud yapılandırma adımını tamamladık. Şimdi, bir tane daha eklemek isterseniz, tekrardan New (Yeni) butonuna tıklayarak devam ediniz.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 16

Aynı şekilde, VMware Windows 10 sanal makina için bir ad veriniz ve Finish butonuna tıklayınız.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 17

GNS3 Cloud ayarları’nda Windows 10 sanal makina için de VMnet2’yi seçiniz. Ve ardından Cloud sembolünü değiştirmek için, Misc. tabına tıklayınız ve sembolü değiştiriniz.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 18

GNS3 Cloud VMware sanal makina bağlantısı işlemlerini tamamladık. Şimdi, GNS3 programında küçük bir ağ tasarımı oluşturarak Cloud’ları test edelim.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 19

Aşağıdaki ekranda gördüğünüz gibi GNS3 araçlar bölümüne 2 adet Cloud bilgisayar eklendi.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 20

VMware üzerindeki sanal makinaların VMnet ayarlarını kontrol ediniz. Virtual Network Editör’de gördüğünüz gibi VMnet’ler Host Only olarak yapılandırılmıştır.

Windows 8.1 sanal makina ayarları aşağıdaki gibidir.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 21

VMware Windows 10 sanal makina ayarlarını da kontrol ediniz.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 22

Sanal makinaları çalıştırmadan önce, fiziksel bilgisayarınızdan Ağ Bağlantısı Ayarları’na giriniz. VMware VMnet1 ve VMnet2 ayarları aşağıdaki gibi olmalıdır.

Burada IP adresi değiştirmenin asıl amacı, .1’li IP adreslerini yaygın olarak varsayılan ağ geçidi olarak kullanmamızdır. Buraya dikkat edilmezse, GNS3 projelerinde bir ağ hatası meydana gelebilir.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 23

GNS3 Cloud yapılandırma adımlarını tamamladıktan sonra, GNS3 Cloud ayarları’nı doğrulamanın en iyi yolu bir proje oluşturmaktır. Aşağıdaki görüntüdeki gibi bir ağ topolojisi oluşturunuz ve eklediğiniz Cloud bilgisayarları çalışma alanına ekleyiniz.

Çalışma alanına eklediğiniz Cloud bilgisayarların Hostname adını değiştirebilirsiniz.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 24

Cloud2’nin de Hostname adını değiştiriniz.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 25

GNS3 ağ topolojisinin son görünümü aşağıdaki gibidir. IP adreslerini de belirledikten sonra, Cisco Router’ı çalıştırınız.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 26

Cisco Router R1 CLI komut istemini açınız ve FastEthernet0/0 ve FastEthernet0/1 arayüzlerine IP adresi atayınız.

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
*Mar  1 00:02:19.999: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar  1 00:02:20.999: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config)#interface fastethernet 0/1          
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#end
R1#

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 27

VMware sanal makinaları çalıştırınız ve IP konfigürasyonunu yapılandırınız.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 28

Aynı şekilde, VMware Windows 10 sanal makina TCP/IP ayarları aşağıdaki gibidir.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 29

VMnet1’e bağlanan Windows 8.1 sanal makina Ping bağlantı testi aşağıdaki gibidir.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

   Adım 30

VMnet2’ye bağlanan VMware Windows 10 sanal makina Ping bağlantı testi de aşağıdaki gibidir.

Görüldüğü gibi iki sanal makina da birbirleriyle Router aracılığıyla başarıyla haberleşmektedir. GNS3 Cloud yapılandırma‘sı sanal makinaların hatasız çalışması için çok önemlidir.

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları Show Komutları

R1#show running-configR1#show ip routeR1#show ip route connected
R1#show running-config
Building configuration…
Current configuration : 1043 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#
R1#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

C 192.168.10.0/24 is directly connected, FastEthernet0/1
C 192.168.5.0/24 is directly connected, FastEthernet0/0
R1#

R1#show ip route connected
C 192.168.10.0/24 is directly connected, FastEthernet0/1
C 192.168.5.0/24 is directly connected, FastEthernet0/0
R1#

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları ⇒ Video

GNS3 Cloud yapılandırma adımlarını aşağıdaki videoyu izleyerek gerçekleştirebilir ve ayrıca YouTube kanalımıza abone olabilirsiniz…

  Son Söz

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları – Bu yazımızda, GNS3 Cloud VMware sanal makina bağlantısını gerçekleştirdik. GNS3’te sanal makina kullanımı için Cloud bilgisayarları kullanmanızı öneririz. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

GNS3 Cloud Yapılandırma | GNS3 Cloud Ayarları İlgili Yazılar

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir