GNS3 Cisco Switch Port Security Yapılandırma – Bu yazımızda GNS3’te Layer 2 Switch üzerinde Port Security (Port Güvenliği) ayarlarını yapılandıracağız. Öncelikle Cisco Switch Port Güvenliği mantığını anlamamız gerekir.
GNS3 Cisco Switch Port Security Yapılandırma

GNS3 Cisco Switch Port Security Yapılandırma

GNS3 Cisco Switch Port Security Yapılandırma

Bir ağda Cisco Switch aygıtları kullanılıyorsa, network güvenliği için aygıtlar üzerinde Port Security (Port Güvenliği) uygulanması gerekmektedir. Port Güvenliği yapılandırması, Cisco Switch üzerinde tümleşik olarak bulunan Interface (Arayüz)’lere uygulanmaktadır. Örneğin, bir firmada muhasebe odasındaki bir bilgisayar Cisco Switch FastEthernet0/5 portuna bağlıysa, ve o bilgisayarı sadece bir kişi kullanıyorsa, FastEthernet 0/5 arayüzünde Port Security uygulanabilir.

Cisco Switch üzerinde Port Security uygulanan bir arayüz, bilgisayarın MAC adresi ile eşleştirilir ve böylece başka bir bilgisayarın bu arayüze bağlanması engellenerek güvenlik sağlanır.

Cisco Switch arayüzü bilgisayarın MAC adresi ile eşleşir ve böylece başka bir MAC adresine sahip bilgisayar, bu Cisco Switch arayüzüne bağlanması kısıtlanır.

Firma bilgilerini izinsiz olarak almak isteyen bir kişi, sadece İnternet üzerinden atağa geçmez. Firma içerisindeki aygıtlara erişebilmesi için, bir personel olarak firmaya başvuru yapabilir.  Böylelikle kendi bilgisayarını ağ aygıtlarına bağlayarak atak yapabilir.

Bu tarz bir girişimi engellemek için, firmada Cisco Switch kullanılıyorsa, Cisco Switch üzerinde Port Güvenliği ayarlarının yapılması gereklidir.

Ayrca, Cisco Switch üzerinde Port Güvenliği için kısıtlamalar da bulunmaktadır. Örneğin;

1. Arayüzü Kapat [ shutdown ]

Bu kısıtlama, ihlal durumunda arayüzü kapatır ve Switch üzerinde bir bildirim gönderir.

2. Arayüzü Kısıtla [ Restrict ]

Bu kısıtlama, ihlal durumunda arayüzü kapatmaz ve sadece bildirim gönderir.

3. Arayüzü Koru [ Protect ]

Bu kısıtlama, ihlal durumunda arayüzü kapatmaz ve bildirim de göndermez. Sadece portu korur.

Port Güvenliği yapılandırılmış bir Switch arayüzüne herhangi bir farklı bilgisayar bağlandığında, Cisco Switch o portu ya kapatır ya da kısıtlar.

Sadece kısıtlama yapıldıysa, Switch arayüzü kapanmayacak fakat erişimi kısıtlayacaktır. Atak yapan bilgisayar ağ üzerinde herhangi bir aygıta kesinlikle erişemeyecektir.

Önceki yazımızda, GNS3 Layer 2 Switch Ekleme adımlarını gerçekleştirmiştik. Cisco Switch üzerinde Port Güvenliğini yapılandırmadan önce GNS3 üzerinde L2 Switch ekleyiniz. Ayrıca, GNS3 üzerinde VPCS (Sanal Bilgisayar) kullanabilmek için, GNS3 VPCS Yapılandırma konusuna göz atabilirsiniz.

Bu yazımızda, GNS3’te Layer 2 Switch üzerinde Port Security (Port Güvenliği) ayarlarını yapılandıracağız. Ve yukarıdaki verdiğimiz saldırı yöntemini engelleyeceğiz.

GNS3’te Layer 2 Switch Port Security Yapılandırma

Cisco L2 anahtar üzerinde Port Güvenliğini etkinleştirmek için GNS3 programının bilgisayarınızda kurulu olması gerekmektedir. Eğer programı kurmadıysanız, GNS3 Kurulumu yapınız.

Adım adım Port Security yapılandırmak için, aşağıdaki adımları takip ediniz.

   Adım 1

GNS3 programını çalıştırınız ve yeni bir proje oluşturunuz.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 2

GNS3 çalışma alanına bir adet Layer 2 Switch ekleyiniz.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 3

GNS3 çalışma alanına iki adet sanal bilgisayar VPCS ekleyiniz.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 4

GNS3’te Cisco Layer 2 Switch’e arayüz eklemek ve performans artışı yapmak için üzerinde sağ tuşa tıklayınız.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 5

L2 Switch üzerinde açılan seçeneklerden Configure (Yapılandır) seçeneğine tıklayınız.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 6

L2 Switch penceresinde, RAM değerini aşağıdaki gibi arttırınız ve ardından HDD sekmesine tıklayınız.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 7

HDD sekmesinde sata seçeneğini seçerek devam ediniz. Bu seçenek Cisco Switch’in daha performanslı çalışmasını sağlayacaktır.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 8

L2 Switch penceresinde Network sekmesine tıklayını ve Adapters (Adaptör/Arayüz) kısmında kaç tane arayüz kullanacaksınız miktarını belirtiniz ve daha sonra OK (Tamam) butonuna tıklayarak ayarları kaydediniz.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 9

GNS3 çalışma alanındaki ağ aygıtlarını kablolamak için, aşağıdaki görüntüdeki gibi kablolama seçeneğine tıklayınız.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 10

Çalışma alanındaki aygıtları kabloladıktan sonra, Start All Nodes (Tüm Düğümleri Başlat) butonuna tıklayarak aygıtları çalıştırınız.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 11

Aşağıdaki görüntüdeki gibi aygıtlar sorunsuz çalışması gerekmektedir.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 12

GNS3 çalışma alanı üzerine açıklamalar ekleyerek işlevselliği arttırabilirsiniz. Şimdi, tüm aygıtların konsol pencerelerini çalıştırınız.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 13

GNS3 Cisco Switch Port Security yapılandırma adımlarından önce, VPCS’leri yapılandırmanız gerekmektedir.

VPCS PC1’e Ip adresi atamak için aşağıdaki komutu uygulayınız.

ip 192.168.5.5/24 192.168.5.1

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 14

VPCS PC2’ye Ip adresi atamak için aşağıdaki komutu uygulayınız.

ip 192.168.5.10/24 192.168.5.1

VPCS PC’leri yapılandırdıktan sonra, show ip komutu ile IP yapılandırmasını kontrol ediniz.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 15

PC1’den PC2’ye bağlantı testi aşağıdaki görüntüdeki gibi başarılıdır.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 16

PC2’den PC1’e bağlantı testi aşağıdaki görüntüdeki gibi başarılıdır.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 17

Layer 2 Cisco Switch üzerinde VLAN1’e IP adresi atamak için aşağıdaki komutları uygulayınız.

Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface vlan 1
*May 26 22:55:21.080: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed s
Switch(config-if)#ip address 192.168.5.100 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#end
Switch#

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 18

GNS3 Cisco Switch Port Security yapılandırma işlemi için aşağıdaki komutları sırasıyla uygulayınız.

Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface gigabitethernet 0/0
Switch(config-if)#switchport host
switchport mode will be set to access
spanning-tree portfast will be enabled
channel group will be disabled

Switch(config-if)#switchport port-security
Switch(config-if)#switchport port-security mac-address sticky
Switch(config-if)#switchport port-security maximum 1
Switch(config-if)#switchport port-security violation shutdown
Switch(config-if)#exit
Switch(config)#
Switch(config)#
Switch(config)#interface gigabitethernet 0/1
Switch(config-if)#switchport host
switchport mode will be set to access
spanning-tree portfast will be enabled
channel group will be disabled

Switch(config-if)#switchport port-security
Switch(config-if)#switchport port-security mac-address sticky
Switch(config-if)#switchport port-security maximum 1
Switch(config-if)#switchport port-security violation shutdown
Switch(config-if)#end
Switch#wr
Switchport Host komutu ile Cisco Switch arayüzünü Dynamic moddan Access moduna ayarlayabiliriz.
Aksi takdirde, Cisco Switch arayüzü Access Port olarak ayarlanmayacaktır!

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 19

Cisco Switch üzerinde privileged modda show port-security komutunu çalıştırarak, arayüzler üzerinde herhangi bir ihlalin olup olmadığını görebilirsiniz.

Şuan herhangi bir atak yapılmadığı için, SecurityViolation kısmı 0 olarak görünecektir.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 20

L2 Switch üzerinde show port-security interface gigabitethernet 0/0 komutunu uygulayarak arayüzün Port Güvenliği ile ilgili bilgileri ve ihlal durumunu görebilirsiniz.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 21

Cisco Switch üzerinde Port Security yapılandırdıktan sonra, PC’ler arasındaki bağlantıyı test edecek olursak, PC1’den PC2’ye bağlantı sağlanmıştır.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 22

PC2’den PC1’e de ping işlemi başarılıdır.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 23

Bilgisayarlar arası Ping işlemi sonrası Cisco Switch üzerinde MAC adres tablosu güncellenmiştir. Cisco Switch PC1 ve PC2’nin MAC adreslerini tablosuna kaydetti ve herhangi bir ihlal durumunda buradaki MAC adresleri ile kıyaslama yapacaktır.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 24

Bilgisayarlardan VLAN1 IP adresine Ping işlemi gerçekleştirdiğimizde bağlantı sağlanacaktır.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 25

PC2’den VLAN1’e Ping işlemi de başarılıdr.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 26

GNS3 Cisco Switch Port Security yapılandırma adımlarını tamamladıktan sonra, Port Güvenliği’nin çalışmasını test etmek için GNS3 çalışma alanına bir adet daha VPCS ekleyiniz.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 27

VPCS PC3’ün IP ayarlarını yapılandırınız.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 28

PC1’den Layer 2 Switch’e giden kabloyu çıkarınız. Kablo üzerinde sağ tuşa tıklayınız ve Delete (Sil) seçeneğine tıklayınız.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 29

VPCS PC3’ü L2 Switch’e bağlamak için kablolama seçeneğine tıklayınız. Daha sonra PC3 üzerine tıklayınız.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 30

L2 Switch üzerine tıkladığınızda, Ethernet0/0 arayüzü seçiniz. Önceden bu arayüzde PC1 bağlıydı ve şimdi ne olacağını görelim.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 31

PC3’ten PC2’ye Ping attığımızda ulaşılamaz mesajını alırız. Switch’i kontrol edelim.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 32

Cisco Switch konsolunda ihlal durumunda hemen bir log kaydı düşecektir. Buradaki log kaydı aşağıdaki gibidir.

Switch#
*May 26 23:03:58.687: %PM-4-ERR_DISABLE: psecure-violation error detected on Gi0/0, putting Gi0/0 in err-disable state
*May 26 23:03:58.697: %PORT_SECURITY-2-PSECURE_VIOLATION: Security violation occurred, caused by MAC address 0050.7966.6802 on port GigabitEthernet0/0.
*May 26 23:03:59.687: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to down
*May 26 23:04:00.693: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to down
Switch#

Yukarıdaki çıktı GigabitEthernet0/0 üzerinde bir güvenlik ihali olduğunu bildirmektedir. Bu bildiriden hemen sonra, Switch ilgili portu kapatacaktır.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 33

L2 Anahtar üzerinde show port-security komutunu çalıştırdığımızda Gig0/0 üzerinde bir ihlal olduğunu gösterecektir.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 34

Aynı şekilde, L2 üzerinde show ip interface brief komutunu çalıştırarak arayüz durumlarını kontrol ettiğimizde, GigabitEthernet0/0 arayüzün kapalı olduğunu görebiliriz.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 35

PC3 ağ ortamına Port Güvenliği nedeniyle ulaşamadı. PC1 bilgisayarı tekrardan L2 Anahtara bağlamak için, kabloyu çıkarınız.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 36

PC1’i tekrar L2 Anahtar üzerinde 0/0 arayüzüne bağlayınız.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 37

Cisco Switch Gig0/0 arayüzünü kapattığı için tekrardan aktif etmemiz gereklidir. Bu arayüzü tekrar akfit etmek için önce shutdown sonra no shutdown komutunu uygulayınız.

Buradaki adımda görüldüğü gibi Switch arayüzü başarıyla kapatarak kendini savunmaya aldı. Eğer Port Security yapılandırma adımında Violation (İhlal) seçeneğini Restrict olarak ayarlasaydık arayüz kapatılmayacaktı.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 38

Tekrardan show port-security komutunu çalıştırdığınızda ihlal kısmının boş olduğunu görebilirsiniz.

GNS3 Cisco Switch Port Security Yapılandırma

   Adım 39

Bağlantı testi yaptığımızda, PC1 tekrardan ağ ortamına başarıyla eriştiğini görebiliriz!

GNS3 Cisco Switch Port Security Yapılandırma

GNS3 Cisco Switch Port Security Yapılandırma Show Komutları

Switch#show port-securitySwitch#show port-security interface gigabitethernet 0/0Switch#show mac address-tableSwitch Violation LogSwitch#show port-security
Switch#show port-security
Secure Port MaxSecureAddr CurrentAddr SecurityViolation Security Action
(Count) (Count) (Count)
—————————————————————————
Gi0/0 1 0 0 Shutdown
Gi0/1 1 0 0 Shutdown
—————————————————————————
Total Addresses in System (excluding one mac per port) : 0
Max Addresses limit in System (excluding one mac per port) : 4096
Switch#

Switch#show port-security interface gigabitethernet 0/0
Port Security : Enabled
Port Status : Secure-up
Violation Mode : Shutdown
Aging Time : 0 mins
Aging Type : Absolute
SecureStatic Address Aging : Disabled
Maximum MAC Addresses : 1
Total MAC Addresses : 0
Configured MAC Addresses : 0
Sticky MAC Addresses : 0
Last Source Address:Vlan : 0000.0000.0000:0
Security Violation Count : 0
Switch#

Switch#show mac address-table
Mac Address Table
——————————————-

Vlan Mac Address Type Ports
—- ———– ——– —–
1 0050.7966.6800 STATIC Gi0/0
1 0050.7966.6801 STATIC Gi0/1
Total Mac Addresses for this criterion: 2
Switch#

Switch#
*May 26 23:03:58.687: %PM-4-ERR_DISABLE: psecure-violation error detected on Gi0/0, putting Gi0/0 in err-disable state
*May 26 23:03:58.697: %PORT_SECURITY-2-PSECURE_VIOLATION: Security violation occurred, caused by MAC address 0050.7966.6802 on port GigabitEthernet0/0.
*May 26 23:03:59.687: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to down
*May 26 23:04:00.693: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to down
Switch#

Switch#show port-security
Secure Port MaxSecureAddr CurrentAddr SecurityViolation Security Action
(Count) (Count) (Count)
—————————————————————————
Gi0/0 1 1 1 Shutdown
Gi0/1 1 1 0 Shutdown
—————————————————————————
Total Addresses in System (excluding one mac per port) : 0
Max Addresses limit in System (excluding one mac per port) : 4096
Switch#

GNS3 Cisco Switch Port Security Yapılandırma ⇒ Video

GNS3 Cisco Switch Port Security yapılandırma ve konfigürasyonu adımlarını videoyu izleyerek gerçekleştirebilir ve ayrıca YouTube kanalımıza abone olabilirsiniz…

  Son Söz

GNS3 Cisco Switch Port Security Yapılandırma – GNS3 üzerinde Layer 2 Switch Port Security konfigürasyonu işlemini tamamladık. GNS3 bilindiği gibi bir ağ simülatörüdür. Gerçek senaryoda Port Güvenliği uygularken, MAC adreslerini Static olarak elle girmenizde fayda vardır. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

GNS3 Cisco Switch Port Security Yapılandırma İlgili Yazılar

GNS3 Cisco Switch Port Security Yapılandırma İlgili Dosyalar
İlgili Dosyalar
Bu yazıda kullanılan GNS3 sürümünü, L2 Switch IOS’u ve GNS3 projesini bilgisayarınıza aşağıdaki butonlardan indirebilirsiniz.

 
 

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir