GNS3 Cisco Switch BackboneFast Yapılandırma – Standart Spanning Tree Protokolünü yapılandırırken, sık sık UplinkFast, PortFast ve BackboneFast gibi terimler ile karşılaşırız. Bu özellikler sadece Cisco markasına özgüdür ve diğer markalar ile kullanılamaz.
GNS3 Cisco Switch BackboneFast Yapılandırma

GNS3 Cisco Switch BackboneFast Yapılandırma

Layer 2 Switch‘lerde ağdaki döngüleri (Loop) önlemek amacıyla STP protokolü çalışır. Rapid STP protokolünü desteklemeyen eski IOS sürümlerinde PVST (Per VLAN Spanning Tree) protokolü kullanılmaktadır. Bu terimi kısaca Standart Spanning Tree Protokolü olarak adlandırabiliriz.

Yedekli bir ağda meydana gelen bir kablo arızası sonucu Spanning Tree Protokolü hemen devreye girer ve paketleri iletmeye devam eder. Fakat Cisco Switch’ler üzerinde STP protokolünü yapılandırmanız gereklidir.

Standart STP protokolünü daha performanslı hale getirmek için PortFast, UplinkFast ve BackboneFast özelliklerini etkinleştirmemiz gerekir.

Spanning Tree BackboneFast özelliği, bir kablo (link) hatası sonucunda Switch’ler arasında hızlı STP Convergence işlemini sağlar. Klasik STP protokolünü kullanan Cisco Switch’ler üzerinde BackboneFast etkinleştirilmediğinde bir link hatasında STP yakınsama süresi 50 saniye sürecektir.

Kısacası Cisco Switch BackboneFast yapılandırma işleminden sonra bir link hatası sonucunda Max Age Timer süresi değerlendirilmeyecek ve 50 saniyelik downtime süresini 30 saniyeye (50-20=30) azaltacaktır.

GNS3 Spanning Tree BackboneFast Konfigürasyonu

Cisco Switch’ler üzerinde BackboneFast etkinleştirmeden önce küçük bir test yaparak downtime süresine göz atacağız. Daha sonra GNS3 programını kullanarak Cisco Switch’ler üzerinde BackboneFast etkinleştireceğiz.

GNS3 Cisco Switch BackboneFast yapılandırma adımlarına başlamadan önce, GNS3 VM Server Kurulumu ve GNS3 VM Cisco IOU Kurulumu adımlarını gerçekleştirmeniz gerekir. BackboneFast anlama ve yapılandırma için Cisco IOU gereklidir aksi takdirde detaylı olarak inceleyemezsiniz.

Spanning Tree BackboneFast konfigürasyonu için aşağıdaki adımları sırasıyla takip ediniz.

   Adım 1

GNS3 programını açınız ve BackboneFast yapılandırması için yeni bir proje oluşturunuz.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 2

Aynı zamanda GNS3 VM Kurulumu yaptıktan sonra VMware Workstation programını açınız.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 3

Cisco IOU kurulumundan sonra, GNS3 programına Layer 2 Switch ekleyiniz ve ardından çalışma alanına 4 adet L2 Switch ekleyiniz.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 4

Cisco Switch’lerin isimlerini aşağıdaki gibi değiştiriniz.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 5

Cisco Layer 2 Switch’leri kabloladıktan sonra, GNS3 çalışma alanına 2 adet VPCS bilgisayar ekleyiniz. GNS3 VM Server kullandığınız için aşağıdaki soruyu soruyor. VPCS bilgisayarları Local olarak çalıştırınız.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 6

VPCS bilgisayarların TCP/IP konfigürasyonunu yapılandırınız ve ardından tüm aygıtları başlatınız.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 7

Lenovo PC’den HP PC’ye Ping atarak ağ bağlantısını kontrol ediniz. Ping işlemi başarılı olduktan sonra bir sonraki adıma geçiniz.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 8

GNS3 Cisco Switch BackboneFast yapılandırma’dan önce Cisco Switch SW1’i Root Bridge olarak yapılandırınız. Daha sonra SW1 CLI komut istemini açınız ve show spanning-tree komutunu çalıştırırak Root Bridge olduğunu kontrol ediniz. Ayrıca, Switch’ler üzerinde Spanning Tree Port Durumlarını da not ediniz.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 9

Root Bridge ve Port Durumlarını belirledikten sonra ağ topolojisi aşağıdaki gibidir.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 10

BackboneFast etkinleştirmeden önce, Lenovo PC’den HP PC’ye sürekli Ping işlemini başlatınız ve hemen sonra SW3 sekmesine tıklayınız.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 11

Indirect link hatası oluşturmak için HP PC’ye doğru çıkış yapan arayüzü shutdown komutu ile kapatabilirsiniz. Daha sonra Lenovo PC sekmesine tıklayarak ne olduğunu inceleyiniz.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 12

Bir link hatası oluşturduktan sonra, Cisco Switch BackboneFast yapılandırılmadığı için aşağıdaki görüntüde gördüğünüz gibi STP Convergence süresi 50 saniye olacaktır.

SW3 Ethernet 0/2 arayüzünü no shutdown komutu ile aktif edebilirsiniz.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 13

GNS3 Cisco Switch BackboneFast yapılandırma için Switch’lerin CLI komut istemlerini açınız ve config modda sırasıyla spanning-tree backbonefast komutunu uygulayınız.

BackboneFast etkinleştirildiğini doğrulamak için show spanning-tree summary komutunu uygulayınız.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 14

Cisco Switch SW2 üzerinde de Spanning Tree BackboneFast etkinleştiriniz.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 15

Aynı şekilde SW3 üzerinde de BackboneFast etkinleştiriniz.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 16

Son olarak Switch SW4 üzerinde BackboneFast özelliğini etkinleştiriniz ve show spanning-tree summary komutu ile yapılandırmayı doğrulayınız.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 17

GNS3 Cisco Switch BackboneFast yapılandırma adımlarını tamamladıktan sonra, Cisco Switch’ler üzerinde BackboneFast özelliğinin nasıl çalıştığını incelemek için Privileged modda debug spanning-tree backbonefast detail komutunu uygulayınız.

Ağ üzerindeki Switch’lerde bir indirect link hatası meydana geldiğinde BackboneFast devreye girecek ve RLQ BPDU paketlerin logları CLI komut istemine düşecektir.

Tüm Layer 2 Switch’ler üzerinde debug spanning-tree backbonefast detail komutunu uygulayınız.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 18

HP PC’ye tekrar sürekli Ping işlemini başlatınız ve hemen ardından SW3 Ethernet 0/2 arayüzünü shutdown komutu ile kapatınız.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 19

Cisco Switch SW3 Ethernet 0/2 arayüzünü kapattıktan hemen sonra SW1, SW2 ve SW4 üzerinde loglar oluşacaktır.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 20

Lenovo PC Ping işlemini kontrol ettiğimizde, Ping işleminde 30 saniyelik bir downtime süresi bulunmaktadır. BackboneFast etkinleştirmeden önce 50 saniyeydi. Fakat BackboneFast özelliğini etkinleştirdikten sonra 20 saniye kurtararak downtime süresini 30 saniyeye indirdik.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 21

SW3 Root Bridge bağlantısını kaybettiği için komşu SW4 Switch’e yeni Root Bridge olmak için bir inferior BPDU paketi gönderir. SW1 SW4’ten aldığı bir inferior (RLQ) paketine aşağıdaki gibi bir yanıt veriyor.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 22

Paketi alan SW2, SW4’ün Ethernet 0/2 Root portu üzerinden paketi iletiyor.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 23

SW4 göndermiş olduğu RLQ paketine yanıt alıyor ve SW3’ten aldığı eski interior paketini sonlandırmak için max age timer süresini atlayarak 20 saniye kazandırmış oluyor.

GNS3 Cisco Switch BackboneFast Yapılandırma

   Adım 24

GNS3 Cisco Switch BackboneFast yapılandırma adımlarını tamamladıktan sonra, aşağıdaki görüntüyü inceleyerek Spanning Tree Protokolünde BackboneFast faydasını görebilirsiniz.

GNS3 Cisco Switch BackboneFast Yapılandırma

GNS3 Cisco Switch BackboneFast Yapılandırma Show Komutları

GNS3 Cisco Switch BackboneFast yapılandırma işleminde kullanılan show komutlarını inceleyebilirsiniz.

Show Spanning-Tree Komutları

Manuel Root Bridge SeçmeSW1#show spanning-treeSW2#show spanning-treeSW3#show spanning-treeSW4#show spanning-tree
SW1#conf t
SW1(config)# spanning-tree vlan 1 priority 4096
SW1(config)# end
SW1#
SW1#show spanning-tree

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address aabb.cc00.0100
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 4097 (priority 4096 sys-id-ext 1)
Address aabb.cc00.0100
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
——————- —- — ——— ——– ——————————–
Et0/0 Desg FWD 100 128.1 Shr
Et0/1 Desg FWD 100 128.2 Shr
Et0/2 Desg FWD 100 128.3 Shr
Et0/3 Desg FWD 100 128.4 Shr
Et1/0 Desg FWD 100 128.33 Shr
Et1/1 Desg FWD 100 128.34 Shr
Et1/2 Desg FWD 100 128.35 Shr
Et1/3 Desg FWD 100 128.36 Shr
Et2/0 Desg FWD 100 128.65 Shr
Et2/1 Desg FWD 100 128.66 Shr
Et2/2 Desg FWD 100 128.67 Shr
Et2/3 Desg FWD 100 128.68 Shr
Et3/0 Desg FWD 100 128.97 Shr
Et3/1 Desg FWD 100 128.98 Shr
Et3/2 Desg FWD 100 128.99 Shr
Et3/3 Desg FWD 100 128.100 Shr

SW1#

SW2#show spanning-tree

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address aabb.cc00.0100
Cost 100
Port 1 (Ethernet0/0)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address aabb.cc00.0200
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
——————- —- — ——— ——– ——————————–
Et0/0 Root FWD 100 128.1 Shr
Et0/1 Desg FWD 100 128.2 Shr
Et0/2 Desg FWD 100 128.3 Shr
Et0/3 Desg FWD 100 128.4 Shr
Et1/0 Desg FWD 100 128.33 Shr
Et1/1 Desg FWD 100 128.34 Shr
Et1/2 Desg FWD 100 128.35 Shr
Et1/3 Desg FWD 100 128.36 Shr
Et2/0 Desg FWD 100 128.65 Shr
Et2/1 Desg FWD 100 128.66 Shr
Et2/2 Desg FWD 100 128.67 Shr
Et2/3 Desg FWD 100 128.68 Shr
Et3/0 Desg FWD 100 128.97 Shr
Et3/1 Desg FWD 100 128.98 Shr
Et3/2 Desg FWD 100 128.99 Shr
Et3/3 Desg FWD 100 128.100 Shr

SW2#

SW3#show spanning-tree

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address aabb.cc00.0100
Cost 100
Port 3 (Ethernet0/2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address aabb.cc00.0300
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
——————- —- — ——— ——– ——————————–
Et0/0 Desg FWD 100 128.1 Shr
Et0/1 Desg FWD 100 128.2 Shr
Et0/2 Root FWD 100 128.3 Shr
Et0/3 Desg FWD 100 128.4 Shr
Et1/0 Desg FWD 100 128.33 Shr
Et1/1 Desg FWD 100 128.34 Shr
Et1/2 Desg FWD 100 128.35 Shr
Et1/3 Desg FWD 100 128.36 Shr
Et2/0 Desg FWD 100 128.65 Shr
Et2/1 Desg FWD 100 128.66 Shr
Et2/2 Desg FWD 100 128.67 Shr
Et2/3 Desg FWD 100 128.68 Shr
Et3/0 Desg FWD 100 128.97 Shr
Et3/1 Desg FWD 100 128.98 Shr
Et3/2 Desg FWD 100 128.99 Shr
Et3/3 Desg FWD 100 128.100 Shr

SW3#

SW4#show spanning-tree

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address aabb.cc00.0100
Cost 200
Port 3 (Ethernet0/2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address aabb.cc00.0400
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
——————- —- — ——— ——– ——————————–
Et0/0 Desg FWD 100 128.1 Shr
Et0/1 Altn BLK 100 128.2 Shr
Et0/2 Root FWD 100 128.3 Shr
Et0/3 Desg FWD 100 128.4 Shr
Et1/0 Desg FWD 100 128.33 Shr
Et1/1 Desg FWD 100 128.34 Shr
Et1/2 Desg FWD 100 128.35 Shr
Et1/3 Desg FWD 100 128.36 Shr
Et2/0 Desg FWD 100 128.65 Shr
Et2/1 Desg FWD 100 128.66 Shr
Et2/2 Desg FWD 100 128.67 Shr
Et2/3 Desg FWD 100 128.68 Shr
Et3/0 Desg FWD 100 128.97 Shr
Et3/1 Desg FWD 100 128.98 Shr
Et3/2 Desg FWD 100 128.99 Shr
Et3/3 Desg FWD 100 128.100 Shr

SW4#

Show Spanning-Tree Summary Komutları

SW1#show spanning-tree summaryBackboneFast EtkinleştirmeSW2# show spanning-tree summarySW3#show spanning-tree summarySW4#show spanning-tree summary
SW1#show spanning-tree summary
Switch is in pvst mode
Root bridge for: VLAN0001
Extended system ID is enabled
Portfast Default is disabled
PortFast BPDU Guard Default is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default is disabled
EtherChannel misconfig guard is enabled
Configured Pathcost method used is short
UplinkFast is disabled
BackboneFast is enabled

Name Blocking Listening Learning Forwarding STP Active
———————- ——– ——— ——– ———- ———-
VLAN0001 0 0 0 16 16
———————- ——– ——— ——– ———- ———-
1 vlan 0 0 0 16 16

BackboneFast statistics
———————–
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
SW1#

SW1#conf t
SW1(config)#spanning-tree backbonefast
SW1(config)# end
SW1#
SW2# show spanning-tree summary
Switch is in pvst mode
Root bridge for: none
Extended system ID is enabled
Portfast Default is disabled
PortFast BPDU Guard Default is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default is disabled
EtherChannel misconfig guard is enabled
Configured Pathcost method used is short
UplinkFast is disabled
BackboneFast is enabled

Name Blocking Listening Learning Forwarding STP Active
———————- ——– ——— ——– ———- ———-
VLAN0001 0 0 0 16 16
———————- ——– ——— ——– ———- ———-
1 vlan 0 0 0 16 16

BackboneFast statistics
———————–
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
SW2(config)#

SW3#show spanning-tree summary
Switch is in pvst mode
Root bridge for: none
Extended system ID is enabled
Portfast Default is disabled
PortFast BPDU Guard Default is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default is disabled
EtherChannel misconfig guard is enabled
Configured Pathcost method used is short
UplinkFast is disabled
BackboneFast is enabled

Name Blocking Listening Learning Forwarding STP Active
———————- ——– ——— ——– ———- ———-
VLAN0001 0 0 0 16 16
———————- ——– ——— ——– ———- ———-
1 vlan 0 0 0 16 16

BackboneFast statistics
———————–
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
SW3#

SW4#show spanning-tree summary
Switch is in pvst mode
Root bridge for: none
Extended system ID is enabled
Portfast Default is disabled
PortFast BPDU Guard Default is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default is disabled
EtherChannel misconfig guard is enabled
Configured Pathcost method used is short
UplinkFast is disabled
BackboneFast is enabled

Name Blocking Listening Learning Forwarding STP Active
———————- ——– ——— ——– ———- ———-
VLAN0001 1 0 0 15 16
———————- ——– ——— ——– ———- ———-
1 vlan 1 0 0 15 16

BackboneFast statistics
———————–
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
SW4#

Debug Logları

SW1#debug spanning-tree backbonefast detailSW1 Debug ÇıktısıSW2 Debug ÇıktısıSW4 Debug Çıktısı
SW1#debug spanning-tree backbonefast detail
Spanning Tree backbonefast detail debugging is on
SW1#
SW1#
*Sep 13 22:11:43.751: STP FAST: VLAN0001 Ethernet0/0: sending requested RLQ response PDU
SW1#
SW2#
*Sep 13 22:11:43.748: STP FAST: VLAN0001 Ethernet0/2: forwarding RLQ request PDU over root port
SW2#
SW4#
*Sep 13 22:11:43.752: STP FAST: received RLQ response PDU was expected on VLAN0001 Ethernet0/2 – resp root id 4097-aabb.cc00.0100 .
*Sep 13 22:11:43.752: STP FAST: received_rlq_bpdu on VLAN0001 Ethernet0/1 – making Ethernet0/1 a designated port
SW4#

Show Running-Config Komutları

SW1#show running-configSW2#show running-configSW3#show running-configSW4#show running-config
SW1#show running-config
Building configuration…

Current configuration : 1587 bytes
!
! Last configuration change at 22:03:42 UTC Wed Sep 13 2017
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW1
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
no ip icmp rate-limit unreachable
!
no ip domain-lookup
ip cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 1 priority 4096
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
interface Ethernet0/0
duplex auto
!
interface Ethernet0/1
duplex auto
!
interface Ethernet0/2
duplex auto
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!
interface Ethernet3/0
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
shutdown
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

SW1#

SW2#show running-config
Building configuration…

Current configuration : 1552 bytes
!
! Last configuration change at 22:09:13 UTC Wed Sep 13 2017
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW2
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
no ip icmp rate-limit unreachable
!
no ip domain-lookup
ip cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
interface Ethernet0/0
duplex auto
!
interface Ethernet0/1
duplex auto
!
interface Ethernet0/2
duplex auto
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!
interface Ethernet3/0
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
shutdown
!
!
no ip http server
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

SW2#

SW3#show running-config
Building configuration…

Current configuration : 1562 bytes
!
! Last configuration change at 22:18:37 UTC Wed Sep 13 2017
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW3
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
no ip icmp rate-limit unreachable
!
no ip domain-lookup
ip cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
!
interface Ethernet0/0
duplex auto
!
interface Ethernet0/1
duplex auto
!
interface Ethernet0/2
shutdown
duplex auto
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!
interface Ethernet3/0
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
shutdown
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

SW3#

SW4#show running-config
Building configuration…

Current configuration : 1552 bytes
!
! Last configuration change at 22:07:26 UTC Wed Sep 13 2017
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW4
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
no ip icmp rate-limit unreachable
!
no ip domain-lookup
ip cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
!
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
interface Ethernet0/0
duplex auto
!
interface Ethernet0/1
duplex auto
!
interface Ethernet0/2
duplex auto
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!
interface Ethernet3/0
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
shutdown
!
!
no ip http server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

Show Spanning-Tree BackboneFast Komutları

SW1#show spanning-tree backbonefastSW2#show spanning-tree backbonefastSW3#show spanning-tree backbonefastSW4#show spanning-tree backbonefast
SW1#show spanning-tree backbonefast
BackboneFast is enabled

BackboneFast statistics
———————–
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 2
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 2
SW1#

SW2#show spanning-tree backbonefast
BackboneFast is enabled

BackboneFast statistics
———————–
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 2
Number of RLQ response PDUs received (all VLANs) : 2
Number of RLQ request PDUs sent (all VLANs) : 2
Number of RLQ response PDUs sent (all VLANs) : 30
SW2#

SW3#show spanning-tree backbonefast
BackboneFast is enabled

BackboneFast statistics
———————–
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
SW3#

SW4#show spanning-tree backbonefast
BackboneFast is enabled

BackboneFast statistics
———————–
Number of transition via backboneFast (all VLANs) : 2
Number of inferior BPDUs received (all VLANs) : 2
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 2
Number of RLQ request PDUs sent (all VLANs) : 2
Number of RLQ response PDUs sent (all VLANs) : 0
SW4#

GNS3 Cisco Switch BackboneFast Yapılandırma ⇒ Video

GNS3 Spanning Tree BackboneFast konfigürasyonu adımlarını aşağıdaki videoyu izleyerek gerçekleştirebilir ve ayrıca YouTube kanalımıza abone olabilirsiniz…

  Son Söz

GNS3 Cisco Switch BackboneFast Yapılandırma – Bu yazımızda Cisco Switch’ler üzerinde BackboneFast yapılandırma adımlarını gerçekleştirdik. Bu Lab’da kullanılan Layer 2 Switch Cisco IOU’su i86bi-linux-l2-ipbasek9-15.1a.bin‘dir. Ayrıca GNS3 Cisco Switch UplinkFast Yapılandırma ve GNS3 Cisco Switch PortFast Yapılandırma yazılarımıza göz atabilirsiniz. Bir sonraki yazımızda, Rapid Spanning Tree Protokolünü inceleyeğiz ve bu protokolü etkinleştirdiğimizde UplinkFast ve BackboneFast yapılandırma adımlarına gerek kalmayacaktır. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

GNS3 Cisco Switch BackboneFast Yapılandırma İlgili Yazılar

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

four × 1 =