GNS3 Cisco Router Static Routing Yapılandırma – Bu yazımızda, GNS3 programını kullanarak küçük iki farklı network üzerindeki bilgisayarları haberleştirmek için Cisco Router‘lar üzerinde Static Routing (Statik Yönlendirme) yapılandıracağız.
GNS3 Cisco Router Static Routing Yapılandırma

GNS3 Cisco Router Static Routing Yapılandırma

Static Routing bir yönlendirme protokolüdür. Router‘lar üzerinde manuel olarak Route (Rota) yapılandırıldığı için Static Routing olarak adlandırılır. Router’lar ağları haberleştirirken, rotalar kullanılır ve bu rotalar sayesinde IP paketleri gideceği yeri belirler.

Cisco Router’lar üzerinde Static Routing yapılandırmak çok basittir. Eğer küçük bir ağ topolojisine sahipseniz, Static Route (Statik Rota) yapılandırmanız önerilir. Statik yönlendirme, dinamik yönlendirme protokollerine göre daha performanslıdır çünkü dinamik yönlendirme protokolleri Router üzerinde ek bir donanım kaynağı kullanır. Ayrıca, bazı durumlarda da Statik Rota yapılandırmak gerekebilir.

Büyüyen bir ağda bu rotaların manuel olarak yapılandırılması zor ve karmaşık olacaktır. Bu yüzden Router’lar ağları otomatik olarak bulması için Dynamic Routing yapılandırılır.

Bu yazımızda Cisco Router’lar üzerinde Static Routing (Statik Yönlendirme) yaparak iki farklı lokasyonda bulunan ağları haberleştireceğiz.

GNS3’te Cisco Router Statik Yönlendirme

Bu yazıda GNS3 ve VMware Workstation programlarını kullanarak, Statik Rota / Statik Yönlendirme yapılandıracağız.

GNS3’te Cisco Router Statik yönlendirme adımlarına geçmeden önce, bilgisayarınızda GNS3 kurulumu ve VMware Workstation kurulumu yapmanız gerekmektedir. Ayrıca GNS3‘te sanal makina kullanımı için, GNS3 ile VMware Workstation bağlantısı adlı yazıya göz atabilirsiniz.

GNS3 ile VMware bağlantısını video olarak izlemek isterseniz, GNS3 ile VMware entegrasyonu adlı videoya göz atabilirsiniz.

   Adım 1

Cisco Router Static Routing yapılandırma adımlarına artık geçebiliriz. GNS3 programını açınız ve yeni bir proje oluşturunuz.

GNS3 Cisco Router Static Routing Yapılandırma

   Adım 2

GNS3 programında aşağıdaki görüntüdeki gibi ağ topolojisi oluşturunuz. Ayrıca açıklamalar da ekleyerek ağ topolojisinin daha net anlaşılabilirliğini sağlayabilirsiniz…

GNS3 Cisco Router Static Routing Yapılandırma

   Adım 3

VMware Workstation üzerinde Windows 8.1 sanal makinenin IP adresi ayarlarını aşağıdaki gibi yapılandırınız.

GNS3 Cisco Router Static Routing Yapılandırma

   Adım 4

Aynı şekilde, VMware Workstation üzerinde Windows 10 sanal makinenin IP adresi ayarlarını aşağıdaki gibi yapılandırınız.

GNS3 Cisco Router Static Routing Yapılandırma

   Adım 5

Cisco Router R1 CLI komut istemini açınız ve FastEthernet 0/1 arayüzünü yapılandırınız. Yapılandırdığınız arayüzleri show ip interface brief komutu ile kontrol edebilirsiniz.

R1# conf t
R1(config)# interface fastethernet 0/1
R1(config-if)# ip address 192.168.5.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# end

 
GNS3 Cisco Router Static Routing Yapılandırma

   Adım 6

Aynı şekilde, Cisco Router R2 üzerinde de 192.168.10.0/24 ağının bağlı olduğu arayüzü yapılandırınız.

R2# conf t
R2(config)# interface fastethernet 0/1
R2(config-if)# ip address 192.168.10.1 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# end

 
GNS3 Cisco Router Static Routing Yapılandırma

   Adım 7

Windows 8 sanal makineden Cisco Router R1’in Fa0/1 arayüzüne Ping işlemi başarılıdır.

GNS3 Cisco Router Static Routing Yapılandırma

   Adım 8

Windows 10 sanal makineden Cisco Router R2’nin Fa0/1 arayüzüne Ping işlemi de başarılıdır.

GNS3 Cisco Router Static Routing Yapılandırma

   Adım 9

Cisco Router R1’in FastEthernet0/0 arayüzünü yapılandırınız.

R1# conf t
R1(config)# interface fastethernet 0/0
R1(config-if)# ip address 10.1.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# end

 
GNS3 Cisco Router Static Routing Yapılandırma

   Adım 10

Aynı şekilde, Cisco Router R2’nin Fa0/0 arayüzünü de yapılandırınız.

R2# conf t
R2(config)# interface fastethernet 0/0
R2(config-if)# ip address 10.1.1.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# end

 
GNS3 Cisco Router Static Routing Yapılandırma

   Adım 11

Cisco Router Static Routing yapılandırmadan önce, Windows 8 sanal makineden Cisco Router R2’nin Fa0/0 arayüzüne ping atınız. Ping işlemi başarısız olacaktır. Çünkü Cisco Router’lara bu ağları bilmesi için herhangi bir konfigürasyon yapmadık.

İşte tam bu noktada Statik Rota veya dinamik yönlendirme protokollerinin önemi ortaya çıkmaktadır.

Windows 8 sanal makineden Cisco Router R2’nin Fa0/2 arayüzüne de Ping işlemi aşağıdaki gibi başarısız olacaktır. Bunu sebebi, Windows 8 sanal makine Cisco Router R2’nin Serial arayüzüne erişemediği içindir.

GNS3 Cisco Router Static Routing Yapılandırma

   Adım 12

Aynı işlemleri Windows 10 sanal makine üzerinden yapınız ve sanal makinenin 192.168.5.0/24 ağına ping atamadığını gözlemleyiniz.

GNS3 Cisco Router Static Routing Yapılandırma

   Adım 13

Şimdi, sanal makineleri haberleştirmek için Cisco Router’lar üzerinde Static Routing yapılandıracağız. Cisco Router R1 üzerine Statik Rota eklemek aşağıdaki komutu uygulayınız.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#ip route 192.168.10.0 255.255.255.0 10.1.1.2
R1(config)#end
R1#
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
L 10.1.1.1/32 is directly connected, FastEthernet0/0
192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/24 is directly connected, FastEthernet0/1
L 192.168.5.1/32 is directly connected, FastEthernet0/1
S 192.168.10.0/24 [1/0] via 10.1.1.2
R1#

 
Cisco Router R1 üzerinde show ip route çıktısı aşağıdaki gibidir.

GNS3 Cisco Router Static Routing Yapılandırma

   Adım 14

Aynı şekilde Cisco Router R2’ye de Statik Rota ekleyiniz ve show ip route komutu ile kontrol ediniz.

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#ip route 192.168.5.0 255.255.255.0 10.1.1.1
R2(config)#end
R2#
R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
L 10.1.1.2/32 is directly connected, FastEthernet0/0
S 192.168.5.0/24 [1/0] via 10.1.1.1
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, FastEthernet0/1
L 192.168.10.1/32 is directly connected, FastEthernet0/1
R2#

 
GNS3 Cisco Router Static Routing Yapılandırma

   Adım 15

VMware Workstation Windows 8.1 sanal makinaya geri dönerek, 192.168.10.0/24 ağındaki Windows 10 sanal makineye Ping attığımızda, Ping işlemi aşağıdaki gibi başarılı olacaktır.

GNS3 Cisco Router Static Routing Yapılandırma

   Adım 16

Windows 10 sanal makine üzerinden de 192.168.5.0/24 ağındaki Windows 8.1 sanal makineye Ping attığınızda, Ping işlemi başarılı olacaktır.

GNS3 Cisco Router Static Routing Yapılandırma

GNS3 Cisco Router Static Routing Yapılandırma Show Komutları

R1#show ip int brR2#show ip int brR1#show ip routeR2#show ip routeR1#show running-configR1#show running-config
R1#show ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.1.1.1 YES manual up up
FastEthernet0/1 192.168.5.1 YES manual up up
R1#
R2#show ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.1.1.2 YES manual up up
FastEthernet0/1 192.168.10.1 YES manual up up
R2#
R1#show ip route Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP + - replicated route, % - next hop override Gateway of last resort is not set 10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks C 10.1.1.0/24 is directly connected, FastEthernet0/0 L 10.1.1.1/32 is directly connected, FastEthernet0/0 192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks C 192.168.5.0/24 is directly connected, FastEthernet0/1 L 192.168.5.1/32 is directly connected, FastEthernet0/1 S 192.168.10.0/24 [1/0] via 10.1.1.2 R1#
R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
L 10.1.1.2/32 is directly connected, FastEthernet0/0
S 192.168.5.0/24 [1/0] via 10.1.1.1
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, FastEthernet0/1
L 192.168.10.1/32 is directly connected, FastEthernet0/1
R2#
R1#show running-config
Building configuration...

Current configuration : 1087 bytes
!
! Last configuration change at 11:27:41 UTC Fri Jun 2 2017
upgrade fpd auto
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
redundancy
!
!
ip tcp synwait-time 5
!
!
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.10.0 255.255.255.0 10.1.1.2
!
no cdp log mismatch duplex
!
!
control-plane
!
mgcp profile default
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
transport input all
!
!
end
R1#
R2#show running-config
Building configuration...

Current configuration : 1087 bytes
!
! Last configuration change at 11:28:22 UTC Fri Jun 2 2017
upgrade fpd auto
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
redundancy
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.5.0 255.255.255.0 10.1.1.1
!
no cdp log mismatch duplex
!
control-plane
!
!
mgcp profile default
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
transport input all
!
!
end
R2#

GNS3 Cisco Router Static Routing Yapılandırma ⇒ Video

GNS3 üzerinde Cisco Router Statik Yönlendirme adımlarını videoyu izleyerek gerçekleştirebilir ve ayrıca bize destek olmak için YouTube kanalımıza abone olabilirsiniz…

  Son Söz

GNS3 Cisco Router Static Routing Yapılandırma – Bu yazımızda, GNS3 ağ simulatör programını kullanarak Cisco yönlendiriciler üzerinde Statik Rotalar yapılandırdık. Static Routing performans açısından tercih edilebilir fakat büyük bir ağda Static Routing kullanımı zor ve karmaşık olacağı için Dynamic Routing kullanımı önerilir. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

GNS3 Cisco Router Static Routing Yapılandırma İlgili Yazılar
GNS3 Cisco Router Static Routing Yapılandırma İlgili Router IOS İmajı
İlgili Dosya

Bu yazıda kullanılan Cisco Router 7200 IOS imajını aşağıdaki butondan bilgisayarınıza indirebilirsiniz…

IOS İmajını İndir

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

five × 1 =