GNS3 Cisco Router RIP Yapılandırma – RIP (Routing Information Protocol – Yönlendirme Bilgisi Protokolü), Router’ların bilmediği ağları birbirlerine haberdar etmek için kullanılan bir yönlendirme protokolüdür.
GNS3 Cisco Router RIP Yapılandırma

GNS3 Cisco Router RIP Yapılandırma

GNS3 Cisco Router RIP Yapılandırma

RIP yönlendirme protokolü, Router’lar arasında Broadcast (255.255.255.255) yayın yapmaktadır. RIP yönlendirme protokolünün Version 1 ve Version 2 sürümleri vardır. RIP V1 sürümü broadcast yayın yapmaktadır. RIP V2 sürümü ise, multicast (224.0.0.9) yayın yapar.

Önceki yazımızda, RIP Yönlendirme Protokolü konusunu incelemiştik. Bu yazımızda, GNS3 simulator programında Cisco Router üzerinde RIP yönlendirme konfigürasyonunu yapılandıracağız.

GNS3’te Router RIP Konfigürasyonu

GNS3’te Router RIP konfigürasyonu işlemine başlamadan önce, VMware Workstation programında iki adet sanal makina oluşturunuz. VMware Virtual Network Editör üzerinde, VMnet oluşturunuz. Daha sonra, GNS3 ile VMware sanal makinaları entegre etmek için, GNS3 çalışma alanına Cloud ekleyiniz ve ayarlamaları yapınız.

GNS3 Cisco Router RIP yapılandırma adımlarına artık geçebiliriz.

   Adım 1

GNS3 programını açınız ve yeni bir proje oluşturunuz.

GNS3 Cisco Router RIP Yapılandırma

   Adım 2

RIP yapılandırması için GNS3’te aşağıdaki görüntüdeki gibi bir ağ topolojisi oluşturunuz.

GNS3 Cisco Router RIP Yapılandırma

   Adım 3

VMware Windows 8.1 sanal makina üzerinde ağ kartı olarak VMnet1 seçilidir. Burada herhangi bir VMnet oluşturup ayarlayabilirsiniz. Bu adımda dikkat edilmesi gereken nokta, VMnet’lerin IP adresi bloğudur.

GNS3 Cisco Router RIP Yapılandırma

   Adım 4

VMware Windows 10 sanal makina ağ kartı ise VMnet2 olarak seçilidir.

GNS3 Cisco Router RIP Yapılandırma

   Adım 5

VMware Virtual Network Editör programında, VMnet1 ve VMnet2 IP adresi bloğu aşağıdaki gibidir. VMware üzerinde oluşturduğunuz sanal makinaları çalıştırınız.

Sanal makinaların TCP/IP konfigürasyonunu yapılandırınız.

GNS3 Cisco Router RIP Yapılandırma

   Adım 6

Windows 8.1 sanal makina IP adresi yapılandırması 192.168.5.0/24 IP adresi aralığındadır.

GNS3 Cisco Router RIP Yapılandırma

   Adım 7

Windows 10 sanal makinamızda 192.168.10.0/24 IP adresi bloğundadır.

GNS3 Cisco Router RIP Yapılandırma

   Adım 8

GNS3 ile VMware temel ayarlarını yapılandırdıktan sonra, Cisco Router R1 CLI komut istemini açınız ve aşağıdaki görüntüye göre IP adresi konfigürasyonunu yapılandırınız.

[code] R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#do show ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.5.1 YES manual up up
Serial0/0 10.1.1.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial0/1 unassigned YES unset administratively down down
[/code]

GNS3 Cisco Router RIP Yapılandırma

   Adım 9

Aynı şekilde Cisco Router R2 arayüzlerini yapılandırınız.

[code] R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#interface fastethernet 0/1
R2(config-if)#ip address 192.168.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface serial 0/1
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#do show ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
Serial0/0 unassigned YES unset administratively down down
FastEthernet0/1 192.168.10.1 YES manual up up
Serial0/1 10.1.1.2 YES manual up up
R2(config)#
[/code]

GNS3 Cisco Router RIP Yapılandırma

   Adım 10

GNS3 Cisco Router RIP yapılandırmadan önce, VMware sanal makinalardan arayüzlere Ping atarak bağlantıyı test ediniz. Windows 8.1 sanal makinadan R1 Fa0/0 ve Serial0/0 arayüzlerini Ping işlemi aşağıdaki gibi başarılıdır.

GNS3 Cisco Router RIP Yapılandırma

   Adım 11

Windows 10 sanal makinanın bağlı olduğu Cisco Router R2 arayüzlerine de Ping atarak bağlantıyı test ediniz.

GNS3 Cisco Router RIP Yapılandırma

   Adım 12

Windows 8.1 sanal makina Cisco Router R2 Serial 0/1 arayüzüne Ping başarısız olacaktır. Çünkü Router’lar yönlendirme yapılandırılmadan birbirlerinin alt ağlarını bilemezler.

GNS3 Cisco Router RIP Yapılandırma

   Adım 13

Windows 10 sanal makinadan da Ping başarısız olacaktır.

GNS3 Cisco Router RIP Yapılandırma

   Adım 14

GNS3 Cisco Router RIP yapılandırma için Router R1 CLI komut istemini açınız ve aşağıdaki komutları yapılandırınız.

[code] R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#
R1(config)#router rip
R1(config-router)#network 10.1.1.0
R1(config-router)#network 192.168.5.0
R1(config-router)#end
R1#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

C 192.168.5.0/24 is directly connected, FastEthernet0/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/0
R1#
[/code]

GNS3 Cisco Router RIP Yapılandırma

   Adım 15

Cisco Router R2 CLI komut isteminde de aşağıdaki komutları uygulayınız.

[code] R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#
R2(config)#router rip
R2(config-router)#network 10.1.1.0
R2(config-router)#network 192.168.10.0
R2(config-router)#end
R2#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

C 192.168.10.0/24 is directly connected, FastEthernet0/1
R 192.168.5.0/24 [120/1] via 10.1.1.1, 00:00:04, Serial0/1
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/1
R2#
[/code]

GNS3 Cisco Router RIP Yapılandırma

   Adım 16

GNS3’te Cisco Router üzerinde RIP yapılandırdıktan sonra, sanal makinalar aşağıdaki gibi başarıyla Ping atabilecektir.

GNS3 Cisco Router RIP Yapılandırma

   Adım 17

Windows 10 sanal makinadan Ping işlemi de aşağıdaki gibi başarılı olacaktır.

GNS3 Cisco Router RIP Yapılandırma

   Adım 18

Cisco Router R1 üzerinde RIP kayıtlarını inceleyebilirsiniz.

GNS3 Cisco Router RIP Yapılandırma

   Adım 19

Aynı şekilde, Cisco Router R2 üzerinde de RIP kayıtlarını inceleyebilirsiniz.

GNS3 Cisco Router RIP Yapılandırma

   Adım 20

RIP Broadcast yayın mesajlarını incelemek için ayrıcalıklı yapılandırma modunda Debug ip rip komutunu çalıştırınız.

GNS3 Cisco Router RIP Yapılandırma

   Adım 21

Router R2 üzerinde de RIP kayıtlarını inceleyebilirsiniz…

GNS3 Cisco Router RIP Yapılandırma

GNS3 Cisco Router RIP Yapılandırma Show Komutları

R1#show ip rip dtbseR2#show ip rip dtbseR1#debug ip ripR2#debug ip ripR1#show ip route ripR2#show ip route ripR1#show running-configR2#show running-config
R1#show ip rip dtbse
10.0.0.0/8 auto-summary
10.1.1.0/24 directly connected, Serial0/0
192.168.5.0/24 auto-summary
192.168.5.0/24 directly connected, FastEthernet0/0
192.168.10.0/24 auto-summary
192.168.10.0/24
[1] via 10.1.1.2, 00:00:20, Serial0/0
R1#
R2#show ip rip dtbse
10.0.0.0/8 auto-summary
10.1.1.0/24 directly connected, Serial0/1
192.168.5.0/24 auto-summary
192.168.5.0/24
[1] via 10.1.1.1, 00:00:02, Serial0/1
192.168.10.0/24 auto-summary
192.168.10.0/24 directly connected, FastEthernet0/1
R2#
R1#debug ip rip
RIP protocol debugging is on
R1#
*Mar 1 00:18:36.167: RIP: received v1 update from 10.1.1.2 on Serial0/0
*Mar 1 00:18:36.167: 192.168.10.0 in 1 hops
R1#
*Mar 1 00:18:37.311: RIP: sending v1 update to 255.255.255.255 via Serial0/0 (10.1.1.1)
*Mar 1 00:18:37.311: RIP: build update entries
*Mar 1 00:18:37.311: network 192.168.5.0 metric 1
R1#
*Mar 1 00:18:40.159: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (192.168.5.1)
*Mar 1 00:18:40.159: RIP: build update entries
*Mar 1 00:18:40.159: network 10.0.0.0 metric 1
*Mar 1 00:18:40.159: network 192.168.10.0 metric 2
R1#
*Mar 1 00:19:03.235: RIP: received v1 update from 10.1.1.2 on Serial0/0
*Mar 1 00:19:03.239: 192.168.10.0 in 1 hops
R1#
*Mar 1 00:19:04.791: RIP: sending v1 update to 255.255.255.255 via Serial0/0 (10.1.1.1)
*Mar 1 00:19:04.791: RIP: build update entries
*Mar 1 00:19:04.791: network 192.168.5.0 metric 1
*Mar 1 00:19:05.731: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (192.168.5.1)
*Mar 1 00:19:05.731: RIP: build update entries
*Mar 1 00:19:05.731: network 10.0.0.0 metric 1
R2#debug ip rip
RIP protocol debugging is on
R2#
*Mar 1 00:18:31.063: RIP: sending v1 update to 255.255.255.255 via Serial0/1 (10.1.1.2)
*Mar 1 00:18:31.063: RIP: build update entries
*Mar 1 00:18:31.063: network 192.168.10.0 metric 1
R2#
*Mar 1 00:18:32.107: RIP: received v1 update from 10.1.1.1 on Serial0/1
*Mar 1 00:18:32.107: 192.168.5.0 in 1 hops
R2#
*Mar 1 00:18:34.803: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/1 (192.168.10.1)
*Mar 1 00:18:34.803: RIP: build update entries
*Mar 1 00:18:34.803: network 10.0.0.0 metric 1
*Mar 1 00:18:34.803: network 192.168.5.0 metric 2
R2#
*Mar 1 00:18:58.323: RIP: sending v1 update to 255.255.255.255 via Serial0/1 (10.1.1.2)
*Mar 1 00:18:58.323: RIP: build update entries
*Mar 1 00:18:58.323: network 192.168.10.0 metric 1
R2#
*Mar 1 00:18:59.911: RIP: received v1 update from 10.1.1.1 on Serial0/1
*Mar 1 00:18:59.911: 192.168.5.0 in 1 hops
R2#
*Mar 1 00:19:04.307: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/1 (192.168.10.1)
*Mar 1 00:19:04.307: RIP: build update entries
*Mar 1 00:19:04.307: network 10.0.0.0 metric 1
*Mar 1 00:19:04.307: network 192.168.5.0 metric 2
R2#
R1#show ip route rip
R 192.168.10.0/24 [120/1] via 10.1.1.2, 00:00:22, Serial0/0
R1#
R2#show ip route rip
R 192.168.5.0/24 [120/1] via 10.1.1.1, 00:00:06, Serial0/1
R2#
R1#show running-config
Building configuration…
Current configuration : 1091 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router rip
network 10.0.0.0
network 192.168.5.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#
R2#show running-config
Building configuration…

Current configuration : 1093 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip tcp synwait-time 5
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.1.2 255.255.255.0
clock rate 2000000
!
router rip
network 10.0.0.0
network 192.168.10.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end
R2#

GNS3 Cisco Router RIP Yapılandırma ⇒ Video

GNS3’te Cisco Router üzerinde RIP konfigürasyonu ve yapılandırması adımlarını videoyu izleyerek gerçekleştirebilirsiniz ve ayrıca YouTube kanalımıza abone olabilirsiniz…

  Son Söz

GNS3 Cisco Router RIP Yapılandırma – Bu yazımızda GNS3 ağ simülatör programı ile Cisco Yönlendiriciler üzerinde RIP yönlendirme yapılandırmasını gerçekleştirdik. Yukarıdaki yapılandırma RIP Versiyon 1 için geçerlidir. Sonraki yazımızda RIP Versiyon 2 sürümünü de yapılandıracağız. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

GNS3 Cisco Router RIP Yapılandırma İlgili Yazılar

GNS3 Cisco Router RIP Yapılandırma İlgili Dosya
İlgili GNS3 Projesi

Bu yazıda kullanılan oluşturulan GNS3 projesini aşağıdaki butondan bilgisayarınıza indirebilirsiniz…

 

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

15 − ten =