GNS3 Cisco Router RIP Version 2 Yapılandırma – Bu yazımızda, GNS3’te RIP yönlendirme protokolünün Version 2 (Versiyon 2) sürümünü yapılandıracağız.
GNS3 Cisco Router RIP Version 2 Yapılandırma

GNS3 Cisco Router RIP Version 2 Yapılandırma

GNS3 Cisco Router RIP Version 2 Yapılandırma

RIP Version 2, RFC 2453‘te tanımlanmıştır. RIP Version 2, yönlendirme tablosu güncellemerinde Broadcast yerine Multicast yayın göndermektedir.

Multicast yayın, VLSM ve CIDR destekler. Böylece, farklı alt ağları birbirleriyle haberleştirebiliriz. Özel IP adresi kullanımını minimum seviyeye indirerek Broadcast trafiğinin de önüne geçeriz.

Önceki yazılarımızda, RIP Protokolü Nedir ve GNS3’te RIP Routing Yapılandırması adlı konular hakkında bilgiler vermiştik. Bu yazımızda, yine GNS3 programını kullanarak RIP Version 2 yönlendirme adımlarını gerçekleştireceğiz.

192.168.5.0/24 ağını iki farklı ağa ayırarak Router’lar üzerinde tanımladıktan sonra, RIP V2 ile bu ağları haberleştireceğiz.

Ayrıca, GNS3 RIP V1 Yapılandırma adımlarını videoyu izleyerek gerçekleştirebilirsiniz.

GNS3’te Cisco Router Üzerinde RIP Versiyon 2 Etkinleştirme

GNS3’te Cisco Router üzerinde RIP version 2 etkinleştirme adımlarına geçmeden önce, GNS3 VPCS Kullanımı adlı konuya göz atabilirsiniz. Bu yazıda, GNS3 RIP yapılandırmasında VPCS (Virtual PC Simulator – Sanal Bilgisayar Emülatörü) kullanacağız.

GNS3’te VMware sanal makina yerine VPCS kullanmak daha performanslı bir işlemdir.

GNS3 Cisco Router RIP Version 2 yapılandırma adımlarına artık geçebiliriz. RIP V2 yapılandırması adımlarını sırasıyla takip ediniz.

   Adım 1

GNS3 programını çalıştırınız ve yeni bir proje oluşturunuz.

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 2

GNS3 RIP V2 konfigürasyonu için aşağıdaki görüntüdeki gibi ağ topolojisi oluşturunuz.

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 3

GNS3 çalışma alanındaki VPCS’leri sırasıyla ağ topolojisine göre yapılandırınız. VPCS PC1 IP adresi ayarları için aşağıdaki komutları uygulayabilirsiniz.

[code] PC1> ip 192.168.5.5/25 192.168.5.1
Checking for duplicate address…
PC1 : 192.168.5.5 255.255.255.128 gateway 192.168.5.1

PC1> show ip

NAME : PC1[1] IP/MASK : 192.168.5.5/25
GATEWAY : 192.168.5.1
DNS :
MAC : 00:50:79:66:68:00
LPORT : 10014
RHOST:PORT : 127.0.0.1:10015
MTU: : 1500
PC1>
[/code]

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 4

VPCS PC2 IP konfigürasyonunu yapılandırınız.

[code] PC2> ip 192.168.5.10/25 192.168.5.1
Checking for duplicate address…
PC1 : 192.168.5.10 255.255.255.128 gateway 192.168.5.1

PC2> show ip

NAME : PC2[1] IP/MASK : 192.168.5.10/25
GATEWAY : 192.168.5.1
DNS :
MAC : 00:50:79:66:68:01
LPORT : 10016
RHOST:PORT : 127.0.0.1:10017
MTU: : 1500
PC2>
[/code]

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 5

VPCS PC3 için IP adresi yapılandırmasında dikkat etmeniz gereken nokta, Subnet Mask (Alt Ağ Maskesi)’tir. VPCS PC3 için IP konfigürasyonunu da yapılandırınız.

[code] PC3> ip 192.168.5.130/25 192.168.5.129
Checking for duplicate address…
PC1 : 192.168.5.130 255.255.255.128 gateway 192.168.5.129

PC3> show ip

NAME : PC3[1] IP/MASK : 192.168.5.130/25
GATEWAY : 192.168.5.129
DNS :
MAC : 00:50:79:66:68:02
LPORT : 10018
RHOST:PORT : 127.0.0.1:10019
MTU: : 1500
PC3>
[/code]

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 6

Son olarak, VPCS PC4’ü yapılandırınız. Aşağıdaki görüntüye dikkat ediniz. PC3 ve PC4 IP adresi ayarları 192.168.5.0/25 bloğundadır.

[code] PC4> ip 192.168.5.135/25 192.168.5.129
Checking for duplicate address…
PC1 : 192.168.5.135 255.255.255.128 gateway 192.168.5.129

PC4> show ip

NAME : PC4[1] IP/MASK : 192.168.5.135/25
GATEWAY : 192.168.5.129
DNS :
MAC : 00:50:79:66:68:03
LPORT : 10020
RHOST:PORT : 127.0.0.1:10021
MTU: : 1500
PC4>
[/code]

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 7

Cisco Router R1 CLI komut istemini açınız ve FastEthernet 0/0 ve Serial 0/0 arayüzlerini yapılandırınız.

[code] R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.128
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
*Mar 1 00:12:56.175: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:12:57.175: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config)#
R1(config)#interface serial 0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#end
R1#
[/code]

R1 üzerinde show ip route komutu ile yapılandırmayı kontrol ediniz.

[code] R1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.5.1 YES manual up up
Serial0/0 10.1.1.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial0/1 unassigned YES unset administratively down down
R1#
[/code]

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 8

Aynı şekilde, Cisco Router R2 arayüzlerini de yapılandırınız. Router R2 FastEthernet 0/1 arayüzü alt ağ maskesine dikkat ediniz.

[code] R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#interface fastethernet 0/1
R2(config-if)#ip address 192.168.5.129 255.255.255.128
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
*Mar 1 00:14:49.607: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Mar 1 00:14:50.607: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R2(config)#
R2(config)#interface serial 0/1
R2(config-if)#ip address 10.1.1.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#end
R2#
[/code]

Router R2 arayüz yapılandırmasını kontrol ediniz.

[code] R2#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
Serial0/0 unassigned YES unset administratively down down
FastEthernet0/1 192.168.5.129 YES manual up up
Serial0/1 10.1.1.2 YES manual up up
R2#
[/code]

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 9

GNS3 Cisco Router RIP Version 2 yapılandırmadan önce, VPCS’ler üzerinden Ping ile bağlantıları kontrol ediniz. VPCS PC1, Router R2 Serial arayüzüne Ping işlemi aşağıdaki gibi başarısız olacaktır.

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 10

VPCS PC3 üzerinde Ping sonucu aşağıdaki gibidir. PC3’te Router R1’in Serial arayüzüne Ping atamayacaktır.

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 11

İki farklı lokasyondaki bilgisayarları haberleştirmek için, RIP Version 2 yapılandırmasını gerçekleştirelim. Cisco Router R1 komut isteminde, aşağıdaki komutları uygulayınız.

[code] R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.1.1.0
R1(config-router)#network 192.168.5.0
R1(config-router)#end
R1#
[/code]

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 12

Aynı şekilde, Cisco Router R2 üzerinde RIP Version 2’yi etkinleştiriniz ve bağlı olduğu ağları tanıtınız.

[code] R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 10.1.1.0
R2(config-router)#network 192.168.5.128
R2(config-router)#end
R2#
[/code]

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 13

GNS3 Cisco Router RIP Version 2 yapılandırma adımlarını tamamladık. Şimdi, VPCS PC’lerden Ping atarak bağlantıyı test ediniz. PC1 üzerinden R2 Serial arayüzüne Ping işlemi başarılı olacaktır. Ve sonuç olarak, PC1 192.168.5.128/25 ağına başarılı bir şekilde erişebilecektir.

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 14

Karşı ağdan PC3 üzerinden de Ping işlemleri aşağıdaki gibi başarılı olacaktır.

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 15

Cisco Router R1 üzerinde show ip route komutunu çalıştırınız ve yönlendirme tablosuna göz atınız. Aşağıdaki görüntüdeki gibi RIP yönlendirme protokolü bilmediği ağları öğrenmiştir.

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 16

Aynı şekilde Cisco Router R2 üzerinde show ip route komutunu uygulayınız.

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 17

Router R2 üzerinde, RIP Versiyon 2 yapılandırmasını kontrol etmek için debug ip rip komutunu çalıştırınız ve aşağıdaki görüntüdeki gibi bir kayıtla karşılaşacaksınız.

Bu görüntüde, RIP V2 yönlendirme güncelleştirmeleri 224.0.09 Multicast adresi ile yapıldığını görebilirsiniz.

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 18

Aynı şekilde, Router R2 üzerinde de RIP V2 kayıtlarını inceleyebilirsiniz.

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 19

GNS3’te Cisco Router RIP Version 2 yapılandırmasını WireShark programı ile de kontrol edebiliriz. WireShark ile RIP Version 2 doğrulamasını yapmak için, R1 ve R2 arasındaki Serial bağlantı üzerinde Sağ Tuş / Start Capture seçeneğine tıklayınız.

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 20

Aşağıdaki görüntüdeki gibi bir pencere açılacaktır. OK (Tamam) butonuna tıklayarak devam ediniz.

GNS3 Cisco Router RIP Version 2 Yapılandırma

   Adım 21

WireShark programı açıldı ve RIP V2 (224.0.0.9) kaydını aşağıdaki görüntüden inceleyebilirsiniz. Kısacası, iki Cisco Router arasında RIP Versiyon 2 Multicast adresi ile yönlendirme güncelleştirmeleri yapılmaktadır.

GNS3 Cisco Router RIP Version 2 Yapılandırma

GNS3 Cisco Router RIP Version 2 Yapılandırma Show Komutları

R1#show running-configR2#show running-configR1#show ip rip dtbseR2#show ip rip dtbseR1#show ip routeR2#show ip routeR1#debug ip ripR2#debug ip rip
R1#show running-config
Building configuration…

Current configuration : 1106 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.128
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router rip
version 2
network 10.0.0.0
network 192.168.5.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#

R2#show running-config
Building configuration…

Current configuration : 1108 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.5.129 255.255.255.128
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.1.2 255.255.255.252
clock rate 2000000
!
router rip
version 2
network 10.0.0.0
network 192.168.5.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R2#

R1#show ip rip dtbse
10.0.0.0/8 auto-summary
10.1.1.0/30 directly connected, Serial0/0
192.168.5.0/24 auto-summary
192.168.5.0/24
[1] via 10.1.1.2, 00:00:22, Serial0/0
192.168.5.0/25 directly connected, FastEthernet0/0
R1#
R2#show ip rip dtbse
10.0.0.0/8 auto-summary
10.1.1.0/30 directly connected, Serial0/1
192.168.5.0/24 auto-summary
192.168.5.0/24
[1] via 10.1.1.1, 00:00:22, Serial0/1
192.168.5.128/25 directly connected, FastEthernet0/1
R2#
R1#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/25 is directly connected, FastEthernet0/0
R 192.168.5.0/24 [120/1] via 10.1.1.2, 00:00:00, Serial0/0
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/0
R1#

R2#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
R 192.168.5.0/24 [120/1] via 10.1.1.1, 00:00:07, Serial0/1
C 192.168.5.128/25 is directly connected, FastEthernet0/1
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/1
R2#

R1#debug ip rip
RIP protocol debugging is on
R1#
*Mar 1 00:24:22.779: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (10.1.1.1)
*Mar 1 00:24:22.779: RIP: build update entries
*Mar 1 00:24:22.779: 192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
R1#
*Mar 1 00:24:34.083: RIP: received v2 update from 10.1.1.2 on Serial0/0
*Mar 1 00:24:34.087: 192.168.5.0/24 via 0.0.0.0 in 1 hops
R1#
*Mar 1 00:24:36.891: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (192.168.5.1)
*Mar 1 00:24:36.891: RIP: build update entries
*Mar 1 00:24:36.891: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:24:36.891: 192.168.5.0/24 via 0.0.0.0, metric 2, tag 0
R1#
*Mar 1 00:24:48.759: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (10.1.1.1)
*Mar 1 00:24:48.759: RIP: build update entries
*Mar 1 00:24:48.759: 192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
R1#
R2#debug ip rip
RIP protocol debugging is on
R2#
*Mar 1 00:24:23.591: RIP: received v2 update from 10.1.1.1 on Serial0/1
*Mar 1 00:24:23.591: 192.168.5.0/24 via 0.0.0.0 in 1 hops
R2#
*Mar 1 00:24:33.427: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/1 (192.168.5.129)
*Mar 1 00:24:33.427: RIP: build update entries
*Mar 1 00:24:33.427: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:24:33.427: 192.168.5.0/24 via 0.0.0.0, metric 2, tag 0
R2#
*Mar 1 00:24:34.803: RIP: sending v2 update to 224.0.0.9 via Serial0/1 (10.1.1.2)
*Mar 1 00:24:34.803: RIP: build update entries
*Mar 1 00:24:34.803: 192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
R2#

GNS3 Cisco Router RIP Version 2 Yapılandırma ⇒ Video

GNS3 Cisco Router RIP Version 2 yapılandırma ve RIP V2 doğrulamasını videoyu izleyerek gerçekleştirebilirsiniz ve ayrıca YouTube kanalımıza abone olabilirsiniz…

  Son Söz

GNS3 Cisco Router RIP Version 2 Yapılandırma – Bu yazımızda, GNS3’te VLSM ile ayrılan 192.168.5.0/24 ağını RIP Versiyon 2 ile haberleştirdik. Eğer bu yazıda, RIP Versiyon 1 kullanılsaydı, buradaki ağlar haberleşemeyecekti. RIP yönlendirme protokolünün 2. Sürümü VLSM desteklediği için, buradaki ağları haberleştirebildik. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

GNS3 Cisco Router RIP Version 2 Yapılandırma İlgili Yazılar

GNS3 Cisco Router RIP Version 2 Yapılandırma İlgili Dosya
İlgili Dosya

Bu yazıda yapılandırılan GNS3 RIP Versiyon 2 projesini aşağıdaki butona tıklayarak bilgisayarınıza indirebilirsiniz…

 

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

11 + sixteen =