GNS3 Cisco Router OSPF Yapılandırma – OSPF (Open Shortest Path First – İlk Açık Yöne Öncelik) yönlendirme protokolü Dynamic Routing protokolüdür. OSPF, Dijkstra algoritmasını kullanarak herhangi bir ağ değişikliğinde yönlendirme rotalarını yeniden hesaplar.
GNS3 Cisco Router OSPF Yapılandırma

GNS3 Cisco Router OSPF Yapılandırma

GNS3 Cisco Router OSPF Yapılandırma

OSPF yönlendirme protokolü AS (Autonomous System) numaraları kullanarak ağ üzerinde ek olarak bir güvenlik sağlar. Aynı AS numarası ile yapılandırılmış Router’lar birbirleriyle haberleşebilmektedir. Buna ek olarak, örneğin AS 1 alanındaki Router’lar AS 2 alanındaki Router’lar ile iletişim kurabilir.

AS içindeki her bir Router bütün ağ topoloji bilgisine sahiptirler. Dolayısıyla OSPF protokolü hedefe giden iyi yolu kolayca belirleyebilirler.

OSPF ile EIGRP protokolü her ne kadar birbirine benzesede aralarındaki en büyük fark, EIGRP yalnızca Cisco cihazlara özgü bir yönlendirme protokolüdür.

Önceki yazımızda, OSPF Protokolü hakkında detaylı bilgiler açıklamıştık. Bu yazımızda, GNS3 ağ simulatör programında Cisco Router’lar üzerinde OSPF yönlendirme protokolünü etkinleştirerek iki farklı ağı haberleştireceğiz.

GNS3’te Cisco Router Üzerinde OSPF Yönlendirme

GNS3 Cisco Router OSPF yapılandırma adımlarına geçmeden önce, GNS3 Cloud bilgisayar ekleme adımlarını gerçekleştiriniz. OSPF yapılandırma işleminde VMware Workstation sanal makinaları kullanacağız.

   Adım 1

Öncelikle GNS3 programını başlatınız ve yeni bir proje oluşturunuz.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 2

GNS3′ OSPF yapılandırması için aşağıdaki görüntüdeki gibi bir ağ topolojisi oluşturunuz. Çalışma alanına açıklamalar ekleyerek daha düzenli bir görünüm sağlayabilirsiniz.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 3

VMware Workstation sanallaştırma programında iki adet sanal makina oluşturunuz. Sanal makina VMnet ayarlarını gerçekleştiriniz. Aşağıdaki gibi Windows 8.1 sanal makina ağ kartı ayarı olarak VMnet1’i seçiniz ve devam ediniz.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 4

Aynı şekilde Windows 10 sanal makina ağ kartı ayarı olarakta VMnet2’yi seçiniz.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 5

VMware Workstation Virtual Network Editör (Sanal Ağ Editörü) programında VMnet ayarlarını kontrol ediniz.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 6

Daha sonra, VMware sanal makinaları çalıştırınız ve ağ topolojisinde belirtilen ağ adreslerine göre TCP/IP ayarlarını yapınız.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 7

Windows 10 sanal makina TCP/IP ayarları da aşağıdaki gibidir.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 8

GNS3 Cisco Router OSPF yapılandırma adımlarında öncelikle Cisco Router R1 arayüzlerini yapılandırınız.

[code] R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
*Mar 1 00:10:50.427: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:10:51.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config)#
R1(config)#interface serial 0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#end
R1#
[/code]

Cisco Router R1 üzerinde show ip interface brief komutunu uygulayarak arayüz durumlarını kontrol edebilirsiniz.

[code] R1#show ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.5.1 YES manual up up
Serial0/0 10.1.1.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial0/1 unassigned YES unset administratively down down
R1#
[/code]

GNS3 Cisco Router OSPF Yapılandırma

   Adım 9

Cisco Router R2 arayüzlerini de yapılandırınız.

[code] R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#
R2(config)#interface fastethernet 0/1
R2(config-if)#ip address 192.168.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
*Mar 1 00:12:31.055: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Mar 1 00:12:32.055: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R2(config)#
R2(config)#interface serial 0/1
R2(config-if)#ip address 10.1.1.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#end
R2#
[/code]

Cisco Router R2 arayüzlerin durumunu aşağıdaki gibi kontrol edebilirsiniz.

[code] R2#show ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
Serial0/0 unassigned YES unset administratively down down
FastEthernet0/1 192.168.10.1 YES manual up up
Serial0/1 10.1.1.2 YES manual up up
R2#
[/code]

GNS3 Cisco Router OSPF Yapılandırma

   Adım 10

GNS3 Cisco Router OSPF yapılandırmadan önce, Windows 8.1 sanal makinadan Router R1 ve R2’nin FastEthernet ve Serial arayüzlerine Ping atarak bağlantıyı test ediniz.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 11

Aynı işlemleri Windows 10 sanal makinadan gerçekleştiriniz. Karşı ağa Ping işlemi aşağıdaki gibi başarısız olacaktır.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 12

GNS3 Cisco Router OSPF yapılandırma adımlarına artık geçebiliriz. Cisco Router R1 CLI komut istemini açınız ve aşağıdaki komutları sırasıyla uygulayınız.

[code] R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#
R1(config)#router ospf 10
R1(config-router)#network 192.168.5.0 ?
A.B.C.D OSPF wild card bits

R1(config-router)#network 192.168.5.0 0.0.0.255 ?
area Set the OSPF area ID

R1(config-router)#network 192.168.5.0 0.0.0.255 area ?
<0-4294967295> OSPF area ID as a decimal value
A.B.C.D OSPF area ID in IP address format

R1(config-router)#network 192.168.5.0 0.0.0.255 area 0
R1(config-router)#network 10.1.1.0 0.0.0.3 area 0
R1(config-router)#end
R1#
[/code]

GNS3 Cisco Router OSPF Yapılandırma

   Adım 13

Cisco Router üzerinde OSPF etkinleştirmek için aşağıdaki komutları uygulayınız.

[code] R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#
R2(config)#router ospf 10
R2(config-router)#network 192.168.10.0 0.0.0.255 area 0
R2(config-router)#network 10.1.1.0 0.0.0.3 area 0
R2(config-router)#
*Mar 1 00:18:09.227: %OSPF-5-ADJCHG: Process 10, Nbr 192.168.5.1 on Serial0/1 from LOADING to FULL, Loading Done
R2(config-router)#end
R2#
[/code]

GNS3 Cisco Router OSPF Yapılandırma

   Adım 14

Cisco Router’lar üzerinde OSPF yapılandırma işleminden sonra, Router R1 ve R2 üzerinde show ip route komutunu uygulayınız ve rota kayıtlarını inceleyiniz.

Cisco Router R1 yönlendirme tablosu;

[code] R1#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

O 192.168.10.0/24 [110/74] via 10.1.1.2, 00:01:02, Serial0/0
C 192.168.5.0/24 is directly connected, FastEthernet0/0
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/0
R1#
[/code]

Cisco Router R2 yönlendirme tablosu;

[code] R2#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

C 192.168.10.0/24 is directly connected, FastEthernet0/1
O 192.168.5.0/24 [110/74] via 10.1.1.1, 00:01:02, Serial0/1
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/1
R2#
[/code]

GNS3 Cisco Router OSPF Yapılandırma

   Adım 15

GNS3 Cisco Router OSPF yapılandırma adımlarını tamamladık. Şimdi sanal makinalardan birbirine Ping atarak bağlantıyı test ediniz.

Windows 8.1 sanal makinadan Windows 10 sanal makinaya Ping işlemi aşağıdaki gibi başarılı olacaktır.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 16

Windows 10 sanal makinadan Windows 8.1 sanal makinaya da Ping işlemi aşağıdaki gibi başarılı olacaktır.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 17

OSPF yapılandırma işlemini tamamladık ve sanal makinalar arasındaki bağlantıyı da sınadıktan sonra, Router’lar üzerinde OSPF show komutlarını inceleyelim.

Cisco Router R1 show komutları aşağıdaki gibidir.

[code] R1#show ip ospf ?
<1-65535> Process ID number
border-routers Border and Boundary Router Information
database Database summary
flood-list Link state flood list
interface Interface information
max-metric Max-metric origination information
mpls MPLS related information
neighbor Neighbor list
request-list Link state request list
retransmission-list Link state retransmission list
sham-links Sham link information
statistics Various OSPF Statistics
summary-address Summary-address redistribution Information
timers OSPF timers information
traffic Traffic related statistics
virtual-links Virtual link information
| Output modifiers

[/code]

Örnek olarak show ip ospf neighbor ve show ip ospf database show komutlarını inceyebilirsiniz.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 18

Cisco Router R2 üzerinde de show komutu çıktılarını inceleyebilirsiniz.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 19

Cisco Router’lar üzerinde OSPF yönlendirme protokolünü doğrulamak için debug ip ospf hello komutunu kullanabilirsiniz. Cisco Router R1 debug ip ospf hello komutu çıktılarını aşağıdaki görüntüden inceleyebilirsiniz.

[code] R1#debug ip ospf ?
adj OSPF adjacency events
database-timer OSPF database timer
events OSPF events
flood OSPF flooding
hello OSPF hello events
lsa-generation OSPF lsa generation
mpls OSPF MPLS
nsf OSPF non-stop forwarding events
packet OSPF packets
retransmission OSPF retransmission events
spf OSPF spf
tree OSPF database tree
[/code]

OSPF yönlendirme prokolü hello paketlerini Multicast (224.0.0.5) adresine göndermektedir.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 20

Cisco Router R2 üzerinde de debug ip ospf hello komutunu uygulayınız. Aşağıdaki görüntüden hello paketlerini görebilirsiniz.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 21

GNS3’te OSPF yapılandırmasını doğrulamanın diğer bir yolu da Wireshark kullanmaktır. Cisco Router’lar arasındaki Serial kablo üzerinde Sağ Tuş / Start Capture seçeneğine tıklayınız.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 22

Packet Capture penceresinde, OK (Tamam) butonuna tıklayarak devam ediniz.

GNS3 Cisco Router OSPF Yapılandırma

   Adım 23

GNS3’te Wireshark programı açıldı ve aşağıdaki görüntüdeki gibi Hello paketlerinin Multicast (224.0.0.5) adresi üzerinden gönderildiğini görebilirsiniz.

GNS3 Cisco Router OSPF Yapılandırma

GNS3 Cisco Router OSPF Yapılandırma Show Komutları

Cisco Router R1 Show Komutları

R1#show ip ospf neighborR1#debug ip ospf helloR1#show running-config
R1#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
192.168.10.1 0 FULL/ – 00:00:32 10.1.1.2 Serial0/0
R1#
R1#show ip ospf database

OSPF Router with ID (192.168.5.1) (Process ID 10)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
192.168.5.1 192.168.5.1 382 0x80000003 0x00832D 3
192.168.10.1 192.168.10.1 383 0x80000002 0x00B1F4 3
R1#

R1#debug ip ospf hello
OSPF hello events debugging is on
R1#
*Mar 1 00:26:47.011: OSPF: Send hello to 224.0.0.5 area 0 on Serial0/0 from 10.1.1.1
R1#
*Mar 1 00:26:48.939: OSPF: Send hello to 224.0.0.5 area 0 on FastEthernet0/0 from 192.168.5.1
*Mar 1 00:26:49.267: OSPF: Rcv hello from 192.168.10.1 area 0 from Serial0/0 10.1.1.2
*Mar 1 00:26:49.267: OSPF: End of hello processing
R1#
*Mar 1 00:26:56.151: OSPF: Rcv hello from 192.168.10.1 area 0 from Serial0/0 10.1.1.2
*Mar 1 00:26:56.151: OSPF: End of hello processing
*Mar 1 00:26:57.011: OSPF: Send hello to 224.0.0.5 area 0 on Serial0/0 from 10.1.1.1
R1#
*Mar 1 00:26:58.939: OSPF: Send hello to 224.0.0.5 area 0 on FastEthernet0/0 from 192.168.5.1
R1#
R1#show running-config
Building configuration…

Current configuration : 1152 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip tcp synwait-time 5
!
!
!
interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 10
log-adjacency-changes
network 10.1.1.0 0.0.0.3 area 0
network 192.168.5.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#

Cisco Router R2 Show Komutları

R2#show ip ospf ?R2#show ip ospf neighborR2#debug ip ospf ?R2#debug ip ospf helloR2#show running-config
R2#show ip ospf ?
Process ID number
border-routers Border and Boundary Router Information
database Database summary
flood-list Link state flood list
interface Interface information
max-metric Max-metric origination information
mpls MPLS related information
neighbor Neighbor list
request-list Link state request list
retransmission-list Link state retransmission list
sham-links Sham link information
statistics Various OSPF Statistics
summary-address Summary-address redistribution Information
timers OSPF timers information
traffic Traffic related statistics
virtual-links Virtual link information
| Output modifiers

R2#

R2#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
192.168.5.1 0 FULL/ – 00:00:32 10.1.1.1 Serial0/1
R2#
R2#show ip ospf database

OSPF Router with ID (192.168.10.1) (Process ID 10)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
192.168.5.1 192.168.5.1 419 0x80000003 0x00832D 3
192.168.10.1 192.168.10.1 418 0x80000002 0x00B1F4 3
R2#

R2#debug ip ospf ?
adj OSPF adjacency events
database-timer OSPF database timer
events OSPF events
flood OSPF flooding
hello OSPF hello events
lsa-generation OSPF lsa generation
mpls OSPF MPLS
nsf OSPF non-stop forwarding events
packet OSPF packets
retransmission OSPF retransmission events
spf OSPF spf
tree OSPF database tree
R2#
R2#debug ip ospf hello
OSPF hello events debugging is on
R2#
*Mar 1 00:27:32.383: OSPF: Send hello to 224.0.0.5 area 0 on FastEthernet0/1 from 192.168.10.1
R2#
*Mar 1 00:27:36.975: OSPF: Rcv hello from 192.168.5.1 area 0 from Serial0/1 10.1.1.1
*Mar 1 00:27:36.975: OSPF: End of hello processing
R2#
*Mar 1 00:27:39.223: OSPF: Send hello to 224.0.0.5 area 0 on Serial0/1 from 10.1.1.2
R2#
*Mar 1 00:27:42.383: OSPF: Send hello to 224.0.0.5 area 0 on FastEthernet0/1 from 192.168.10.1
R2#
R2#show running-config
Building configuration…

Current configuration : 1154 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.1.2 255.255.255.252
clock rate 2000000
!
router ospf 10
log-adjacency-changes
network 10.1.1.0 0.0.0.3 area 0
network 192.168.10.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R2#

GNS3 Cisco Router OSPF Yapılandırma ⇒ Video

GNS3 Cisco Router OSPF yapılandırma ve doğrulama adımlarını videoyu izleyerek gerçekleştirebilir ve ayrıca YouTube kanalımıza abone olabilirsiniz…

  Son Söz

GNS3 Cisco Router OSPF Yapılandırma – Bu yazımızda, GNS3 ağ simulatör programında OSPF Dynamic Routing prokolü konfigürasyonunu yapılandırdık. OSPF yönlendirme protokolünü temel olarak ele aldık. Daha gelişmiş topolojilere de değineceğiz. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

GNS3 Cisco Router OSPF Yapılandırma İlgili Yazılar

GNS3 Cisco Router OSPF Yapılandırma İlgili Dosya
İlgili Dosya

Bu yazıda yapılandırılan GNS3 OSPF projesini aşağıdaki butondan bilgisayarınıza indirebilirsiniz…

 

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

thirteen − three =