GNS3 Cisco Router EIGRP Yapılandırma – EIGRP, Cisco cihazlara özgü bir yönlendirme protokolüdür. EIGRP ağda meydana gelen bir değişiklite yönlendirme güncellemelerini gönderir.
GNS3 Cisco Router EIGRP Yapılandırma

GNS3 Cisco Router EIGRP Yapılandırma

GNS3 Cisco Router EIGRP Yapılandırma

EIGRP yönlendirme protokolü Cisco olmayan cihazlarda kullanılamaz. EIGRP yalnızca Cisco markalı ağ cihazlarında kullanılmaktadır. EIGRP yönlendirme protokolü Multicast (224.0.0.10) yayın yapar. Cisco Router’lar üzerinde EIGRP yapılandırmadan önce, config modunda Router EIGRP (AS Numarası) komutu kullanılarak etkinleştirilir.

Önceki yazımızda, EIGRP protokolü hakkında bilgiler vermiştik. Bu yazımızda, GNS3’te Cisco Router EIGRP Routing (Yönlendirme) konfigürasyonunu yapılandıracağız.

GNS3’te Cisco Router Üzerinde EIGRP Konfigürasyonu

GNS3’te Cisco Router üzerinde EIGRP konfigürasyonu adımlarına geçmeden önce, GNS3 ile VMware Workstation sanal makina entegrasyonu işlemini gerçekleştiriniz. Daha sonra aşağıdaki adımları sırasıyla takip ederek GNS3’te EIGRP yapılandırma işlemini gerçekleştiriniz.

   Adım 1

GNS3 programını açınız ve yeni bir proje oluşturunuz.

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 2

GNS3 Cisco Router EIGRP yapılandırma’sı için aşağıdaki görüntüdeki gibi bir ağ topolojisi oluşturunuz. Ardından Cisco Router’ları çalıştırınız ve CLI komut istemlerini açınız.

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 3

Cisco Router R1 arayüzlerini yapılandırınız. Aşağıdaki komutları uygulayabilirsiniz.

[code] R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
*Mar 1 00:00:43.715: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:00:44.715: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config)#
R1(config)#interface serial 0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#end
R1#
[/code]

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 4

Aynı şekilde Cisco Router R2 arayüzlerini de yapılandırınız.

[code] R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#interface fastethernet 0/1
R2(config-if)#ip address 192.168.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
*Mar 1 00:02:07.995: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Mar 1 00:02:08.995: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R2(config)#
R2(config)#interface serial 0/1
R2(config-if)#ip address 10.1.1.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#end
R2#
[/code]

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 5

GNS3’e VMware sanal makinaları entegre ettikten sonra, sanal makina VMnet ayarlarını yapılandırmak gerekir. Windows 8.1 sanal makinanın ağ kartı olarak VMnet1’i seçiniz ve sanal makinayı çalıştırınız.

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 6

Windows 10 sanal makina ağ kartı olarak VMnet2 tanımlanmıştır. Windows 10 sanal makinayı da çalıştırınız.

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 7

Windows 8.1 sanal makina TCP/IP ayarlarını yapılandırdıktan sonra, Cisco Router FastEthernet 0/0 ve Serial 0/0 arayüzlerine Ping atarak bağlantıyı test ediniz.

Ayrıca, EIGRP yapılandırmadan önce, Router R2 arayüzlerine de Ping atarak bağlantıyı kontrol ediniz. Aşağıdaki görüntüdeki gibi Ping işlemi başarısız olacaktır.

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 8

Aynı işlemleri Windows 10 sanal makina üzerinde de gerçekleştiriniz.

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 9

GNS3 Cisco Router EIGRP yönlendirme adımlarına artık geçebiliriz. İki farklı ağı EIGRP yönlendirme protokolü ile haberleştirmek için Cisco Router R1 CLI komut istemini açınız ve aşağıdaki komutları uygulayınız.

Burada dikkat edilmesi gereken nokta, EIGRP protokolünde network’ler tanımlanırken Wild Card Mask kullanılmasıdır.

[code] R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#
R1(config)#router eigrp 1
R1(config-router)#network 10.1.1.0 ?
A.B.C.D EIGRP wild card bits

R1(config-router)#network 10.1.1.0 0.0.0.3
R1(config-router)#network 192.168.5.0 0.0.0.255
R1(config-router)#end
R1#
[/code]

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 10

Cisco Router R2 CLI komut isteminde de aşağıdaki komutları uygulayınız.

[code] R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#
R2(config)#router eigrp 1
R2(config-router)#network 10.1.1.0 0.0.0.3
R2(config-router)#network 192.
*Mar 1 00:26:14.107: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.1.1 (Serial0/1) is up: new adjacency
R2(config-router)#network 192.168.10.0 0.0.0.255
R2(config-router)#end
R2#
[/code]

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 11

Cisco Router R1 üzerinde show ip route komutunu çalıştırınız ve EIGRP Routing protokolünün tanımladındğını görebilirsiniz.

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 12

Cisco Router R2 üzerinde show ip route komutu çıktısı aşağıdaki gibidir.

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 13

GNS3 Cisco Router EIGRP yapılandırma işleminden sonra tekrar sanal makinalara gelerek, Ping işlemini gerçekleştiriniz ve iki ağ arasındaki bağlantıyı test ediniz.

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 14

Windows 10 sanal makinadan Ping işlemi aşağıdaki gibi başarılı olacaktır.

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 15

EIGRP Show komutlarını inceleyecek olursak, Cisco Router R1 üzerinde uygulanan Show komutları aşağıdaki gibidir.

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 16

Aynı şekilde, Cisco Router R2 üzerinde Show komutu çıktıları aşağıdaki gibidir.

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 17

Cisco Router üzerinde EIGRP konfigürasyonu’nu doğrulamak için, debug eigrp packets komutunu kullanabilirsiniz.

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 18

Aynı komutu Router R2 üzerinde de çalıştırınız. Cisco Router’lar üzerinde EIGRP yönlendirme protokolünün Hello paketlerini görebilirsiniz.

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 19

EIGRP yapılandırmasını doğrulamanın diğer bir yolu da Wireshark progrmaını kullanmaktır. Cisco Router’ları birbirine bağlayan Serial kablo üzerinde Sağ Tuş / Start Capture seçeneğine tıklayınız.

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 20

Packet Capture penceresiden OK (Tamam) butonuna tıklayınız.

GNS3 Cisco Router EIGRP Yapılandırma

   Adım 21

OK butonuna basar basmaz Wireshark programı açılacaktır. Wireshark üzerinde EIGRP paketlerini görebilirsiniz. EIGRP Hello paketlerinin 224.0.0.10 Multicast adres üzerinden yapıldığını görebilirsiniz.

GNS3 Cisco Router EIGRP Yapılandırma

GNS3 Cisco Router EIGRP Yapılandırma Show Komutları

R1#show ip routeR2#show ip routeR1#debug eigrp packetsR2#debug eigrp packetsR1#show running-configR2#show running-config
R1#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

D 192.168.10.0/24 [90/2195456] via 10.1.1.2, 00:00:47, Serial0/0
C 192.168.5.0/24 is directly connected, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/0
D 10.0.0.0/8 is a summary, 00:01:48, Null0
R1#

R2#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

C 192.168.10.0/24 is directly connected, FastEthernet0/1
D 192.168.5.0/24 [90/2195456] via 10.1.1.1, 00:01:28, Serial0/1
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/1
D 10.0.0.0/8 is a summary, 00:01:20, Null0
R2#

R1#debug eigrp packets
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, SIAREPLY)
R1#
*Mar 1 00:40:53.527: EIGRP: Received HELLO on Serial0/0 nbr 10.1.1.2
*Mar 1 00:40:53.531: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
R1#
*Mar 1 00:40:55.623: EIGRP: Sending HELLO on Serial0/0
*Mar 1 00:40:55.623: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Mar 1 00:40:55.987: EIGRP: Sending HELLO on FastEthernet0/0
*Mar 1 00:40:55.987: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R1#
*Mar 1 00:40:58.299: EIGRP: Received HELLO on Serial0/0 nbr 10.1.1.2
*Mar 1 00:40:58.303: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
R1#
*Mar 1 00:41:00.439: EIGRP: Sending HELLO on Serial0/0
*Mar 1 00:41:00.439: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Mar 1 00:41:00.651: EIGRP: Sending HELLO on FastEthernet0/0
*Mar 1 00:41:00.651: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R1#
*Mar 1 00:41:02.979: EIGRP: Received HELLO on Serial0/0 nbr 10.1.1.2
*Mar 1 00:41:02.983: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
R1#
R2#debug eigrp packets
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, SIAREPLY)
R2#
*Mar 1 00:41:30.323: EIGRP: Received HELLO on Serial0/1 nbr 10.1.1.1
*Mar 1 00:41:30.323: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
R2#
*Mar 1 00:41:31.767: EIGRP: Sending HELLO on Serial0/1
*Mar 1 00:41:31.767: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R2#
*Mar 1 00:41:33.027: EIGRP: Sending HELLO on FastEthernet0/1
*Mar 1 00:41:33.027: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R2#
*Mar 1 00:41:35.619: EIGRP: Received HELLO on Serial0/1 nbr 10.1.1.1
*Mar 1 00:41:35.623: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
*Mar 1 00:41:36.551: EIGRP: Sending HELLO on Serial0/1
*Mar 1 00:41:36.551: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R2#
R1#show running-config
Building configuration…

Current configuration : 1119 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router eigrp 1
network 10.1.1.0 0.0.0.3
network 192.168.5.0
auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#

R2#show running-config
Building configuration…

Current configuration : 1121 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.1.2 255.255.255.252
clock rate 2000000
!
router eigrp 1
network 10.1.1.0 0.0.0.3
network 192.168.10.0
auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R2#

GNS3 Cisco Router EIGRP Yapılandırma ⇒ Video

GNS3 Cisco Router EIGRP yapılandırma ve doğrulama adımlarını videoyu izleyerek gerçekleştirebilir ve ayrıca YouTube kanalımıza abone olabilirsiniz…

  Son Söz

GNS3 Cisco Router EIGRP Yapılandırma – Bu yazımızda iki farklı ağı Cisco EIGRP yönlendirme protokolünü kullanarak haberleştirdik. EIGRP yapılandırırken network komutu kullanımında Wild Card Mask adresini doğru olarak yapılandırmanız gerekir. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

GNS3 Cisco Router EIGRP Yapılandırma İlgili Yazılar

GNS3 Cisco Router EIGRP Yapılandırma İlgili Dosya
İlgili Dosya

Bu yazıda yapılandırılan GNS3 projesini aşağıdaki butondan bilgisayarınıza indirebilirsiniz…

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

11 − three =