How to Configure Static Routing on Cisco Router in GNS3? – In this article, we will use GNS3 to communicate with two different networks connected to Cisco Routers by configuring Static Routing.
How to Configure Static Routing on Cisco Router in GNS3?

How to Configure Static Routing on Cisco Router in GNS3?

Static Routing is a routing protocol. It is called Static Routing because it is configured manually on the Router. Routers on the network use Routes to communicate, and they determine where IP packets go through the Route.

Configuring Static Routing on Cisco Routers is simple. If you have a small network, it is recommended to configure Static Route because the resource usage of a dynamic routing protocol on the Router is excessive. In addition, Static Route is required in some cases.

Manual configuration of static routes in a growing network will be difficult and complicated. For this reason, you must use Dynamic Routing instead of Static Routing because the dynamic routing protocol is configured once on the Routers.

In this article, we will configure Static Routing on Cisco Routers to networks in two different locations.

Our Recommendation

You can purchase “CCNA Routing and Switching Complete Study Guide” from Amazon.

How to Configure Static Routing in GNS3?

In this article, we will implement the Static Route / Static Routing steps using GNS3 and VMware Workstation programs.

Before moving on to the steps to configure Static Routing on Cisco Router in GNS3, you need to install GNS3 and install VMware Workstation on your computer. You can also browse how to integrate GNS3 and VMware Workstation for the use of virtual machines in GNS3.

If you want to watch the VMware connection with GNS3 as a video, you can watch the video called VMware integration with GNS3.

   Step 1

Open the GNS3 program and create a new project. Next, follow the steps below to configure Static Routing on GNS3.

How to Configure Static Routing on Cisco Router in GNS3?

   Step 2

In the GNS3 program, create the network topology as shown in the following figure. You can also add clarifications to make network topology more understandable.

How to Configure Static Routing on Cisco Router in GNS3?

   Step 3

Configure the IP address settings of the Windows 8.1 virtual machine on VMware Workstation as follows.

How to Configure Static Routing on Cisco Router in GNS3?

   Step 4

Likewise, configure the IP address settings of the Windows 10 virtual machine on VMware Workstation as follows.

How to Configure Static Routing on Cisco Router in GNS3?

   Step 5

Open the Cisco Router R1 CLI command prompt and configure the FastEthernet 0/1 interface. You can control the interface with show ip interface brief command.

R1# conf t
R1(config)# interface fastethernet 0/1
R1(config-if)# ip address 192.168.5.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# end

 
How to Configure Static Routing on Cisco Router in GNS3?

   Step 6

Likewise, configure the interface on the Cisco Router R2 where the 192.168.10.0/24 network is connected.

R2# conf t
R2(config)# interface fastethernet 0/1
R2(config-if)# ip address 192.168.10.1 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# end

 
How to Configure Static Routing on Cisco Router in GNS3?

   Step 7

Ping operation from the Windows 8 virtual machine to the Fa0/1 interface of Cisco Router R1 is successful.

How to Configure Static Routing on Cisco Router in GNS3?

   Step 8

Ping from the Windows 10 virtual machine to the Fa0/1 interface of Cisco Router R2 is also successful.

How to Configure Static Routing on Cisco Router in GNS3?

   Step 9

Configure the FastEthernet0/0 interface of Cisco Router R1.

R1# conf t
R1(config)# interface fastethernet 0/0
R1(config-if)# ip address 10.1.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# end

 
How to Configure Static Routing on Cisco Router in GNS3?

   Step 10

Likewise, configure the Fa0/0 interface of Cisco Router R1.

R2# conf t
R2(config)# interface fastethernet 0/0
R2(config-if)# ip address 10.1.1.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# end

How to Configure Static Routing on Cisco Router in GNS3?

   Step 11

Before configuring Static Route on Cisco Routers, test the network connection by pinging the Fa0/0 interface of Cisco Router R2 from the Windows 8 virtual machine. Ping will fail because Static Routing is not configured on Cisco Routers.

At this point, the need for static routing or a dynamic routing configuration emerges.

Pinging the Fa0/2 interface of Cisco Router R2 from the Windows 8 virtual machine fails. If R1 can not reach the internal interface of R2, the computers will not be able to communicate.

How to Configure Static Routing on Cisco Router in GNS3?

   Step 12

Likewise, test the network connection from Windows 10 virtual machine to the 192.168.5.0/24 network.

How to Configure Static Routing on Cisco Router in GNS3?

   Step 13

Specify a static route on the Cisco Router R1.

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#ip route 192.168.10.0 255.255.255.0 10.1.1.2
R1(config)#end
R1#
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
L 10.1.1.1/32 is directly connected, FastEthernet0/0
192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/24 is directly connected, FastEthernet0/1
L 192.168.5.1/32 is directly connected, FastEthernet0/1
S 192.168.10.0/24 [1/0] via 10.1.1.2
R1#

 
The show ip route output on Cisco Router R1 is as follows.

How to Configure Static Routing on Cisco Router in GNS3?

   Step 14

Configure the Static Route in Cisco Router R2 in the same way.

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#ip route 192.168.5.0 255.255.255.0 10.1.1.1
R2(config)#end
R2#
R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
L 10.1.1.2/32 is directly connected, FastEthernet0/0
S 192.168.5.0/24 [1/0] via 10.1.1.1
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, FastEthernet0/1
L 192.168.10.1/32 is directly connected, FastEthernet0/1
R2#

 
How to Configure Static Routing on Cisco Router in GNS3?

   Step 15

Go back to the Windows 8.1 virtual machine and ping the Windows 10 virtual machine at 192.168.10.0/24, the ping will succeed as follows.

How to Configure Static Routing on Cisco Router in GNS3?

   Step 16

If you ping the Windows 8.1 virtual machine on the 192.168.5.0/24 network via the Windows 10 virtual machine, the ping operation will succeed.

How to Configure Static Routing on Cisco Router in GNS3?

Show Commands Related to How to Configure Static Routing on Cisco Router in GNS3

R1#show ip int brR2#show ip int brR1#show ip routeR2#show ip routeR1#show running-configR1#show running-config
R1#show ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.1.1.1 YES manual up up
FastEthernet0/1 192.168.5.1 YES manual up up
R1#
R2#show ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.1.1.2 YES manual up up
FastEthernet0/1 192.168.10.1 YES manual up up
R2#
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
L 10.1.1.1/32 is directly connected, FastEthernet0/0
192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/24 is directly connected, FastEthernet0/1
L 192.168.5.1/32 is directly connected, FastEthernet0/1
S 192.168.10.0/24 [1/0] via 10.1.1.2
R1#
R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, FastEthernet0/0
L 10.1.1.2/32 is directly connected, FastEthernet0/0
S 192.168.5.0/24 [1/0] via 10.1.1.1
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, FastEthernet0/1
L 192.168.10.1/32 is directly connected, FastEthernet0/1
R2#
R1#show running-config
Building configuration...

Current configuration : 1087 bytes
!
! Last configuration change at 11:27:41 UTC Fri Jun 2 2017
upgrade fpd auto
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
redundancy
!
!
ip tcp synwait-time 5
!
!
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.10.0 255.255.255.0 10.1.1.2
!
no cdp log mismatch duplex
!
!
control-plane
!
mgcp profile default
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
transport input all
!
!
end
R1#
R2#show running-config
Building configuration...

Current configuration : 1087 bytes
!
! Last configuration change at 11:28:22 UTC Fri Jun 2 2017
upgrade fpd auto
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
redundancy
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.5.0 255.255.255.0 10.1.1.1
!
no cdp log mismatch duplex
!
control-plane
!
!
mgcp profile default
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
transport input all
!
!
end
R2#

How to Configure Static Routing on Cisco Router in GNS3? ⇒ Video

To configure Static Routing on Cisco Routers using GNS3, you can watch the following video. You can also subscribe to our YouTube channel to support us…

  Final Word

How to Configure Static Routing on Cisco Router in GNS3? – In this article, we have configured Static Routing on Cisco Routers on the GNS3 network simulator program to communicate computers on different networks. For performance, Static Routing is useful, but it is better to use Dynamic Routing on a large network. Thanks for following us!

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to browser bookmarks by pressing the CTRL+D to read this article later!

Articles Related to How to Configure Static Routing on Cisco Router in GNS3

Articles Related to How to Configure Static Routing on Cisco Router in GNS3
Related Products


Files Related to How to Configure Static Routing on Cisco Router in GNS3
Related Files

You can download the Cisco Router 7200 IOS image used in this article to your computer at the button below…

Download 7200 Router IOS

Leave a Reply

Your email address will not be published. Required fields are marked *

4 + six =