How to Configure Static NAT on Cisco Router? – The NAT operation on Cisco Routers is enabled to allow the computers on the network to surf the Internet. After creating a small topology with the GNS3 program, we will define the NAT configuration on the Cisco Router.
How to Configure Static NAT on Cisco Router?

How to Configure Static NAT on Cisco Router?

How to Configure Static NAT on Cisco Router?

Prior to the configure Static NAT on Cisco Router, there are two parameters in the Static NAT process.These are; Inside and Outside. When any computer on the network wants to open a web page on the Internet, the packet will first go through the Router’s Inside by going through the switch on the network. On the Router, this packet will be transmitted from the Outside to the Internet.

According to the network topology, these legs must be identified by determining which router the router will send the computers on the LAN to the Internet. This is the most important point in the Cisco Router Static NAT configuration process.

Before moving on to the Cisco Router Static NAT configuration process, we create the topology in the GNS3 program as shown below. While creating this topology in the GNS3 program, you need to be near your modem. This is because we need to connect the Internet cloud in the topology to the Ethernet network card of the physical computer. It’s not the VMnet of the VMware Workstation.

If we try this operation with GNS3 program with WiFi card, it will give an error due to the program and the connection will fail.

How to integrate VMware into GNS3? You can read “How to Integrate VMware with GNS3?” to answer the question…

Our Recommendation

You can purchase “Cisco CCNA in 60 Days” from Amazon.

Cisco NAT Configuration with GNS3

You can download the Cisco IOS image used for the Cisco NAT configuration from the following link.

 
   Step 1

Create the topology as shown the below image by opening the GNS3 for Cisco NAT configuration with GNS3.

How to Configure Static NAT on Cisco Router?

   Step 2

In the process to configure Static NAT on Cisco Router, we were manually issuing IP addresses to Cisco Interfaces previously. Here we can also give a static IP address. However, we have used the IP address DHCP command in the interface to see that the Cisco Router has successfully connected with our ADSL Modem.

How to Configure Static NAT on Cisco Router?

   Step 3

According to the topology in the GNS3 program, you can install any operating system in VMware Workstation. Since I am using the Windows 10 operating system in this topology after I run the Windows 10 virtual machine, I assigned the 192.168.8.0/24 Ip block to the FastEthernet0/1 interface of the Cisco Router, so I test the interface from the virtual machine by pinging the IP address of the interface.

From the Windows 10 virtual machine, the Cisco Router FastEthernet 0/1 interface has been successfully pinged.

How to Configure Static NAT on Cisco Router?

   Step 4

We used the IP address DHCP command for the Cisco Router FastEthernet 0/0 interface. From the DHCP Server of the ADSL modem received the IP address 192.168.1.103. Pinging from the Windows 10 virtual machine to the Cisco Router FastEthernet0/0 interface;

How to Configure Static NAT on Cisco Router?

   Step 5

However, if we ping the Google DNS addresses from the Windows 10 virtual machine, the operation will fail.

How to Configure Static NAT on Cisco Router?

   Step 6

We continue to the processes to configure Static NAT on Cisco Router. In this step, we need to apply the necessary commands to the Cisco Router for Cisco NAT configuration.

Apply the following commands, respectively, to the Cisco Router.

R1# conf t
R1(config)# interface fastethernet 0/0
R1(config-if)# ip address dhcp
R1(config-if)# no shutdown
R1(config-if)# ip nat outside
R1(config-if)# exit
R1(config)# interface fastethernet 0/1
R1(config-if)# ip address 192.168.8.1 255.255.255.0
R1(config-if)# ip nat inside
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# ip nat inside source static 192.168.8.10 192.168.1.50
R1(config)# ip name-server 192.168.1.1
R1(config)# ip domain-lookup
R1(config)# end
R1# copy running-config startup-config

After the IP address DHCP command for the Cisco Router FastEthernet0/0 interface;

How to Configure Static NAT on Cisco Router?

   Step 7

After applying the commands required to configure Static NAT on Cisco Router, if you ping the Google DNS servers from Windows 10, you can see that the process is successful in the following display.

How to Configure Static NAT on Cisco Router?

   Step 8

In Windows 10 Ip configuration, if you leave the DNS server section blank, the web page will not open when you type Google.com in the browser address line.

When you give the address of ADSL modem IP to the DNS part, you can see that the site of google.com is successfully accessed.

How to Configure Static NAT on Cisco Router?

   Step 9

The show commands are another step in the process to configure Static NAT on Cisco Router. We can test the operation with NAT show commands. In the image below, the entries for the Google.com website will appear when the show ip nat translations command is executed.

The process to configure Static NAT on Cisco Router is quite easy. In the following image, we can see what the Static NAT process does. The internal 192.168.8.10 IP address is translated to 192.168.1.50 IP address on the Cisco Router. And so the virtual machine will come out the Internet.

How to Configure Static NAT on Cisco Router?

   Step 10

Sometimes we may have to delete these NAT translations in the Cisco Router CLI console when we encounter problems in the network environment. When we want to delete NAT records on the Cisco router, all translated Static NAT records will be deleted from the NAT table when we apply the [clear ip nat translations *] command in the privileged configuration mode.

How to Configure Static NAT on Cisco Router?

   Step 11

If we apply for the show ip nat translations command in privileged configuration mode again, we can see that the records are deleted.

How to Configure Static NAT on Cisco Router?

   Step 12

For example, when we open Facebook.com, Cisco Router Static NAT records will match again.

How to Configure Static NAT on Cisco Router?

Cisco Router Static NAT Configuration Show Commands

R1# show running-configR1#show ip nat statisticsR1#show ip nat translationsR1#show ip nat translationsR1#show ip nat statistics

R1# show running-config
Building configuration…

Current configuration : 1050 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
ip name-server 192.168.1.1
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip nat inside source static 192.168.8.10 192.168.1.50
!
no cdp log mismatch duplex
!
!
control-plane
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#

R1#show ip nat statistics
Total active translations: 2 (1 static, 1 dynamic; 1 extended)
Outside interfaces:
FastEthernet0/0
Inside interfaces:
FastEthernet0/1
Hits: 7 Misses: 1
CEF Translated packets: 8, CEF Punted packets: 0
Expired translations: 0
Dynamic mappings:
Appl doors: 0
Normal doors: 0
Queued Packets: 0

R1#show ip nat translations
Pro          Inside global            Inside local                       Outside local                   Outside global
icmp       192.168.1.50:1      192.168.8.10:1              8.8.8.8:1                              8.8.8.8:1
—            192.168.1.50           192.168.8.10                   —                                             —

R1#show ip nat translations
Pro Inside global Inside local Outside local Outside global
tcp 192.168.1.50:49704 192.168.8.10:49704 204.79.197.200:443 204.79.197.200:443
tcp 192.168.1.50:49705 192.168.8.10:49705 93.184.220.20:80 93.184.220.20:80
tcp 192.168.1.50:49706 192.168.8.10:49706 204.79.197.200:443 204.79.197.200:443
tcp 192.168.1.50:49707 192.168.8.10:49707 204.79.197.200:443 204.79.197.200:443
tcp 192.168.1.50:49708 192.168.8.10:49708 204.79.197.200:443 204.79.197.200:443
tcp 192.168.1.50:49709 192.168.8.10:49709 204.79.197.200:443 204.79.197.200:443
tcp 192.168.1.50:49710 192.168.8.10:49710 204.79.197.200:443 204.79.197.200:443
tcp 192.168.1.50:49711 192.168.8.10:49711 31.13.92.36:443 31.13.92.36:443
tcp 192.168.1.50:49712 192.168.8.10:49712 31.13.92.36:443 31.13.92.36:443
tcp 192.168.1.50:49713 192.168.8.10:49713 93.184.220.29:80 93.184.220.29:80
tcp 192.168.1.50:49714 192.168.8.10:49714 31.13.92.36:443 31.13.92.36:443
tcp 192.168.1.50:49715 192.168.8.10:49715 31.13.92.36:443 31.13.92.36:443
tcp 192.168.1.50:49716 192.168.8.10:49716 93.184.220.29:80 93.184.220.29:80
tcp 192.168.1.50:49717 192.168.8.10:49717 31.13.93.7:443 31.13.93.7:443
tcp 192.168.1.50:49718 192.168.8.10:49718 31.13.93.7:443 31.13.93.7:443
tcp 192.168.1.50:49719 192.168.8.10:49719 31.13.93.10:443 31.13.93.10:443
tcp 192.168.1.50:49720 192.168.8.10:49720 31.13.93.10:443 31.13.93.10:443
tcp 192.168.1.50:49721 192.168.8.10:49721 207.46.101.29:80 207.46.101.29:80
udp 192.168.1.50:51647 192.168.8.10:51647 192.168.1.1:53 192.168.1.1:53
udp 192.168.1.50:53083 192.168.8.10:53083 192.168.1.1:53 192.168.1.1:53
udp 192.168.1.50:58578 192.168.8.10:58578 192.168.1.1:53 192.168.1.1:53
udp 192.168.1.50:59312 192.168.8.10:59312 192.168.1.1:53 192.168.1.1:53
udp 192.168.1.50:59671 192.168.8.10:59671 192.168.1.1:53 192.168.1.1:53
Pro Inside global Inside local Outside local Outside global
udp 192.168.1.50:59896 192.168.8.10:59896 192.168.1.1:53 192.168.1.1:53
udp 192.168.1.50:60946 192.168.8.10:60946 192.168.1.1:53 192.168.1.1:53
udp 192.168.1.50:61739 192.168.8.10:61739 192.168.1.1:53 192.168.1.1:53
udp 192.168.1.50:64596 192.168.8.10:64596 192.168.1.1:53 192.168.1.1:53
— 192.168.1.50 192.168.8.10 — —

R1#show ip nat statistics
Total active translations: 2 (1 static, 1 dynamic; 1 extended)
Outside interfaces:
FastEthernet0/0
Inside interfaces:
FastEthernet0/1
Hits: 2735 Misses: 78
CEF Translated packets: 2699, CEF Punted packets: 227
Expired translations: 89
Dynamic mappings:
Appl doors: 0
Normal doors: 0
Queued Packets: 0
R1#

How to Configure Static NAT on Cisco Router? ⇒ Video

You can watch the steps to configure Static NAT on Cisco Router. Also, you can subscribe to our YouTube channel…

  Final Word

How to Configure Static NAT on Cisco Router? – After completing the Cisco NAT configuration process, we looked at the show commands for Static NAT registers on the Cisco Router CLI console.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to the browser bookmarks by pressing the Ctrl+D to read this article later!

Articles Related to How to Configure Static NAT on Cisco Router

Products Related to How to Configure Static NAT on Cisco Router
Related Products

Leave a Reply

Your email address will not be published. Required fields are marked *