How to Configure RIP Version 2 on Cisco Router in GNS3? – In this article, we will configure Version 2 of the RIP routing protocol in GNS3.
How to Configure RIP Version 2 on Cisco Router in GNS3?

How to Configure RIP Version 2 on Cisco Router in GNS3?

How to Configure RIP Version 2 on Cisco Router in GNS3?

RIP Version 2 is defined in RFC 2453. RIP Version 2 sends Multicast broadcast instead of Broadcast for the routing table update.

It supports multicast broadcast, VLSM, and CIDR. Thus, we can communicate different subnets to each other. We also reduce the use of private IP address to the minimum level to prevent Broadcast traffic.

In our previous articles, we have provided information on what is RIP Protocol in networking and how to configure RIP Routing on Cisco Router in GNS3. In this article, we will use the GNS3 program to implement RIP Version 2 routing steps.

Once we identified the 192.168.5.0/24 on two different networks, we will communicate these networks with RIP V2 on Cisco Routers.

You can also provide the GNS3 RIP V1 Configuration steps by watching the video.

Our Recommendation

You can purchase “How to Master CCNA” from Amazon.

How to Enable RIP Version 2 on Cisco Router?

Before moving on to RIP version 2 activation steps on the Cisco Router in GNS3, you can browse GNS3 VPCS Usage. In this article, we will use the Virtual PC Simulator (VPCS) in the GNS3 RIP configuration.

Using VPCS instead of VMware virtual machine in GNS3 is a more performance operation.

We can now move on to configure RIP Version 2 on Cisco Router in GNS3. Follow the steps for RIP V2 configuration in order.

   Step 1

Run the GNS3 program and create a new project.

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 2

For the GNS3 RIP V2 configuration, create the network topology as shown below.

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 3

Configure the VPCS in the GNS3 workspace according to the network topology, respectively. You can apply the following commands for VPCS PC1 IP address settings.

PC1> ip 192.168.5.5/25 192.168.5.1
Checking for duplicate address...
PC1 : 192.168.5.5 255.255.255.128 gateway 192.168.5.1

PC1> show ip

NAME        : PC1[1]
IP/MASK     : 192.168.5.5/25
GATEWAY     : 192.168.5.1
DNS         : 
MAC         : 00:50:79:66:68:00
LPORT       : 10014
RHOST:PORT  : 127.0.0.1:10015
MTU:        : 1500
PC1> 

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 4

Configure the VPCS PC2 IP configuration.

PC2> ip 192.168.5.10/25 192.168.5.1 
Checking for duplicate address...
PC1 : 192.168.5.10 255.255.255.128 gateway 192.168.5.1

PC2> show ip

NAME        : PC2[1]
IP/MASK     : 192.168.5.10/25
GATEWAY     : 192.168.5.1
DNS         : 
MAC         : 00:50:79:66:68:01
LPORT       : 10016
RHOST:PORT  : 127.0.0.1:10017
MTU:        : 1500
PC2> 

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 5

The important thing to note when configuring the IP address for the VPCS PC3 is the Subnet Mask. Also, configure the IP configuration for the VPCS PC3.

PC3> ip 192.168.5.130/25 192.168.5.129
Checking for duplicate address...
PC1 : 192.168.5.130 255.255.255.128 gateway 192.168.5.129

PC3> show ip

NAME        : PC3[1]
IP/MASK     : 192.168.5.130/25
GATEWAY     : 192.168.5.129
DNS         : 
MAC         : 00:50:79:66:68:02
LPORT       : 10018
RHOST:PORT  : 127.0.0.1:10019
MTU:        : 1500
PC3> 

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 6

Finally, configure the VPCS PC4. Note the image below. PC3 and PC4 IP address settings are in the 192.168.5.0/25 block.

PC4> ip 192.168.5.135/25 192.168.5.129
Checking for duplicate address...
PC1 : 192.168.5.135 255.255.255.128 gateway 192.168.5.129

PC4> show ip

NAME        : PC4[1]
IP/MASK     : 192.168.5.135/25
GATEWAY     : 192.168.5.129
DNS         : 
MAC         : 00:50:79:66:68:03
LPORT       : 10020
RHOST:PORT  : 127.0.0.1:10021
MTU:        : 1500
PC4> 

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 7

Open the Cisco Router R1 CLI command prompt and configure the FastEthernet 0/0 and Serial 0/0 interfaces.

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.128
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
*Mar  1 00:12:56.175: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar  1 00:12:57.175: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config)#
R1(config)#interface serial 0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#end
R1#

Use the show ip route command on R1 to check the configuration.

R1#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.5.1     YES manual up                    up      
Serial0/0                  10.1.1.1        YES manual up                    up      
FastEthernet0/1            unassigned      YES unset  administratively down down    
Serial0/1                  unassigned      YES unset  administratively down down    
R1#

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 8

Likewise, configure the Cisco Router R2 interfaces. Pay attention the Router R2 Fast Ethernet 0/1 interface subnet mask.

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#interface fastethernet 0/1
R2(config-if)#ip address 192.168.5.129 255.255.255.128
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
*Mar  1 00:14:49.607: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Mar  1 00:14:50.607: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R2(config)#
R2(config)#interface serial 0/1
R2(config-if)#ip address 10.1.1.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#end
R2#

Check the Router R2 interface configuration.

R2#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down    
Serial0/0                  unassigned      YES unset  administratively down down    
FastEthernet0/1            192.168.5.129   YES manual up                    up      
Serial0/1                  10.1.1.2        YES manual up                    up      
R2#

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 9

Before configuring RIP Version 2 on Cisco Router in GNS3, check the VPCS connections with Ping. Ping process from VPCS PC1 to Router R2 serial interface will fail as follows.

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 10

The result of Ping on VPCS PC3 is as follows. Also, PC3 will not ping Router R1 Serial interface.

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 11

To communicate computers at two different locations, configure RIP Version 2. At the Cisco Router R1 command prompt, perform the following commands.

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.1.1.0
R1(config-router)#network 192.168.5.0
R1(config-router)#end
R1#

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 12

Likewise, enable RIP Version 2 on Cisco Router R2 and identify the networks to which it is connected.

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 10.1.1.0
R2(config-router)#network 192.168.5.128
R2(config-router)#end
R2#

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 13

We completed the process to configure RIP Version 2 on Cisco Router in GNS3. Now, test the connection by pinging VPCS PCs. Ping operation to R2 Serial interface via PC1 will be successful. And as a result, PC1 will successfully access the 192.168.5.128/25 network.

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 14

Ping operations from PC3 to the opposite network will be successful as follows.

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 15

Run the show ip route command on Cisco Router R1 and browse through the routing table. As shown in the image below, the RIP learned the networks that the routing protocol does not know.

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 16

Likewise, apply for the show ip route command on Cisco Router R2.

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 17

On Router R2, run the debug ip rip command to check the RIP Version 2 configuration and you will see a record like the one below.

In this view, you can see that RIP V2 routing updates are done by 224.0.09 Multicast address.

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 18

Likewise, you can also check RIP V2 records on Router R2.

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 19

In GNS3 we can also check the Cisco Router RIP Version 2 configuration with the Wireshark program. To validate RIP Version 2 with Wireshark, click Right Button / Start Capture on the Serial connection between R1 and R2.

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 20

A window like the one below will open. Click the OK button to continue.

How to Configure RIP Version 2 on Cisco Router in GNS3?

   Step 21

The Wireshark program launched and you can view the RIP V2 (224.0.0.9) record from the following display. In short, the routing updates applied between the two Cisco Routers with the RIP Version 2 Multicast address.

How to Configure RIP Version 2 on Cisco Router in GNS3?

Show Commands Related to How to Configure RIP Version 2 on Cisco Router in GNS3

R1#show running-configR2#show running-configR1#show ip rip dtbseR2#show ip rip dtbseR1#show ip routeR2#show ip routeR1#debug ip ripR2#debug ip rip
R1#show running-config
Building configuration…

Current configuration : 1106 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
ip tcp synwait-time 5
!
!
!
interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.128
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router rip
version 2
network 10.0.0.0
network 192.168.5.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#

R2#show running-config
Building configuration…

Current configuration : 1108 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.5.129 255.255.255.128
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.1.2 255.255.255.252
clock rate 2000000
!
router rip
version 2
network 10.0.0.0
network 192.168.5.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R2#

R1#show ip rip dtbse
10.0.0.0/8 auto-summary
10.1.1.0/30 directly connected, Serial0/0
192.168.5.0/24 auto-summary
192.168.5.0/24
[1] via 10.1.1.2, 00:00:22, Serial0/0
192.168.5.0/25 directly connected, FastEthernet0/0
R1#
R2#show ip rip dtbse
10.0.0.0/8 auto-summary
10.1.1.0/30 directly connected, Serial0/1
192.168.5.0/24 auto-summary
192.168.5.0/24
[1] via 10.1.1.1, 00:00:22, Serial0/1
192.168.5.128/25 directly connected, FastEthernet0/1
R2#
R1#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/25 is directly connected, FastEthernet0/0
R 192.168.5.0/24 [120/1] via 10.1.1.2, 00:00:00, Serial0/0
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/0
R1#

R2#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
R 192.168.5.0/24 [120/1] via 10.1.1.1, 00:00:07, Serial0/1
C 192.168.5.128/25 is directly connected, FastEthernet0/1
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/1
R2#

R1#debug ip rip
RIP protocol debugging is on
R1#
*Mar 1 00:24:22.779: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (10.1.1.1)
*Mar 1 00:24:22.779: RIP: build update entries
*Mar 1 00:24:22.779: 192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
R1#
*Mar 1 00:24:34.083: RIP: received v2 update from 10.1.1.2 on Serial0/0
*Mar 1 00:24:34.087: 192.168.5.0/24 via 0.0.0.0 in 1 hops
R1#
*Mar 1 00:24:36.891: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (192.168.5.1)
*Mar 1 00:24:36.891: RIP: build update entries
*Mar 1 00:24:36.891: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:24:36.891: 192.168.5.0/24 via 0.0.0.0, metric 2, tag 0
R1#
*Mar 1 00:24:48.759: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (10.1.1.1)
*Mar 1 00:24:48.759: RIP: build update entries
*Mar 1 00:24:48.759: 192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
R1#
R2#debug ip rip
RIP protocol debugging is on
R2#
*Mar 1 00:24:23.591: RIP: received v2 update from 10.1.1.1 on Serial0/1
*Mar 1 00:24:23.591: 192.168.5.0/24 via 0.0.0.0 in 1 hops
R2#
*Mar 1 00:24:33.427: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/1 (192.168.5.129)
*Mar 1 00:24:33.427: RIP: build update entries
*Mar 1 00:24:33.427: 10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:24:33.427: 192.168.5.0/24 via 0.0.0.0, metric 2, tag 0
R2#
*Mar 1 00:24:34.803: RIP: sending v2 update to 224.0.0.9 via Serial0/1 (10.1.1.2)
*Mar 1 00:24:34.803: RIP: build update entries
*Mar 1 00:24:34.803: 192.168.5.0/24 via 0.0.0.0, metric 1, tag 0
R2#

How to Configure RIP Version 2 on Cisco Router in GNS3? ⇒ Video

You can watch how to configure RIP Version 2 on Cisco Router in GNS3 and how to verify RIP Routing from the video below. And also, subscribe to our YouTube channel…

  Final Word

How to Configure RIP Version 2 on Cisco Router in GNS3? – In this article, we have connected with RIP Version 2 the 192.168.5.0/24 network separated by VLSM in GNS3. If RIP Version 1 in this article had used, the networks would not be able to communicate. Since Version 2 of the RIP routing protocol supports VLSM, the networks can communicate.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to browser bookmarks by pressing the CTRL+D to read this article later!

Articles Related to How to Configure RIP Version 2 on Cisco Router in GNS3

Products Related to How to Configure RIP Version 2 on Cisco Router in GNS3
Related Products

File Related to How to Configure RIP Version 2 on Cisco Router in GNS3
Related File

You can download the GNS3 RIP Version 2 project, which configured in this article, by clicking the following button …

 

Leave a Reply

Your email address will not be published. Required fields are marked *