How to Configure RIP Routing on Cisco Router in GNS3? – RIP (Routing Information Protocol) is a routing protocol used to inform each other of networks that Routers do not know.
How to Configure RIP Routing on Cisco Router in GNS3?

How to Configure RIP Routing on Cisco Router in GNS3?

How to Configure RIP Routing on Cisco Router in GNS3?

The RIP routing protocol broadcasts between the Routers (255.255.255.255). Version 1 and Version 2 of the RIP routing protocol are available. The RIP V1 version broadcasts. The RIP V2 version broadcasts multicast (224.0.0.9).

In our previous article, we discussed the RIP Routing Protocol topic. In this article, we will configure the RIP routing configuration on the Cisco Router in GNS3 simulator program.

How to Configure RIP Routing Protocol in GNS3?

Before moving onto the Router RIP configuration in GNS3, create two virtual machines in VMware Workstation. On the VMware Virtual Network Editor, create the VMnet. Later, to integrate VMware virtual machines with GNS3, add and adjust the Cloud to the GNS3 workspace.

We can move on to the steps to configure RIP Routing on Cisco Router in GNS3.

Our Recommendation

You can purchase “Routing and Switching Complete Study Guide” from Amazon.

   Step 1

Open the GNS3 program and create a new project.

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 2

For RIP configuration, create a network topology in GNS3 as shown below.

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 3

On the VMware Windows 8.1 virtual machine, VMnet1 is selected as the network card. Here you can create and set up any VMnet. The point to note in this step is the VMnet IP address block.

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 4

VMware Windows 10 virtual machine network card selected as VMnet2.

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 5

In the VMware Virtual Network Editor program, the VMnet1 and VMnet2 IP address block is as follows. Run the virtual machines you created on VMware.

Configure the TCP/IP configuration of the virtual machines.

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 6

Windows 8.1 virtual machine IP address config is in the IP address range 192.168.5.0/24.

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 7

Our Windows 10 virtual machine has 192.168.10.0/24 IP address block.

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 8

After configuring VMware basic settings with GNS3, open the Cisco Router R1 CLI command prompt and configure the IP address configuration according to the following display.

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#do show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.5.1     YES manual up                    up      
Serial0/0                  10.1.1.1        YES manual up                    up      
FastEthernet0/1            unassigned      YES unset  administratively down down    
Serial0/1                  unassigned      YES unset  administratively down down

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 9

Configure the Cisco Router R2 interfaces in the same way.

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#interface fastethernet 0/1
R2(config-if)#ip address 192.168.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface serial 0/1
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#do show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down    
Serial0/0                  unassigned      YES unset  administratively down down    
FastEthernet0/1            192.168.10.1    YES manual up                    up      
Serial0/1                  10.1.1.2        YES manual up                    up      
R2(config)#

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 10

Before configuring RIP Routing on Cisco Router in GNS3, check out the connection by pinging the interfaces from VMware virtual machines. Ping the R1 Fa0/0 and Serial0/0 interfaces from the Windows 8.1 virtual machine. Ping process will be successful as follows.

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 11

Check out the connection by pinging the Cisco Router R2 interfaces to which the Windows 10 virtual machine connected.

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 12

Ping will fail from Windows 8.1 virtual machine to the Cisco Router R2 Serial 0/1 interface. Because Routers do not know each other’s subnets without routing configured.

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 13

Ping will also fail from Windows 10 virtual machine.

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 14

To configure RIP Routing protocol in GNS3, open the Router R1 CLI command prompt and apply the following commands.

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#
R1(config)#router rip
R1(config-router)#network 10.1.1.0
R1(config-router)#network 192.168.5.0
R1(config-router)#end
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.5.0/24 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Serial0/0
R1#

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 15

At the Cisco Router R2 CLI command prompt, perform the following commands.

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#
R2(config)#router rip
R2(config-router)#network 10.1.1.0
R2(config-router)#network 192.168.10.0
R2(config-router)#end
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.10.0/24 is directly connected, FastEthernet0/1
R    192.168.5.0/24 [120/1] via 10.1.1.1, 00:00:04, Serial0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Serial0/1
R2#

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 16

After configuring RIP on Cisco Router in GNS3, the virtual machines can successfully Ping as follows.

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 17

Pinging from Windows 10 virtual machine will also succeed as follows.

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 18

You can review the RIP entries on Cisco Router R1.

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 19

Likewise, you can also check RIP entries on Cisco Router R2.

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 20

Run the Debug ip rip command in privileged configuration mode to examine RIP Broadcast broadcast messages.

How to Configure RIP Routing on Cisco Router in GNS3?

   Step 21

You can also check RIP entries on Router R2…

How to Configure RIP Routing on Cisco Router in GNS3?

Show Commands Related to How to Configure RIP Routing on Cisco Router in GNS3

R1#show ip rip dtbseR2#show ip rip dtbseR1#debug ip ripR2#debug ip ripR1#show ip route ripR2#show ip route ripR1#show running-configR2#show running-config
R1#show ip rip dtbse
10.0.0.0/8 auto-summary
10.1.1.0/24 directly connected, Serial0/0
192.168.5.0/24 auto-summary
192.168.5.0/24 directly connected, FastEthernet0/0
192.168.10.0/24 auto-summary
192.168.10.0/24
[1] via 10.1.1.2, 00:00:20, Serial0/0
R1#
R2#show ip rip dtbse
10.0.0.0/8 auto-summary
10.1.1.0/24 directly connected, Serial0/1
192.168.5.0/24 auto-summary
192.168.5.0/24
[1] via 10.1.1.1, 00:00:02, Serial0/1
192.168.10.0/24 auto-summary
192.168.10.0/24 directly connected, FastEthernet0/1
R2#
R1#debug ip rip
RIP protocol debugging is on
R1#
*Mar 1 00:18:36.167: RIP: received v1 update from 10.1.1.2 on Serial0/0
*Mar 1 00:18:36.167: 192.168.10.0 in 1 hops
R1#
*Mar 1 00:18:37.311: RIP: sending v1 update to 255.255.255.255 via Serial0/0 (10.1.1.1)
*Mar 1 00:18:37.311: RIP: build update entries
*Mar 1 00:18:37.311: network 192.168.5.0 metric 1
R1#
*Mar 1 00:18:40.159: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (192.168.5.1)
*Mar 1 00:18:40.159: RIP: build update entries
*Mar 1 00:18:40.159: network 10.0.0.0 metric 1
*Mar 1 00:18:40.159: network 192.168.10.0 metric 2
R1#
*Mar 1 00:19:03.235: RIP: received v1 update from 10.1.1.2 on Serial0/0
*Mar 1 00:19:03.239: 192.168.10.0 in 1 hops
R1#
*Mar 1 00:19:04.791: RIP: sending v1 update to 255.255.255.255 via Serial0/0 (10.1.1.1)
*Mar 1 00:19:04.791: RIP: build update entries
*Mar 1 00:19:04.791: network 192.168.5.0 metric 1
*Mar 1 00:19:05.731: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (192.168.5.1)
*Mar 1 00:19:05.731: RIP: build update entries
*Mar 1 00:19:05.731: network 10.0.0.0 metric 1
R2#debug ip rip
RIP protocol debugging is on
R2#
*Mar 1 00:18:31.063: RIP: sending v1 update to 255.255.255.255 via Serial0/1 (10.1.1.2)
*Mar 1 00:18:31.063: RIP: build update entries
*Mar 1 00:18:31.063: network 192.168.10.0 metric 1
R2#
*Mar 1 00:18:32.107: RIP: received v1 update from 10.1.1.1 on Serial0/1
*Mar 1 00:18:32.107: 192.168.5.0 in 1 hops
R2#
*Mar 1 00:18:34.803: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/1 (192.168.10.1)
*Mar 1 00:18:34.803: RIP: build update entries
*Mar 1 00:18:34.803: network 10.0.0.0 metric 1
*Mar 1 00:18:34.803: network 192.168.5.0 metric 2
R2#
*Mar 1 00:18:58.323: RIP: sending v1 update to 255.255.255.255 via Serial0/1 (10.1.1.2)
*Mar 1 00:18:58.323: RIP: build update entries
*Mar 1 00:18:58.323: network 192.168.10.0 metric 1
R2#
*Mar 1 00:18:59.911: RIP: received v1 update from 10.1.1.1 on Serial0/1
*Mar 1 00:18:59.911: 192.168.5.0 in 1 hops
R2#
*Mar 1 00:19:04.307: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/1 (192.168.10.1)
*Mar 1 00:19:04.307: RIP: build update entries
*Mar 1 00:19:04.307: network 10.0.0.0 metric 1
*Mar 1 00:19:04.307: network 192.168.5.0 metric 2
R2#
R1#show ip route rip
R 192.168.10.0/24 [120/1] via 10.1.1.2, 00:00:22, Serial0/0
R1#
R2#show ip route rip
R 192.168.5.0/24 [120/1] via 10.1.1.1, 00:00:06, Serial0/1
R2#
R1#show running-config
Building configuration…
Current configuration : 1091 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router rip
network 10.0.0.0
network 192.168.5.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#
R2#show running-config
Building configuration…

Current configuration : 1093 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip tcp synwait-time 5
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.1.2 255.255.255.0
clock rate 2000000
!
router rip
network 10.0.0.0
network 192.168.10.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end
R2#

How to Configure RIP Routing on Cisco Router in GNS3? ⇒ Video

You can watch how to RIP Routing on Cisco Router in GNS3 and also subscribe to our YouTube channel…

  Final Word

How to Configure RIP Routing on Cisco Router in GNS3? – In this article, we implemented the RIP routing configuration on Cisco Routers with the GNS3 network simulator program. The above configuration applies to RIP Version 1. We will also configure RIP Version 2 in the next post.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to browser bookmarks by pressing the CTRL+D to read this article later!

Articles Related to How to Configure RIP Routing on Cisco Router in GNS3

Products Related to How to Configure RIP Routing on Cisco Router in GNS3
Related Products

File Related to How to Configure RIP Routing on Cisco Router in GNS3
Related File

You can download the created GNS3 project used in this article from your computer…

 

Leave a Reply

Your email address will not be published. Required fields are marked *