How to Configure PAT NAT Overload on Cisco Router in GNS3? – Another configuration of the Cisco Router NAT configuration is NAT Overload and known Port Address Translation (PAT).
How to Configure PAT NAT Overload on Cisco Router in GNS3?

How to Configure PAT NAT Overload on Cisco Router in GNS3?

How to Configure PAT NAT Overload on Cisco Router in GNS3?

Cisco router PAT configuration is different according to Static NAT and Dynamic NAT. In the Cisco router Static NAT process, the IP address is statically configured in the CLI console to access the Internet. In Dynamic NAT, this process works with a pool system. The NAT pool system consists of the IP addresses assigned by the Internet Service Provider.

In the Cisco Router Dynamic NAT operation, the private IP addresses of the computers going out to the Internet via LAN are converted to general IP addresses by using idle IP address in the pool system in Dynamic NAT process. Each private IP address that accesses the Internet matches with the port number.

The process to configure PAT NAT Overload on Cisco Router is the most common operation on the network. Because most companies have a single IP address assigned by the ISP. Therefore, implementing NAT overload is the most logical way to ensure that all the computers on the LAN can access the Internet.

For Static NAT configuration on the Cisco router, you can read the topic called “How to Configure Static NAT on Cisco Router?“.

Required Cisco IOS  to Configure PAT NAT Overload on Cisco Router in GNS3

 

Our Recommendation

You can purchase “The Book of GNS3” from Amazon.

PAT Configuration on the Cisco Router in GNS3

PAT configuration on the Cisco router is very similar to Dynamic NAT.  However, the IP address pool is not defined in the PAT configuration. Companies with a single generic IP address implement PAT configuration on the Cisco router.

We will use the GNS3 and VMware Workstation programs for the process to configure PAT NAT Overload on Cisco Router.

For the process of including VMware virtual machines in GNS3, you can read the topic called “How to Integrate VMware with GNS3?“.

   Step 1

First, open the GNS3 program and create a new project. Next, add the Router, Cloud, Switch and two Host to the GNS3 workspace. Afterward, create the topology as shown below.

How to Configure PAT NAT Overload on Cisco Router in GNS3?

   Step 2

After you entered your Cloud settings, select and add the physical Ethernet of your computer to the Ethernet tab.

How to Configure PAT NAT Overload on Cisco Router in GNS3?

   Step 3

In the GNS3 program, some problems occur when two computers add to a Switch. You can solve this problem by changing the port numbers where the computers installed in the Switch settings as shown in the following image.

How to Configure PAT NAT Overload on Cisco Router in GNS3?

   Step 4

Add VMnet3 in the Virtual Network Editor program of VMware Workstation. After setting the IP address block, select VMnet3 from the Ethernet tab in the settings of the computers on the GNS3 workspace and save the settings.

How to Configure PAT NAT Overload on Cisco Router in GNS3?

   Step 5

For the process to configure PAT NAT Overload on Cisco Router double-click on the Cisco Router and the CLI command console will open. Apply the commands required for PAT configuration on the Cisco router to the CLI console, respectively.

[code] R1# conf t
R1(config)# interface fastethernet 0/0
R1(config)# ip address 192.168.8.1 255.255.255.0
R1(config-if)# ip nat inside
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface fastethernet 0/1
R1(config-if)# ip address dhcp
R1(config-if)# ip nat outside
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# access-list 1 permit 192.168.8.0 0.0.0.255
R1(config)# ip nat inside source list 1 interface fastethernet 0/1 overload
R1(config)#exit
R1# copy running-config startup-config
[/code]

How to Configure PAT NAT Overload on Cisco Router in GNS3?

   Step 6

After the required commands for the process to configure PAT NAT Overload on Cisco Router, let’s ping to the Google DNS server from the Windows 8.1 virtual machine installed on the VMware Workstation.

Ping process is successful!

How to Configure PAT NAT Overload on Cisco Router in GNS3?

   Step 7

Ping process to the Google DNS server from the Windows 10 virtual machine is successful as well.

How to Configure PAT NAT Overload on Cisco Router in GNS3?

   Step 8

When you run the show ip nat translations command on the Cisco Router in privileged configuration mode, you can see the IP addresses and port numbers established with the Internet in the following image.

How to Configure PAT NAT Overload on Cisco Router in GNS3?

   Step 9

When we apply the show ip nat statistics command on the Cisco Router, we can see the output about the NAT operation.

How to Configure PAT NAT Overload on Cisco Router in GNS3?

   Step 10

After the process to configure PAT NAT Overload on Cisco Router, we can remove with the clear ip nat translations * command the private LAN Ip addresses converted the public Ip address entries from the NAT table on the Cisco Router CLI console.

How to Configure PAT NAT Overload on Cisco Router in GNS3?

Show Commands Related to How to Configure PAT NAT Overload on Cisco Router in GNS3

R1#show running-configR1# show ip nat translationsR1# show ip nat translations
R1#show running-config
Building configuration…

Current configuration : 1095 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address 192.168.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 192.168.8.0 0.0.0.255
no cdp log mismatch duplex
!
!
control-plane
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#

R1# show ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 192.168.1.102:1 192.168.8.5:1 8.8.8.8:1 8.8.8.8:1
tcp 192.168.1.102:49193 192.168.8.5:49193 2.17.20.139:80 2.17.20.139:80
tcp 192.168.1.102:49194 192.168.8.5:49194 2.17.20.139:80 2.17.20.139:80
tcp 192.168.1.102:49195 192.168.8.5:49195 2.22.109.171:80 2.22.109.171:80
icmp 192.168.1.102:0 192.168.8.10:1 8.8.8.8:1 8.8.8.8:0
tcp 192.168.1.102:49706 192.168.8.10:49706 23.62.98.64:80 23.62.98.64:80
tcp 192.168.1.102:49730 192.168.8.10:49730 23.62.98.64:80 23.62.98.64:80
tcp 192.168.1.102:49731 192.168.8.10:49731 23.62.98.8:80 23.62.98.8:80
tcp 192.168.1.102:49736 192.168.8.10:49736 23.62.98.8:80 23.62.98.8:80
tcp 192.168.1.102:49809 192.168.8.10:49809 173.223.11.177:80 173.223.11.177:80
tcp 192.168.1.102:49854 192.168.8.10:49854 13.107.4.50:80 13.107.4.50:80
tcp 192.168.1.102:49858 192.168.8.10:49858 23.62.98.8:80 23.62.98.8:80
tcp 192.168.1.102:49895 192.168.8.10:49895 13.107.4.50:80 13.107.4.50:80
tcp 192.168.1.102:49897 192.168.8.10:49897 13.107.4.50:80 13.107.4.50:80
tcp 192.168.1.102:49908 192.168.8.10:49908 40.77.229.91:443 40.77.229.91:443
tcp 192.168.1.102:49909 192.168.8.10:49909 40.77.229.17:443 40.77.229.17:443
tcp 192.168.1.102:49914 192.168.8.10:49914 40.77.229.10:443 40.77.229.10:443
tcp 192.168.1.102:49916 192.168.8.10:49916 40.77.226.250:443 40.77.226.250:443
tcp 192.168.1.102:49917 192.168.8.10:49917 92.123.166.179:443 92.123.166.179:443
udp 192.168.1.102:59225 192.168.8.10:59225 192.168.1.1:53 192.168.1.1:53
R1# show ip nat translations
Pro Inside global Inside local Outside local Outside global
tcp 192.168.1.102:49212 192.168.8.5:49212 151.101.194.49:80 151.101.194.49:80
R1# show ip nat statistics
Total active translations: 1 (0 static, 1 dynamic; 1 extended)
Outside interfaces:
FastEthernet0/1
Inside interfaces:
FastEthernet0/0
Hits: 180715 Misses: 431
CEF Translated packets: 179908, CEF Punted packets: 2474
Expired translations: 635
Dynamic mappings:
— Inside Source
[Id: 1] access-list 1 interface FastEthernet0/1 refcount 1
Appl doors: 0
Normal doors: 0
Queued Packets: 0
R1#

For Dynamic NAT configuration on the Cisco router, I recommend you read the topic called “How to Configure Dynamic NAT on Cisco Router?“.

How to Configure PAT NAT Overload on Cisco Router in GNS3? ⇒ Video

You can watch how to configure PAT NAT Overload on Cisco Router in GNS3 and you can also subscribe to our YouTube channel…

  Final Word

How to Configure PAT NAT Overload on Cisco Router in GNS3? – PAT configuration on the Cisco router is only commonly used for a network with a general IP address.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to the browser bookmarks by pressing the Ctrl+D to read this article later!

Articles Related to How to Configure PAT NAT Overload on Cisco Router in GNS3
Products Related to How to Configure PAT NAT Overload on Cisco Router in GNS3
Related Products

Leave a Reply

Your email address will not be published. Required fields are marked *

4 × 1 =