How to Configure NAT with Cisco SDM on Cisco Router? – The SDM installation on the Cisco Router provides web-based management of Cisco Routers. With Cisco SDM, simple and advanced settings can make on the Cisco Router. One of those is a NAT operation.
How to Configure NAT with Cisco SDM on Cisco Router?

How to Configure NAT with Cisco SDM on Cisco Router?

How to Configure NAT with Cisco SDM on Cisco Router?

We can connect the computers on the LAN to the Internet with the process to configure NAT with Cisco SDM on Cisco Router. NAT is a must in a network environment. Because, with the NAT operation, we can connect the private IP addresses on the network to the Internet. Private IP addresses are defined in RFC1918.

The private IP addresses on the LAN can be converted with NAT process to the real IP addresses when going out to the Internet. We will do this practice with the process to configure NAT with Cisco SDM on Cisco Router.

For static NAT configuration on the Cisco Router, you can read the topic called “How to Configure Static NAT on Cisco Router?“.

To configure NAT with Cisco SDM on Cisco Router, it is first necessary to install the Security Device Manager. To perform SDM installation on the Cisco Router, you can read the topic called “How to Install Cisco Security Device Manager (SDM)?“.

Download Cisco IOS Used to Configure NAT with Cisco SDM on Cisco Router

You can download Cisco IOS by clicking the below button.

 

Cisco Router SDM NAT Configuration

We can move on the Cisco Router SDM NAT configuration steps. In the Cisco Router SDM NAT configuration, we will use the GNS3 and VMware Workstation software. A virtual machine is sufficient for the VMware Workstation program and the GNS3 program. Configure the VMnet you created in the VMware Virtual Network Editor program as host-only.

For VMware integration with GNS3, you can read the topic called “How to Integrate VMware with GNS3?“.

   Step 1

For Cisco Router SDM NAT configuration, first, create a topology in the GNS3 program as shown in the following image.

How to Configure NAT with Cisco SDM on Cisco Router?

   Step 2

In the second steps the process to configure NAT with Cisco SDM on Cisco Router, you need to install the virtual machine on the VMware Workstation. After you install the SDM software on the Cisco Router, run Cisco SDM.

After you access the Cisco SDM program from the Internet browser, click on the Configure tab.

How to Configure NAT with Cisco SDM on Cisco Router?

   Step 3

Click on Configure on the Cisco SDM, and then click the NAT option in the left pane.

How to Configure NAT with Cisco SDM on Cisco Router?

   Step 4

On the Cisco Router SDM NAT configuration, select Simple NAT, and then click the Launch the selected task button.

How to Configure NAT with Cisco SDM on Cisco Router?

   Step 5

For Cisco Router SDM NAT configuration, click the Next button in the wizard window.

How to Configure NAT with Cisco SDM on Cisco Router?

   Step 6

In the Basic NAT Wizard window, the interface connected to the Internet must be selected. Because the Cisco Router NAT process includes the Inside Leg and the Outside Leg. Computers coming on the Inside leg should be set to Outside leg so that they will come out from the outside.

As you can see in the image below, click the down arrow to view the Cisco router interfaces.

How to Configure NAT with Cisco SDM on Cisco Router?

   Step 7

Select the interface connected to the Internet.

How to Configure NAT with Cisco SDM on Cisco Router?

   Step 8

After you select the FastEthernet0/1 interface, you need to select the IP address range.

How to Configure NAT with Cisco SDM on Cisco Router?

   Step 9

Cisco Router SDM NAT configuration has completed the necessary adjustments. Now click on the Next button to continue.

How to Configure NAT with Cisco SDM on Cisco Router?

   Step 10

Click the Finish button to apply the NAT configuration commands on the Cisco Router.

How to Configure NAT with Cisco SDM on Cisco Router?

   Step 11

The commands were successfully sent to the Cisco Router. Click the OK button to close the window.

How to Configure NAT with Cisco SDM on Cisco Router?

   Step 12

We have completed the process to configure NAT with Cisco SDM on Cisco Router. The setting made in the Cisco SDM program interface is visible.

How to Configure NAT with Cisco SDM on Cisco Router?

   Step 13

The ping operation from the Windows 8.1 virtual machine installed on VMware Workstation to Google DNS servers has completed successfully.

How to Configure NAT with Cisco SDM on Cisco Router?

   Step 14

Because the ping uses the ICMP protocol, when we display the NAT translations in the Cisco Router CLI console, NAT process is applied to the computer with 192.168.8.5 IP address.

To display NAT address translations, use the show ip nat translations command at the Cisco router prompt.

How to Configure NAT with Cisco SDM on Cisco Router?

   Step 15

If we provide access to the Google search engine from a Windows 8.1 virtual machine, let’s look at the NAT process on the Cisco Router.

How to Configure NAT with Cisco SDM on Cisco Router?

   Step 16

When we apply the show ip  nat translations command on the Cisco router, it is like below from the virtual machine to Google website access.

How to Configure NAT with Cisco SDM on Cisco Router?

   Step 17

Finally, when I run the show ip nat statistics command, we can see the number of the converted entries.

How to Configure NAT with Cisco SDM on Cisco Router?

For DHCP configuration on the Cisco router, you can read the topic called “How to Configure DHCP on Cisco Router?“.

Show Commands for Configure NAT with Cisco SDM on Cisco Router

R1#show running-configR1#show ip nat statisticsR1#show ip nat translations

R1#show running-config
Building configuration…

Current configuration : 1449 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
crypto pki trustpoint TP-self-signed-4279256517
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4279256517
revocation-check none
rsakeypair TP-self-signed-4279256517
!
!
username ciscosdm privilege 15 secret 5 $1$P8AQ$58kw7DHT7YUj3far7KDoM.
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
!
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.8.0 0.0.0.255
no cdp log mismatch duplex
!
!
!
control-plane
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login local
transport input telnet
!
!
end
R1#

R1#show ip nat statistics
Total active translations: 85 (0 static, 85 dynamic; 85 extended)
Outside interfaces:
FastEthernet0/1
Inside interfaces:
FastEthernet0/0
Hits: 2977 Misses: 94
CEF Translated packets: 2921, CEF Punted packets: 297
Expired translations: 62
Dynamic mappings:
— Inside Source
[Id: 1] access-list 1 interface FastEthernet0/1 refcount 85
Appl doors: 0
Normal doors: 0
Queued Packets: 0
R1#

R1#show ip nat translations
Pro Inside global Inside local Outside local Outside global
udp 192.168.1.101:49225 192.168.8.5:49225 192.168.1.1:53 192.168.1.1:53
udp 192.168.1.101:49701 192.168.8.5:49701 192.168.1.1:53 192.168.1.1:53
tcp 192.168.1.101:49750 192.168.8.5:49750 23.198.21.99:80 23.198.21.99:80
tcp 192.168.1.101:49751 192.168.8.5:49751 204.79.197.203:80 204.79.197.203:80
tcp 192.168.1.101:49753 192.168.8.5:49753 204.79.197.203:80 204.79.197.203:80
tcp 192.168.1.101:49754 192.168.8.5:49754 151.101.193.108:80 151.101.193.108:80
tcp 192.168.1.101:49755 192.168.8.5:49755 13.107.5.80:80 13.107.5.80:80
tcp 192.168.1.101:49756 192.168.8.5:49756 13.107.5.80:80 13.107.5.80:80
tcp 192.168.1.101:49757 192.168.8.5:49757 195.175.112.105:80 195.175.112.105:80
tcp 192.168.1.101:49758 192.168.8.5:49758 195.175.112.105:80 195.175.112.105:80
tcp 192.168.1.101:49759 192.168.8.5:49759 195.175.112.105:80 195.175.112.105:80
tcp 192.168.1.101:49760 192.168.8.5:49760 195.175.112.105:80 195.175.112.105:80
tcp 192.168.1.101:49761 192.168.8.5:49761 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.101:49762 192.168.8.5:49762 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.101:49763 192.168.8.5:49763 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.101:49764 192.168.8.5:49764 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.101:49765 192.168.8.5:49765 2.17.23.122:80 2.17.23.122:80

Configure NAT with Cisco SDM on Cisco Router ⇒ Video

  Final Word

How to Configure NAT with Cisco SDM on Cisco Router? – We have completed the Cisco Router SDM NAT configuration process. This process can be done in more advanced settings with the basics. We can also perform NAT on the Cisco router from the CLI console.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to the browser bookmarks by pressing the Ctrl+D to read this article later!

Articles Related to Configure NAT with Cisco SDM on Cisco Router;


Products Related to Configure NAT with Cisco SDM on Cisco Router;

Leave a Reply

Your email address will not be published. Required fields are marked *

fifteen − twelve =