How to Configure EIGRP on Cisco Router in GNS3? – EIGRP is a routing protocol specific to Cisco devices. EIGRP sends routing packets when occurs a change in the network.
How to Configure EIGRP on Cisco Router in GNS3?

How to Configure EIGRP on Cisco Router in GNS3?

How to Configure EIGRP on Cisco Router in GNS3?

The EIGRP routing protocol is not available on non-Cisco devices. EIGRP is only used on Cisco-branded network devices. The EIGRP routing protocol broadcasts Multicast (224.0.0.10). Before configuring EIGRP on Cisco Routers, enable it in config mode using the Router EIGRP (AS Number) command.

In our previous article, we provided information about the EIGRP protocol. In this article, we will configure EIGRP on Cisco Router in GNS3.

Our Recommendation

You can purchase “Cisco Router Configuration Guide” from Amazon.

How to Configure EIGRP in GNS3?

Before configuring EIGRP on Cisco Router in GNS3, perform the VMware Workstation virtual machine integration process with GNS3. Then provide the processes to configure EIGRP in GNS3 by following the steps below.

   Step 1

Open the GNS3 program and create a new project.

How to Configure EIGRP on Cisco Router in GNS3?

   Step 2

For GNS3 Cisco Router EIGRP configuration, create a network topology as shown in the following image. Then run Cisco Routers and open CLI command prompts.

How to Configure EIGRP on Cisco Router in GNS3?

   Step 3

Configure the Cisco Router R1 interfaces. You can apply the following commands.

[code] R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
*Mar 1 00:00:43.715: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:00:44.715: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config)#
R1(config)#interface serial 0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#end
R1#
[/code]

How to Configure EIGRP on Cisco Router in GNS3?

   Step 4

Also, configure Cisco Router R2 interfaces in the same way.

[code] R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#interface fastethernet 0/1
R2(config-if)#ip address 192.168.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#
*Mar 1 00:02:07.995: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Mar 1 00:02:08.995: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R2(config)#
R2(config)#interface serial 0/1
R2(config-if)#ip address 10.1.1.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#end
R2#
[/code]

How to Configure EIGRP on Cisco Router in GNS3?

   Step 5

After you have integrated VMware virtual machines in GNS3, you need to configure the virtual machine VMnet settings. Select VMnet1 as the network card of the Windows 8.1 virtual machine and run the virtual machine.

How to Configure EIGRP on Cisco Router in GNS3?

   Step 6

Windows 10 virtual machine network card is defined as VMnet2. Afterward, run the Windows 10 virtual machine.

How to Configure EIGRP on Cisco Router in GNS3?

   Step 7

After configuring the Windows 8.1 virtual machine TCP/IP settings, test the connection by pinging the Cisco Router FastEthernet 0/0 and Serial 0/0 interfaces.

Also, before configuring EIGRP, check the connection by pinging Router R2 interfaces. Ping will fail as shown below.

How to Configure EIGRP on Cisco Router in GNS3?

   Step 8

Do the same on the Windows 10 virtual machine.

How to Configure EIGRP on Cisco Router in GNS3?

   Step 9

We can now move on to configure EIGRP on Cisco Router in GNS3. To communicate two different networks with the EIGRP routing protocol, open the Cisco Router R1 CLI command prompt and execute the following commands.

Pay attention to that the Wild Card Mask is used when defining networks in the EIGRP protocol.

[code] R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#
R1(config)#router eigrp 1
R1(config-router)#network 10.1.1.0 ?
A.B.C.D EIGRP wild card bits
<cr>
R1(config-router)#network 10.1.1.0 0.0.0.3
R1(config-router)#network 192.168.5.0 0.0.0.255
R1(config-router)#end
R1#
[/code]

How to Configure EIGRP on Cisco Router in GNS3?

   Step 10

At the Cisco Router R2 CLI command prompt, execute the following commands.

[code] R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#
R2(config)#router eigrp 1
R2(config-router)#network 10.1.1.0 0.0.0.3
R2(config-router)#network 192.
*Mar 1 00:26:14.107: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.1.1 (Serial0/1) is up: new adjacency
R2(config-router)#network 192.168.10.0 0.0.0.255
R2(config-router)#end
R2#
[/code]

How to Configure EIGRP on Cisco Router in GNS3?

   Step 11

Run the show ip route command on Cisco Router R1 and see that the EIGRP Routing protocol has identified.

How to Configure EIGRP on Cisco Router in GNS3?

   Step 12

The show ip route command on Cisco Router R2 is as follows.

How to Configure EIGRP on Cisco Router in GNS3?

   Step 13

After configuring EIGRP on Cisco Router in GNS3, come back to the virtual machine, perform the ping operation and test the connection between the two networks.

How to Configure EIGRP on Cisco Router in GNS3?

   Step 14

Pinging from Windows 10 virtual machine will succeed as follows.

How to Configure EIGRP on Cisco Router in GNS3?

   Step 15

If we are going to examine the EIGRP Show commands, the Show commands on Cisco Router R1 are as follows.

How to Configure EIGRP on Cisco Router in GNS3?

   Step 16

Likewise, the Show command output on Cisco Router R2 is as follows.

How to Configure EIGRP on Cisco Router in GNS3?

   Step 17

To verify the EIGRP configuration on the Cisco Router, you can use the debug eigrp packets command.

How to Configure EIGRP on Cisco Router in GNS3?

   Step 18

Run the same command on Router R2. You can see the Hello packets of the EIGRP routing protocol on Cisco Routers.

How to Configure EIGRP on Cisco Router in GNS3?

   Step 19

Another way to verify the EIGRP configuration is to use the Wireshark program. On the serial cable that connects the Cisco routers, click the Right Button / Start Capture option.

How to Configure EIGRP on Cisco Router in GNS3?

   Step 20

Click on the OK button in the Packet Capture window.

How to Configure EIGRP on Cisco Router in GNS3?

   Step 21

The Wireshark program will open as soon as you press the OK button. You can see EIGRP packages on Wireshark. You can see that EIGRP hello packages are sent via 224.0.0.10 Multicast address.

How to Configure EIGRP on Cisco Router in GNS3?

Show Commands Related to How to Configure EIGRP on Cisco Router in GNS3

R1#show ip routeR2#show ip routeR1#debug eigrp packetsR2#debug eigrp packetsR1#show running-configR2#show running-config
R1#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

D 192.168.10.0/24 [90/2195456] via 10.1.1.2, 00:00:47, Serial0/0
C 192.168.5.0/24 is directly connected, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/0
D 10.0.0.0/8 is a summary, 00:01:48, Null0
R1#

R2#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

C 192.168.10.0/24 is directly connected, FastEthernet0/1
D 192.168.5.0/24 [90/2195456] via 10.1.1.1, 00:01:28, Serial0/1
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial0/1
D 10.0.0.0/8 is a summary, 00:01:20, Null0
R2#

R1#debug eigrp packets
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, SIAREPLY)
R1#
*Mar 1 00:40:53.527: EIGRP: Received HELLO on Serial0/0 nbr 10.1.1.2
*Mar 1 00:40:53.531: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
R1#
*Mar 1 00:40:55.623: EIGRP: Sending HELLO on Serial0/0
*Mar 1 00:40:55.623: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Mar 1 00:40:55.987: EIGRP: Sending HELLO on FastEthernet0/0
*Mar 1 00:40:55.987: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R1#
*Mar 1 00:40:58.299: EIGRP: Received HELLO on Serial0/0 nbr 10.1.1.2
*Mar 1 00:40:58.303: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
R1#
*Mar 1 00:41:00.439: EIGRP: Sending HELLO on Serial0/0
*Mar 1 00:41:00.439: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Mar 1 00:41:00.651: EIGRP: Sending HELLO on FastEthernet0/0
*Mar 1 00:41:00.651: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R1#
*Mar 1 00:41:02.979: EIGRP: Received HELLO on Serial0/0 nbr 10.1.1.2
*Mar 1 00:41:02.983: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
R1#
R2#debug eigrp packets
EIGRP Packets debugging is on
(UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, SIAQUERY, SIAREPLY)
R2#
*Mar 1 00:41:30.323: EIGRP: Received HELLO on Serial0/1 nbr 10.1.1.1
*Mar 1 00:41:30.323: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
R2#
*Mar 1 00:41:31.767: EIGRP: Sending HELLO on Serial0/1
*Mar 1 00:41:31.767: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R2#
*Mar 1 00:41:33.027: EIGRP: Sending HELLO on FastEthernet0/1
*Mar 1 00:41:33.027: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R2#
*Mar 1 00:41:35.619: EIGRP: Received HELLO on Serial0/1 nbr 10.1.1.1
*Mar 1 00:41:35.623: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
*Mar 1 00:41:36.551: EIGRP: Sending HELLO on Serial0/1
*Mar 1 00:41:36.551: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R2#
R1#show running-config
Building configuration…

Current configuration : 1119 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router eigrp 1
network 10.1.1.0 0.0.0.3
network 192.168.5.0
auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#

R2#show running-config
Building configuration…

Current configuration : 1121 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.1.2 255.255.255.252
clock rate 2000000
!
router eigrp 1
network 10.1.1.0 0.0.0.3
network 192.168.10.0
auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R2#

How to Configure EIGRP on Cisco Router in GNS3? ⇒ Video

You can watch how to configure EIGRP on Cisco Router in GNS3 and you can also subscribe to our YouTube channel…

  Final Word

How to Configure EIGRP on Cisco Router in GNS3? – In this article, we have communicated two different networks using the Cisco EIGRP routing protocol. When configuring EIGRP, you must configure the Wild Card Mask address correctly when using the network command.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to browser bookmarks by pressing the CTRL+D to read this article later!

Articles Related to How to Configure EIGRP on Cisco Router in GNS3

Articles Related to How to Configure EIGRP on Cisco Router in GNS3
Related Products

File Related to How to Configure EIGRP on Cisco Router in GNS3
Related File

You can download the GNS3 project that is configured in this article from your computer at the following …

Leave a Reply

Your email address will not be published. Required fields are marked *

4 × one =