How to Configure Dynamic NAT on Cisco Router in GNS3? – We have done the Cisco Router Static NAT configuration before. In the router, dynamic NAT configuration is to use the IP address from the IP address pool of the computers that are going to the Internet via LAN.
How to Configure Dynamic NAT on Cisco Router in GNS3?

How to Configure Dynamic NAT on Cisco Router in GNS3?

How to Configure Dynamic NAT on Cisco Router in GNS3?

In our previous articles, we have given detailed information about NAT. In this article, we will perform Dynamic NAT configuration on Cisco routers using GNS3.

You can also download the Cisco Router IOS image that is used in this article to your computer from the link under the article.

How to Configure Dynamic NAT in GNS3?

We can now go through the Cisco Router Dynamic NAT configuration steps. An access-list needs to be created first for dynamic NAT. After creating the Ip pool with the ip nat pool command, by giving access to the private IP block used on the LAN with access-list, then it is necessary to write the IP address addresses assigned by the Internet Service Provider.

In the process to configure Dynamic NAT on Cisco Router uses VMware Workstation and the GNS3 program. VMnet Workstation Create a VMnet with the Virtual Network Editor program. Then, enter the Ip block of the VMnet you created.

The most important part of the process to configure Dynamic NAT on Cisco Router is that we need to bring our computer to the Internet with an Ethernet port. Because, as we mentioned earlier, GNS3 will give an error when the connection is made from the Wifi card in the program.

Our Recommendation

You can purchase “Cisco CCNA Networking for Beginners” from Amazon.

   Step 1

We can now pass the steps to configure Dynamic NAT on Cisco Router in GNS3. First, run the GNS3 program and create a new project.

How to Configure Dynamic NAT on Cisco Router in GNS3?

   Step 2

Create the topology as shown below. You can also create a different topology for the process to configure Dynamic NAT on Cisco Router Dynamic.

How to Configure Dynamic NAT on Cisco Router in GNS3?

   Step 3

After adding a Cloud to the GNS3 workspace, select and add Ethernet, which is the physical connection of your computer in the Cloud configuration. This is the most important step in the process to configure Dynamic NAT on Cisco Router. If you choose a WiFi card, you can not remove the virtual machines to the Internet.

How to Configure Dynamic NAT on Cisco Router in GNS3?

   Step 4

After running the Router, open the CLI command console and execute the following commands, respectively.

Required commands to configure Dynamic NAT on Cisco Router.

R1# conf t
R1(config)# interface fastethernet0/0
R1(config-if)# ip address 192.168.8.1 255.255.255.0
R1(config-if)# ip nat inside
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)#interface fastethernet0/1
R1(config-if)# ip address dhcp
R1(config-if)# ip nat outside
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# access-list 1 permit 192.168.8.0 0.0.0.255
R1(config)# ip nat pool DYNAMICNAT 192.168.1.20 192.168.1.25 netmask 255.255.255.0
R1(config)# ip nat inside source list 1 pool DYNAMICNAT
R1(config)# exit
R1# copy running-config startup-config

With the Access-list we let the network go out to the Internet. Then, we specified the IP address range allocated by the Internet Service Provider with ip nat pool command. Computers on the LAN will access to the Internet with the IP addresses created in this pool.

In the Dynamic NAT configuration, the only difference from Static NAT configuration is to create an IP address pool and to specify the IP addresses in this pool in the ip nat command.

How to Configure Dynamic NAT on Cisco Router in GNS3?

   Step 5

After the step 4 to configure Dynamic NAT on Cisco Router, let’s ping the Router’s FastEthernet0/0 interface from the Windows 8.1 virtual machine.

How to Configure Dynamic NAT on Cisco Router in GNS3?

   Step 6

Let’s ping the FastEthetnet0/0 interface of the Router from the Windows 10 virtual machine.

How to Configure Dynamic NAT on Cisco Router in GNS3?

   Step 7

Let’s test the show ip interface brief command to see if the Cisco router interfaces are open.

How to Configure Dynamic NAT on Cisco Router in GNS3?

   Step 8

When pinging Google DNS servers from the Cisco router, ICMP packets are successfully forwarded.

How to Configure Dynamic NAT on Cisco Router in GNS3?

   Step 9

The Windows 8.1 virtual machine is successfully pinging Google DNS servers.

How to Configure Dynamic NAT on Cisco Router in GNS3?

   Step 10

Windows 10 virtual machines are successfully pinging Google DNS servers.

How to Configure Dynamic NAT on Cisco Router in GNS3?

   Step 11

When we have returned to the Cisco Router CLI console, we can see below that the 192.168.8.5 and 192.168.8.10 Ip addresses are converted to public IP addresses according to the NAT process when we apply for the show ip nat translation command.

Virtual machines used the 192.168.1.20 and 192.168.1.21 IP addresses idled in the NAT pool.

How to Configure Dynamic NAT on Cisco Router in GNS3?

   Step 12

In the Cisco router CLI console, we can see the transient packet numbers when we apply the show ip nat statistics command.

How to Configure Dynamic NAT on Cisco Router in GNS3?

Show Commands Related to How to Configure Dynamic NAT on Cisco Router in GNS3

R1#show running-configR1#show ip nat statisticsR1#show ip nat translations
R1#show running-config
Building configuration…

Current configuration : 1175 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address 192.168.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip nat pool DYNAMICNAT 192.168.1.20 192.168.1.25 netmask 255.255.255.0
ip nat inside source list 1 pool DYNAMICNAT
!
access-list 1 permit 192.168.8.0 0.0.0.255
no cdp log mismatch duplex
!
!
!
control-plane
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#

R1#show ip nat statistics
Total active translations: 134 (0 static, 134 dynamic; 132 extended)
Outside interfaces:
FastEthernet0/1
Inside interfaces:
FastEthernet0/0
Hits: 17148 Misses: 402
CEF Translated packets: 17183, CEF Punted packets: 731
Expired translations: 165
Dynamic mappings:
— Inside Source
[Id: 2] access-list 1 pool DYNAMICNAT refcount 134
pool DYNAMICNAT: netmask 255.255.255.0
start 192.168.1.20 end 192.168.1.25
type generic, total addresses 6, allocated 2 (33%), misses 0
— Outside Destination
[Id: 1] access-list 1 pool 1 refcount 0
Appl doors: 0
Normal doors: 0
Queued Packets: 0
R1#

R1#show ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 192.168.1.21:1 192.168.8.5:1 8.8.8.8:1 8.8.8.8:1
tcp 192.168.1.21:49159 192.168.8.5:49159 2.17.229.218:80 2.17.229.218:80
tcp 192.168.1.21:49161 192.168.8.5:49161 195.175.116.65:80 195.175.116.65:80
tcp 192.168.1.21:49162 192.168.8.5:49162 195.175.116.65:80 195.175.116.65:80
tcp 192.168.1.21:49163 192.168.8.5:49163 151.101.193.108:80 151.101.193.108:80
tcp 192.168.1.21:49164 192.168.8.5:49164 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.21:49165 192.168.8.5:49165 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.21:49166 192.168.8.5:49166 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.21:49167 192.168.8.5:49167 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.21:49168 192.168.8.5:49168 104.40.210.32:80 104.40.210.32:80
tcp 192.168.1.21:49169 192.168.8.5:49169 173.223.10.201:80 173.223.10.201:80
tcp 192.168.1.21:49170 192.168.8.5:49170 37.252.172.42:80 37.252.172.42:80
tcp 192.168.1.21:49176 192.168.8.5:49176 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.21:49177 192.168.8.5:49177 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.21:49181 192.168.8.5:49181 37.252.172.70:80 37.252.172.70:80
tcp 192.168.1.21:49183 192.168.8.5:49183 152.115.75.199:80 152.115.75.199:80
tcp 192.168.1.21:49184 192.168.8.5:49184 152.115.75.199:80 152.115.75.199:80
tcp 192.168.1.21:49185 192.168.8.5:49185 151.101.192.249:80 151.101.192.249:80
tcp 192.168.1.21:49186 192.168.8.5:49186 79.125.113.96:80 79.125.113.96:80
tcp 192.168.1.21:49187 192.168.8.5:49187 37.157.2.30:80 37.157.2.30:80
tcp 192.168.1.21:49188 192.168.8.5:49188 37.157.2.30:80 37.157.2.30:80
tcp 192.168.1.21:49189 192.168.8.5:49189 23.23.101.79:80 23.23.101.79:80
Pro Inside global Inside local Outside local Outside global
tcp 192.168.1.21:49190 192.168.8.5:49190 104.40.210.32:80 104.40.210.32:80
tcp 192.168.1.21:49191 192.168.8.5:49191 104.40.210.32:80 104.40.210.32:80
tcp 192.168.1.21:49192 192.168.8.5:49192 104.40.210.32:80 104.40.210.32:80
tcp 192.168.1.21:49193 192.168.8.5:49193 54.246.116.186:443 54.246.116.186:443
tcp 192.168.1.21:49194 192.168.8.5:49194 152.115.75.199:80 152.115.75.199:80
tcp 192.168.1.21:49195 192.168.8.5:49195 2.22.128.84:80 2.22.128.84:80
tcp 192.168.1.21:49196 192.168.8.5:49196 104.40.210.32:80 104.40.210.32:80
tcp 192.168.1.21:49197 192.168.8.5:49197 152.115.75.199:80 152.115.75.199:80
tcp 192.168.1.21:49198 192.168.8.5:49198 195.175.116.58:80 195.175.116.58:80
tcp 192.168.1.21:49199 192.168.8.5:49199 195.175.116.58:80 195.175.116.58:80
tcp 192.168.1.21:49200 192.168.8.5:49200 195.175.116.58:80 195.175.116.58:80
tcp 192.168.1.21:49201 192.168.8.5:49201 37.157.2.30:80 37.157.2.30:80
tcp 192.168.1.21:49202 192.168.8.5:49202 37.252.172.70:80 37.252.172.70:80
tcp 192.168.1.21:49204 192.168.8.5:49204 37.252.172.42:443 37.252.172.42:443
tcp 192.168.1.21:49205 192.168.8.5:49205 37.252.172.42:443 37.252.172.42:443
tcp 192.168.1.21:49208 192.168.8.5:49208 216.58.208.98:80 216.58.208.98:80
tcp 192.168.1.21:49209 192.168.8.5:49209 216.58.208.98:80 216.58.208.98:80
tcp 192.168.1.21:49210 192.168.8.5:49210 54.93.210.130:80 54.93.210.130:80
tcp 192.168.1.21:49211 192.168.8.5:49211 216.58.208.98:80 216.58.208.98:80
tcp 192.168.1.21:49212 192.168.8.5:49212 54.93.210.130:80 54.93.210.130:80
tcp 192.168.1.21:49213 192.168.8.5:49213 37.252.172.42:443 37.252.172.42:443
tcp 192.168.1.21:49214 192.168.8.5:49214 207.46.194.10:80 207.46.194.10:80
Pro Inside global Inside local Outside local Outside global
tcp 192.168.1.21:49215 192.168.8.5:49215 54.93.210.130:80 54.93.210.130:80
tcp 192.168.1.21:49216 192.168.8.5:49216 193.0.160.207:80 193.0.160.207:80
tcp 192.168.1.21:49217 192.168.8.5:49217 193.0.160.207:80 193.0.160.207:80
tcp 192.168.1.21:49218 192.168.8.5:49218 193.0.160.207:80 193.0.160.207:80
tcp 192.168.1.21:49222 192.168.8.5:49222 54.251.40.111:80 54.251.40.111:80
tcp 192.168.1.21:49223 192.168.8.5:49223 54.251.40.111:80 54.251.40.111:80
tcp 192.168.1.21:49224 192.168.8.5:49224 54.251.40.111:80 54.251.40.111:80
tcp 192.168.1.21:49225 192.168.8.5:49225 213.19.162.80:80 213.19.162.80:80
tcp 192.168.1.21:49226 192.168.8.5:49226 213.19.162.80:80 213.19.162.80:80
tcp 192.168.1.21:49227 192.168.8.5:49227 213.19.162.80:80 213.19.162.80:80
tcp 192.168.1.21:49228 192.168.8.5:49228 185.29.133.52:80 185.29.133.52:80
tcp 192.168.1.21:49229 192.168.8.5:49229 185.29.133.52:80 185.29.133.52:80
tcp 192.168.1.21:49230 192.168.8.5:49230 185.29.133.52:80 185.29.133.52:80
tcp 192.168.1.21:49232 192.168.8.5:49232 104.86.253.50:80 104.86.253.50:80
tcp 192.168.1.21:49233 192.168.8.5:49233 104.86.253.50:80 104.86.253.50:80
tcp 192.168.1.21:49234 192.168.8.5:49234 185.33.222.62:80 185.33.222.62:80
tcp 192.168.1.21:49236 192.168.8.5:49236 185.33.222.62:80 185.33.222.62:80
tcp 192.168.1.21:49237 192.168.8.5:49237 173.223.11.169:80 173.223.11.169:80
tcp 192.168.1.21:49238 192.168.8.5:49238 173.223.11.169:80 173.223.11.169:80
tcp 192.168.1.21:49239 192.168.8.5:49239 54.251.40.111:80 54.251.40.111:80
tcp 192.168.1.21:49240 192.168.8.5:49240 185.33.222.62:80 185.33.222.62:80
tcp 192.168.1.21:49243 192.168.8.5:49243 80.231.241.51:80 80.231.241.51:80
Pro Inside global Inside local Outside local Outside global
tcp 192.168.1.21:49244 192.168.8.5:49244 80.231.241.51:80 80.231.241.51:80
tcp 192.168.1.21:49245 192.168.8.5:49245 104.86.244.241:80 104.86.244.241:80
tcp 192.168.1.21:49247 192.168.8.5:49247 54.251.40.111:80 54.251.40.111:80
tcp 192.168.1.21:49248 192.168.8.5:49248 54.251.40.111:80 54.251.40.111:80
tcp 192.168.1.21:49249 192.168.8.5:49249 104.86.244.241:80 104.86.244.241:80
tcp 192.168.1.21:49250 192.168.8.5:49250 104.86.244.241:80 104.86.244.241:80
tcp 192.168.1.21:49251 192.168.8.5:49251 104.86.244.241:80 104.86.244.241:80
tcp 192.168.1.21:49252 192.168.8.5:49252 104.86.244.241:80 104.86.244.241:80
tcp 192.168.1.21:49254 192.168.8.5:49254 37.252.172.42:80 37.252.172.42:80
tcp 192.168.1.21:49255 192.168.8.5:49255 37.252.172.42:80 37.252.172.42:80
tcp 192.168.1.21:49256 192.168.8.5:49256 195.175.116.72:80 195.175.116.72:80
tcp 192.168.1.21:49258 192.168.8.5:49258 216.58.209.4:80 216.58.209.4:80
tcp 192.168.1.21:49259 192.168.8.5:49259 216.58.209.4:80 216.58.209.4:80
tcp 192.168.1.21:49260 192.168.8.5:49260 52.201.128.6:80 52.201.128.6:80
tcp 192.168.1.21:49261 192.168.8.5:49261 152.115.75.199:80 152.115.75.199:80
tcp 192.168.1.21:49262 192.168.8.5:49262 152.115.75.199:80 152.115.75.199:80
tcp 192.168.1.21:49265 192.168.8.5:49265 172.217.17.163:80 172.217.17.163:80
tcp 192.168.1.21:49266 192.168.8.5:49266 172.217.17.163:80 172.217.17.163:80
tcp 192.168.1.21:49267 192.168.8.5:49267 172.217.17.163:443 172.217.17.163:443
tcp 192.168.1.21:49268 192.168.8.5:49268 185.33.222.16:443 185.33.222.16:443
tcp 192.168.1.21:49269 192.168.8.5:49269 23.55.149.163:80 23.55.149.163:80
tcp 192.168.1.21:49273 192.168.8.5:49273 216.58.209.14:80 216.58.209.14:80
Pro Inside global Inside local Outside local Outside global
tcp 192.168.1.21:49274 192.168.8.5:49274 54.247.73.98:443 54.247.73.98:443
tcp 192.168.1.21:49275 192.168.8.5:49275 104.86.225.240:80 104.86.225.240:80
tcp 192.168.1.21:49276 192.168.8.5:49276 93.184.221.200:443 93.184.221.200:443
tcp 192.168.1.21:49277 192.168.8.5:49277 93.184.221.200:443 93.184.221.200:443
tcp 192.168.1.21:49278 192.168.8.5:49278 93.184.221.200:443 93.184.221.200:443
tcp 192.168.1.21:49279 192.168.8.5:49279 172.217.17.163:443 172.217.17.163:443
tcp 192.168.1.21:49280 192.168.8.5:49280 172.217.17.163:443 172.217.17.163:443
tcp 192.168.1.21:49281 192.168.8.5:49281 216.58.209.3:443 216.58.209.3:443
tcp 192.168.1.21:49283 192.168.8.5:49283 172.217.17.163:443 172.217.17.163:443
tcp 192.168.1.21:49287 192.168.8.5:49287 172.217.17.163:443 172.217.17.163:443
tcp 192.168.1.21:49294 192.168.8.5:49294 13.107.5.80:80 13.107.5.80:80
tcp 192.168.1.21:49295 192.168.8.5:49295 13.107.5.80:80 13.107.5.80:80
tcp 192.168.1.21:49300 192.168.8.5:49300 31.13.92.36:80 31.13.92.36:80
tcp 192.168.1.21:49301 192.168.8.5:49301 31.13.92.36:80 31.13.92.36:80
tcp 192.168.1.21:49302 192.168.8.5:49302 31.13.92.36:443 31.13.92.36:443
tcp 192.168.1.21:49304 192.168.8.5:49304 31.13.93.7:443 31.13.93.7:443
tcp 192.168.1.21:49305 192.168.8.5:49305 31.13.93.7:443 31.13.93.7:443
tcp 192.168.1.21:49306 192.168.8.5:49306 31.13.93.7:443 31.13.93.7:443
tcp 192.168.1.21:49307 192.168.8.5:49307 31.13.93.7:443 31.13.93.7:443
tcp 192.168.1.21:49308 192.168.8.5:49308 31.13.93.7:443 31.13.93.7:443
tcp 192.168.1.21:49309 192.168.8.5:49309 31.13.93.7:443 31.13.93.7:443
tcp 192.168.1.21:49310 192.168.8.5:49310 31.13.93.7:443 31.13.93.7:443
Pro Inside global Inside local Outside local Outside global
tcp 192.168.1.21:49311 192.168.8.5:49311 31.13.93.7:443 31.13.93.7:443
tcp 192.168.1.21:49312 192.168.8.5:49312 31.13.93.7:443 31.13.93.7:443
tcp 192.168.1.21:49313 192.168.8.5:49313 31.13.93.7:443 31.13.93.7:443
tcp 192.168.1.21:49314 192.168.8.5:49314 31.13.93.10:443 31.13.93.10:443
tcp 192.168.1.21:49315 192.168.8.5:49315 31.13.93.10:443 31.13.93.10:443
tcp 192.168.1.21:49316 192.168.8.5:49316 31.13.92.14:443 31.13.92.14:443
tcp 192.168.1.21:49317 192.168.8.5:49317 31.13.92.14:443 31.13.92.14:443
tcp 192.168.1.21:49318 192.168.8.5:49318 31.13.92.36:443 31.13.92.36:443
tcp 192.168.1.21:49320 192.168.8.5:49320 204.79.197.200:443 204.79.197.200:443
— 192.168.1.21 192.168.8.5 — —
icmp 192.168.1.20:1 192.168.8.10:1 8.8.8.8:1 8.8.8.8:1
tcp 192.168.1.20:49712 192.168.8.10:49712 204.79.197.203:443 204.79.197.203:443
tcp 192.168.1.20:49713 192.168.8.10:49713 204.79.197.203:443 204.79.197.203:443
tcp 192.168.1.20:49742 192.168.8.10:49742 31.13.93.36:443 31.13.93.36:443
tcp 192.168.1.20:49743 192.168.8.10:49743 31.13.92.2:443 31.13.92.2:443
tcp 192.168.1.20:49745 192.168.8.10:49745 31.13.92.14:443 31.13.92.14:443
tcp 192.168.1.20:49746 192.168.8.10:49746 31.13.92.14:443 31.13.92.14:443
tcp 192.168.1.20:49753 192.168.8.10:49753 40.77.226.250:443 40.77.226.250:443
— 192.168.1.20 192.168.8.10 — —

How to Configure Dynamic NAT on Cisco Router in GNS3? ⇒ Video

You can watch the steps to configure Dynamic NAT on Cisco Router in GNS3 as video. Also, subscribe to our YouTube channel…

  Final Word

How to Configure Dynamic NAT on Cisco Router in GNS3? – The processes to configure Dynamic NAT on Cisco Router only work with the pool system according to Static NAT. With GNS3 and VMware Workstation you can easily perform and implement these operations.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to the browser bookmarks by pressing the Ctrl+D to read this article later!

Related Articles to How to Configure Dynamic NAT on Cisco Router in GNS3

Products Related to How to Configure Dynamic NAT on Cisco Router in GNS3
Related Products

File Related to How to Configure Dynamic NAT on Cisco Router in GNS3
Related File
You can also download the Cisco Router IOS image that is used in this article to your computer from the link under the article…

Leave a Reply

Your email address will not be published. Required fields are marked *