How to Configure Cloud in GNS3? – The best way to use VMware or VirtualBox virtual machines in GNS3 is to use the Cloud structure.
How to Configure Cloud in GNS3?

How to Configure Cloud in GNS3?

How to Configure Cloud in GNS3?

With the continuous updating of the GNS3 program, the program becomes easier to use. By using virtual machines in GNS3 we can create a more realistic network design. With the release of GNS3 2.0.2, we can easily integrate VMware virtual machines into GNS3 with the new Cloud Nodes.

The steps to configure Cloud in GNS3 are slightly different in the new version. But the GNS3 Cloud settings are easy and simple. In this article, we will add Cloud virtual computers to our network topology using GNS3 and VMware Workstation programs.

In the old version of GNS3, there was a Host option in the Tools section. And we were setting up VMware connectivity with GNS3 from this Host option. With GNS3 version 2.0.2, we can integrate virtual machines more easily by coming to Cloud option.

Our Recommendation

You can purchase “The Book of GNS3” from Amazon.

How to Connect VMware Virtual Machines to GNS3?

To connect VMware Virtual Machines to GNS3, firstly, create two virtual machines in VMware Workstation. It doesn’t matter the version of operating systems that you will install for GNS3.

Follow the GNS3 Cloud configuration steps in order.

   Step 1

First open the GNS3 program and create a new project.

How to Configure Cloud in GNS3?

   Step 2

Click on the GNS3 Edit menu.

How to Configure Cloud in GNS3?

   Step 3

From the Edit menu, click Preferences.

How to Configure Cloud in GNS3?

   Step 4

As in the image below, the GNS3 Cloud configuration window will open. Then in this window, click on GNS3 Cloud Nodes for GNS3 Cloud settings.

In the Cloud node templates window, click the New button to create a Cloud template.

How to Configure Cloud in GNS3?

   Step 5

You can enter the virtual machine operating system name because of the Cloud node will be related to the virtual machines.

How to Configure Cloud in GNS3?

   Step 6

After you type the name of the VMware virtual machine operating system, click Finish.

How to Configure Cloud in GNS3?

   Step 7

GNS3 Cloud configuration process is not complete. Click on the Edit button to continue.

How to Configure Cloud in GNS3?

   Step 8

In the following screen, we need to add an Ethernet interface created in our physical computer for Cloud. To see the VMnets you have created in the VMware Virtual Network Editor program on this screen, you need to check the option below.

Click Show special Ethernet interfaces.

How to Configure Cloud in GNS3?

   Step 9

Click the down arrow to select VMnet.

How to Configure Cloud in GNS3?

   Step 10

Select VMware VMnet1 and click the Add button.

How to Configure Cloud in GNS3?

   Step 11

Since VMware Windows 8.1 virtual machine is defined in VMnet1, we chose VMnet1 in this step. It’s completed the process to configure Cloud in GNS3. But the last thing left is to change the Cloud symbol.

Click on the Misc tab to continue.

How to Configure Cloud in GNS3?

   Step 12

Click the Browse button to change the GNS3 Cloud symbol.

How to Configure Cloud in GNS3?

   Step 13

In the symbol window opened, select the computer symbol and click on the OK button.

How to Configure Cloud in GNS3?

   Step 14

Click the OK button to close the window.

How to Configure Cloud in GNS3?

   Step 15

We have completed the GNS3 Cloud configuration step for the VMware Windows 8.1 virtual machine. Now, if you want to add another one, click on the New button again to continue.

How to Configure Cloud in GNS3?

   Step 16

In the same way, give a name for the VMware Windows 10 virtual machine and click on the Finish button.

How to Configure Cloud in GNS3?

   Step 17

In the GNS3 Cloud settings, select VMnet2 for the Windows 10 virtual machine. And then, click on the Misc tab and change the symbol to change the Cloud symbol.

How to Configure Cloud in GNS3?

   Step 18

We have completed the GNS3 Cloud VMware virtual machine connection process. Now let’s test the Clouds by creating a small network design in the GNS3 program.

How to Configure Cloud in GNS3?

   Step 19

As you can see on the screen below, 2 Cloud computers have been added to the GNS3 tools section.

How to Configure Cloud in GNS3?

   Step 20

Check the VMnet settings of virtual machines on VMware. As you can see in the Virtual Network Editor, VMnets are configured as Host Only.

Windows 8.1 virtual machine settings are as follows.

How to Configure Cloud in GNS3?

   Step 21

Also, check the VMware Windows 10 virtual machine settings.

How to Configure Cloud in GNS3?

   Step 22

Before running the virtual machines, enter the Network Connection Settings from your physical computer. VMware VMnet1 and VMnet2 settings should be as follows.

The main purpose of changing IP addresses here is to use IP addresses with .1 as the default gateway. If you do not pay attention to this, a network failure may occur in GNS3 projects.

How to Configure Cloud in GNS3?

   Step 23

After completing the steps to configure Cloud in GNS3, the best way to verify the GNS3 Cloud settings is to create a project. Create a network topology as shown below and add the Cloud computers you have added to the workspace.

You can change the Hostname of the Cloud computers you added to the workspace.

How to Configure Cloud in GNS3?

   Step 24

Change the Hostname of Cloud2.

How to Configure Cloud in GNS3?

   Step 25

The final view of the GNS3 network topology is as follows. After specifying the IP addresses, run the Cisco Router.

How to Configure Cloud in GNS3?

   Step 26

Open the Cisco Router R1 CLI command prompt and assign the IP address to FastEthernet0/0 and FastEthernet0/1 interfaces.

[code] R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.5.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#
*Mar 1 00:02:19.999: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:02:20.999: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config)#interface fastethernet 0/1
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#end
R1#
[/code]

How to Configure Cloud in GNS3?

   Step 27

Run the VMware virtual machine and configure the IP configuration.

How to Configure Cloud in GNS3?

   Step 28

Likewise, VMware Windows 10 virtual machine TCP/IP settings are as follows.

How to Configure Cloud in GNS3?

   Step 29

Ping connection test from Windows 8.1 virtual machine connected to VMnet1 is as follows.

How to Configure Cloud in GNS3?

   Step 30

Ping connection test from VMware Windows 10 virtual machine connected to VMnet2 is as follows.

As you can see, the two virtual machines successfully communicate with each other via the Router. The GNS3 Cloud configuration is crucial for the fault-free operation of virtual machines.

How to Configure Cloud in GNS3?

Show Commands Related to How to Configure Cloud in GNS3

R1#show running-configR1#show ip routeR1#show ip route connected
R1#show running-config
Building configuration…
Current configuration : 1043 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#
R1#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

C 192.168.10.0/24 is directly connected, FastEthernet0/1
C 192.168.5.0/24 is directly connected, FastEthernet0/0
R1#

R1#show ip route connected
C 192.168.10.0/24 is directly connected, FastEthernet0/1
C 192.168.5.0/24 is directly connected, FastEthernet0/0
R1#

How to Configure Cloud in GNS3? ⇒ Video

You can watch how to configure Cloud in GNS3 and you can also subscribe to our YouTube channel…

  Final Word

How to Configure Cloud in GNS3? – In this article, we have implemented the GNS3 Cloud VMware virtual machine connection. In GNS3 we recommend using Cloud Computers for virtual machine use.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to browser bookmarks by pressing the CTRL+D to read this article later!

Articles Related to How to Configure Cloud in GNS3

Products Related to How to Configure Cloud in GNS3
Related Products

Leave a Reply

Your email address will not be published. Required fields are marked *

five × two =