How to Configure Cisco Switch Step by Step? – In this article, we will review the process to configure Cisco Switch step by step. Later, we will complete the steps to configure VLAN on Cisco Switch step by step.
How to Configure Cisco Switch Step by Step?

How to Configure Cisco Switch Step by Step?

How to Configure Cisco Switch Step by Step?

We will perform the steps to configure Cisco Switch step by step using GNS3 and VMware Workstation programs. Cisco Switches are divided into Layer2 and Layer3 in the OSI layer. Switches running on OSI Layer2 provide communication of computers by using MAC address tables. In addition, Layer 2 Switches have the VLAN feature.

By sending MAC address frames on the network, the Switches form the MAC address table. Switches are used in the network environment to prevent the broadcast collision, thereby improving performance in network traffic.

Individuals preparing for Cisco CCNA exams use GNS3 or Cisco Packet Tracer programs. These programs allow you to simulate and use Cisco products on your computer.

Now, we can move on to the steps to configure Cisco Switch step by step. You can follow the steps to configure VLAN on Cisco Switch step by step.

Our Recommendation

You can purchase “Cisco System 24-Port Gigabit Switch” from Amazon.

How to Configure Cisco Switch in GNS3?

Follow the steps to configure Cisco Switch in GNS3 respectively.

   Step 1

First run the GNS3 program and create a new project. Next, create a topology like the one below. In this topology is used Layer 3 Switch. Layer 3 Switches operate at the Network layer of the OSI layer.

How to Configure Cisco Switch Step by Step?

   Step 2

In the Switch CLI console window, you need to apply the commands required to configure Cisco Switch step by step. In this step, Cisco Switch IP addressing, Cisco Switch Telnet configuration, and Cisco Switch initial configuration are performed.

Enter the following commands in the Cisco Switch CLI console.

[code] ESW1# conf t
ESW1(config)# hostname IT
IT# conf t
IT(config)# interface fastethernet 0/0
IT(config-if)# no shutdown
IT(config-if)# exit
IT(config)# interface fastethernet 0/1
IT(config-if)# no shutdown
IT(config-if)# exit
IT(config)# username cisco password cisco123
IT(config)# line vty 0 4
IT(config-line)# login local
IT(config-line)# transport input telnet
IT(config-line)# exit
IT(config)# enable password 12345
IT(config)# enable secret 123456
IT(config)# service password-encryption
IT(config)# banner motd #
Enter TEXT message. End with the character ‘#’.
###Unauthorized Access###
IT(config)# ip default-gateway 192.168.8.254
IT(config)# end
IT# wr
[/code]

Cisco Switch Ip Address Configuration

In the Cisco Switch Ip address configuration, Ip address is given to the VLAN1 interface created by default on the Switch. VLAN1 is the management interface. To apply the Cisco Switch IP address configuration to the VLAN1 interface, execute the following command.

[code] IT# conf t
IT(config)# interface vlan1
IT(config-vlan)# ip address 192.168.8.10 255.255.255.0
IT(config-vlan)# no shutdown
IT(config-vlan)# end
IT# wr
[/code]

How to Configure Cisco Switch Step by Step?

To create a virtual machine on the VMware virtualization program, you can read the topic called “Create Virtual Machine on VMware Workstation 12“.

   Step 3

Once you have created a virtual machine in VMware Workstation, you can install Windows 10 or another operating system. After running the virtual machine on VMware, let’s check the ip settings.

Press and hold Windows Key + R to open the Run window and type CMD and click Enter. The CMD command prompt will open and you can check the ip configuration with the ipconfig command.

How to Configure Cisco Switch Step by Step?

   Step 4

In the Cisco Switch IP address configuration, we assigned the IP address to the VLAN interface. Now, let’s ping from VMware virtual machine to the Cisco Switch VLAN management interface.

How to Configure Cisco Switch Step by Step?

   Step 5

Also, in the steps to configure Cisco Switch step by step, we performed the Cisco Switch Telnet configuration process. From the VMware virtual machine, perform the command telnet 192.168.10.10 at the CMD command prompt to perform the telnet connection to the Cisco Switch VLAN management interface.

To enable Telnet Client on Windows, we recommend you to read the topic called “What is Telnet Used For?“!

How to Configure Cisco Switch Step by Step?

   Step 6

We implemented Telnet connectivity for Cisco Switch VLAN management. Once you have entered the created username and password, you can go into global configuration mode.

How to Configure Cisco Switch Step by Step?


How to Configure VLAN on Cisco Switch Step by Step?

The processes to configure Cisco Switch step by step consist of several commands. To use Cisco Switches in more detail, we need to create VLANs. After the process to configure VLAN on Cisco Switch step by step, we will test the inter-VLAN connectivity.

   Step 1

In the process to configure VLAN on Cisco Switch step by step, after you apply the show vlan-switch command on the privileged mode on the Cisco Switch, you can see the VLAN structure.

How to Configure Cisco Switch Step by Step?

   Step 2

Open the Cisco Router CLI command window and configure the FastEthernet0/0 interface as shown in the following image.

Cisco Router Interface Ip Address Configuration;

[code] R1# conf t
R1(config)# interface fastethernet 0/0
R1(config-if)# ip address 192.168.8.254 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# exit
R1# wr
[/code]

How to Configure Cisco Switch Step by Step?

For Cisco Router detailed interface configuration, you can read the topic called “Giving Cisco Router Ip Address“.

   Step 3

Pinging from the VMware virtual machine to the Cisco Router FastEthernet0/0 interface is successful!

How to Configure Cisco Switch Step by Step?

   Step 4

Now, we will perform the process to configure VLAN on Cisco Switch step by step. Run the Cisco Switch CLI console and apply the following commands respectively.

Configure VLAN on Cisco Switch;

Make sure you are in privileged mode in the step to configure VLAN on Cisco Switch step by step.

[code] IT# vlan database
IT(vlan)# vlan 10 name ITVLAN10
VLAN 10 added:
Name: ITVLAN10
IT(vlan)# vlan 20 name ITVLAN20
VLAN 20 added:
Name: ITVLAN10
IT(vlan)# vlan 100 name ITMANAGEMENTVLAN100
VLAN 100 added:
Name: ITMANAGEMENTVLAN100
IT(vlan)# exit
APPLY completed.
Exiting….
IT#
[/code]

How to Configure Cisco Switch Step by Step?

   Step 5

Run the show vlan-switch command on the Cisco Switch CLI console and check the VLANs you have created.

How to Configure Cisco Switch Step by Step?

   Step 6

Add one VPCS to the GNS3 workspace as follows. Connect your VPCS to the Cisco Switch FastEthernet0/10 interface.

How to Configure Cisco Switch Step by Step?

   Step 7

Assign the IP address to the VPCS by opening the PC1 CLI console.

How to Configure Cisco Switch Step by Step?

What is VPCS in GNS3? To answer the question, read the topic called “How to Add VPCS in GNS3?

   Step 8

After configuring VLAN on Cisco Switch step by step, the VPCS must be a member of a VLAN. In the Cisco Switch VLAN insertion process, if which interface is connected to VPCS, we need to add that interface in the VLAN.

Due to we have connected the VPCS to the Cisco Switch FastEthernet0/10 interface, we need to make member the VLAN10 to the FastEthernet0/10 interface.

For the communication of VLANs, we must configure the interface with the Cisco Router TRUNK configuration.

VPCS Cisco Switch VLAN10 Configuration;

[code] IT# conf t
IT(config)# interface fastethernet 0/10
IT(config-if)# switchport mode access
IT(config-if)# switchport access vlan 10
IT(config-if)# exit
IT(config)# interface fastethernet 0/0
IT(config-if)# switchport mode trunk
IT(config-if)# exit
IT(config)# end
IT# wr
[/code]

How to Configure Cisco Switch Step by Step?

   Step 9

After creating the Cisco Switch VLAN, we must create a Subinterface on the Cisco Router to communicate VLANs.

Cisco Router Trunk Configuration

Apply the following commands in order for the Cisco Router Trunk configuration.

[code] R1# conf t
R1(config)# interface fastethernet 0/0
R1(config-if)# no ip address
R1(config-if)# exit
R1(config)# interface fastethernet 0/0.1
R1(config-if)# ip address 192.168.8.254 255.255.255.0
R1(config-if)# encapsulation dot1Q 1
R1(config-if)# exit
R1(config)# interface fastethernet 0/0.10
R1(config-if)# ip address 192.168.10.254 255.255.255.0
R1(config-if)# encapsulation dot1Q 10
R1(config-if)# exit
R1(config)# end
R1# wr
[/code]

How to Configure Cisco Switch Step by Step?

   Step 10

With the show vlan-switch command on the Cisco Switch, let’s check the interfaces.

How to Configure Cisco Switch Step by Step?

   Step 11

On the Cisco Switch, let’s check the status of interfaces with show ip  interface brief command. The interfaces we have configured are Up.

How to Configure Cisco Switch Step by Step?

   Step 12

When we check the Cisco Router interfaces with the same command, there is no problem in Cisco interfaces.

How to Configure Cisco Switch Step by Step?

   Step 13

If we have ping to the VMware virtual machine via VPCS, you can see that the operation is successful.

How to Configure Cisco Switch Step by Step?

   Step 14

Let’s check the VMware virtual machine TCP/IP settings. There are no problems.

How to Configure Cisco Switch Step by Step?

   Step 15

Likewise, when we ping from a VMware virtual machine to the VPCS, you can see that the process is successful.

How to Configure Cisco Switch Step by Step?

Commands Related to How to Configure Cisco Switch Step by Step

Cisco Switch Basic CommandsCisco Switch VLAN CreationCisco Switch Trunk SettingCisco Router Trunk SettingVPCS TCP/IP Setting

ESW1# conf t
ESW1(config)# hostname IT
IT# conf t
IT(config)# interface fastethernet 0/0
IT(config-if)# no shutdown
IT(config-if)# exit
IT(config)# interface fastethernet 0/1
IT(config-if)# no shutdown
IT(config-if)# exit
IT(config)# username cisco password cisco123
IT(config)# line vty 0 4
IT(config-line)# login local
IT(config-line)# transport input telnet
IT(config-line)# exit
IT(config)# enable password 12345
IT(config)# enable secret 123456
IT(config)# service password-encryption
IT(config)# banner motd #
Enter TEXT message. End with the character ‘#’.
###Unauthorized Access###
IT(config)# ip default-gateway 192.168.8.254
IT(config)# end
IT# wr

IT# vlan database
IT(vlan)# vlan 10 name ITVLAN10
VLAN 10 added:
Name: ITVLAN10
IT(vlan)# vlan 20 name ITVLAN20
VLAN 20 added:
Name: ITVLAN10
IT(vlan)# vlan 100 name ITMANAGEMENTVLAN100
VLAN 100 added:
Name: ITMANAGEMENTVLAN100
IT(vlan)# exit
APPLY completed.
Exiting….
IT#

IT# conf t
IT(config)# interface fastethernet 0/10
IT(config-if)# switchport mode access
IT(config-if)# switchport access vlan 10
IT(config-if)# exit
IT(config)# interface fastethernet 0/0
IT(config-if)# switchport mode trunk
IT(config-if)# exit
IT(config)# end
IT# wr

R1# conf t
R1(config)# interface fastethernet 0/0
R1(config-if)# no ip address
R1(config-if)# exit
R1(config)# interface fastethernet 0/0.1
R1(config-if)# ip address 192.168.8.254 255.255.255.0
R1(config-if)# encapsulation dot1Q 1
R1(config-if)# exit
R1(config)# interface fastethernet 0/0.10
R1(config-if)# ip address 192.168.10.254 255.255.255.0
R1(config-if)# encapsulation dot1Q 10
R1(config-if)# exit
R1(config)# end
R1# wr

PC1> ip 192.168.10.10/24 192.168.10.254

How to Configure Cisco Switch Step by Step ⇒ Video

You can watch how to configure Cisco Switch step by step. Also, subscribe to our YouTube channel.

  Final Word

How to Configure Cisco Switch Step by Step? – As a result, the Cisco Switch commands look like Cisco Router commands. We have completed the Switch configuration steps with a few commands.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to the browser bookmarks by pressing the Ctrl+D to read this article later!

Articles Related to How to Configure Cisco Switch Step by Step
Products Related to How to Configure Cisco Switch Step by Step
Related Products

Leave a Reply

Your email address will not be published. Required fields are marked *

16 + seven =