How to Configure BackboneFast on Cisco Switch in GNS3 – When configuring the standard Spanning Tree Protocol, we often encounter terms like UplinkFast, PortFast, and BackboneFast. These features are specific to the Cisco brand and can not be used with other brands.
How to Configure BackboneFast on Cisco Switch in GNS3

How to Configure BackboneFast on Cisco Switch in GNS3

In Layer 2 Switches, the STP protocol runs in order to prevent loops in the network. Older versions of IOS that do not support the Rapid STP protocol use the Per VLAN Spanning Tree (PVST) protocol. We can call this term simply Standard Spanning Tree Protocol.

A cable malfunctioning spanning tree network in a redundancy network immediately switches on and continues to forward packets. However, you need to configure the STP protocol on Cisco Switches.

To make the standard STP protocol more capable, we need to enable the PortFast, UplinkFast and BackboneFast features.

The Spanning Tree BackboneFast feature provides fast STP Convergence between Switches as a result of a link failure. If BackboneFast is not enabled on Cisco Switches used the classic STP protocol, the STP convergence time will take 50 seconds to a link failure.

In short, after the Cisco Switch BackboneFast configuration, the Max Age Timer duration as a result of a link failure will not be evaluated and will reduce the 50-second downtime time to 30 seconds (50-20 = 30).

Our Recommendation

You can purchase “CCNP Switching” from Amazon.

How to Configure Spanning Tree BackboneFast in GNS3

Before enabling BackboneFast on Cisco Switches, we will take a little test and take a look at the downtime time. We will then enable BackboneFast on Cisco Switches using the GNS3 program.

Before moving on to the steps to configure BackboneFast on Cisco Switch in GNS3, you need to perform the GNS3 VM Server Setup and GNS3 VM Cisco IOU Setup steps. For understanding and configuring BackboneFast you need the Cisco IOU, otherwise, you can not examine it in detail.

Follow the steps below for the configuration of Spanning Tree BackboneFast.

   Step 1

Open the GNS3 program and create a new project for the BackboneFast configuration.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 2

At the same time, after installing GNS3 VM, open the VMware Workstation program.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 3

After the Cisco IOU installation, add a Layer 2 Switch to the GNS3 program and then add 4 L2 Switches to the workspace.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 4

Change the names of the Cisco Switches as follows.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 5

After cabling Cisco Layer 2 Switches, add 2 VPCS computers to the GNS3 workspace. It is asking the following question because you are using GNS3 VM Server. Run VPCS computers locally.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 6

Configure the TCP/IP configuration of the VPCS computers and then start all devices.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 7

Ping from Lenovo PC to HP PC to check the network connection. Once the ping is successful, proceed to the next step.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 8

Before the steps to configure BackboneFast on Cisco Switch in GNS3, configure Cisco Switch SW1 as the Root Bridge. Then open the SW1 CLI command prompt and run the show spanning-tree command to check that it is the Root Bridge. Also, note the Spanning Tree Port States on Switches.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 9

After specifying the Root Bridge and the Port States, the network topology is as follows.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 10

Before enabling BackboneFast, start the Ping from the Lenovo PC to the HP PC continuously, and then click the SW3 tab.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 11

To create an Indirect link failure, you can shutdown the interface outgoing to the HP PC with the shutdown command. Then click on the Lenovo PC tab to see what it is.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 12

After creating a link failure, the Cisco Switch BackboneFast is not configured, so the STP Convergence time will be 50 seconds, as you can see in the image below.

You can activate SW3 Ethernet 0/2 interface with no shutdown command.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 13

To configure BackboneFast on Cisco Switch in GNS3, open the CLI command prompts of the Switches and apply spanning-tree backbonefast command in config mode respectively.

Apply the show spanning-tree summary command to verify that BackboneFast is enabled.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 14

Also enable Spanning Tree BackboneFast on the Cisco Switch SW2.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 15

Activate BackboneFast on SW3 in the same way.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 16

Finally, enable the BackboneFast feature on Switch SW4 and verify the configuration with the show spanning-tree summary command.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 17

After completing the steps to configure BackboneFast in GNS3, use the debug spanning-tree backbonefast detail command in Privileged mode to examine how BackboneFast works on Cisco switches.

When an indirect link error occurs in the switches on the network, BackboneFast will be enabled and the logs of the RLQ BPDU packets will be dropped to the CLI command prompt.

On all Layer 2 switches, implement the debug spanning-tree backbonefast detail command.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 18

Start the Ping operation again from the Lenovo PC to the HP PC and immediately close the SW3 Ethernet 0/2 interface with the shutdown command.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 19

Logs will be generated on SW1, SW2, and SW4 immediately after you close the Cisco Switch SW3 Ethernet 0/2 interface.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 20

When we check Lenovo PC Ping, there is a downtime of 30 seconds during ping. It was 50 seconds before BackboneFast not enabled. However, after activating BackboneFast we saved 20 seconds and reduced the downtime to 30 seconds.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 21

Because SW3 lost the Root Bridge connection, it sends an inferior BPDU packet to the neighboring SW4 Switch to become the new Root Bridge. SW1 responds to an inferior (RLQ) packet from SW4 as follows.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 22

SW2 received packet is transmitting via Ethernet 0/2 Root port of SW4.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 23

SW4 receives the response to the RLQ packet that it has sent, and it saves 20 seconds by skipping the max age timer to terminate the old interior package from SW3.

How to Configure BackboneFast on Cisco Switch in GNS3

   Step 24

Once you have completed the GNS3 Cisco Switch BackboneFast configuration steps, you can view the BackboneFast in the Spanning Tree Protocol by reviewing the following image.

How to Configure BackboneFast on Cisco Switch in GNS3

Show Commands Related to How to Configure BackboneFast on Cisco Switch in GNS3

You can review the show commands used in the process to configure Spanning Tree BackboneFast in GNS3.

Show Spanning-Tree Commands

Manual Root Bridge SelectionSW1#show spanning-treeSW2#show spanning-treeSW3#show spanning-treeSW4#show spanning-tree
SW1#conf t
SW1(config)# spanning-tree vlan 1 priority 4096
SW1(config)# end
SW1#
SW1#show spanning-tree

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address aabb.cc00.0100
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 4097 (priority 4096 sys-id-ext 1)
Address aabb.cc00.0100
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
——————- —- — ——— ——– ——————————–
Et0/0 Desg FWD 100 128.1 Shr
Et0/1 Desg FWD 100 128.2 Shr
Et0/2 Desg FWD 100 128.3 Shr
Et0/3 Desg FWD 100 128.4 Shr
Et1/0 Desg FWD 100 128.33 Shr
Et1/1 Desg FWD 100 128.34 Shr
Et1/2 Desg FWD 100 128.35 Shr
Et1/3 Desg FWD 100 128.36 Shr
Et2/0 Desg FWD 100 128.65 Shr
Et2/1 Desg FWD 100 128.66 Shr
Et2/2 Desg FWD 100 128.67 Shr
Et2/3 Desg FWD 100 128.68 Shr
Et3/0 Desg FWD 100 128.97 Shr
Et3/1 Desg FWD 100 128.98 Shr
Et3/2 Desg FWD 100 128.99 Shr
Et3/3 Desg FWD 100 128.100 Shr

SW1#

SW2#show spanning-tree

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address aabb.cc00.0100
Cost 100
Port 1 (Ethernet0/0)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address aabb.cc00.0200
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
——————- —- — ——— ——– ——————————–
Et0/0 Root FWD 100 128.1 Shr
Et0/1 Desg FWD 100 128.2 Shr
Et0/2 Desg FWD 100 128.3 Shr
Et0/3 Desg FWD 100 128.4 Shr
Et1/0 Desg FWD 100 128.33 Shr
Et1/1 Desg FWD 100 128.34 Shr
Et1/2 Desg FWD 100 128.35 Shr
Et1/3 Desg FWD 100 128.36 Shr
Et2/0 Desg FWD 100 128.65 Shr
Et2/1 Desg FWD 100 128.66 Shr
Et2/2 Desg FWD 100 128.67 Shr
Et2/3 Desg FWD 100 128.68 Shr
Et3/0 Desg FWD 100 128.97 Shr
Et3/1 Desg FWD 100 128.98 Shr
Et3/2 Desg FWD 100 128.99 Shr
Et3/3 Desg FWD 100 128.100 Shr

SW2#

SW3#show spanning-tree

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address aabb.cc00.0100
Cost 100
Port 3 (Ethernet0/2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address aabb.cc00.0300
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
——————- —- — ——— ——– ——————————–
Et0/0 Desg FWD 100 128.1 Shr
Et0/1 Desg FWD 100 128.2 Shr
Et0/2 Root FWD 100 128.3 Shr
Et0/3 Desg FWD 100 128.4 Shr
Et1/0 Desg FWD 100 128.33 Shr
Et1/1 Desg FWD 100 128.34 Shr
Et1/2 Desg FWD 100 128.35 Shr
Et1/3 Desg FWD 100 128.36 Shr
Et2/0 Desg FWD 100 128.65 Shr
Et2/1 Desg FWD 100 128.66 Shr
Et2/2 Desg FWD 100 128.67 Shr
Et2/3 Desg FWD 100 128.68 Shr
Et3/0 Desg FWD 100 128.97 Shr
Et3/1 Desg FWD 100 128.98 Shr
Et3/2 Desg FWD 100 128.99 Shr
Et3/3 Desg FWD 100 128.100 Shr

SW3#

SW4#show spanning-tree

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 4097
Address aabb.cc00.0100
Cost 200
Port 3 (Ethernet0/2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address aabb.cc00.0400
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
——————- —- — ——— ——– ——————————–
Et0/0 Desg FWD 100 128.1 Shr
Et0/1 Altn BLK 100 128.2 Shr
Et0/2 Root FWD 100 128.3 Shr
Et0/3 Desg FWD 100 128.4 Shr
Et1/0 Desg FWD 100 128.33 Shr
Et1/1 Desg FWD 100 128.34 Shr
Et1/2 Desg FWD 100 128.35 Shr
Et1/3 Desg FWD 100 128.36 Shr
Et2/0 Desg FWD 100 128.65 Shr
Et2/1 Desg FWD 100 128.66 Shr
Et2/2 Desg FWD 100 128.67 Shr
Et2/3 Desg FWD 100 128.68 Shr
Et3/0 Desg FWD 100 128.97 Shr
Et3/1 Desg FWD 100 128.98 Shr
Et3/2 Desg FWD 100 128.99 Shr
Et3/3 Desg FWD 100 128.100 Shr

SW4#

Show Spanning-Tree Summary Commands

SW1#show spanning-tree summaryEnabling BackboneFastSW2# show spanning-tree summarySW3#show spanning-tree summarySW4#show spanning-tree summary
SW1#show spanning-tree summary
Switch is in pvst mode
Root bridge for: VLAN0001
Extended system ID is enabled
Portfast Default is disabled
PortFast BPDU Guard Default is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default is disabled
EtherChannel misconfig guard is enabled
Configured Pathcost method used is short
UplinkFast is disabled
BackboneFast is enabled

Name Blocking Listening Learning Forwarding STP Active
———————- ——– ——— ——– ———- ———-
VLAN0001 0 0 0 16 16
———————- ——– ——— ——– ———- ———-
1 vlan 0 0 0 16 16

BackboneFast statistics
———————–
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
SW1#

SW1#conf t
SW1(config)#spanning-tree backbonefast
SW1(config)# end
SW1#
SW2# show spanning-tree summary
Switch is in pvst mode
Root bridge for: none
Extended system ID is enabled
Portfast Default is disabled
PortFast BPDU Guard Default is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default is disabled
EtherChannel misconfig guard is enabled
Configured Pathcost method used is short
UplinkFast is disabled
BackboneFast is enabled

Name Blocking Listening Learning Forwarding STP Active
———————- ——– ——— ——– ———- ———-
VLAN0001 0 0 0 16 16
———————- ——– ——— ——– ———- ———-
1 vlan 0 0 0 16 16

BackboneFast statistics
———————–
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
SW2(config)#

SW3#show spanning-tree summary
Switch is in pvst mode
Root bridge for: none
Extended system ID is enabled
Portfast Default is disabled
PortFast BPDU Guard Default is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default is disabled
EtherChannel misconfig guard is enabled
Configured Pathcost method used is short
UplinkFast is disabled
BackboneFast is enabled

Name Blocking Listening Learning Forwarding STP Active
———————- ——– ——— ——– ———- ———-
VLAN0001 0 0 0 16 16
———————- ——– ——— ——– ———- ———-
1 vlan 0 0 0 16 16

BackboneFast statistics
———————–
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
SW3#

SW4#show spanning-tree summary
Switch is in pvst mode
Root bridge for: none
Extended system ID is enabled
Portfast Default is disabled
PortFast BPDU Guard Default is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default is disabled
EtherChannel misconfig guard is enabled
Configured Pathcost method used is short
UplinkFast is disabled
BackboneFast is enabled

Name Blocking Listening Learning Forwarding STP Active
———————- ——– ——— ——– ———- ———-
VLAN0001 1 0 0 15 16
———————- ——– ——— ——– ———- ———-
1 vlan 1 0 0 15 16

BackboneFast statistics
———————–
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
SW4#

Debug Logs

SW1#debug spanning-tree backbonefast detailSW1 Debug OutputSW2 Debug OutputSW4 Debug Output
SW1#debug spanning-tree backbonefast detail
Spanning Tree backbonefast detail debugging is on
SW1#
SW1#
*Sep 13 22:11:43.751: STP FAST: VLAN0001 Ethernet0/0: sending requested RLQ response PDU
SW1#
SW2#
*Sep 13 22:11:43.748: STP FAST: VLAN0001 Ethernet0/2: forwarding RLQ request PDU over root port
SW2#
SW4#
*Sep 13 22:11:43.752: STP FAST: received RLQ response PDU was expected on VLAN0001 Ethernet0/2 – resp root id 4097-aabb.cc00.0100 .
*Sep 13 22:11:43.752: STP FAST: received_rlq_bpdu on VLAN0001 Ethernet0/1 – making Ethernet0/1 a designated port
SW4#

Show Running-Config Commands

SW1#show running-configSW2#show running-configSW3#show running-configSW4#show running-config
SW1#show running-config
Building configuration…

Current configuration : 1587 bytes
!
! Last configuration change at 22:03:42 UTC Wed Sep 13 2017
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW1
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
no ip icmp rate-limit unreachable
!
no ip domain-lookup
ip cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 1 priority 4096
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
interface Ethernet0/0
duplex auto
!
interface Ethernet0/1
duplex auto
!
interface Ethernet0/2
duplex auto
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!
interface Ethernet3/0
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
shutdown
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

SW1#

SW2#show running-config
Building configuration…

Current configuration : 1552 bytes
!
! Last configuration change at 22:09:13 UTC Wed Sep 13 2017
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW2
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
no ip icmp rate-limit unreachable
!
no ip domain-lookup
ip cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
interface Ethernet0/0
duplex auto
!
interface Ethernet0/1
duplex auto
!
interface Ethernet0/2
duplex auto
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!
interface Ethernet3/0
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
shutdown
!
!
no ip http server
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

SW2#

SW3#show running-config
Building configuration…

Current configuration : 1562 bytes
!
! Last configuration change at 22:18:37 UTC Wed Sep 13 2017
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW3
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
no ip icmp rate-limit unreachable
!
no ip domain-lookup
ip cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
!
interface Ethernet0/0
duplex auto
!
interface Ethernet0/1
duplex auto
!
interface Ethernet0/2
shutdown
duplex auto
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!
interface Ethernet3/0
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
shutdown
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

SW3#

SW4#show running-config
Building configuration…

Current configuration : 1552 bytes
!
! Last configuration change at 22:07:26 UTC Wed Sep 13 2017
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW4
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
no ip icmp rate-limit unreachable
!
no ip domain-lookup
ip cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
!
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
interface Ethernet0/0
duplex auto
!
interface Ethernet0/1
duplex auto
!
interface Ethernet0/2
duplex auto
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!
interface Ethernet3/0
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
shutdown
!
!
no ip http server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
end

Show Spanning-Tree BackboneFast Commands

SW1#show spanning-tree backbonefastSW2#show spanning-tree backbonefastSW3#show spanning-tree backbonefastSW4#show spanning-tree backbonefast
SW1#show spanning-tree backbonefast
BackboneFast is enabled

BackboneFast statistics
———————–
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 2
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 2
SW1#

SW2#show spanning-tree backbonefast
BackboneFast is enabled

BackboneFast statistics
———————–
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 2
Number of RLQ response PDUs received (all VLANs) : 2
Number of RLQ request PDUs sent (all VLANs) : 2
Number of RLQ response PDUs sent (all VLANs) : 30
SW2#

SW3#show spanning-tree backbonefast
BackboneFast is enabled

BackboneFast statistics
———————–
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
SW3#

SW4#show spanning-tree backbonefast
BackboneFast is enabled

BackboneFast statistics
———————–
Number of transition via backboneFast (all VLANs) : 2
Number of inferior BPDUs received (all VLANs) : 2
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 2
Number of RLQ request PDUs sent (all VLANs) : 2
Number of RLQ response PDUs sent (all VLANs) : 0
SW4#

How to Configure BackboneFast on Cisco Switch in GNS3 ⇒ Video

You can watch how to configure and enable BackboneFast on Layer 2 Switches in GNS3 and you can also subscribe to our Youtube channel…

  Final Word

How to Configure BackboneFast on Cisco Switch in GNS3 – In this article, we have implemented the steps for configuring BackboneFast on Cisco switches. The Layer 2 Switch Cisco IOU used in this lab is i86bi-linux-l2-ipbasek9-15.1a.bin. You can also browse How to Configure UplinkFast on Cisco Switch in GNS3 and How to Enable PortFast on Cisco Switch in GNS3. In the next article, we will examine the Rapid Spanning Tree Protocol and we will not need to configure UplinkFast and BackboneFast steps when we enable this protocol.

If this article is helpful, send me feedback by commenting! Thanks in advance, take care of yourself!

Also, you can add to browser bookmarks by pressing the CTRL+D to read this article later!

Articles Related to How to Configure BackboneFast on Cisco Switch in GNS3

Products Related to How to Configure BackboneFast on Cisco Switch in GNS3
Related Products

Leave a Reply

Your email address will not be published. Required fields are marked *

3 × four =