Cisco SDM NAT Konfigürasyonu – Cisco Router üzerine SDM kurulması Cisco Router’ların web tabanlı yönetimini sağlamaktadır. Cisco SDM ile Cisco Router üzerinde basit ve gelişmiş ayarlar yapılabilmektedir. Bunlardan bitanesi de NAT işlemidir.
Cisco SDM NAT Konfigürasyonu

Cisco SDM NAT Konfigürasyonu

Cisco SDM NAT Konfigürasyonu

Cisco SDM NAT konfigürasyonu ile LAN üzerindeki bilgisayarı İnternet’e çıkarabiliriz. NAT işlemi bir ağ ortamında olmazsa olmazlardandır. Çünkü, NAT işlemi ile ağ üzerindeki özel Ip adreslerini, İnternet’e çıkarabiliriz. Özel Ip adresleri RFC1918‘de tanımlanmıştır.

LAN üzerindeki özel Ip adresleri İnternet’e çıkarken gerçek Ip adreslerine NAT işlemi ile çıkabilmektedir. Cisco SDM NAT konfigürasyonu ile bu işlemi gerçekleştireceğiz.

Cisco Router üzerinde Statik NAT yapılandırma işlemi için, Cisco Router Static NAT Yapılandırma adlı yazıyı okuyabilirsiniz…

Best-Selling-Routers
Best-Selling-Routers

Cisco SDM NAT konfigürasyonu için öncelikle Security Device Manager (Güvenlik Aygıt Yöneticisi)’ın kurulması gereklidir. Cisco Router üzerinde SDM kurulumunu gerçekleştirmek için, Cisco SDM Nedir? Cisco SDM Nasıl Kurulur? adlı yazıyı okuyabilirsiniz.

Cisco SDM NAT Konfigürasyonu İçin Kullanılan Cisco IOS

Cisco IOS’u indirmek için aşağıdaki butona tıklayabilirsiniz.

 

Cisco Router SDM ile NAT Yapılandırma

Cisco Router SDM ile NAT yapılandırma adımlarına artık geçebiliriz. Cisco Router SDM ile NAT yapılandırma işlemlerinde GNS3 ve VMware Workstation programlarını kullanacağız. GNS3 programı için VMware Workstation programında sanal bir makina yeterlidir. VMware Virtual Network Editor programında oluşturduğunuz VMnet’i host-only olarak yapılandırınız.

GNS3 ile VMware entegrasyonu için, GNS3 ile VMware Workstation Bağlantısı adlı yazıyı okuyabilirsiniz…

   Adım 1

Best-Selling-Routers
Best-Selling-Routers

Cisco Router SDM ile NAT yapılandırma için öncelikle GNS3 programında aşağıdaki görüntüdeki gibi bir topoloji oluşturunuz.

Cisco SDM NAT Konfigürasyonu

   Adım 2

Cisco SDM NAT konfigürasyonu 2. adımında, VMware Workstation üzerinde sanal bir makina oluşturunuz. Cisco Router üzerine SDM yazılımını yükledikten sonra, Cisco SDM’i çalıştırınız.

Cisco SDM programına Internet tarayısından eriştikten sonra, Configure (Yapılandır) sekmesine tıklayınız.

Cisco SDM NAT Konfigürasyonu

   Adım 3

Cisco SDM üzerinde Configure sekmesine tıkladıktan sonra, sol bölümde bulunan NAT seçeneğine tıklayınız.

Cisco SDM NAT Konfigürasyonu

   Adım 4

Cisco Router SDM ile NAT yapılandırma’sında, Basit NAT (Temel NAT) seçeneğini seçiniz ve ardından Launch the selected task (Seçili görevi başlat) butonuna tıklayınız.

Cisco SDM NAT Konfigürasyonu

   Adım 5

Cisco Router SDM ile NAT yapılandırması Wizard penceresinde Next (İleri) butonuna tıklayınız.

Cisco SDM NAT Konfigürasyonu

   Adım 6

Basic NAT Wizard penceresinde, İnternet’e bağlı olan İnterface (Arayüz) seçili olması gereklidir. Çünkü, Cisco Router NAT işleminde İç Bacak ve Dış Bacak bulunmaktadır. Bu bacaklar ile LAN üzerinden gelen bilgisayarlar Dış bacaktan çıkacağı için, Outside (Dış Bacak) belirlenmelidir.

Aşağıdaki görüntüde gördüğünüz gibi, Cisco yönlendirici arayüzlerini görüntülemek için aşağı ok’a tıklayınız.

Cisco SDM NAT Konfigürasyonu

   Adım 7

İnternet’e bağlı olan arayüzü seçiniz.

Cisco SDM NAT Konfigürasyonu

   Adım 8

FastEthernet0/1 arayüzünü seçtikten sonra, Ip adres aralığını seçmeniz gerekmektedir.

Cisco SDM NAT Konfigürasyonu

   Adım 9

Cisco Router SDM ile NAT yapılandırma’sında gerekli ayarlamalar tamamlandı. Şimdi Next butonuna tıklayarak devam ediniz.

Cisco SDM NAT Konfigürasyonu

   Adım 10

Cisco Router üzerinde NAT konfigürasyonu komutlarının uygulanması için Finish butonuna tıklayınız.

Cisco SDM NAT Konfigürasyonu

   Adım 11

Komutlar başarılı bir şekilde Cisco Router’a gönderildi. OK butonuna tıklayarak pencereyi kapatınız.

Cisco SDM NAT Konfigürasyonu

   Adım 12

Cisco SDM NAT konfigürasyonu’nu tamamladık. Cisco SDM programı arayüzünde yapılan ayar gözükmektedir.

Cisco SDM NAT Konfigürasyonu

   Adım 13

VMware Workstation üzerinde kurulu olan Windows 8.1 sanal makinadan Google DNS sunucularına ping işlemi başarılı bir şekilde tamamlanmıştır.

Cisco SDM NAT Konfigürasyonu

   Adım 14

Ping işlemi ICMP protokolünü kullandığı için, Cisco Router CLI konsolunda NAT çevirilerini görüntülediğimizde, 192.168.8.5 Ip adresine sahip bilgisayar NAT işlemi uygulanmıştır.

NAT adres çevirilerini görüntülemek için Cisco yönlendirici komut isteminde show ip nat translations komutunu uygulayınız.

Cisco SDM NAT Konfigürasyonu

   Adım 15

Windows 8.1 sanal makinadan Google arama motoruna erişim sağladığımızda, Cisco Router üzerinde NAT işlemine bakalım.

Cisco SDM NAT Konfigürasyonu

   Adım 16

Cisco yönlendirici üzerinde show ip nat translations komutunu uyguladığımızda, sanal makinadan Google web sitesine erişim sağladıktan sonraki çıktısı aşağıdaki gibidir.

Cisco SDM NAT Konfigürasyonu

   Adım 17

Son olarak, show ip nat statistics komutunu uyguladığımızda çevrime uğrayan işlem sayısını görebiliriz.

Cisco SDM NAT Konfigürasyonu

Cisco yönlendirici üzerinde DHCP konfigürasyonu için, Cisco Router DHCP Yapılandırma adlı yazıyı okuyabilirsiniz…

Cisco SDM NAT Konfigürasyonu Show Komutları

R1#show running-configR1#show ip nat statisticsR1#show ip nat translations

R1#show running-config
Building configuration…

Current configuration : 1449 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
crypto pki trustpoint TP-self-signed-4279256517
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4279256517
revocation-check none
rsakeypair TP-self-signed-4279256517
!
!
username ciscosdm privilege 15 secret 5 $1$P8AQ$58kw7DHT7YUj3far7KDoM.
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
!
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.8.0 0.0.0.255
no cdp log mismatch duplex
!
!
!
control-plane
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login local
transport input telnet
!
!
end
R1#

R1#show ip nat statistics
Total active translations: 85 (0 static, 85 dynamic; 85 extended)
Outside interfaces:
FastEthernet0/1
Inside interfaces:
FastEthernet0/0
Hits: 2977 Misses: 94
CEF Translated packets: 2921, CEF Punted packets: 297
Expired translations: 62
Dynamic mappings:
— Inside Source
[Id: 1] access-list 1 interface FastEthernet0/1 refcount 85
Appl doors: 0
Normal doors: 0
Queued Packets: 0
R1#

R1#show ip nat translations
Pro Inside global Inside local Outside local Outside global
udp 192.168.1.101:49225 192.168.8.5:49225 192.168.1.1:53 192.168.1.1:53
udp 192.168.1.101:49701 192.168.8.5:49701 192.168.1.1:53 192.168.1.1:53
tcp 192.168.1.101:49750 192.168.8.5:49750 23.198.21.99:80 23.198.21.99:80
tcp 192.168.1.101:49751 192.168.8.5:49751 204.79.197.203:80 204.79.197.203:80
tcp 192.168.1.101:49753 192.168.8.5:49753 204.79.197.203:80 204.79.197.203:80
tcp 192.168.1.101:49754 192.168.8.5:49754 151.101.193.108:80 151.101.193.108:80
tcp 192.168.1.101:49755 192.168.8.5:49755 13.107.5.80:80 13.107.5.80:80
tcp 192.168.1.101:49756 192.168.8.5:49756 13.107.5.80:80 13.107.5.80:80
tcp 192.168.1.101:49757 192.168.8.5:49757 195.175.112.105:80 195.175.112.105:80
tcp 192.168.1.101:49758 192.168.8.5:49758 195.175.112.105:80 195.175.112.105:80
tcp 192.168.1.101:49759 192.168.8.5:49759 195.175.112.105:80 195.175.112.105:80
tcp 192.168.1.101:49760 192.168.8.5:49760 195.175.112.105:80 195.175.112.105:80
tcp 192.168.1.101:49761 192.168.8.5:49761 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.101:49762 192.168.8.5:49762 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.101:49763 192.168.8.5:49763 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.101:49764 192.168.8.5:49764 2.18.213.33:80 2.18.213.33:80
tcp 192.168.1.101:49765 192.168.8.5:49765 2.17.23.122:80 2.17.23.122:80

Cisco SDM NAT Konfigürasyonu ⇒ Video

Cisco SDM NAT konfigürasyonu adımlarını video olarak izleyebilirsiniz. Ayrıca, YouTube kanalıma abone olabilirsiniz…

  Son Söz

Cisco SDM NAT Konfigürasyonu – Cisco Router SDM ile NAT yapılandırma işlemini tamamladık. Bu işlem temel olmakla birlikte, daha gelişmiş ayarlarda yapılabilmektedir. Cisco yönlendirici üzerinde NAT işlemini CLI konsolundan da gerçekleştirebiliriz. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

Cisco SDM NAT Konfigürasyonu İlgili Yazılar

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

seven − 1 =