Cisco Router Static NAT YapılandırmaCisco Router‘larda NAT işlemi yerel ağ üzerindeki bilgisayarları İnternet’e çıkarabilmek için etkinleştirilir. GNS3 programı ile küçük bir topoloji oluşturduktan sonra Cisco Router üzerinde NAT konfigürasyonunu yapılandıracağız.
Cisco Router Static NAT Yapılandırma

Cisco Router Static NAT Yapılandırma | Cisco NAT Konfigürasyonu

GNS3 kullanarak Cisco Router üzerinde Static NAT yapılandırma adımlarına geçmeden önce, Static NAT işleminde iki parametre vardır. Bunlar; Inside (İç Bacak) ve Outside (Dış Bacak)‘tır. Ağ üzerinde herhangi bir bilgisayarın İnternet üzerinde bir web sayfasını açma isteğinde bulunduğunda, paket öncelikle ağ üzerinde bulunan Switch‘ten geçerek Router’ın Inside (İç Bacak) kısmına gelecektir. Router’da bu paketi Outside (Dış Bacak)‘tan İnternet ortamına iletecektir.

Ağ topolojisine göre, LAN üzerindeki bilgisayarların İnternet’e hangi Router’dan iletileceğini belirleyerek NAT INSIDE ve NAT OUTSIDE tanımlanmalıdır. Cisco Router Static NAT yapılandırma işleminde en önemli nokta bu kısımların belirlenmesidir.

Cisco Router üzerinde Static NAT yapılandırma işlemine geçmeden önce GNS3 programında Adım 1’deki gibi ağ topoloji oluşturunuz. GNS3 programında bu topolojiyi oluştururken, modeminizin yanında bulunmanız gerekmektedir. Çünkü, aşağıdaki topolojideki İnternet bulutunu VMware Workstation‘a ait VMnet‘lere değil de, fiziksel bilgisayarın Ethernet ağ kartına bağlamamız gerekir.

GNS3 programında bu işlemi Wifi kartı ile denediğimizde programdan ötürü bir hata verecek ve bağlantı başarısız olacaktır.

GNS3’e VMware nasıl entegre edilir? Sorunun cevabı için GNS3 ile VMware Workstation Bağlantısı adlı konuyu okuyabilirsiniz…

GNS3 ile Cisco NAT Konfigürasyonu

GNS3 kullanarak Cisco Router üzerinde Statik NAT konfigürasyonu için aşağıdaki adımları sırasıyla takip ediniz…

   Adım 1

Static NAT yapılandırması için GNS3 programını açınız ve aşağıdaki görüntüdeki gibi topoloji oluşturunuz.

Cisco Router Static NAT Yapılandırma

   Adım 2

Cisco Arayüzlere Ip adresi verirken bu işlemi manuel olarak yapıyorduk.. Burada da statik Ip adresi verebiliriz fakat Cisco Router’ın ADSL Modemimiz ile başarılı bir şekilde bağlantı kurduğunu görmemiz açısından arayüz içerisinde ip address dhcp komutunu kullanacağız.

Cisco Router Static NAT Yapılandırma

   Adım 3

GNS3 programında topolojiye göre VMware Workstation programında herhangi bir işletim sistemi kurabilirsiniz. Bu topolojide Windows 10 işletim sistemi kullandığımız için, Windows 10 sanal makineyi çalıştırdıktan sonra Cisco Router’ın FastEthernet0/1 arayüzüne 192.168.8.0/24 Ip bloğunu atadığımız için FastEthernet arayüzünün Ip adresine ping atarak sanal makinadan bağlantıyı test edelim.

Windows 10 sanal makinadan, Cisco Router’ın FastEthernet 0/1 arayüzüne başarılı bir şekilde Ping işlemi gerçekleşmiştir.

Cisco Router Static NAT Yapılandırma

   Adım 4

Cisco Router’ın FastEthernet 0/0 arayüzü için ip address dhcp komutunu kullanmıştık. ADSL modem DHCP sunucusundan 192.168.1.103 Ip adresini almıştı. Windows 10 sanal makinadan Cisco Router’ın FastEthernet0/0 arayüzüne Ping işlemi aşağıdaki görüntüdeki gibi başarılı olacaktır.

Cisco Router Static NAT Yapılandırma

   Adım 5

Fakat, Windows 10 sanal makinadan Google DNS adreslerine ping attığımızda işlem başarısız olacaktır.

Cisco Router Static NAT Yapılandırma

   Adım 6

Cisco Router Static NAT yapılandırma işlemlerine devam ediyoruz ve bu adımda Cisco NAT konfigürasyonu için gerekli komutları Cisco Router‘a uygulamamız gerekmektedir.

Aşağıdaki komutları sırasıyla Cisco Router’a uygulayınız.

R1# conf t
R1(config)# interface fastethernet 0/0
R1(config-if)# ip address dhcp
R1(config-if)# no shutdown
R1(config-if)# ip nat outside
R1(config-if)# exit
R1(config)# interface fastethernet 0/1
R1(config-if)# ip address 192.168.8.1 255.255.255.0
R1(config-if)# ip nat inside
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# ip nat inside source static 192.168.8.10 192.168.1.50
R1(config)# ip name-server 192.168.1.1
R1(config)# ip domain-lookup
R1(config)# end
R1# copy running-config startup-config

 
ip address dhcp komutu ile ADSL modemimizden IP adresi aldıktan sonra Router üzerinde Google DNS sunucusuna ping atarak bağlantıyı test ediniz. Ping işleminin başarılı olduğunu aşağıdaki görüntüde görebilirsiniz.

Cisco Router Static NAT Yapılandırma

   Adım 7

Cisco Router üzerinde Static NAT yapılandırdıktan sonra, Windows 10’dan Google DNS sunucularına ping attığımızda da işlemin başarılı olduğunu aşağıdaki görüntüden görebilirsiniz.

Cisco Router Static NAT Yapılandırma

   Adım 8

Windows 10 Ip yapılandırmasında, eğer DNS kısmını boş bırakırsanız, tarayıcı adres satırına Google.com yazdığınızda web sayfası açılmayacaktır.

DNS kısmına ADSL modemin Ip adresini verdiğimizde, Google.com sitesine başarılı bir şekilde ulaşıldığını görebilirsiniz.

Cisco Router Static NAT Yapılandırma

   Adım 9

Cisco NAT konfigürasyonu işlemlerinde diğer bir adımda show komutlarıdır. NAT show komutları ile yapılan işlemleri test edebiliriz. Aşağıdaki görüntüde show ip nat translations komutu uygulandığında Google.com websitesi için kayıtlar gözükecektir.

GNS3 ile Statik NAT yapılandırma oldukça basittir. Aşağıdaki görüntüde Statik NAT işleminin ne işe yaradığını anlayabiliriz. İç bacaktan gelen 192.168.8.10 Ip adresi Cisco Router’da 192.168.1.50 Ip adresine çevrilmiştir. Ve böylece sanal makina İnternete çıkabilmektedir.

Cisco Router Static NAT Yapılandırma

   Adım 10

Bazen ağ ortamında çıkan sorunlar ile uğraştığımızda, Cisco Router CLI konsolunda bu NAT çevirilerini silmemiz gerekebilir. Cisco yönlendirici üzerinde NAT kayıtları silmek istediğimizde, ayrıcalıklı yapılandırma modunda [ clear ip nat translations * ] komutunu kullanarak çevrilen tüm Static NAT kayıtlarını NAT tablosundan silebiliriz.

Cisco Router Static NAT Yapılandırma

   Adım 11

Ayrıcalıklı yapılandırma modunda tekrardan show ip nat translations komutunu uyguladığımızda kayıtların silindiğini görebiliriz.

Cisco Router Static NAT Yapılandırma

   Adım 12

Örneğin, Facebook.com sitesini açtığımızda, Cisco Router Static NAT kayıtları tekrar oluşturulacaktır.

Cisco Router Static NAT Yapılandırma

Cisco Router Static NAT Yapılandırma Show Komutları

R1# show running-configR1#show ip nat statisticsR1#show ip nat translationsR1#show ip nat translationsR1#show ip nat statistics
R1# show running-config
Building configuration...

Current configuration : 1050 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
ip name-server 192.168.1.1
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip nat inside source static 192.168.8.10 192.168.1.50
!
no cdp log mismatch duplex
!
!
control-plane
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
R1#
R1#show ip nat statistics
Total active translations: 2 (1 static, 1 dynamic; 1 extended)
Outside interfaces:
FastEthernet0/0
Inside interfaces:
FastEthernet0/1
Hits: 7 Misses: 1
CEF Translated packets: 8, CEF Punted packets: 0
Expired translations: 0
Dynamic mappings:
Appl doors: 0
Normal doors: 0
Queued Packets: 0
R1#show ip nat translations
Pro          Inside global            Inside local                       Outside local                   Outside global
icmp       192.168.1.50:1      192.168.8.10:1              8.8.8.8:1                              8.8.8.8:1
---            192.168.1.50           192.168.8.10                   ---                                             ---
R1#show ip nat translations Pro Inside global Inside local Outside local Outside global tcp 192.168.1.50:49704 192.168.8.10:49704 204.79.197.200:443 204.79.197.200:443 tcp 192.168.1.50:49705 192.168.8.10:49705 93.184.220.20:80 93.184.220.20:80 tcp 192.168.1.50:49706 192.168.8.10:49706 204.79.197.200:443 204.79.197.200:443 tcp 192.168.1.50:49707 192.168.8.10:49707 204.79.197.200:443 204.79.197.200:443 tcp 192.168.1.50:49708 192.168.8.10:49708 204.79.197.200:443 204.79.197.200:443 tcp 192.168.1.50:49709 192.168.8.10:49709 204.79.197.200:443 204.79.197.200:443 tcp 192.168.1.50:49710 192.168.8.10:49710 204.79.197.200:443 204.79.197.200:443 tcp 192.168.1.50:49711 192.168.8.10:49711 31.13.92.36:443 31.13.92.36:443 tcp 192.168.1.50:49712 192.168.8.10:49712 31.13.92.36:443 31.13.92.36:443 tcp 192.168.1.50:49713 192.168.8.10:49713 93.184.220.29:80 93.184.220.29:80 tcp 192.168.1.50:49714 192.168.8.10:49714 31.13.92.36:443 31.13.92.36:443 tcp 192.168.1.50:49715 192.168.8.10:49715 31.13.92.36:443 31.13.92.36:443 tcp 192.168.1.50:49716 192.168.8.10:49716 93.184.220.29:80 93.184.220.29:80 tcp 192.168.1.50:49717 192.168.8.10:49717 31.13.93.7:443 31.13.93.7:443 tcp 192.168.1.50:49718 192.168.8.10:49718 31.13.93.7:443 31.13.93.7:443 tcp 192.168.1.50:49719 192.168.8.10:49719 31.13.93.10:443 31.13.93.10:443 tcp 192.168.1.50:49720 192.168.8.10:49720 31.13.93.10:443 31.13.93.10:443 tcp 192.168.1.50:49721 192.168.8.10:49721 207.46.101.29:80 207.46.101.29:80 udp 192.168.1.50:51647 192.168.8.10:51647 192.168.1.1:53 192.168.1.1:53 udp 192.168.1.50:53083 192.168.8.10:53083 192.168.1.1:53 192.168.1.1:53 udp 192.168.1.50:58578 192.168.8.10:58578 192.168.1.1:53 192.168.1.1:53 udp 192.168.1.50:59312 192.168.8.10:59312 192.168.1.1:53 192.168.1.1:53 udp 192.168.1.50:59671 192.168.8.10:59671 192.168.1.1:53 192.168.1.1:53 Pro Inside global Inside local Outside local Outside global udp 192.168.1.50:59896 192.168.8.10:59896 192.168.1.1:53 192.168.1.1:53 udp 192.168.1.50:60946 192.168.8.10:60946 192.168.1.1:53 192.168.1.1:53 udp 192.168.1.50:61739 192.168.8.10:61739 192.168.1.1:53 192.168.1.1:53 udp 192.168.1.50:64596 192.168.8.10:64596 192.168.1.1:53 192.168.1.1:53 --- 192.168.1.50 192.168.8.10 --- ---
R1#show ip nat statistics
Total active translations: 2 (1 static, 1 dynamic; 1 extended)
Outside interfaces:
FastEthernet0/0
Inside interfaces:
FastEthernet0/1
Hits: 2735 Misses: 78
CEF Translated packets: 2699, CEF Punted packets: 227
Expired translations: 89
Dynamic mappings:
Appl doors: 0
Normal doors: 0
Queued Packets: 0
R1#

Cisco Router Static NAT Yapılandırma ⇒ Video

GNS3 ve VMware Workstation kullanarak Cisco Router üzerinde Static NAT yapılandırmak ve doğrulamak için aşağıdaki videoyu izleyebilirsiniz. Ayrıca, bize destek olmak için YouTube kanalımıza abone olabilirsiniz…

  Son Söz

Cisco Router Static NAT Yapılandırma adımlarını tamamladıktan sonra, Cisco Router CLI konsolunda Static NAT kayıtları için show komutlarına göz attık. Sonraki yazılarımızda, NAT ile ilgili daha detaylı projeler oluşturacağız. Sizlere faydalı olması dileğiyle hoşçakalın, takipte kalın!

Eğer bu makale faydalı ise, yorum yazarak geri bildirim gönderiniz. Şimdiden teşekkürler!

Yazıyı daha sonra tekrar okumak isterseniz, CTRL + D ‘ye basarak yer işaretlerine ekleyebilirsiniz!

Cisco Router Static NAT Yapılandırma ile İlgili Konular

GNS3 ile Cisco NAT Konfigürasyonu İlgili Router İmajı
İlgili Router IOS

Bu yazıda kullanılan Cisco Router IOS imajını aşağıdaki butondan bilgisayarınıza indirebilirsiniz…

c3725-adventerprisek9_ivs-mz.124-25a İndir

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

18 + seven =